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Data Manipulation 

Sorting and Filtering 
Sorting and Filtering allow you to manipulate data in a worksheet based on given set of criteria. 

Basic Sorts 

To execute a basic descending or ascending sort based on one column: 

▪ Highlight the cells that will be sorted 

▪ Click the Sort & Filter button on the Home tab 

▪ Click the Sort Ascending (A-Z) button or Sort Descending (Z-A) button  

 

Custom Sorts 

To sort on the basis of more than one column: 

▪ Click the Sort & Filter button on the Home tab 

▪ Choose which column you want to sort by first 

▪ Click Add Level 

▪ Choose the next column you want to sort  

▪ Click OK 
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Subtotals 
 

Once you have a conventional range, sort the data according to your subtotaling needs. For instance, to 

subtotal the Total column by Salesperson, you must first sort the data by Salesperson, as follows: 

1. Click in any Salesperson cell.  

2. In Excel 2003 and earlier, click Sort Ascending or Sort Descending, accordingly. Excel 2010 users 

much select a specific sort by clicking Sort and Filter in the Editing group on the Home tab.  

 

Now you’re ready to add subtotals, as follows: 

1. Click anywhere inside the spreadsheet.  

2. In Excel 2003, choose Subtotals from the Data menu. Excel 2010 users should click Subtotal in 

the Outline group on the Data tab. In the Subtotal dialog box, you have a number of choices:  

o From the At Each Change In control, choose the column by which you’re subtotaling 

(not the column that contains the values you’re subtotaling). In this case, that’s the 

Salesperson column.  
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o From the Use Function control, select the appropriate function. Sum is the default, and 

in this case, the desired function.  

o Check the appropriate columns in the Add Subtotal To section. In this case, check Total.  

3. After specifying the right columns and functions, click OK.  

 

 

Filtering 

Filtering allows you to display only data that meets certain criteria. To filter: 

▪ Click the column or columns that contain the data you wish to filter 

▪ On the Home tab, click on Sort & Filter 

▪ Click Filter button 

▪ Click the Arrow at the bottom of the first cell 

▪ Click the Text Filter  

▪ Click the Words you wish to Filter 
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▪ To clear the filter click the Sort & Filter button 

▪ Click Clear 

 

 

Custom Views 
In an Excel file, you might need to change the layout, before you print a report. For example,  

• in a customer report, the pricing columns are hidden.  

• for a supplier report, you filter for a specific product, and hide some columns.  

• for your internal reports, all the columns and rows are visible.  

To quickly show the different layouts, without any programming, you can create Custom Views, and 

select one from a drop down list.  

NOTE: In Excel 2010 and Excel 2010, the Custom View options are not available, if there is a named 

Excel Table, anywhere in the workbook. 

 

Set Up a Default Custom View 

If you’re creating Custom Views, you should create a default Custom View first, with the layout that you 

use most often. In this example, the default worksheet layout has all the columns and rows visible.  

To create a Custom View  
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• On the Excel Ribbon, click the View tab  

• Click Custom Views  

 

• In the Custom Views dialog box click Add  

 

• Type a name for the Custom View, then click OK  

 

Set Up the Alternate Custom Views 

After you set up the default worksheet Custom View, change the layout for the next Custom View. In 

this example columns C:E are hidden. 
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• Click the Custom Views command again, and add a Custom View for this layout – Print_Hidden.  

 

Create as many custom views as you need. This example has a filter applied for paper products, and the 

Custom View will include those filter settings.  

 

Add a Custom Views List to the Ribbon  

To make it easy to switch between Custom Views, you can add a drop-down list of Custom Views to the 

Excel Ribbon. (If you're using Excel 2010, you can add this drop-down list to the Quick Access Toolbar, 

instead of the Ribbon.) 

• In Excel 2010, right-click the Ribbon, and click Customize the Ribbon  
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• In the Excel Options window, at the right, click the + to the left of the View tab.  

• Click Workbook Views, to select that Group, and click the New Group button. That will add a 

new Group below Workbook Views.  

 

• With the new Group selected, click Rename  

• Type a name For the new group, and click OK – in this example the new group is called MY 

VIEWS  

     

• With the MY VIEWS group selected, click the drop down arrow for Choose Commands From  

• Click on Commands Not in the Ribbon  
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• Scroll down and click on Custom Views, then click Add, to move that command to the MY VIEWS 

group.  

 

• Click OK, to close the Excel Options window.  

Test the Custom Views 

On the Excel Ribbon’s View tab, you'll see the Custom Views drop down list. Select one of the Custom 

Views to see that layout. 

 

No Excel Tables With Custom Views  

Remember though – if you have a named Excel table in your workbook – on any sheet – the Custom 

Views options will not be available. Strange, but true. 
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Tables 

Create or delete an Excel table in a worksheet 
When you create a table (previously known as list) in a Microsoft Office Excel worksheet (worksheet: 

The primary document that you use in Excel to store and work with data. Also called a spreadsheet. A 

worksheet consists of cells that are organized into columns and rows; a worksheet is always stored in a 

workbook.), you can manage and analyze the data in that table independently of data outside the table 

 

 

If you do not want to work with your data in a table, you can convert the table to a regular range while 

keeping any table style formatting that you applied. When you no longer need a table, you can delete it. 

 Note   Excel tables should not be confused with the data tables (data table: A range of cells that shows 

the results of substituting different values in one or more formulas. There are two types of data tables: 

one-input tables and two-input tables.) that is part of a suite of what-if analysis commands. For more 

information about data tables, see Calculate multiple results with a data table. 
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Create a table 
You can use one of two ways to create a table. You can either insert a table in the default table style or 

you can format your data as a table in a style that you choose. 

Insert a table 

On a worksheet, select the range of cells that you want to include in the table. The cells can be empty or 

can contain data. 

On the Insert tab, in the Tables group, click Table. 

 

Keyboard shortcut  You can also press CTRL+L or CTRL+T. 

If the selected range contains data that you want to display as table headers, select the My table has 

headers check box. 

Table headers display default names if you do not select the My table has headers check box. You can 

change the default names by typing the text that you want.  

 Note   If you do not want to display table headers, you can turn them off later. For more information 

about how to turn table headers off, see Turn Excel table headers on or off. 

Tips 

After you create a table, the Table Tools become available, and a Design tab is displayed. You can use 

the tools on the Design tab to customize or edit the table. 

Unlike lists in Office Excel 2003, a table does not have a special row (marked with *) for quickly adding 

new rows. For more information about how to add or insert rows in a table, see Add or remove table 

rows and columns in an Excel table. 

Format data as a table 

On the worksheet, select a range of empty cells or cells that contain the data that you want to quickly 

format as a table. 

On the Home tab, in the Styles group, click Format as Table. 

http://office.microsoft.com/en-us/excel-help/redir/HA010062136.aspx?CTT=5&origin=HA010013764
http://office.microsoft.com/en-us/excel-help/redir/HA010013765.aspx?CTT=5&origin=HA010013764
http://office.microsoft.com/en-us/excel-help/redir/HA010013765.aspx?CTT=5&origin=HA010013764
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 Note   When you use Format as Table, Office Excel automatically inserts a table. 

Under Light, Medium, or Dark, click the table style that you want to use. 

 Note   Custom table styles are available under Custom after you create one or more of them. For 

information about how to create a custom table style, see Format an Excel table. 

Tips 

After you create a table, the Table Tools become available, and a Design tab is displayed. You can use 

the tools on the Design tab to customize or edit the table. 

Unlike lists in Office Excel 2003, a table does not have a special row (marked with *) for quickly adding 

new rows. For more information about how to add or insert rows in a table, see Add or remove table 

rows and columns in an Excel table. 

Convert a table to a range of data 
Click anywhere in the table.  

 Tip   This displays the Table Tools, adding the Design tab. 

On the Design tab, in the Tools group, click Convert to Range. 

 

 Note   Table features are no longer available after you convert the table back to a range. For example, 

the row headers no longer include the sort and filter arrows, and structured references (references that 

use table names) that were used in formulas turn into regular cell references. 

 

Pivot Tables 
 

Creating a PivotTable report 
In the example that follows, a PivotTable report is created from the original Excel data list shown in the 

previous section. Begin by selecting any cell in the list from which you want to create your table. On the 

http://office.microsoft.com/en-us/excel-help/redir/HA010013769.aspx?CTT=5&origin=HA010013764
http://office.microsoft.com/en-us/excel-help/redir/HA010013765.aspx?CTT=5&origin=HA010013764
http://office.microsoft.com/en-us/excel-help/redir/HA010013765.aspx?CTT=5&origin=HA010013764
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toolbar, click Data, and then click PivotTable and PivotChart Report. This action displays the PivotTable 

and PivotChart Wizard, which prompts you to follow these steps: 

Step 1: Specify the type of data source 

On the first page of the PivotTable and PivotChart Wizard, specify the type of data source on which the 

table will be based and whether you want to create a PivotTable report or a PivotChart report. 

1. Under Where is the data that you want to analyze? select Microsoft Excel list or database.  

2. Under What kind of report do you want to create? select PivotTable. Click Next.  

 

Step 2: Indicate the location of your source data 

On the second page of the wizard, indicate the location of your source data. If you're basing your 

PivotTable report on an Excel data list and you selected a cell in that list before invoking the wizard, the 

wizard already has the location of your data but merely prompts you to confirm the location. If your 

data source is an Excel data list that isn't currently open, click Browse to find it.  

 Note   Your Excel data list must include a unique field name at the top of each column. 

 

Step 3: Indicate where you want to put your PivotTable report 
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On the third page of the wizard, indicate where you want your PivotTable report to appear. To place the 

report on a new worksheet (always a safe choice), select New Worksheet. Otherwise, select Existing 

Worksheet and supply a range reference or name in the text box. Click Finish to exit the wizard. 

 

Laying out the PivotTable report 

When you have completed following the instructions in the PivotTable and PivotChart Wizard, Excel 

displays a blank table similar to the one that follows. The only remaining task is to drag field headings 

from the Field List dialog box to the appropriate places on the PivotTable report layout. 

 

For this example, from the Field List dialog box, the Channel and CatalogNo fields was moved to the row 

axis, the Quarter and Year headings to the column axis, and the Sales heading to the data area. You can 

put as many fields as you like in any of the areas of the layout. To remove a field, drag its heading off the 

layout.  
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 Note   If you find the Field List dialog box distracting, you can hide it by clicking its Close button. With 

the field list hidden, you can rearrange your PivotTable report by dragging field headings from their row, 

column, and page positions. To redisplay the Field List dialog box, on the PivotTable report toolbar, click 

Show Field List. 

Pivoting a PivotTable report 

To pivot, or rearrange, a PivotTable report, drag one or more field headings. For example, to move a 

field from the column axis to the row axis, all you have to do is drag it’s heading from the column area to 

the row area. In addition to transforming rows, you can change the order in which fields are displayed 

on the column or row axis. In this example, the Channel heading was dragged to the left of the Catalog 

No heading to produce the following PivotTable report. 
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Arrange Multiple Data Fields 

If you place two fields in the Data area of a 

Pivot Table, they might appear vertically 

arranged.  

In this pivot table, the Units and Total fields 

have been added to the data area in the 

Pivot Table Wizard. 

  

 

  

 

In the pivot table, the two data fields, Sum 

of Units and Sum of Total, appear in a single 

column, stacked vertically in the pivot table. 

This layout makes it difficult to compare the 

Units sold for each product or to compare 

the total sales per product. 

 

To make the data easier to read, you can 

rearrange the table layout. If you move the 

data fields into the pivot table's column 

area, each data field will appear in a single 

column. 

To change the layout, follow these steps: 

  

  

1. In the pivot table, point to the grey 

button for the Data field 

2. Hold the left mouse button, and 

drag the Data button onto the cell 

which contains the word 'Total'  

3. Release the mouse button  
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The Data fields will now be arranged 

horizontally, with each data field in a single 

column.  

  

 

 

    

Rename Data Fields 

When you add fields to the Data area, they are renamed, e.g. 'Units' becomes 'Sum of Units'. 

Instead of using these default names, you can change the field names to something shorter, 

or more descriptive. 

There are several ways to change the names, but the following is probably the easiest. 

1. Select the heading cell in the Pivot Table.  

2. Type a new heading.  

3. Press the Enter key.  

Note: The typed name can't be the same as the original field name. For example, if the 

original field name is Units, you can't change 'Sum of Units' to 'Units'. However, you can type 

the original field name, and add a space character at the end, e.g. 'Units ' or at the beginning 

-- ' Units' 

 

Set up the Pivot Table 

At the right is a pivot table which contains monthly 

sales figures for several products. In the pivot table, 

Date is in the row area, grouped by month. Product is 

in the column area, and Units sold, shown as Sum of 

Units, is in the data area.  

We can see the Grand Total for each month, and for 

each product code. 

Currently, there are only Normal calculations in the 

pivot table, no custom calculations. 
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Add a Custom Calculation 

To calculate a running total of units sold, for each 

Product, over the three months, we'll change the 

Units to a custom calculation. 

1. Right-click one of the cells in the Data area, 

and select Field Settings...  

2. In the Field Settings dialog box, type a name 

for the field, e.g. Sales  

3. Click the Options button, to expand the 

dialog box  

4. From the Show data as dropdown list, select 

Running Total in  

5. From the Base field list, choose Date  

6. Click the OK button  

Note: If you select a base field that isn’t in the row or 

column area, all the results will show a #N/A error. 

Also, if there’s an error in any month’s results, it will 

carry down through the remaining months.  

You can now see that there were 621 units of the 

A703 product sold by the end of February. The Grand 

Total column shows that 1355 units, of all products, 

were sold by the end of March. 

  

  

 

Change the Base Field 

Because you chose Date as the base field, each 

Product column shows a running total for the year, 

by month.  

If you select Product as the base field, the running 

total accumulates across the pivot table, in each 

month row, as shown in the pivot table at the right.  

In the February row, you can see that 326 units of the 

first product were sold. In the next column, you can 
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see that 345 units were sold, which includes the B306 

units. 

  

Running Totals with Multiple Row Fields 

For pivot tables with multiple fields in the row area, 

the running totals work the same way, but may be 

harder to follow as the layout becomes more 

complex.  

For example, in the original pivot table in this pivot 

table tutorial, we could move the Product field to the 

row area, as you can see in the pivot table at the 

right. All the original amounts are still shown, but 

they're all in the same column.  

At right is the pivot table as it looks before we add 

the running totals.  

  

  

When we add the Running Total custom calculation, 

with Product moved to the row area, the running 

total amounts are the same but are arranged 

vertically, as shown at the right.  

In the February section you can see that 621 units of 

the A703 product sold by the end of that month. 

The February total shows the running total for all 

products, at the end of that month. 
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When we add the Running Total custom calculation, 

with Product moved to the row area, the running 

total amounts are the same but are arranged 

vertically, as shown at the right.  

In the February section, you can see that 326 units of 

the first product were sold. In the next row, you can 

see that 345 units were sold, which includes the B306 

units. 

Because the Running Total is by Product, the month 

totals are blank. The last product in each month 

shows that month's total units sold. 
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Creating Excel Pivot Table Subtotals  
If your pivot table has only one field in the Row Labels area, you 

won't see any Row subtotals.  

In the pivot table shown below, Service is in the Row Labels area, 

Lead Tech is in the Column Labels area, and Labor Cost is in the 

Values area. Because Service is the only field in the Row Labels 

area, it has no subtotal. 

 

  

    

When you add another field to the Row Labels area, a subtotal is 

automatically created for the first field. In this example, the District 

field is added to the Row Labels area, below the Service field.  

 The Service field is an Outer Field, because there is a field 

below it (District).  

 The District field is an Inner Field, because there is NO field 

below it.  

Because Service is now an Outer Field, it automatically has a 

subtotal after each Service type. Each subtotal shows the name of 

the Service type, and "Total", such as Install Total. 
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Add Another Subtotal  

If you add another field to the Row Labels area, below the District 

field, the new field becomes the Inner Field, and District changes to 

an Outer Field. 

In the pivot table below, the Technician Count field was added 

below District, and the District field now has a subtotal after each 

District name. 
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Automatic Subtotal Summary Function  

When a subtotal is added to a pivot table, its Summary Function is 

set to Automatic. With that setting, the subtotal automatically uses 

the same Summary Function as the Value fields in each column. 

In the pivot table shown above, the Value fields are using the SUM 

function, so the subtotals also show the SUM of the values. 

In the pivot table shown below, the Value fields have been 

changed to the MAX function, so the subtotals also show the MAX 

of the values. A few of the MAX values are highlighted in green, to 

show that the values and both subtotals are the same. 

Even though the Summary Function has been changed to MAX, 

each subtotal still shows the name of the item, and "Total", such as 

Central Total. 
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Change the Subtotal Summary Function  

Instead of using the Automatic setting for subtotals, you can select 

a Custom setting. To change the setting: 

1. Right-click a label for the field in which you want to change 

the subtotal. In this example, right-click cell B5, which has 

the Install label.  

2. In the pop-up menu, click Field Settings  

3. In the Field Settings dialog box, click the Subtotals & Filters 

tab  

4. Under Subtotals, click Custom  

5. In the list of Summary Functions, click one or more 

function names  

6. Click OK to close the dialog box.  
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Show Multiple Subtotals  

In the Field Settings dialog box shown above, there are two 

functions, Count and Max, selected in the list of Summary 

Functions for the Service field. 

After selecting these functions, the pivot table shows two subtotals 

for each Service type. When you use Custom functions, the 

subtotal row shows the item name, and the name of the Function, 

such as Install Count. 

The subtotals for District are not changed, nor are the other values 

in the pivot table. 
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Slicers 
Create a slicer in an existing PivotTable 

1. Click anywhere in the PivotTable report for which you want to create a slicer. 

This displays the PivotTable Tools, adding an Options and a Design tab. 

2. On the Options tab, in the Sort & Filter group, click Insert Slicer. 

 

3. In the Insert Slicers dialog box, select the check box of the PivotTable fields for which you want 

to create a slicer. 

4. Click OK. 

A slicer is displayed for every field that you selected. 

5. In each slicer, click the items on which you want to filter. 

To select more than one item, hold down CTRL, and then click the items on which you want to filter. 
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Create a standalone slicer 

1. On the Insert tab, in the Filter group, click Slicer. 

 

2. In the Existing Connections dialog box, in the Show box, do one of the following:  

• To display all connections, click All Connections. This is selected by default.  

• To display only the recently used list of connections, click Connections in this Workbook.  

This list is created from connections that you have already defined, that you have created by using the 

Select Data Source dialog box of the Data Connection Wizard, or that you have previously selected as a 

connection from this dialog box. 

• To display only the connections that are available on your computer, click Connection files on 

this computer. 

This list is created from the My Data Sources folder that is usually stored in the My Documents folder. 

• To display only the connections that are available from a connection file that is accessed from 

the network, click Connection files on the Network. 

This list is created from a Data Connection Library (DCL) on a Microsoft Office SharePoint Server 2010 or 

Microsoft SharePoint Server 2010 site. A DCL is a document library in a SharePoint Foundation site that 

contains a collection of Office Data Connection (ODC) files (.odc). Typically, a DCL is set up by a site 

administrator, who can also configure the SharePoint site to display ODC files from this DCL in the 

External Connections dialog box. 

Tip If you do not see the connection that you want, you can create a connection. Click Browse for More, 

and then in the Select Data Source dialog box, click New Source to start the Data Connection Wizard so 

that you can select the data source that you want to connect to. 

Note If you select a connection from the Connection files on the network or Connection files on these 

computer categories, the connection file is copied into the workbook as a new workbook connection, 

and is then used as the new connection information. 

3. Under Select a Connection, click the connection that you want, and then click Open. 

4. In the Insert Slicer dialog box, click the check box of the fields for which you want to create a 

slicer. 

5. Click OK. 
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A slicer is created for every field that you selected. 

 

Format a slicer 

1. Click the slicer that you want to format. 

This displays the Slicer Tools, adding an Options tab. 

2. On the Options tab, in the Slicer Styles group, click the style that you want. 

To see all available styles, click the More button . 

 

Share a slicer by connecting to another PivotTable 

You can share a slicer with another PivotTable by connecting it to that PivotTable. You can also insert a 

slicer from another PivotTable by connecting to that PivotTable. 

Make a slicer available for use in another PivotTable 

1. Click the slicer that you want to share in another PivotTable. 

This displays the Slicer Tools, adding an Options tab. 

2. On the Options tab, in the Slicer group, click PivotTable Connections. 

 

3. In the PivotTable Connections dialog box, select the check box of the PivotTables in which you 

want the slicer to be available. 

Use a slicer from another PivotTable 

1. Create a connection to the PivotTable that contains the slicer that you want to share by doing 

the following: 

1. On the Data tab, in the Get External Data group, click Existing Connections 
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2. In the Existing Connections dialog box, in the Show box, make sure that All Connections is 

selected. 

Tip If you do not see the connection that you want, you can create a connection. Click Browse for More, 

and then in the Select Data Source dialog box, click New Source to start the Data Connection Wizard so 

that you can select the data source that you want to connect to. 

3. Select the connection that you want, and then click Open.  

4. In the Import Data dialog box, under Select how you want to view this data in your workbook, 

click PivotTable Report.  

2. Click anywhere in the PivotTable report for which you want to insert a slicer from another 

PivotTable. 

This displays the PivotTable Tools, adding an Options and a Design tab. 

3. On the Options tab, in the Sort & Filter group, click the Insert Slicer arrow, and then click Slicer 

Connections. 

 

4. In the Slicer Connections dialog box, select the check box of the slicers that you want to use. 

5. Click OK. 

6. In each slicer, click the items on which you want to filter. 

To select more than one item, hold down CTRL, and then click the items that you want to filter. 

Note All PivotTables that share the slicer will instantly display the same filtering state. 

Disconnect or delete a slicer 

If you no longer need a slicer, you can disconnect it from the PivotTable report, or you can delete it. 

Disconnect a slicer 
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1. Click anywhere in the PivotTable report for which you want to disconnect a slicer. 

This displays the PivotTable Tools, adding an Options and a Design tab. 

2. On the Options tab, in the Sort & Filter group, click the Insert Slicer arrow, and then click Slicer 

Connections. 

 

3. In the Slicer Connections dialog box, clear the check box of any PivotTable fields for which you 

want to disconnect a slicer. 

Delete a slicer 

Do one of the following: 

• Click the slicer, and then press DELETE. 

• Right-click the slicer, and then click Remove <Name of slicer>. 

 

Calculated Fields 
Create formulas in a PivotTable report 

Important    You cannot create formulas in a PivotTable report that is connected to an Online Analytical 

Processing (OLAP) (OLAP: A database technology that has been optimized for querying and reporting, 

instead of processing transactions. OLAP data is organized hierarchically and stored in cubes instead of 

tables.) data source. 

Before you start, decide whether you want a calculated field or a calculated item within a field. Use a 

calculated field when you want to use the data from another field in your formula. Use a calculated item 

when you want your formula to use data from one or more specific items (item: A subcategory of a field 

in PivotTable and PivotChart reports. For instance, the field "Month" could have items such as "January," 

"February," and so on.) within a field. 

For calculated items, you can enter different formulas cell by cell. For example, if a calculated item 

named OrangeCounty has a formula of =Oranges * .25 across all months, you can change the formula to 

=Oranges *.5 for June, July, and August. 

If you have multiple calculated items or formulas, you can adjust the order of calculation. 
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Add a calculated field 

1. Click the PivotTable report. 

This displays the PivotTable Tools, adding the Options and Design tabs. 

2. On the Options tab, in the Calculations group, click Fields, Items, & Sets, and then click 

Calculated Field. 

 

3. In the Name box, type a name for the field. 

4. In the Formula box, enter the formula for the field.  

To use the data from another field in the formula, click the field in the Fields box, and then click Insert 

Field. For example, to calculate a 15% commission on each value in the Sales field, you could enter = 

Sales * 15%. 

5. Click Add. 

Add a calculated item to a field 

1. Click the PivotTable report. 

This displays the PivotTable Tools, adding the Options and Design tabs. 

2. If items in the field are grouped, on the Options tab, in the Group group, click Ungroup. 

 

3. Click the field where you want to add the calculated item. 

4. On the Options tab, in the Calculations group, click Fields, Items, & Sets, and then click 

Calculated Item. 
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5. In the Name box, type a name for the calculated item. 

6. In the Formula box, enter the formula for the item.  

To use the data from an item in the formula, click the item in the Items list, and then click Insert Item 

(the item must be from the same field as the calculated item). 

7. Click Add. 

Enter different formulas cell by cell for calculated items 

1. Click a cell for which you want to change the formula.  

To change the formula for several cells, hold down CTRL and click the additional cells. 

2. In the formula bar (formula bar: A bar at the top of the Excel window that you use to enter or 

edit values or formulas in cells or charts. Displays the constant value or formula stored in the 

active cell.), type the changes to the formula. 

Adjust the order of calculation for multiple calculated items or formulas 

1. Click the PivotTable report. 

This displays the PivotTable Tools, adding the Options and Design tabs. 

2. On the Options tab, in the Calculations group, click Fields, Items, & Sets, and then click Solve 

Order. 

 

3. Click a formula, and then click Move Up or Move Down. 

4. Continue until the formulas are in the order that you want them to be calculated. 

View all formulas that are used in a PivotTable report 

You can display a list of all the formulas that are used in the current PivotTable report. 

1. Click the PivotTable report. 
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This displays the PivotTable Tools, adding the Options and Design tabs. 

2. On the Options tab, in the Calculations group, click Fields, Items, & Sets, and then click List 

Formulas. 

 

Edit a PivotTable formula 

Before you edit a formula, determine whether that formula is in a calculated field or a calculated item. If 

the formula is in a calculated item, also determine whether the formula is the only one for the 

calculated item. 

For calculated items, you can edit individual formulas for specific cells of a calculated item. For example, 

if a calculated item named OrangeCalc has a formula of =Oranges * .25 across all months, you can 

change the formula to =Oranges *.5 for June, July, and August. 

Determine whether a formula is in a calculated field or a calculated item 

1. Click the PivotTable report. 

This displays the PivotTable Tools, adding the Options and Design tabs. 

2. On the Options tab, in the Calculations group, click Fields, Items, & Sets, and then click List 

Formulas. 

 

3. In the list of formulas, find the formula that you want to change listed under Calculated Field or 

Calculated Item. 

 

When there are multiple formulas for a calculated item, the default formula that was entered 

when the item (item: A subcategory of a field in PivotTable and PivotChart reports. For instance, 

the field "Month" could have items such as "January," "February," and so on.) was created has 

the calculated item name in column B. For additional formulas for a calculated item, column B 

contains both the calculated item name and the names of intersecting items. 
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For example, you might have a default formula for a calculated item named MyItem, and another 

formula for this item identified as MyItem January Sales. In the PivotTable report, you would find this 

formula in the Sales cell for the MyItem row and January column. 

 

4. Continue by using one of the following editing methods.  

Edit a calculated field formula 

1. Click the PivotTable report. 

This displays the PivotTable Tools, adding the Options and Design tabs. 

2. On the Options tab, in the Calculations group, click Fields, Items, & Sets, and then click 

Calculated Field. 

 

3. In the Name box, select the calculated field for which you want to change the formula. 

4. In the Formula box, edit the formula. 

5. Click Modify. 

Edit a single formula for a calculated item 

1. Click the field that contains the calculated item. 

2. On the Options tab, in the Calculations group, click Fields, Items, & Sets, and then click 

Calculated Item. 

 

3. In the Name box, select the calculated item. 

4. In the Formula box, edit the formula. 

5. Click Modify. 

Edit an individual formula for a specific cell of a calculated item 
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1. Click a cell for which you want to change the formula.  

To change the formula for several cells, hold down CTRL and click the additional cells. 

2. In the formula bar, type the changes to the formula. 

Tip    If you have multiple calculated items or formulas, you can adjust the order of calculation. For more 

information, see Adjust the order of calculation for multiple calculated items or formulas. 

Delete a PivotTable formula 

Note    Deleting a PivotTable formula removes it permanently. If you do not want to remove a formula 

permanently, you can hide the field or item instead by dragging it out of the PivotTable report. 

1. Determine whether the formula is in a calculated field or a calculated item.  

Calculated fields appear in the PivotTable Field List. Calculated items appear as items within other fields. 

2. Do one of the following: 

• To delete a calculated field, click anywhere in the PivotTable report. 

• To delete a calculated item, in the PivotTable, click the field that contains the item that 

you want to delete. 

This displays the PivotTable Tools, adding the Options and Design tabs. 

3. On the Options tab, in the Calculations group, click Fields, Items, & Sets, and then click 

Calculated Field or Calculated Item. 

 

4. In the Name box, select the field or item that you want to delete. 

5. Click Delete. 

 

Reverse a pivot table 
Alt D + P 

Pivot table chart wizard 

How to Create a Reverse PivotTable  

http://www.myonlinetraininghub.com/pivot-tables-explained-excel-2007
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There comes a time when you are presented with data in a cross-tabular format but your analysis 

requires that the data be formatted into a traditional table (or normalized) structure. 

Your report is in this format… 

 

… but you need it to be in THIS format. 

 

How can this be achieved? 

The answer is simpler than you may think. 

The first thing you need to do is access a tool that, prior to Excel 2010, was fairly easy to reach. 
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It has now been pushed into the background of Excel 2010 and Excel 2010; that tool is the Pivot Table 

and Pivot Chart Wizard. 

This used to be the de facto standard tool for building Pivot Tables and Pivot Charts prior to the 2010 

redesign. 

The tool still exists within Excel, you just have to dig a bit to find its hiding place. 

Part A: Load the Pivot Table and Pivot Chart Wizard into your Quick Access Toolbar 

1. Click the small down arrow to the right of the Quick Access Toolbar (top left corner of Excel) and 

select More Commands… 

 

2. Click the dropdown arrow next to Choose commands from: and select Commands Not in the 

Ribbon. This will produce a list of Excel features not located on the Ribbon. Scroll down and 

select PivotTable and PivotChart Wizard. 
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3. Click the Add >> button in the middle of the Excel Options dialog box. 

 

This will place the PivotTable and PivotChart Wizard feature in the right column of selected Quick 

Access Toolbar features.  

 

4. Click OK to continue. 

Part B: Reverse the Pivot 

1. Click the PivotTable and PivotChart Wizard button on the Quick Access Toolbar 

 

 

2. In Step 1 of the wizard, select Multiple Consolidated Ranges from the top question and 

PivotTable from the bottom question then click Next >. 
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3. In Step 2 of the wizard, select I will create the page fields and then click Next >. 

 

4. With your cursor in the Range: field, highlight the area of data you are wishing to convert to a 

table and then click the Add button. IMPORTANT: DO NOT highlight any total columns or rows 

that may be to the right or below the data. In this example, the selected data would start in 

cell A2 and end in cell E9. Finish this step by clicking Next >. 
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5. In step 3 of the wizard, select New Worksheet and then click Finish. 
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This will produce a new pivot table similar to the one below. Do not worry about any of the numbers or 

layout; this is an intermediate step that will be discarded in the end. 

 

6. Double click on the Grand Total number (in this example, the number 20 in the lower right). This 

will generate your normalized table as seen below. 

 

Because not every row category contains a corresponding column category entry, those entries have no 

values. You can either filter out the “Blanks” or sort the list by value and then delete the rows with no 

values. 
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Notes: 


