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About this User Guide 
 

Why a User Guide? 

Simply put, because our customers asked for it! You wanted an easy-to-reference collection of information on ProFile’s functionality, organized and simple 

to use. You also wanted something that you could hand to seasonal hires and employees to help get them started with ProFile, without requiring a lot of 

coaching. 

 

For new ProFile customers you will find a wealth of easy-to-review material that covers the basic functionality of ProFile. You can come back to the User 

Guide as the tax season progresses and the way you use ProFile changes. 

 

For returning ProFile customers you will already know the basic (and even the advanced) functionalities within ProFile. The User Guide puts all the 

information in one convenient, easy-to-use document that you can review, print, and bookmark for future reference. 

 

Have More Questions? 

If something you need to know is not included in the User Guide, or if you need more information about ProFile and its functions, call us toll-free at 1-800-

452-9970. Our support hours are from Monday to Friday, 9:00 a.m. to 6:00 p.m. EST.  
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System Requirements for ProFile 
 

Before installing ProFile, please note the following important points: 

 .NET 4.5.2 installation and registration are required. 
 Internet connectivity is required for licensing and software updates. 
 Windows server software is not supported. 
 Network/workstation install UNC path is not supported. 
 Apple products are not supported. 

Note: ProFile supports only Windows 7 with service pack 1, Windows 8/8.1 and Windows 10. 

To get the best results from your software, ProFile requires the following minimum configuration: 
 

Processor 1 GHz or faster 

Operating System Windows 7 with Service Pack 1, Windows 8/8.1, or Windows 10 

Memory Minimum 2 GB (recommend 4 GB or higher) 

Hard Drive Capacity Approximately 900MB of free hard drive space for download and 1.5GB for installation 

Printer Windows-compatible printer(s) 

Display  16-bit or higher color 
 1024 x 768 minimum resolution 

Internet  Internet Explorer 11.0 or higher 
 A high-speed Internet connection is recommended 
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Getting Started with ProFile 
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Downloading and Installing ProFile 

 

Please be aware: an Internet connection is required to download and install ProFile. In addition, you must have administrator rights for the computer on 

which you wish to install ProFile. 

 

Download ProFile 

Navigate to the ProFile download page: 

http://profile.intuit.ca/professional-tax-software/download.jsp 

Determine if you are a new customer, returning customer, if you require OnePay, or a reinstall of ProFile. 

Follow the necessary instructions. In many cases, the requirement will include the download the ProFile installation file (titled “gpsetup.exe”). 

Your web browser may ask you to confirm if the file download can proceed…click “Yes” or “OK” when prompted. If prompted to select a location to store 

the installation file, we recommend your computer’s “Desktop” or “Downloads” folder, or another easy-to-find folder. 

The download may take several minutes. 

 

Install ProFile 

Locate the saved “gpsetup.exe” installation file. 

Double-click the file to begin the installation. If you are using Windows 8 or Windows 7, right-click the file and select the “Run as Administrator” option. 

Follow the dialogue boxes when prompted to install ProFile. 

 

 

 

 

 

 

 

 

 

http://profile.intuit.ca/professional-tax-software/download.jsp
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Activating ProFile 

 

Please be aware: an Internet connection is required to activate ProFile. In addition, you must have administrator rights for the 

computer on which you wish to install ProFile.   

 

Activating from ProFile icon 

Locate the ProFile icon on the computer desktop; it installed there during the download 

and activation process.  

Double-click the ProFile icon. 

The product code prompt displays when ProFile opens. The product code and license key 

information is on the purchase receipt. 

Enter your “Product Code” and “License Key” and click the “Activate” button. 

The product code and license key activate; ProFile displays a confirmation message. 

Click “Add another license” to add more licenses, if necessary. If you have purchased 

additional licenses for a module, enter the “Product Code” and “License Key” only once 

on each additional computer. 

Click the “I’m Done” button after all product codes have been entered. Activation may 

take a few minutes to complete. 

ProFile displays a message requesting a check to determine if you are using the most 

current version of the software. You can skip or delay this check, or click the “OK” button 

to proceed with the check. 

You have successfully activated ProFile. 
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QuickStart Menu in ProFile 

The QuickStart menu makes getting started with ProFile easier 
and faster. 

QuickStart menu tabs 

Each available module occupies a tab along the top of the 
QuickStart menu. 

Each module tab features a small black arrow that expands to list 
display previous tax years. 

 
Actions in the QuickStart menu 

Links from the QuickStart window lets preparers easily 
undertake the following:   

 create a new file or return 
 open an existing file that was previously saved 
 carry forward a file from a previous taxation year to the 

current taxation year 
 open a file that was recently worked on 
 access in-product Help, user forums, and more support 

resources 

 

Turn off the QuickStart menu 

 

The QuickStart menu can be turned off if you prefer not to use its functionality. 

 

Identify the checkbox in the bottom corner of the QuickStart menu. 

 

Toggle off the checkbox; the QuickStart menu will no longer appear when ProFile starts. 

 

To re-establish the QuickStart menu at a later time, select the “QuickStart” option under the “Help” toolbar menu. 
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Using a Trial License in ProFile 
 

A trial license gives preparers the opportunity to try the functionality of ProFile 
without any cost. 

 

What is included with a trial license? 

A trial includes access to all the modules and features ProFile has to offer, with the 
exception of filing completed tax returns.  

These features include:   

 T1/TP1 for Individual tax returns 
 T2 for Corporate tax returns 
 T3/TP-646 for Trust returns 
 FX/FXQ for additional forms (T4/T5, etc.) 

 
Getting a trial license 

Visit the “free trial” section of the ProFile website. 

Complete the information fields on the trial page and submit. 

The temporary license key and product codes are provided via email. 

Download ProFile, enter your license key/product codes, and begin your free trial. 

  

http://profile.intuit.ca/professional-tax-software/free-trial.jsp
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Using the Start Screen in ProFile 

 
The ProFile “start screen” contains most of the options and elements required to complete forms and slips. When starting ProFile for the first time, many of 
the action icons will be “greyed out” or inactive; once forms and slips are created, many will become active for use. 

 

The top toolbar menu 

ProFile’s top toolbar menu contains most options necessary to begin completing and filing client returns: 

 

The “File” menu includes many of the functional features for ProFile, including Open a return, Carry Forward, Import Data, and Print. 

The “Goto” menu activates the ProFile database options of Form Explorer and Client Explorer, as well as Hub. 

The “Form” menu allows users to open, print, and close forms in ProFile, as well as clear populated forms. 

The “Options” menu allows preparers to customize the ProFile environment, pricing, module, and database. 

The “EFILE” menu displays current and archived EFILE returns, as well as the ability to set EFILE options. 

The “Online” menu connects users to online support materials, the Live Community, and software updates. 

The “Training” menu lists in-product tutorials for individual tax years and modules.   

The “Window” menu gives ProFile users the ability to reorient the view of ProFile. 

The “Help” menu links users to support materials, flexible licensing options, and the in-product Help feature. 

  



 
15 

 

Setting Preparer Information in ProFile 
 

Preparer information can be conveniently entered in ProFile. This allows the 

“Preparer” section of ProFile “Info” forms to automatically populate whenever a 

new form is created. 

Select the “Environment…” option from the “Options” drop-down menu in the top 
toolbar. 

The “Environment Options” window displays. 

Select the “Preparer” tab; a list of information fields displays. 

Complete the necessary fields. 

Click the “OK” button. 

The preparer information saves. 
 

Automatically updating preparer information changes 

Preparers can set an automatic update for the “Preparer” section of returns when 
changes are retroactively made to the preparer information. For example, if the 
name of the preparer’s firm changes, the returns with the firm’s name 
automatically update to the new name. 

Select the “Module…” option from the “Options” drop-down menu. 

In the “General” tab, scroll down to the “Options” section. 

Activate the “Update preparer information on Info form” checkbox. 

Click the “OK” button; the setting saves.  
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Setting up for EFILE in ProFile 
 

Prior to using the EFILE function for a return, it is necessary to use the set-up 

wizard in ProFile. 

 

Setting up for EFILE: 

 

Select the “Set EFILE Password” option from the “EFILE” drop-down menu in 

the top toolbar. 

 

The “EFILE Wizard” displays. 

 

Click the “Next” button to proceed. 

 

During the “Set EFILE Password” process, users will require the following: 

 

 EFILE On-Line Number (from CRA) 

 EFILE On-Line Password (from CRA) 

 NetFile Quebec Number (if applicable, from MRQ) 

 NetFile Quebec Password (if applicable, from MRQ) 

 EFILE number (from CRA) 

 

Click the “Finish” button when all applicable information is entered. 

 

Note: if you are using an Options Package, you need to save the options package after entering in the new EFILE information 
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Creating a New File in ProFile 
 

Creating a new file or return in ProFile is quick and convenient. 

 

Note: only tax modules that have been purchased can be created in ProFile. 

However, previous tax years are made available for the purchased tax module. 

 

Creating a new file 

 

Open ProFile. 

 

Select the “New” option from the “File” drop-down menu in the top toolbar. 

 

A list of available modules displays in the menu. 

 

Select the desired module; a new return opens in ProFile. 

 

 

Creating Older Files 

 

There are three options under the “New” option in the “File” drop-down menu for older 

modules: 

 

 Older T1/TP1 Modules 

 Older T3 Modules 

 Older FX Modules 

 

Select the applicable option for creating an older module (e.g., T1/TP1); a list of previous 

tax years supported by ProFile displays. 

 

Select the desired module; a new return opens in ProFile. 
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Fast Reopening of Files 
 

ProFile lets preparers quickly reopen returns that they have recently worked on. 
 
 
Fast reopen of returns 

Click the arrow next to the file folder icon in the top ProFile toolbar. 

A list of recently opened returns displays.  

Select the return to continue working on; the return opens. 

Note: preparers can also review a list of recently opened returns under the “File” menu in the top ProFile toolbar. 
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Using Form Explorer in ProFile 

 
The “Form Explorer” feature allows preparers to 

locate individual forms, lines, and details within 

a client’s return. In addition, preparers can print 

forms from the Form Explorer and determine 

when it was last updated. 

 

Starting the Form Explorer   

Open ProFile. 

Open a return (e.g., a T1).  

Select the “Form Explorer” option from the “Goto” drop-
down menu in the top toolbar. 

The Form Explorer opens; the client’s name displays in the 
top-left corner. 

Using the Form Explorer 

Select a view option from the top-right menu buttons. 

View options include: 

 “List” displays all forms in the return 

 “Detail” displays details and/or status about 
all forms in the return 

 “Key” searches the return for key words (e.g., 
“RRSP”) 

 “Line” displays each line in every form in the return. 

Tip: hover the mouse over each form to see a full title. 

Double-click any form listed in the Forms Explorer; the form opens in ProFile. 

Click the “Print” button to print any form from the Form Explorer. 
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Carry Forward Files in ProFile 

 

Carry forward is a ProFile service that allows existing client information from 

previous year’s files to be “carried forward” into a new file, saving time and 

effort for preparers. Preparers can also carry forward a previous year’s ProFile 

file or a file prepared using a competitor’s product, as well as multiple files at 

one time. 

Carry forward files in ProFile 

Select the “Carry Forward…” option from the “File” drop-down menu in the top 
toolbar. 

The carry forward window displays. 

Select the module (e.g., T1) and tax year of the file to carry forward from the 
drop-down list. 

A list of applicable files displays. 

Select the specific file to carry forward. 

Click the “Carry forward” button. 

The selected file carries forward. 

Carry forward competitor files 

ProFile supports the carry forward of files for the following competitors: 
Taxprep, Cantax, and DTMax. 

2016-2017 TaxPrep-to-ProFile carry forward preview (T1)  
 
Supported TaxPrep versions include 2016.v1.0, 2016.v2.0, 2016.v3.0, 2016.v4.0, 
and 2016.v5.0. 
 
2016-2017 Cantax-to-ProFile carry forward preview (T1)  

Supported Cantax versions include 16.1.303.100, 16.2.303.107, 16.3.303.111, 
16.5.303.119, and 16.6.303.124. 

2016-2017 DTMax-to-ProFile carry forward preview (T1)  

The current version of the ProFile T1 allows carry forward of a DTMax T1 file.  
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Carry Forward Files in ProFile (continued…) 

 

Carrying forward multiple files using the Client Explorer database 

If the preparer used ProFile in the previous tax year… 

Select the “Client Explorer” option from the “Goto” drop-down menu 
in the top toolbar. 

The Client Explorer displays a list of last year's files. 

Click on the “Filter” button; the filter option window displays. 

Use the filter options to identify which files to carry forward. For 
example, if you only want to carry forward T1 files from the year 2016, 
you would select the “T1” module tab, then the “2016” year 
designation. 

Click the “Apply Filters” button. The files matching the selected filter 
options display. 

Select the files to carry forward. To select all files, right-
click in the window and select “Select All” from the pop-
up menu; all files highlight. 

Right-click on the selected file(s) and select the “Carry 
Forward Files” option from the menu.  

The file(s) carry forward. 

 

Related Article: Carry forward files using the Client 

Explorer database 

  

http://support.intuit.ca/profile/en-ca/document.jsp?product=profile-english&id=HOW14683
http://support.intuit.ca/profile/en-ca/document.jsp?product=profile-english&id=HOW14683
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Checking Version of ProFile 

 

ProFile is constantly undergoing improvements and adding to its features to benefit 

customers. It is important for preparers to have the latest version to ensure the full 

functionality of ProFile is available. 

In addition, knowing where and how to check the version of ProFile is helpful in the case of 

a support call; ProFile’s Care representatives will often ask which version of the software is 

in use when troubleshooting an issue. 

 

Checking ProFile version 

Open ProFile. 

Select the “About” option from the “Help” drop-down menu in the top toolbar. 

The “About” window displays. 

Review the ProFile version number (e.g. “2017.1.0”). 
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Updating ProFile to the Latest Version 

 
During the tax season, ProFile is often updated with new CRA information, tax rates, forms, and more. It is important to keep ProFile up to date to ensure 
compliance with the latest CRA requirements. The recommendation is to check - at the very minimum - once per week.  

ProFile can be updated two different ways: 

 manually, where the user manual checks 

to see if any updates are available 

 automatically, where the user allows 

ProFile to check itself if updates are 

available  

 

Manually updating ProFile  

Open ProFile. 

Select the “Check for Updates…” option from the “Online” drop-down menu in the top toolbar. 

ProFile connects to the Internet to see if there are any available updates. If there are, you are prompted to download and install the newest update.  

If no updates are available, click the “OK” button to close the window. 

 

Automatically updating ProFile  

Open ProFile. 

Select the “Environment…” option from the “Options” drop-down menu in the top toolbar; the “Environment Options” window displays 

Select the “System” tab. 

In the “Automatic Check for Updates” section, put a checkmark in the "Enable automatic check for updates" box. 

You can choose: 

 how frequently ProFile will check for updates 

 what time ProFile will check for updates 

 whether you would like to be notified before connecting to the Internet 

 whether you would like to be notified before downloading an update to your system 
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Using ProFile Notification Services 
 

The ProFile notification service provides timely and important information directly to 

customers. This may include CRA announcements, ProFile releases and patches, or critical 

issues. 

 

Start-Up Notifications 

 

Start-Up notifications display when ProFile starts; they are often urgent messages that 

affect most or all preparers. They may include reminders of recent software updates, CRA 

changes, or notices of service interruptions. 

 

 

ProFile in-application Notification Centre 

The in-application Notification Centre displays within the ProFile application, usually on the 

right side of the ProFile window. It lists recent notifications in the sequence they arrive. Each 

can be deleted if the information is no longer relevant the preparer.  Preparers can also turn 

the in-application Notification Centre to “off” status to no longer see notifications in the 

application. 

 

Information Call-out 

The Information Call-out highlights general, non-emergency information for ProFile 

customers. The call-out displays temporarily then removes itself from view. 
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Using Options in ProFile 
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Setting Environment Options in ProFile 
 

ProFile users can set options for their ProFile working environment. This includes 

PDF settings, form settings, reminders, security, and more. Select the 

“Environment…” option from the “Options” drop-down menu in ProFiel. 

Edit tab 

The “Edit” tab includes options for common tasks, such as allowing predictive 
typing, date stamping, SIN validation, and capitalization. 

Display tab 

The “Display” tab includes options for the display of ProFile, including font scaling, 
tab icons, and page breaks. 

File tab 

The “File” tab includes options for setting file directories, managing recently used 
files, and auto-saving files. 

Preparer tab 

The “Preparer” tab allows preparers to insert their personal and firm information, 
including RepID, Group ID, and initials. 

Discounter tab 

The “Discounter” tab allows a discounter to insert their personal and firm 
information, including “Discounter Registration Number”. 

Trustee tab 

The “Trustee” tab allows trustees to insert their personal and firm information. 

Audit tab 

The “Audit” tab allows preparers set audit and/or error styles, as well as establish standards to prevent a return from being prematurely filed.  

System tab 

The “System” tab includes options for setting shared folders, checking for software updates, and utilizing online features. 

PDF tab 

The “PDF” tab allows preparers specify PDF characteristics for printed returns, PDF archive directories, and PDF security. 
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Using File Pathing in ProFile 

 
About file pathing 

ProFile users can set where their client’s returns are stored. The file path can be changed 
or locked to prevent deletion or copying. 

 
Managing file paths 

Select the “Environment…” option from the “Options” drop-down menu in the toolbar. 

Select the “File” tab in the “Environment Options” window. 

Files paths display under the “File Directories” section of the window. 

Files in the file path display in the corresponding directory in Explorer.   

Click the “Lock” checkbox to lock the file path; the lock feature will default back to this file 

directory but can be changed even when locked. 
 

Changing file path 

Click on the file directory to change. 

Click the “show path” button. 

The “Browse” window explorer displays. 

Select a new location from the “Browse” window; click the “OK” button. 
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Using Module Options in ProFile 

 
Module options overview 

ProFile users can set options for each tax module (e.g., T1, T2, etc.) for which they are preparing returns.  
 

Select the “Module…” option from the “Options” drop-down menu in the top toolbar. 

 

Setting module options 

Each module tab includes an active “down” arrow; click the arrow to display the available tax years for the module display. 
 

General tab 

The “General” tab includes options for carry-forward, individual forms, access, and 
more. 

Data Locking tab 

The “Data Locking” tab allows preparers to set the criteria for locking a file. For 
instance, if the file carries forward or is transmitted. 

Variance tab 

The “Variance” tab allows the setting of the “Minimum Variance”, using the criteria 
of “Dollar” and/or “Percentage”. 

Disclaimer tab 

The “Disclaimer” tab includes the option to include a standard disclaimer on all 
prepared forms. 

T1/TP1 Review tab 

The “T1/TP1 Review” tab allows the setting of the “Variance Thresholds”, using the 
criteria of “Dollar” and/or “Percentage”. 
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Using Template in ProFile 

 
Templates allow preparers to save time and effort by creating 
commonly used communications that can be sent to one or more 
clients. 
 

Selecting templates 

Select the “Templates” option from the “Options” drop-down menu 
in the top toolbar. 

The “Template Editor” window displays. 
 

Using templates 

The template list includes the most-common communications 
required by preparers including engagement letters, client invoices, 
and payment emails. 

Both French and English templates are provided.  

Double-click any template; the template opens in the editor pane. 

Edit the template required and save for future use or additional 
editing and customization. 

 

Tip: press “F1” on any field in the Template Editor to learn more 
about its function. 
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Using Form Selection in ProFile 

 
Form selection overview 

The “Form Selection” menu allows preparers to set print options for forms. 
 

Selecting templates 

Select the “Form Selection” option from the “Options” drop-down toolbar 
menu. 

The “Form Selection” menu displays. 
 

Using form selection 

A list of print options displays in the “Form Selection” menu. 

This list includes the ability to set the print options for “File”, “Client”, and 
“CRA”. Individual forms are listed, including the option for setting language. 

Toggle any box to activate a print option for the particular form. 

At any time, you can restore your defaults by clicking the “Set Defaults”  
button. 

Tip: press “F1” on any field to learn more about its functionality.  
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Setting Pricing in ProFile 

 
The ProFile pricing feature provides a convenient method 

for preparers to set costs and bill clients for services.  

 

Getting started with pricing 

 

Select the “Pricing…” option from the “Options” 

drop-down menu in the top toolbar. 

 

The “Pricing Schedule” window displays.  

Pricing options 

Select the module for which to set pricing options for (e.g., 
T1)…the current and previous tax year pricing displays. 

Enter information for the GST registration number, invoice 
number, and GST/HST/PST rate. 

Select the invoice type: “Detailed”, or “Brief”. 

Select the invoice methodology: by “Schedule” or “Hour”. 

Insert costs for services (e.g., basic charge, capital gains, 
etc.) 

Click the “OK” button to save the pricing information.   

Carry forward pricing 

ProFile lets preparers carry forward pricing from previous tax year’s to the current tax year. 

Select the previous tax year (e.g. 2015 T1/TP1).  

Review the pricing for services.   

If the same pricing is to apply to the current tax year, click the “Carry Forward” button. 

Click “OK” when asked to carry forward prices to the current tax year.   

The previous tax year pricing displays in the current tax year. It can be changed at any time. 
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Using Flexible Licensing in ProFile 

 
Flexible licensing temporarily suspends a ProFile license on one computer in order for the license to be activated on another computer... without having to 
delete the license or purchase an additional seat. 

For example, you can suspend your Profile license on an office computer and activate the same Profile license on a laptop in order to meet with clients in 
the field. When you return to the office, simply suspend the license on the laptop and resume the license on your office computer. 

What is a "Seat"? 

The number of seats determines the maximum amount of users that can be activated on the Product Code and License Key combination: when you 
purchase a base license, you get one seat. When you purchase additional licenses, you get an increase to the number of seats that can be activated on your 
license. 

What is required to use Flexible Licensing? 

Flexible licensing requires 
 
•    Tax year 2016 or later license (earlier tax years are not supported at this time) 
•    ProFile version 2016.0.3 or later 
•    Internet connection during activation and suspension of license 

Can I still work offline? 

Yes. Once you have activated your license you can use ProFile without an Internet connection. Features like “Auto-fill my return” and EFILE will still require 
an Internet connection to work. 
 
What does Flexible Licensing Cost? 

There is no cost for flexible licensing. The feature is included as part of your license purchase. 

How many machines can I install ProFile on? 

Unlimited. ProFile is a free download, but the licensing determines what can be done with the program. You can add your licenses to as many computers as 
you wish with flexible licensing, but you can only have the number of licenses that you paid for active at the same time. 
 
Is Flexible Licensing going to be “ON” by default? 

No. The flexible licensing option is activated manually. 
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Flexible Licensing: Enable during Activation 

 
Flexible Licensing can be enabled during the ProFile 

activation sequence, for preparers who want to start using 

the feature right away. 

Enabling Flexible License during Activation: 

Enter your product code and license key during activation. 

Click the “Next - Setup Flexible Licensing” button.  

The “Flexible Licensing Settings” window displays. 

Click the “Enable flexible licensing on this computer” check 
box. 
 
Select either the “Manual” or the “Automatic” mode button 
to activate your choice. 

The “Manual” mode displays the choice of two additional 
options: 

 “Prompt me every time when I close ProFile” – 
selecting this option results in ProFile prompting the 
user to suspend your license when closing the 
application 
 

 “Don’t prompt me. I’ll do it manually” – selecting this 
option requires the user to suspend their license 
manually 
 themselves when closing the application 

Click the “Save” button to save your preferences.   
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Flexible Licensing: Suspending the License Automatically 
 

The “Automatic” mode automatically suspends or activates your 
licenses when you close and open ProFile, respectively.  

Note: a working Internet connection is required to suspend a license. 
 

Suspending the License Automatically: 

Select the “Configure Flexible Licensing” option from the “Help” 
drop-down menu in the top toolbar. 

The “Flexible Licensing Settings” window displays. 

Click the “Enable flexible licensing on this computer”  
box. 

Select the “Automatic” mode button. 

Click the “Save” button to save your preferences.   

Close the ProFile application, either by clicking the “X” icon on the 
application or by selecting the “Exit” option under the “File” menu. 

The ProFile application closes. 

A message displays indicating that your license is suspended on the 
computer. 
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Flexible Licensing: Suspending the License Manually 

 
Manual suspension occurs when the user suspends the licensing themselves 
in ProFile. 

Note: this process needs to be undertaken each time ProFile is closed to ensure 
the Flexible Licensing is properly suspended. Proper suspension ensures the 
license can be activated on another computer. 

Suspending the License Manually: 

Save any files being used in ProFile. 

Click the “X” icon on top-right corner of ProFile or select the “Exit” option under 
the “File” drop-down menu. 

A prompt displays asking if you would like to suspend your license and work 
 on another computer. 

Select the “Yes” option. 

A message displays, confirming the license suspension can proceed. 

A confirmation message displays when the license is suspended. 
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Setting Client Explorer as the ProFile Database 
 

ProFile users can set and use Client Explorer as the database when preparing 

client returns. 

 

Setting Client Explorer as database 

 

Open ProFile. 

 

Select the “Database” option from the “Options” drop-down menu in the top 

toolbar. 

 

The “Database/Client Explorer Options” window displays. 

 

Select the “Use Client Explorer” option; the Client Explorer menu displays. 

 

Select the “Personal Server” or “Shared Server” option. 

 

Select the folder path if a shared server is being used. 

 

To create a shared server, click the “Setup Wizard” button. 

 

Click the “Advanced” button to explore additional options, including the 

handling of clients with no SIN. 

 

Click the “OK” button when completed. 

 

The Client Explorer is set as the database option. 
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Using Filters in Client Explorer 
 

By default, the Client Explorer displays all files 

regardless of the type of return, taxation year, or 

status. Filters allow the display of only those files that 

meet the criteria preparers set, such as those which 

have been filed or those which are still outstanding. 

 

Viewing Filter options 

 

Select the “Client Explorer” option from the “Goto” 

drop-down menu in the top toolbar. 

 

A list of all available returns for clients displays. 

 

Click the “Filter” button. 

 

The filter window displays at the bottom of the ProFile program. The filter pane contains all filter options for clients and their returns. (3) 

 

Options for filtering display in individual tabs and include: 

 available tax years 

 modules (e.g., T1, T2, etc.) 

 Client Status 

 EFILE status  

 SEND status 

 EVENT 
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Using Filters in Client Explorer: T1 EFILE Filtering Example 
 

Example: filter for only T1 returns that are completed and ready to EFILE. 

 

Select the “Client Explorer” option from the “Goto” drop-down menu in the top toolbar. 

 

Click the “Filter” button; the filter window displays at the bottom of the window. 

  

Selecting forms 

 

Select the checkbox on the “T1” tab and clear the other module tabs by unchecking them. This displays only T1 forms. 

 

Select the checkbox for the current year (e.g., “2016”) on the “T1” tab and clear the checkboxes for all other years by unchecking them. This displays only 

2016 tax year.  

 

Select the checkbox for “Carry Forward” in the “Client Status” column and clear the other statuses by unchecking them. This displays only those returns in 

the “carry forward” state. 
 

 

Select the checkbox for “Eligible” in the “T1 EFILE Status” column and clear the other statuses by unchecking them. This displays only those returns in the 

“eligible” state. 

 

Applying filters 

 

Click the “Apply Filters” button.  

 

Click the “All” tab in the Client view.  

 

The current year T1 files that are eligible for EFILE display.   
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Printing Reports in Client Explorer 
 

The Client Explorer’s report function allows preparers to print data from ProFile returns. 

Note: a query applies only to returns of a single type (e.g., 2016 T1 returns). 
 

Setting Client Explorer Report Parameters and Data: 

 

Open Client Explorer in ProFile. 

 

Filter returns by the necessary parameters (e.g., tax year, module, status, etc.). 

 

Select the “Select All” option under the “Database” drop-down menu in the top toolbar.  

 

Select the “Print Report” option under the “Database” drop-down menu; the “Create 

Report” window displays. 

 

Click the “Options” button; the “Report Options” window displays. 

 

Select the “Fields” tab.  

 

The options display for creating a report, including column, rows, titles, and 

organization of report content. 

 

Select the data to be listed under each report heading. 

 

Running a Client Explorer report 

 

Click the “Save” button in the “Report Options” window; the report paramaters save. 

 

Click the “OK” button; the “Report Options” window closes. 

 

Click the “Print” option from the “Create Report” window. 

 

The report compiles and is sent to the designated printer. 

 

 



 
41 

 

Using Mailing Labels in Client Explorer 
 

ProFile’s Client Explorer provides preparers with a simple and convenient method 
for printing mailing labels. 
 
Choosing a mailing label 

Select the “Setup Mailing Labels…” option from the “File” drop-down menu in the 
top toolbar. 

The “Label Selection” window displays. 

Select the return type (e.g., T1) and tax year (e.g., 2016) from the tab menu. 

Select the “Label Type” from the drop-down menu. 
 

Creating a new mailing label 

Click the “New Label” button; the “Label Details” fields activate and populate.  

Enter the specific measurements for the label in the “Label Details” fields.  

Save the name of the new label in the “Label Details” field (e.g., “T1 2016 Label”). 

Click the “OK” button; the label saves and the window closes. 
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Using Mailing Labels in Client Explorer (continued…) 

 

Printing mailing labels 

Open the Client Explorer database in ProFile. 

Select the client for which the label will apply. 

Select the “Print Mailing Labels” option under the “Database” drop-down menu in the top toolbar; 
the “Print Labels” window displays. 

Select the number of labels to print under the “Copies” field. 

Select the checkbox for “Print only one label for coupled return?”, if required. 

Click the “OK” button; the label(s) print. 
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Batch EFILE in Client Explorer 

ProFile users can build and EFILE files to CRA for multiple clients and returns at once. Doing so creates a 
“batch”, a set of individual and client files ready for EFILE, which ProFile sends to CRA or RQ all at once.  

Batch and transmit files 

Open Client Explorer in ProFile. 

Select the type of EFILE operation to perform from the drop-down menu; ProFile filters the list of files to 
reflect only those with the selected status (e.g., “T1 - EFILE Eligible”). 

The list of eligible files displays. 

Select the files to include in the batch transition. 

Right-click on the selected files and select the “Build EFILE File…” option from the menu. 

The build window displays. 

If necessary, specify the ty  pe of EFILE file to create, or the agency, data type, or slip type. 

Click the “OK” button. 

The EFILE files build; the build status of each return displays as “Successful” or “Failed”.  

Click the red “X” to display the issue with the “Failed” return. Click the “Transmit now” button; the files transmit to CRA; you can also select the “Transmit 
later” option. 
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Batch EFILE in Client Explorer (continued…) 

Transmit batch files at a later time 

Select the “Transmit later” button when prompted during the batch process. 

When ready to EFILE, select the “EFILE Online Batch” option from the “EFILE” drop-down menu 
in the top toolbar. 

ProFile searches the EFILE folder and sub-folders for any unsent transmission files and displays 
those meeting the criteria. 

Select the files to EFILE and click the “OK” button. 

The EFILE files build; the build status of each return displays as “Successful” or “Failed”.  

Click the red “X” to display the issue with the “Failed” return. 

Note: CRA stipulates a two-second pause between the EFILE of each file; this may result in a slower-than-expected process to EFILE for customers with a 

large number of files in a batch. 
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Batch Carry Forward Files 

Carry forward of batch files is an option available in ProFile that easily beings previous 
year’s returns forward into the current module. 

Open Client Explorer in ProFile.  

Client Explorer displays a list of tax return files. 

Click on the “Filter” button; the filter menu displays at the bottom of the Client Explorer 
window. 

Select files to carry forward (e.g. all T1 files) and the previous year (e.g. 2016) from the 
checkbox menu.  

Click the “Apply Filters” button; the filter displays all files meeting the selected criteria. 

Click the “Select All” link on the left-side menu; all files select.  

 Click the “Carry Forward Files” option on the left-side menu. 

The files carry forward. 
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Batch Printing Forms in Client Explorer 

It is easy to print pre-configured print sets for multiple clients at the same time.  

Printing forms for a group of clients 

Open Client Explorer. 

Select the designation for clients in the drop-down list (e.g. “T1 - EFILE Eligible”); the clients matching the 
designation displays. 

Select the clients to batch print. 

Select the “Print file” option from the “Database” drop-down menu. 

Profile automatically selects the forms to print for each file based on the print job and print setting 
options configured in the “form selection” window. For example, ProFile detects that each client selected 
will receive an “overdue invoice” letter. 

The files print. 
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Batch Printing Forms in Client Explorer (continued…) 

Printing the same forms from each file 

It is simple to print the same form for multiple clients at once in a batch. For example, a ProFile user 
may want to print a form for each client so that is can be mailed for the client’s signature. 

Note: when printing forms from multiple clients at the same time, you can print only forms from 
files of the same module and year. 

Printing forms 

Select the designation for clients in the drop-down list (e.g. “T1 - EFILE Eligible”); the clients 
matching the designation displays. 

Right-click in the client list and choose the “Select All” option from the menu. 

All forms are selected. 

Select the “Print Forms in File…” option from the “Database” drop-down menu. 

The “Print Selected Forms” window displays.  

Enter the name of the form to print (e.g. “t2038”). 

Note: to print several forms, enter them all with a semi-colon as a divider between each form (e.g. 
“t2038; t2036”). 

Click the “OK” button; the forms print.  
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Using Queries in Client Explorer 
 

Note: a query applies only to returns of a single type (e.g., 2015 T1 returns). 

The Client Explorer’s query function allows preparers to produce a list of files with 
specific values for batch printing or to include on a report. Queries can also select data 
to export or to select files that require mailing labels. 

The query function filters the client list to compare fields and display the matching 
client files. A query can be applied for any field in the client file, including client city, 
debt level, return status, or age. 

Query example 

 a preparer wishes to select all clients who have birthdates prior to January 1, 
1934, but later than December 31, 1932: these are the clients who turned age 
69 during 2002 

 
Running a query 

Set Client Explorer as the database option in ProFile.  

 

Open Client Explorer in ProFile; a list of clients displays. 

 

Click the “Filter” button; a list of options displays. 

 

Select the module to be queried (e.g., T1) and tax year to be queried (e.g., 2016). 

 

Click the “Advanced” button; the “Advance Filters” window displays.  

 

Click the “New” button; the “Advanced Filter” window expands to display the “Add” 

button and three “Conditions” for queries. 

 

Click the “Add” button; the “Add Condition” window displays. 
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Using Queries in Client Explorer (continued…) 
 

 

Setting conditions for queries 

 

In this instance, we will be querying client invoices for amounts no greater than than 

$10,000. 

 

Click the drop-down menu in the “Condition” field of the “Add Condition” window; a 

list of conditions displays. 

 

Select the condition necessary for the query. For example, you may be seeking value 

“not greater than” the amount of $10,000. If this condition is selected, no amount 

greater than $10,000 displays in the query results. 

 

Click the drop-down menu in the “Compare to” field of the “Add Condition” window; 

a list of conditions displays. 

 

Set the condition necessary for the query. For example, if you are querying invoices for 

billings of less than $10,000, select the appropriate invoice field to query.  

 

If this query will be used again at a later time, enter the query name in the “Field 

Name” field (e.g. “Invoices less than 10K”).  

 

Click the “Add” button; the newly created query saves in the query list. 

 

In the Client Explorer, click the “Apply Filters” button. The query runs and displays 

results. 
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Overview of ProFile Hub 
 

Hub is a document management dashboard that helps you access customer information quickly and seamlessly so you may process returns more 
efficiently.  
  
Within Hub, you can access client contact information, check the status of a return and review any notes that may have been added. 
  
Within Hub, you have access to document management sources, such as Link, to help you gather information from your clients in one secure place. Hub will 
be your one-stop shop for all of your data sources and much more. 
 
What modules does Hub support? 
 
Hub supports T1 and T2 modules. 
 
Does Hub support Auto-fill my Return (AFR)? 
 
Yes. 
  
How does Hub work with Inuit Link? 
  
Hub works effortlessly with Link, a user-friendly online portal that helps you collaborate more effectively with your clients to gather their information for 
tax season. 
  
Through Link, you can seamlessly create and send personalized requests to clients to request documents and information. You can also leverage templates 
already created within Link or create specific requests based on previous year’s returns. 
  
You are also able to send reminders within Link if you would like to follow-up on outstanding items. 
  
Together, Intuit Hub and Link streamline document management in ProFile. 
  
How much do Hub and Link cost? 
  
Hub and Link are complimentary with 2016 ProFile. Customers need to have purchased a ProFile T1 module. 
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Initial Setup of Hub 
 

Note: preparers should download the latest version of ProFile 

before undergoing the Hub setup process. 

Setting up Hub 

Open the ProFile application.  

Select the “Hub” option from the “Goto” drop-down menu in the 
top toolbar. 

The “ProFile Hub Set Up” window displays.  

Select the “Enable ProFile Hub” check box.  

The options menu for Hub set up becomes active. 

Select an option from the “How are your ProFile client files 
stored?” section; preparers select “Local Server” or Network 
Server” for file storage. 

Click the “Browse” button in the “Where are your client files stored?” section. 

Select the location where client files are stored; this allows Hub to access client information. 

Click the “Read files” button. 

The Hub interface populates with returns; these files originate from the location selected in 
the “Where are your client files stored?” section.  

Select the applicable tax year from the drop-down menu to filter imported returns.  

The list of client returns displays. 
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Import Data via Auto-Fill my Return (AFR) in Hub 
 
Note: a completed T1013 form is required before a preparer can 
import data to Hub via AFR. 

 

Importing Data in Hub 

Open ProFile. 

Select the “Hub” option from the “Goto” drop-down menu in the top 
toolbar. 

Hub opens, displaying the list of clients. Add a new client if required. 

Identify the client to undergo data import. 

Click the “Run CRA Import” link in the “CRA IMPORT” column. 

A prompt displays inquiring to the completion of a T1013 for. 

Click the “OK” button to proceed. 

The ProFile “CRA Data Import” window displays. 

Complete the prompts; the data import process in Hub is identical to that in ProFile 
from this point onwards. 
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Using Filters in Hub 
 

Hub allows preparers to filter the tax year of returns in the client list. 

Preparers can view returns from specific years or from all years. 

 

Setting filters in Hub 

 

Open ProFile.  

 

Select the “Hub” option from the “Goto” drop-down menu in the top toolbar. 

  

Hub opens, displaying a list of clients.  

 

The filter drop-down menu displays at the top of the client list. 

 

Select the drop-down menu; a list of available tax years displays.  

 

The “All years” designation also displays. 

 

Select the applicable option to filter. 

 

The filtered results display in the client list. 
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Using Checklists in Hub 

 
Hub allows users to maintain a checklist of tasks and/or requests assigned to a client. This list generates automatically based on the client's prior-year 
return that can be added to or changed as needed. 

  
Reviewing a checklist 
  
Open ProFile. 
  
Select the "Hub" option from the "Goto" drop-down menu in the top 
toolbar.   
  
Hub opens, displaying a list of clients. Identify the client that requires a 
checklist for (e.g., "Brown, Dan"). Click the "Invite" button associated with 
the client. 
  
The "Invite Clients to Use Link" window opens. Select the "Edit" link from the "Checklist" option. 
  
The "Edit Document Checklist" window displays. The checklist details the client, the 
individual requests made to the client (based on the previous-year's requests) and the 
action that can be undertaken. 
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Using Checklists in Hub (continued…) 
 
Deleting an existing checklist entry 
  
Identify the checklist entry to be deleted.  
  
Click on the "trash can" icon next to the checklist entry under the "ACTION" 
menu; the entry deletes. 
  
Note: Hub users will not see a confirmation window; the checklist entry deletes 
immediately. 
  
Click the "Done" button. The checklist updates and the "Edit Document Checklist" window closes. 
  
Click the "Invite" button in the "Invite Clients to Use Link" window. 
  
The invitation with the checklist is sent to the client. 
  
 
Adding a new checklist entry 
  
Click the "Add New Request" button in the "Edit Document Checklist" window. 
 
A new blank checklist entry field is created. 
  
Enter the new checklist entry (e.g., "Travel receipts"). 
  
Click the "Done" button. The checklist updates and the "Edit Document 
Checklist" window closes.  
  
Click the "Invite" button in the "Invite Clients to Use Link" window. 
  
The invitation with the checklist is sent to the client. 
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Using Questionnaires in Hub 
 

The questionnaire template in Hub allows users to compile and send questions via email for clients to answer.  

 

Questionnaire templates are customizable to the type of clients, their location, or any other need. Response types can include either “Yes/No” or “Open-

ended” responses.  

 
Opening a questionnaire template 

Open ProFile.  

Select the “Hub” option from the “Goto” drop-down menu in the top toolbar. 

Hub opens, displaying a list of clients. 

Identify the client to whom you want to send an engagement letter (e.g., “Brown, John”). 

 

Click the “Invite” button associated with the client. 
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Using Questionnaires in Hub (continued…) 

The “Invite Clients to Use Link” window opens. 

Select the “Edit” link from the “Engagement Letter” option. 

The “Edit Questionnaire” window displays. 

Users can undertake the following actions: 

 edit the existing questions 

 remove an existing question 

 create new questions 

 assign an answer type 

 delete a question 

 create a new questionnaire template 

The questionnaire is sent to the selected client and responses are tracked 
under their entry in Hub. 

Related Articles 

Click here to review our full suite of Hub articles. 

 

  

https://profile-en.community.intuit.ca/articles/1623666-intuit-hub-and-link-information-articles
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Using Engagement Letters in Hub 
 

Engagement letters allow a preparer to communicate with 

clients via letters that are personalized and reusable to reduce 

time and effort. 

 

There are two options for personalizing an engagement letter 

in Hub: 

 

 use an existing engagement letter from a template 

 

 create a new engagement letter 

 

Using an existing engagement Letter 

  

Open ProFile. 

 

Select the “Hub” option from the “Goto” drop-down menu in 

the top toolbar. 

 

Hub opens, displaying a list of clients. 

 

Identify the client to whom you want to send an engagement 

letter (e.g., “Brown, John”).  

 

Click the “Invite” button associated with the client.  

 

The “Invite Clients to Use Link” window opens.  

 

Select the “Edit” link from the “Engagement Letter” option. 
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Using Engagement Letters in Hub (continued…) 
 

The "Edit Engagement Letter” window opens. 

 

Click the drop-down menu at the top of the window; a list of existing 

letter templates displays. 

 

Select the template to be edited and sent to the client (e.g., “Letter of 

Engagement”). 

 

The template-editing window displays. 

 

Make any edits in the template-editing window.  

 

Click the “Add” button above the editing window to save any changes. 

 

Click the “Done” button; the engagement letter saves.  

 

Click the “Invite” button in the “Invite Clients to Use Link”; the 

engagement letter is sent to the client. 
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Using Engagement Letters in Hub (continued…) 

 
Adding a new engagement letter 

  

Open ProFile. 

 

Select the “Hub” option from the “Goto” drop-

down menu in the top toolbar. 

 

Hub opens, displaying a list of clients. 

 

Identify the client to whom you want to send an engagement 

letter (e.g., “Brown, John”).  

 

Click the “Invite” button associated with the client.  

 

The “Invite Clients to Use Link” window opens.  

 

Select the “Edit” link from the “Engagement Letter” option. 
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Using Engagement Letters in Hub (continued…) 
 

The “Edit Engagement Letter” editing window displays. 

  

Click the “ADD” button above the letter content. 

 

The “New Engagement Letter” window displays. 

 

Enter the name of the new template in the field (e.g. “Receipt Request 

Letter”). 

 

Click the “OK” button. 

 

The new letter  is added to the drop-down list of available engagement letter 

templates. 

 

Add the necessary content and information to the new engagement letter. 

 

Click the “Done” button; the template saves. 

 

The new letter is available under the drop-down menu when creating 

future engagement letters. 

  

Click the “Invite” button in the “Invite Clients to Use Link”; the new 

engagement letter is sent to the client. 
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Overview of ProFile Link 
 

Intuit Link is a secure, web-based portal that accountants use to gather tax data and responses from their clients. 
  
What are the benefits of Link? 
  
Link provides several benefits to a preparer’s clients, including but not limited to:  

 clarity on what a preparer needs to prepare a client’s tax return(s) 
 flexibility to collect and share tax data year-round from any device 
 convenience of providing preparers with materials via pictures taken with a mobile device or from a financial institution 
 ability to keep track of what material has been submitted or is still outstanding 
 bank-level encryption to protect client data 

How much does Link Cost? 
  
Link is complimentary with 2016 ProFile and later years. Customers need to have purchased a ProFile T1 module or current year Service Pack. 
  
 How do I review documents my client has provided?  

You can check the responses from clients in Hub; the details of their responses display in Link. 
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Accountant View in Link 
 
The “accountant” view in Link displays the majority of information that a preparer needs to manage client invitations and acceptances. 
 

Tax year selection: filter the client list by the appropriate tax year 

Clients: displays clients that have been added to Link 

Firm Settings: details the firm information, notification settings, and template options 

New Features: details new Link features as they become available 

Learning Library: opens an external link to the “Link Learning Library” 

Invitation status: details status of invitations, including those accepted, pending, declined, and done. 

Client details: lists the name, progress, activity, and actions for each client in Link 

Client activity: details recent client activity, such as acceptance of invitations or completed tasks 

Invitation Reminder: sends clients a reminder that a previous invitation is still pending 

Add New Client: adds a new client to the client list 
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Adding a Client to Link’s Accountant View 
 

Preparers can add clients into the “Accountant” view in Link to help track communications and progress in delivering materials (receipts, forms, etc.) 

 
Navigating to Hub 

Open ProFile. 

Select the “Hub” option from the “Goto” drop-down menu in the top toolbar. 

Sign in to Hub using your “One Intuit” username and password. 

A list of clients in Hub displays. 

Select the appropriate module (e.g. “T1 Module”) from the drop-down menu in the top left corner of Hub. 

The list of Hub clients filters. 

 

For T1 clients 

Create a new “T1 Individual” client return in ProFile. 

Navigate to the Hub application; the client named in the newly created T1 displays. 

Click the “Invite” link under the “Intuit Link” column for the new client. 

The new client information exports from ProFile and displays in Link. 
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Adding a Client to Link’s Accountant’s View (continued…) 

 
For non-T1 clients 

Note: ProFile displays the Link status of clients that have been invited from ProFile. Those created within Link as described below will NOT be connected to 
the desktop program in any way. 

You can create the new client (Individual) in Link and the new client will flow back to your ProFile Online client list. 

Navigate to the Link website: 
 
https://link.intuit.com/accountant/login/#/signin 
 
Sign in using your “One Intuit” username and password. 

Link opens; a list of clients who have accepted the invitation displays. 

Click the "Add New Client" button from the right-side menu. 
 
The "Add Client" window displays. 
  
Indicate if the client is an "Individual" or "Organization". 
  
For an "Individual", populate the "First Name", "Last Name", and "Email" fields. "Mobile 
Phone" is an optional field. 
  
For an "Organization", populate the "Organization Name" and "Email" fields. "Work 
Phone" is an optional field. 
  
Click the "OK" button; the client is added to the client list. 
 

 

  

https://link.intuit.com/accountant/login/#/signin
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Sorting Client List in Link 
 
Preparers can sort the client list in Intuit Link to display and identify clients of a particular status. 

Categories for sorting include: 

 “NAME” 
 “TYYY PROGRESS” (e.g., “TY16 PROGRESS”) 
 “LAST ACTIVITY” 

  

Example: Sorting alphabetically by “NAME” 

Log in to the Intuit Link site.  

Select the “Clients” link on the left-side menu. 

The list of clients displays. 

Click the text within the column header (e.g. “NAME”). 

The sort order displays, listed alphabetically by the client’s last name. 

 Note: users must click on the text itself, not the space surrounding the text to sort the order list.  
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Using Email Templates in Link 

Intuit Link’s custom email templates allow 
preparers to streamline communications with 
clients by creating unique email content that can 
be easily re-utilized, rather than having to copy-
and-paste or rewrite emails from previous 
examples. 

Email templates can include invite emails, 
reminder emails, and request emails. 

Creating custom Email templates 

Login to the Intuit Link site.  

Select the “Clients” link on the left-side menu; 
the client list displays. 

Select the client. 

Click the “Firm Settings” option from the left-side 
 menu.  

The “Firm Settings” display. 
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Using Email Templates in Link (continued…) 

Click the “Email Templates” link in the menu bar. 

Click the “New Template” button. 

Complete the “New Template” fields: 

 “Template Name” gives the new template a name (e.g., “Due Date Email”) 
 

 “Email Subject” gives the email a title that a client will see in their inbox (e.g., 
“A due date is approaching for return forms”) 
 

 “Email Body” is the text that a client will see in their inbox (e.g., “This is a reminder that 
March 15th is the due date for all return forms to be provided”) 

Click the “Save” button. 

The new email template displays under the “Email Templates” menu.  
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Using the Active Auditor in ProFile 
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Using the Active Auditor in ProFile 

 
Profile’s Active Auditor displays messages that relate to the data file. These 

include passive audit messages, notices, processing errors, overridden fields, fields 

that have memos attached, fields with review marks, and EFILE-related messages. 

 

Error messages or errors that may restrict processing the return display in red 

text. 

 

Accessing the Active Auditor 

 

The Active Auditor is accessed two ways: 

 

 select the “Active Auditor” icon in the top toolbar menu 

 

 right-click on any form and select the option “Show Auditor” from the 

menu 

Selecting Active Auditor options 

Note: setting the Active Auditor options in one location applies the settings 
for all modules Open ProFile. 

Select “Environment…” from the “Options” drop-down menu in the top toolbar. 

Select the “Audit” tab; the audit options window displays. 

Each section of the audit options window has pre-set default selections. 

Note: modules may display different tabs in the Active Auditor based on the nature of the module itself, rather than settings. 

“Preferences” settings 

The “Preferences” section of the “Audit” tab includes settings that affect the display of warnings.  

Note: ProFile recommends the “Show Auditor Tabs” option be selected to provide the clearest feedback and indication of errors on forms. 
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Using the Active Auditor in ProFile (continued…) 

 “Summary Tab Includes” settings 

The “Summary Tab Includes” section of the “Audit” tab includes options that display in the auditor toolbar. Each of the selected options displays related 
errors in the corresponding Active Auditor tab. 

“Prevent Filing” settings 

The “Prevent Filing” section of the “Audit” tab includes options that halt the filing of the form. Errors created by the violation of these options must be 
cleared before filing can take place. 

“Remove Audit Messages” settings 

The “Remove Audit Messages” section of the “Audit” tab includes options as to who can remove errors in the Active Auditor for a form.  

Note: Profile recommends one or both options be selected; otherwise error messages in the Active Auditor cannot be cleared to allow filing.- 

Clearing Active Auditor messages 

Error messages display as red text in the Active Auditor tabs. 

Double-click on an error warning in the tab. 

The error circles in red on the form. 

Resolve the error; the specific error in the tab details the issue. 

In some cases, the error – as identified by ProFile – may actually be acceptable to the 
preparer and/or the client. For example, an RRSP amount may be acceptable but ProFile 
suggests the amount is outside the range expected by CRA and determines it to be an 
“error”. 

In such cases the individual selected in the “Remove Audit Messages” section of the “Audit” tab can “sign-off’, or approve, the “error”.hghg 
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Using Review Marks in ProFile 

Preparers assign review marks while undertaking returns in ProFile. Preparers use review marks to indicate if 
field contents are correct and verified or if the field requires further review or data from a client.  

Review marks appear on the ProFile top toolbar menu as red icons: check marks, an” X”, and a question mark.  

Types of review marks 

There are four types of review marks available in ProFile: 

 Preparer sign-off: the preparer of the return must provide sign-off 

 Partner sign-off: the partner of the return must provide sign-off 

 Correction required: the field requires a correction (amount, etc.) 

 Question: the data provided in the field prompts a question or clarification 

Using review marks 

Open the return that requires review marks. 

Select the appropriate review mark from the top toolbar menu; the mouse pointer changes to an arrow with the 
corresponding mark attached.  

Click on the appropriate field in the return to apply the review mark; the review mark appears over the black status box 
to the right of the field. 

Save the return. The added review marks are retained in the return until addressed/removed by the preparer.  
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Using additional ProFile features 
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Using Intuitive Copy in ProFile 

The “copy and paste” function allows preparers to save time when it is necessary to create a copy of a business statement already in use. 

For example, a preparer may be completing business statement for non-spousal partners in a T1 return. Using “copy and paste”, it is not necessary to re-
enter the same business data in both files.  

Using Form copy and paste 

Open ProFile. 

Complete the necessary statement in the client file.  

Select the “Copy Form” option from the “Edit” drop-down menu in the top toolbar. 

Open the data file for the partner.  

Open a blank copy of the same statement in the partner’s file. 

Select the “Paste Form” option from the “Edit” drop-down menu in the top toolbar; the blank form populates. 

Edit/complete the populated form for this client.  

Intuitive Copy and Paste 

ProFile business statements include a section for partner details, including the name, social insurance number, and percentage of share in the partnership. 
“Intuitive copy and paste” allows this information to be copied quickly into each partner form. 

Finalize all business statement data. 

 Select the “Intuitive copy” option from the “Edit” drop-down menu in the top toolbar; the statement’s data copies. 

Open the business statement in the partner’s file. 

Select the “Intuitive paste” option from the “Edit” drop-down menu in the top toolbar; the copied data pastes into the partner’s statement. 

ProFile automatically adjusts all amounts and partner details. Attached memos and tapes also copy to the partner’s business statement. 
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Attaching Tapes in ProFile 
 
Using ProFile, preparers can attach tapes to fields. The “Attach Tape” feature 
functions much like an adding machine that performs and records calculations.  
 
Tape options are managed in the “Options” -> “Environment…” -> “Edit” tab in 
ProFile. 
 
 Attaching a tape 
 
Open a file in ProFile. 
 
Select a field to attach a tape.  
 
Right-click and select the “Attach Tape” option from the menu. 
 
The “Tape” window displays. 
 
Enter a description (e.g. “Shirts”) into the left-side field of the table. 
 
Enter a value (e.g., “$500.00) into the right-side field of the table. 
 
Press the <Tab> key to cycle through the fields and start a new row.  
 
Press the <Enter> key; the total is calculated and inserted into the selected field on 
the form. 
 
The background color of the field changes to green when a field has a tape  
attached. 
 
Note: Only the sum of a tape - not individual entry details - are printed or transmitted 
with the tax return data. The details and descriptions are for preparer reference only.  
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Attaching Tapes (continued…) 

 
Clearing an Attached Tape 
 
Open the file with the attached tape in ProFile. 
 
Select the field from which an attached tape is to be cleared.  
 
Right-click and select the “Attach Tape” option from the menu. 
 
The “Tape” window displays. 
 
Click the “Clear” button; the tape clears. 
 
Click the “OK” button; the window closes and the tape clears from the field. 
 
 
Copying a Tape from One Field to Another 
 
Open the file with the attached tape in ProFile. 
 
Select the field with a tape attached. 
 
Right-click and select the “Copy Memo/Tape” option from the menu.  
 
Select the destination field for the copied tape. 
 
Right-click the destination field and select the “Paste Memo/Tape” option from the menu. 

 
The tape attaches to the destination field. 
 
Note: when pasting a tape to a destination field, the value of the destination field will be set to the total in the tape. If that destination field is also a 
calculated field, ProFile sets the override flag on that field. 
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Attaching Memos in ProFile 

Preparers can attach memos to fields on all ProFile forms. Memos are short notes and 
reminders, like “sticky notes”. Memos are useful for leaving notes or reminders for 
partners or reviewers to read. 

Note: memos do not print or transmit over the Internet with a tax return file or affect the 
calculation of a return.  

Memo text displays in a pop-up window when hovering the mouse over a field with a 
memo.  

Fields with attached memos also appear in the “Memo” and “Summary” tabs in the Active 
Auditor.  
 

Attaching a memo 

Right-click in a field and select the “Attach memo” option from the menu.  

The “Memo” window displays. 

Enter the memo content into the text field in the “Memo” window. 

Click the “OK” button. 

The memo attaches. The color background of the field changes to green. 
 

Clearing a memo 

Right-click in a memo field and select the “Attach memo” option from the menu.  

Click the “Clear” button. 

Click the “OK” button. 

The memo text clears from the form field. 
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Attaching Hyperdocs in ProFile 

ProFile’s “HyperDocs” feature allows multiple documents in any format to attach to a 
form or field in a return.  

Note: HyperDocs are stored with the preparer files but are not included with T1 EFILE or 
TP1 NETFILE transmissions. 

Attaching HyperDocs 

Open a form in ProFile. 

Select the field to attach a HyperDoc. 

Select the “HyperDocs…” option from the “File” drop-down menu in the top toolbar. 

The “HyperDocs” window displays. 

Click the “add” button in the top-right corner of the window. 

Navigate to the location of the document to attach. Select the document and click the “OK” button. 

The options window displays. 

Select one of the options presented: 

 “Embedded” documents open in “read-only” state and cannot be edited in ProFile 
 

 “Linked” documents open from the source and can be edited in ProFile; any changes are saved 
in the source document in the file location 

Click the “OK” button; the document attaches to the field as a HyperDoc. The field displays in green 
color, indicating the HyperDoc attachment. 
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Attaching Hyperdocs in ProFile (continued…) 

Detaching HyperDocs from a field 

Right-click on the field with the attached HyperDoc. 

Select the “Detach HyperDoc” option from the menu. 

The document detaches and the field restores to its default color. 

Note: the document remains attached to the form but is not linked to a 
specific field.  

Removing HyperDocs from a form 

Select the “Hyperdocs…” option from the “File” drop-down menu in the top 
toolbar. 

The “HyperDocs” window displays. 

Select the document from the HyperDoc list of attached documents. 

The red “X” logo in the top-right corner activates. 

Click the red “X” logo. 

Click the “Yes” button to confirm the removal of the document.  

The document detaches from the form. 
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Setting up Data Monitors in ProFile 

ProFile’s “Data Monitor” feature displays any number of fields at the bottom of the “Edit” window. By default, the software monitors several key fields in 
the client file. Preparers can observe the totals for these fields change while working on different forms in ProFile.  

Selecting fields for data monitoring 

You may decide to monitor different fields. Then, as you make changes in other areas of the file, look at the bottom of the screen to see the effect those 
changes have on the fields you are monitoring.  

A monitor amount that appears bold means that the field was affected by the last recalculation. A monitor amount that appears in red is a negative 
number.  

Hint: Right-click on the Data Monitor and select “Monitor” from the menu to access several options, including the option to rename the monitor field 
description. This makes it easy to remember what is being monitoring.  
 

To monitor a data field to the Data Monitor  

Click and hold on the field. After a brief pause, the cursor will change to an arrow carrying a white square.  

To replace another field already on the Data Monitor, drag the cursor to that cell and release the mouse button. The field code (or name, if there is one), 
along with the current value of the field, will appear in the monitor cell.  

To add a new cell to the Data Monitor (on a new row, if necessary) drag the white square and release your mouse button when the cursor is over top of the 
+ symbol in the bottom right corner of the ProFile window. 

 

 

  

  

Related Articles: 

To add more than four (4) data monitors, review the support article. 

To transfer data monitors to a new computer, review the support article. 

  

http://support.intuit.ca/profile/en-ca/document.jsp?product=profile-english&id=HOW14689
http://support.intuit.ca/profile/en-ca/document.jsp?product=profile-english&id=HOW25277
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Using Multiple Windows in ProFile 
 

The “multiple windows” features allows the preparer to view two ProFile returns, each in its own window. This is a 

useful feature when the preparer needs to see two returns side-by-side for clarity or comparison. For example, a 

preparer can open two T1 returns and view them at the same time, rather than having to toggle back-and-forth 

between them. 

Opening multiple windows outside ProFile 

Open two or more returns in ProFile. 

Click the “tile window” icon in the ProFile top toolbar. 

The returns open in individual windows on the desktop. 

Click the “tile window” icon in each individual window to collapse the return back into 

ProFile. 

 

Opening multiple windows inside ProFile 

Open two or more returns in ProFile. 

Select the appropriate option from the “Window” drop-down menu in 

the top toolbar. These include: 

 Tile Horizontally: the returns are “stacked” on top of each other 

 Cascade: the returns each open in a smaller window that can be 

manipulated 

 Launch Current Window: the current return opens in a new 

window outside ProFile 

 

Toggling between multiple open returns 

Select the “Window” drop-down menu in the top toolbar. 

Any open returns displays at the bottom of the menu; the active 

window is marked with a checkmark. 

Select any return listed in the menu to display it. 
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Viewing EFILE Reports in ProFile 
 

EFILE reports provide preparers with the date, time, and the confirmation 

number of the EFILE from CRA. 

 

To view reports from files used during current EFILE and NetFile services 

Select the “Reports” option from the “EFILE” drop-down menu in the top 

toolbar, and then select the “Current” option. 

The “Open EFILE Report” window displays. 

Select the type of file in the “Files of type” field from which you want to 

generate a report: 

 EFILE Submission files (*.TAX) 

 TP1 NetFile Submission files (*.EAX) 

 Session logs (*.SLG)  

Session logs are descriptions of events that occurred while you were 

connected to the NetFile Québec website. If you choose "Session logs", 

select a session log and click the “Open” button to view the full report. 

For other file types, select the option and click the “Open” button; ProFile 

displays the report information. 

Click the “Print” button from the report to print a copy for your records. 
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Viewing EFILE Reports in ProFile (continued…) 
 

Setting up a shared EFILE folder 

If you installed ProFile onto a shared network folder, you can use the 

default folders created during installation. For each module that uses 

EFILE, you will find appropriate EFILE folders within each module's files 

folder. 

Alternatively, you can use any shared folder on your network as a shared 

EFILE folder. To do so, you must specify that folder on each workstation. 

 

For T1/TP1 returns 

Select the “Options…” entry from the “EFILE” drop-down menu in the top 

toolbar.  

Select the option for the EFILE service that you want to configure from the 

left-side menu. 

Select the “Common” option under the “T1” section of the “General” menu. 

Click the “Browse” button; the “EFILE Directory” window displays. 

Navigate to the folder used as a shared EFILE folder. 

Click the “OK” button. 

Click the “OK” button in the EFILE options window; the folder is assigned. 

 

For T2 returns 

Select the “T2 EFILE” option under the “T2” section of the “General” menu. 

Click the “Browse” button; the “EFILE Directory” window displays. 

Navigate to the folder use as a shared EFILE folder. 

Click the “OK” button. 

Click the “OK” button in the EFILE options window; the folder is assigned. 
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What Can Undergo EFILE in ProFile 
 

The CRA makes changes each tax year as to what can (and cannot) undergo the EFILE process.  

ProFile maintains a support article that addresses the EFILE status of all modules, as well as independent forms that undergo EFILE separately from the 

return (e.g., T1013, T1135, etc.). 

Review the list of what can undergo EFILE from ProFile. 

  

http://support.intuit.ca/profile/en-ca/document.jsp?product=profile-english&id=INF28401
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Managing T1 returns in ProFile 
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Overview of T1 Module in ProFile 
 

What is a T1? 

The T1 General Tax Form (usually referred to casually as a “T1”) is used by individual Canadians to complete their personal income tax return.  

It has five sections for personal and income information: 

 Identification, for details including name, address, SIN and marital status. 

 Total income, for declaration of income, including employment, self-employment, disability, foreign income, and any others. 

 Net income, where childcare expenses, union dues, and more are subtracted from total income. 

 Taxable income, where allowable deductions like capital gains are subtracted from net income. 

 Refund or balance owing, where it is determined if any money must be paid or any money is paid back. 

 

Submission Dates for T1 

April 30 of the following year is the deadline for most individuals to file a T1 return, or June 15 of the following year for self-employed individuals and their 

spouses or common-law partners.  

In the event that April 30 falls on a weekend, the following Monday becomes the deadline. 

If the individual owes money to the CRA, the due date of April 30 is the hard due date for filing. 

Late payment results in penalties being applied by the CRA. 
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Using T1013 Authorizations for T1 in ProFile 
 

The T1013 form “Authorizing or Cancelling a Representative” authorizes a 

representative to access a taxpayer’s tax information via the CRA.  

Thing to know about T1013 authorizations 

 the taxpayer can grant access to a person, a group, or a business. To 

grant a group online access, the GroupID number must appear 

correctly in Part 2 of T1013. 

 the T1013 is submitted to the Government of Canada separately 

from the T1 return  

 the T1013 can be completed either manually or automatically by 

ProFile 

 the T1013 has two levels of authorization: Level 1 allows CRA to 

disclose information to the representative, and Level 2 allows CRA to 

disclose information to the representative and the representative to 

request change.  

 parts 3, 4, and 5 of the T1013 must be completed manually 

Entering preparer credentials 

ProFile lets you enter preparer credentials; select the “Environment…” option 

under the “Options” drop-down menu in the top toolbar. Select the 

“Preparer” tab and complete the credentials. The information populates Part 

2 (both sections A and B) of the T1013.  

 

Setting default options via the software options 

Most of the T1013 content is automatically populated; select the “Module…” option from the “Options” drop-down menu in the top toolbar. Options are 

presented under the “Carry Forward” and “New Files” section of the “Module Options” window. Select the required options; the T1013 populates based on 

the selections, which should also include the purpose of the form, representative information and authorization, and the level of authorization. 

 

EFILE the T1013 

Select the “EFILE the T1013 for this taxpayer” option from the “EFILE” drop-down menu in the top toolbar. The T1013 only transmits if Part 2 A is selected. 

Related Articles 

For detailed steps on completing the T1013, visit the support article. For detailed steps on EFILE of the T1013 from T1, visit the support article.  

http://support.intuit.ca/profile/en-ca/document.jsp?product=profile-english&id=HOW25344
http://support.intuit.ca/profile/en-ca/document.jsp?product=profile-english&id=HOW25345
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Using T1135 EFILE for T1 in ProFile 
 

All Canadian resident taxpayers (including non-resident trusts 

deemed resident in Canada by section 94 of the Act) are required to 

file Form T1135, Foreign Income Verification Statement, if at any 

time in the year the total cost amount of all specified foreign 

property to the taxpayer was more than $100,000 (CAD). 

Note: The T1135 does not EFILE with a T1 or T2; it must undergo 

EFILE independently. 

 

Finding the T1135 

Enter “t1135” into the forms search bar in the top toolbar menu. Select the “T1135” Foreign income verification statement” from the search results. 

The initial question is located in the “Filing” section of the T1 “Info” tab: 

 

EFILE the T1135 

 

 

 

 

Ensure the related “Yes/No” question is answered affirmatively on the T1 “Info” tab. 

Select the “EFILE the T1135…” option from the “EFILE” drop-down menu in the top toolbar; a transmission window displays indicating that the T1135 is 

ready to transmit.  

Click the “OK” button; the T1135 transmits to CRA and a confirmation number is provided.  

Note: the confirmation number can also be viewed on the information tab of a T1 or T2 return, post-transmission. 

 

Related Articles 

Common questions regarding T1135 are found on the CRA website. 

Review the support article regarding the T1135. 

https://www.canada.ca/en/revenue-agency/services/tax/international-non-residents/information-been-moved/foreign-reporting/questions-answers-about-form-t1135.html
http://support.intuit.ca/profile/en-ca/document.jsp?product=profile-english&id=GEN88885
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Using CRA Data Import with AFR for T1 in ProFile 
 

Auto-Fill My Return (AFR) is a secure CRA service. It allows authorized representatives to 

electronically request and receive certain tax information to fill in parts of their client’s income 

tax and benefit return. ProFile offers the service for both single and multiple individual T1 

returns. 

Acquiring AFR permissions 

The tax preparer must have a valid authorization from the taxpayer to access the “Represent a 
Client” website. There are two ways to acquire this authorization: 

 the taxpayer can access CRA's My Account service. Preparer’s request that the taxpayer enter 
the Rep ID to authorize the preparer as an individual, a Group ID to authorize a group of 
representatives, or a business's Business Number (BN) to authorize all employees of a 
business 

 request the permission of the taxpayer to file a “T1013 - Authorizing or Cancelling a 
Representative” form 

 

Importing data with AFR 

Open or create a T1 return. 

Select the “Import CRA data” option from the “File” drop-down menu in the top toolbar; the 

“CRA Data Import Tool” window displays. 

Click the “Launch CRA Website” button; the CRA's “Represent a Client” window launches in a 

separate browser window. 

Sign in to the CRA site. The “CRA Data Import” window lists the clients whose SINs can be 

entered into the CRA website. 

Select the client and click the “Next” button to provide confirmation; the CRA system 

processes the request. The “Successfully Connected” message displays when the connection 

has been made between the ProFile and CRA systems.  

ProFile’s “Data Import Worksheet” window displays; the default display setting is the “basic” view. Click the “+” icon next to each statement to reveal the 

“expanded” view of the information which displays more details. 

Review the data and forms to be imported; if correct, click the “Import Selected Data” button. Click the “Close” button. 

To review the data imported, click on the Data Import tab in ProFile's Auditor. 
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Using ReFILE for T1 in ProFile 

If you are an EFILE service provider, you can use ReFILE to send T1 adjustments online for tax years 
2015 and 2016 on behalf of your clients. The ReFILE service allows you to change the same lines 
that individual taxpayers can with the “Change my Return” service in “My Account”. 
 

Who can use ReFILE?  

Preparers can use the ReFILE service under the following conditions: 

 you have ProFile version 2016.4.3 or later (for tax year 2015 and 2016 ReFILE)  

 you have level 2 authorization from your client 

 the initial return was filed online via EFILE 

 the initial return was assessed 

 you have acquired a new sign-off of a revised T183 from client 
 

What tax years does ReFILE support? 

ReFILE is supported for 2015 and 2016 tax years with the latest ProFile version (2016.4.3 or later). 
 

Undertaking the ReFILE process 

Open a T1 return that has already undergone EFILE and for which a CRA assessment has been received. 

Save the return as a new file, using the “Save As...” option from the “File” drop-down menu in the top toolbar.   

Enter the new information that mandates a ReFILE into the return. For example, a client has received an unexpected T4 indicating additional income.  

Open a “T1ReFILE” form. 

Ensure the client information (SIN, Name) is correct and enter the current date in the “Date of ReFILE” field. 

Select the “Yes” option in the “Is this an amended tax return?” field. 

Reprint and get the client to sign off on a new T183. 

Select the “EFILE/ReFILE this return” option from the “EFILE” drop-down menu in the top toolbar.   

You will get a new confirmation number on the return’s “Info” page.  

Related Articles 

Review the support article for a list of detailed steps, additional resources and a FAQ about ReFILE. 

http://support.intuit.ca/profile/en-ca/document.jsp?product=profile-english&id=INF31265
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Using a Direct Deposit Request in ProFile 

The Direct Deposit Request form allows a refund, tax credit, or payment to be directly deposited into a taxpayer’s account. 

If you used EFILE to file a return, complete the Direct Deposit 
Request form to change the direct deposit information already 
provided to the CRA. 

Regarding Direct Deposit service 

Do not complete this form if you already use the direct deposit 
service and your banking information has not changed. 

Your direct deposit request will stay in effect until you change the 
information or cancel the service. 

Eligible deposit types 

The form is for the following types of deposits: 

 income tax return refund 
 Goods and Services Tax / Harmonized sales tax credit (GST/HST), including certain related provincial payments 
 Working Income Tax Benefit (WITB) advance payment 
 Canada Child Tax Benefit payment 
 Universal Child Care Benefit payment 
 Canada Pension Plan payment 
 Old Age Security payment 
 Veterans Affairs payment 

You can also use the online Direct Deposit form if you do not use EFILE and you need to update your banking information with the CRA. 
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Using Preauthorized Debit (PAD) for T1 in ProFile 
 

Pre-Authorized Debit (PAD) is a CRA feature that allows tax professionals to submit 

a payment to CRA on behalf of taxpayer clients who have an amount due on their 

current-year T1 Personal returns. This feature saves the taxpayer time over 

printing a T7DR(A) form and making the payment in-person at their Bank. 

Note: complete a PAD and EFILE it for each taxpayer. If there is a spouse with 
balance owing, the spouse requires his or her own PAD form to be completed and 
undergo EFILE.  

 
Completing the PAD Form   

Complete the taxpayer’s T1 Personal return in ProFile and EFILE. 

Select the “Form Explorer” option from the ProFile “GoTo” menu. 

Search for “T1PAD” and open the PAD form. 

Note: if the taxpayer has completed the T1DD form, you can retrieve their banking 
information from the T1DD to automatically populate the PAD form. 

Change the “Do you wish to set up Pre-Authorized Debits (PAD) for current year tax owing” value from “no” to “yes”: 

 
 
 

Enter the amount to be paid into the “Total amount you would like to pay through PAD (single one-time payment) field. 

For payment in full, check the “Pay in full” checkbox. For partial payment, enter the amount in the value field. 

Enter a payment date; the date must be between five days and one year in advance of the current date. 

Enter details of the bank and account the payment is being made from. 

The PAD form is completed. 
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T1: Preauthorized Debit (PAD) (con’t…) 
 

Completing the T183 Form   

Select the “Form Explorer” option from the GoTo” drop-down menu in the top toolbar. 

Search for “T183” and open the T183 form from the results.  

Complete “Part C” of the T183 form, including the current date, date of payment, amount, 

and branch information. 

Print the T183 form and acquire a physical signature from the taxpayer. 

Print and save the T183 form and retain a copy for the preparer’s records. Provide the taxpayer 

with a copy of the physical, signed form.  

 

EFILE the PAD Form from the T1   

Return to the taxpayer’s T1 form that underwent EFILE. 

Select the “EFILE Pre-authorized Debit for this taxpayer...” option from the “EFILE” drop-down 

menu in the top toolbar. 

The PAD form undergoes EFILE; the preparer receives a confirmation number that populates the 

PAD form (field “T1PAD confirmation number”) and on the information page following the EFILE. 

 

Additional information 

Read the CRA guide on PAD for more information.  

Review a detailed support article on PAD for ProFile customers. 

 

  

http://www.cra-arc.gc.ca/gncy/mkpymnt/prthrzdbt-eng.html
http://support.intuit.ca/profile/en-ca/document.jsp?product=profile-english&id=INF31270
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Using Express Notice of Assessment (ENOA) for T1 in ProFile 

ENOA is a CRA service that allows individuals and authorized representatives to view the basic result of an assessment immediately after filing a return and 
to receive the full notice of assessment the next day. 

The instant assessment results provide the status of the return with a summary of the 
refund, amount owing, or a zero balance and deposit information, if applicable. 

The full notice of assessment provides an account summary with the result of the assessed 
return showing a refund, a zero balance, or a balance owing, tax assessment summary, 
explanation of changes and other information, and RRSP/PRPP deduction limit statement.  

Note: While the CRA processes most ENOA requests within 24 hours, some cases may 
require up to five days for processing. 
 
Making the initial ENOA request  

Open the return that ENOA is being sought for. 

Select the “View Notice of Assessment (ENOA)” option from the “EFILE” drop-down menu 
in the top toolbar. The ENOA wizard displays in ProFile. Review the wizard content and 
click the “Next” button. 

If this is a spousal return, select a specific spouse from the drop-down menu, then click the 
“Launch CRA Website” button 

The ENOA wizard indicates that the CRA website is launched in a separate browser 
window. Navigate to the “CRA Login” browser window and enter the user ID and password 
information. Click the “Login” button. 
 
In the CRA web browser, the ENOA “request processing” status displays. 
 
The CRA web browser displays the SIN of the client for whom the ENOA request is being 
made; if the number correctly corresponds to the client, click the “Next” button. 
 
A new browser displays the details of the successful ENOA request; this page can be saved 
or printed. 
 
Click the “Close” button; it is now necessary to wait a minimum of 24 hours to repeat the 
request and acquire the full ENOA summary.  
 
More information: review our full support article for more information on ENOA and FAQ. 
  

http://support.intuit.ca/profile/en-ca/document.jsp?product=profile-english&id=INF31261
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Using Couple’s Returns for T1 in ProFile 

Creating a couple’s return 

Open or create the T1 return for the client.  

On the “Info” form, select either "Married" or "Living common-law" for the marital status. 

Click the “switch to spouse” button on the top toolbar menu; the “Couple Returns” 
window displays. 

Choose whether to create a new return for the spouse, or couple the file to an existing return.  

 select “Create a new return for spouse” to open a new return for the spouse, or 

 select “Open an existing return” to browse to a file on your hard drive and select it 

Note: after combining the data, ProFile will ask if you want to delete the original file for the 

spouse. Delete the file to avoid duplication or possible confusion of the original spouse's file 

and the same return in the new coupled file.  

Select the “Save” option from the “File” drop-down menu in the top toolbar. 

ProFile saves both spouses' tax returns in the same data file. This keeps the tax returns together as file operations are performed on the tax return file 
(e.g., backing up to a disk).  

Once returns are coupled, select <F5> on the keyboard to toggle between the returns. 

Uncoupling a couple’s return 

Open the coupled return.  

Select the “Uncouple” option from the “File” drop-down menu in the top toolbar menu. 

Confirm the desire to uncouple the returns. ProFile automatically prompts the option save the spouse's return in a separate file.  

Click the “Save” button. The client's file keeps the coupled file name (e.g., “Couple, Joe and Thelma.T08”). It may be renamed by selecting the “Save As” 
option from the “File” drop-down menu in the top toolbar. 

On the Info form in each file, select "Widowed", "Divorced", "Separated" or "Single" for the marital status. 
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Using a Medical Expense form for T1 in ProFile 

 
Taxpayers may claim medical expenses for any 12-month period that 

ends in the current tax year. Expenses already claimed on last year's tax 

return cannot be claimed again. Generally, all amounts paid can be 

claimed even if they were not paid in Canada. 

Opening the Medical Expense form 

Search using the term “medical” in the ProFile 
search bar, located in the top toolbar menu.  

Select the “Medical expenses” form displayed in 
the search results. 

If a coupled return… 

The “Medical Expense” form in ProFile 
automatically shares information between 
coupled returns 

To optimize medical expenses, select the “Yes” option to the “Optimize medical expenses?" question at the top of the form.  

ProFile determines which taxpayer should claim the deduction at lines 330, according to the lowest net income (as long as the taxpayer can claim all 
expenses). 

To decide independently which spouse should claim the deduction, select the “No” option to the “Optimize medical expenses?" question at the top of the 

form and select the “Yes” option to the "Are you claiming medical expenses?" question.  

Select “Percentage” and enter it in the corresponding field for the current return to allocate a percentage to each spouse. The spouse's return will 

automatically reflect the remaining percentage. 
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Using a Charitable Donations Form for T1 in ProFile 

 
The ProFile “Donations” form is used to enter charitable donations for 

the taxpayer. Donations can be entered for both Canadian and U.S. 

organizations. 

Search for the term “donations” in the ProFile search bar in the 

top toolbar menu; select the appropriate form (e.g., “Charitable donations”). 

Carrying forward donations  

If a return carried forward from a 
previous taxation year, ProFile 
copies the list of organizations 
into the “Charitable donations 
details” and “Donations to U.S. 
organizations” tables, but leaves 
amounts as “0”.  

Any donation amounts can be entered to the same organizations for the current year in the appropriate rows.  

When completed delete the remaining organizations, right-click in each table and select the “Remove 'zero' lines” option. 

If the taxpayer has donation amounts from slips (e.g.,T4 slips), enter those amounts on the related slip or slips (e.g. T4, T3, T2202A, T4A, and T5013). ProFile 
automatically carries donation amounts from slips to the “Reported on slips” line in the “Donations” worksheet. 

The donation carry forwards display at the bottom of the “Charitable donations” form. ProFile automatically claims older donations first to ensure that the 
taxpayer uses them before they expire; charitable donations for up to 5 years are eligible for carry forward. 

Transferring donations to spouse 

Open the donations form. 

Right-click on the form and select the option “Transfer all donations” or “Transfer current donation”. 

The donations transfers to the spouse. 

  

mk:@MSITStore:C:/Program%20Files%20(x86)/ProFile/Help/T1SSE.CHM::/text/en/common/topics/taxline_t4.html
mk:@MSITStore:C:/Program%20Files%20(x86)/ProFile/Help/T1SSE.CHM::/text/en/common/topics/taxline_t3.html
mk:@MSITStore:C:/Program%20Files%20(x86)/ProFile/Help/T1SSE.CHM::/text/en/common/topics/taxline_t2202a.html
mk:@MSITStore:C:/Program%20Files%20(x86)/ProFile/Help/T1SSE.CHM::/text/en/common/topics/taxline_t4a.html
mk:@MSITStore:C:/Program%20Files%20(x86)/ProFile/Help/T1SSE.CHM::/text/en/common/topics/taxline_t5013.html
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Adding Dependants for T1 in ProFile 

 
There is no limit to the number of dependants that can be added to the 

form; a new blank column displays when the last column provided is 

populated. 

 

Completing the “Dependant information” form 

Enter the term “dependant” into the ProFile search field in the top 
toolbar menu; select the form from the search results (e.g. “Dependant 
information”). 

Enter the dependent information in full. 

Personal information entered on the Dependent form automatically 
populates for both spouses, regardless of which is chosen. 

 

Selecting family linking 

Select the “Module…” option form the “Options” drop-down menu in the 

top toolbar. 

Ensure the “Allow family linking” option is checked in the “Allow family 

linking” section of the “General” tab. 

Click the “OK” button. 

Identify the dependant in the “Dependant information” form that to link. 

Right-click in one of the dependant’s form fields; select the “Return for” option from the 

menu. 

Click the “Yes” button when asked “Create a new return for?” 

The new return is created for the dependant. 
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Family Linking for T1 Returns 

A number of file management features make it easy to work with linked T1 or T1/TP1 files for members of the same family: 

 linking family returns 

 working with linked files 

 printing linked files 

 saving linked files 

 sharing income between spouses 

 sharing data between family members 

 estimating Child Tax Benefits 

 open and close family files 

Working with linked family files 

Once linked, family files can be opened and closed together. 

If you prefer working with family files open together, open them all together when beginning to work on a set of family files.  

If files were closed together, (e.g. “File” -> “Close family”) ProFile will open the returns together. 

If closing the file for one family member separately, automatic opening of all family files together will not occur until after the next time you open all the 
files at once. 

Optimize Transfer Credits 

When opening all family files together, ProFile optimizes transfer credits among the different returns. 

Switch between Family Members 

Use the toolbar icon, the “Form” menu or the “Window” menu to switch between open files for members of a family. 

Print Family Files 

When selecting “File” -> “Print” option for a linked file, the “Print Selection” dialog box displays a tab for each family member whose file is currently open to 
permit printing returns for the whole family at once. 
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T1 Family Linking (continued…) 

File Properties 

View the “File Properties” details for all family files open together and listed in the “Window” menu. 

Deactivate Family Files 

To deactivate the family file-handling features, clear the checkbox “Allow family linking” under “Options” -> “Module” > “T1/TP1” -> “General” -> 
“Calculation” options. 
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Using Pension Split Optimization for T1 in ProFile 
 
Canadian residents who received eligible pension income during the taxation year may be able to allocate up to half of their eligible income to their spouse 
(or common-law partner) for income tax purposes. 

Completing T1032 form 

Open form T032, “Joint Election to Split Pension Income”. 

Indicate at the top of form T1032 whether you are the “Pensioner” (transferring pension income to 
his/her spouse) or the “Pension Transferee” (receiving pension income from his/her spouse). 

Enter the amount of the elected split pension on “Line E” of the form. Based on your 
Pensioner/Pension Transferee selection, the amounts will automatically flow to lines 210/116 of 
each of the spouse's returns. 

 
Utilizing the pension optimizer worksheet 

Open the form T1032OPT, “Optimize – Split-pension income”. 

To view the amount that ProFile recommends that the taxpayer transfer to his/her spouse or 

common law partner, right-click on the worksheet and select the “Optimize split-pension 

income” option. 

 

Utilizing scenarios in the "Calculator" section 

Open the form T1032OPT, “Optimize – Split-pension income”. 

Enter the amount of pension income to be split in the "Elected split-pension amount box" under Scenario # 1. 

Press "Enter". 

The calculator displays the "Total Payable and Balance Owing" for each individual, as well as combined totals for the couple. 

 

Related Articles 

Review the pension-splitting support article to learn more about pension splitting. 

  

http://support.intuit.ca/profile/en-ca/document.jsp?product=profile-english&id=HOW14727


 
103 

 

Using Business Statements for T1 in ProFile 
 

There are multiple business statements in ProFile, including: 

 T2125 - Statement of Business or Professional Activities 

 T776 - Statement of Real Estate Rentals 

 T2042 - Statement of Farming Activities 

 T2121 - Statement of Fishing Activities 

 T1163 & T1273 - AgriStability 

Each statement has their own set of forms such as the asset, CCA, and 

summary forms. 

Amounts from certain slips are transferable to a business statement. It 

gives the option to transfer on the slip.      

These statements are multi-copy forms; in order to create a secondary 

statement, select the “New Form” option from the “Form” drop-down 

menu in the top toolbar menu. 

   

Deleting business statement sets (T4slip) 

If you delete any form in a business statement set, ProFile deletes all the related forms in the same set. ProFile 

automatically selects for printing any of the business statement forms that are used. Unused forms in a set have no 

impact on a tax return filing. 

To clear a particular form in the set, open the form in the “Edit “window and select the “Clear Form” option from the 

“Form” drop-down menu in the top toolbar menu.  

This option does not impact other forms in the same set. 

 

Related Articles 

Review the “business statement” and “Asset details” entries in ProFile’s “Help” feature for additional information.  
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Adding Motor Vehicles for T1 in ProFile 

The “Motor vehicle expenses (Business)” worksheet 
lists motor vehicle expenses used for business purposes, 
related to the T2125, T2121, T2042 and Quebec business 
statements. 

From the “Allocation of expenses” drop-down menu, 
select your business statement (if you have not yet 
opened a business statement, the drop down list will be 
empty).  

Data entered on the “Business Auto” form flows to the 
selected business statement(s). 

In the case of the T2125, T2121 and T2042 business statements, ProFile transfers automobile expenses to different areas on the statements depending on 
the taxpayer's percentage of ownership of the business: 

 if the business is a sole proprietorship (% ownership = 100%), then the automobile expenses are   transferred to the expense section of the business 
statement (line 9281 or 9819, depending on the business statement). 

 if the business is a partnership, the expenses are transferred to line 9943, "Other amounts deductible from your share of net partnership income 
(loss)". 

As you complete the Business Auto worksheet, ProFile automatically transfers the required information to the related Quebec business auto form (for 
example, TP80Auto, TP1FishingAuto). 

Capital Cost Allowance (CCA) 

Chart C of the “Business Auto” worksheet lets you calculate the Capital Cost Allowance (CCA). CCA amounts are transferred to the business statement's 
“CCASummary” or the CCA (assets owned by partner) table of the relevant business statement, depending on whether or not the vehicle is owned by the 
business. This is specified in the “Owned by business?” column of the “Allocation of expenses” table. For vehicles owned by a partner in a business, ensure 
that the “Owned by business?” column is set to “No” for the related business statement. 
 
Sharing automobile expenses between spouses 

ProFile does not automatically share the details of motor vehicle expenses with the spouse's return. If both spouses have expenses related to the business 
use of an automobile, they will each have to create their own “Business Auto” form. 
 
Related Articles 

To learn more about CCA for motor vehicles, click here. 

mk:@MSITStore:C:/Program%20Files%20(x86)/ProFile/Help/T1SSE.CHM::/text/en/profile_t1/product/auto_exp_allocation.html
mk:@MSITStore:C:/Program%20Files%20(x86)/ProFile/Help/T1SSE.CHM::/text/en/profile_t1/product/auto_cca.html
http://support.intuit.ca/profile/en-ca/document.jsp?product=profile-english&id=HOW14726
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Adding Assets and CCA for T1 in ProFile 
 

Asset details forms are part of the business-statement set. For each business statement, 

ProFile creates a corresponding “asset details” and “asset list” form. For example, when 

creating a T2125#1 form, ProFile creates the corresponding T2125Asset#1 and 

T2125AssetList#1 forms. 

Use “asset details” and “asset list” list forms to track business and rental assets. Enter 
asset information on the “asset details” form. ProFile automatically transfers this 
information to the corresponding “asset list” form. The “asset list” form displays all assets 
in a single table that you can print.  

Note: it is not possible to print the “asset list” form. 

Entering asset information 

Complete a separate entry for each asset.  

A list of assets appears in the panel on the left of the “asset details” form. Click on one of 
these items to display the asset details for a particular asset.  

Click “New” to enter information in a blank column. ProFile automatically numbers each 
asset as entered on the information and creates a blank entry for the next asset. Complete 
a separate entry for each asset.  

Enter details for each asset under the Federal/Quebec headings. ProFile automatically 
calculates the net cost or proceeds and transfers the amount to the “CCA” form to 
calculate the capital cost allowance (CCA), recapture, or terminal loss.  

Capital Cost Allowance (CCA) form 

Capital Cost Allowance (CCA) forms and summaries are part of the business statement set. For each business statement, ProFile creates a corresponding 

“CCA” and “CCASummary” form. For example, when creating a T2125#1, ProFile creates the corresponding T2125CCA#1 and T2125CCASummary#1 forms. 
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Using the Employment Expenses form for T1 in ProFile 
 

Use form T777 to calculate allowable employment expenses.  

There are four forms related to employment expenses:  

 T777 

 T777Details 

 T777Other 

 T777Auto 

Enter employment expenses for commission and non-commission 

employees on T777Details. 

 

Enter expenses for musicians, forestry workers and apprentice mechanics 

on T777Other.  

Use form T777Auto to calculate automobile expenses related to earning 

employment income 

 

T777Auto#: Motor vehicle expenses 

Use this form to calculate automobile expenses related to earning 
employment income. 

Create a new T777Auto worksheet for each automobile. 

Complete the expense details for the automobile.  

Right-click on the form and select “New form” from the context-sensitive 
menu. 
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Using Comparative Summary for T1 in ProFile 

ProFile provides summary forms that present the tax return data in different ways. These 
include: 

 Summary - 2016 Tax Summary (Federal): this form displays all the non-zero line 
items of a single taxpayer's T1 return (each field that contains data in the return) 

 T1Summary - 2016 Tax Return Summary, TP1Summary - Tax Summary (Québec): this 
form displays major items from the taxpayer's return 

 5Year - 5 Year Tax Summary (Federal), TP15Year - TP1 5 Year Tax summary (Québec: 
this form displays the major items for a single taxpayer's last five years of tax returns 

 Comparative - Comparative Tax Summary (Federal), TP1Comparative - TP1 
Comparative tax summary: this form compares the major items from this year's tax 
return to last year's tax return for a single taxpayer. If the return carried forward 
using Profile, last year's amounts appear automatically on the comparative summary 

 NRTC - Comparative NRTC Summary: this form compares the non-refundable tax 
credits on the federal and provincial tax returns 

 T1Review - T1 Review, TP1Review - TP1 Review: similar to the Comparative Tax 
Summary, this form compares the major items from this year's tax return to last 
year's tax return for a single taxpayer, with a special focus on review. The form uses 
the variance thresholds specified under “Options” -> “Module…” -> “T1/TP1 Review” 
to highlight significant changes between current and prior year returns. It is also 
possible to adjust the variance threshold in the “Review” preferences section of the 
form. ProFile calculates the differences and displays them on the “T1/TP1 Review” 
tab in dollar and/or percentage amounts.  

Five-year comparative summaries are part of the business-statement 
set. For each business statement, ProFile creates a corresponding five-
year comparative summary form. For example, if creating a T2125#1 
form, ProFile creates the T2125Comparative#1 form. This form is used 
to compare up to five years of business statement information. 

ProFile automatically carries forward previous-year business statement 
information from the previous year to this form. Enter any additional 
information directly in the summary. 

If creating a new return, rather than undertaking the carry forward of 
an existing return, enter the prior year information directly on the comparative summary. ProFile carry forwards this information in the following year. 
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Using Tax Planner for T1 in ProFile 

The tax planner in ProFile prepares a projection of the taxpayer's 
position for the next taxation year. 

“Tax Planner” is an unlimited form, so as many different scenarios 
as required can be created for a single T1 file.  

 
Creating a T1 tax plan  

Enter the term “tax plan” in the ProFile search bar in the top 
toolbar. 

Select the “PLAN: Tax planner” option from the search results; the 
tax planner displays. 

Right-click on a form field and select the “New form” option from 
the menu. 

Enter a description for the scenario in the “Description” field at the top of the form. This description displays in the “Form Explorer” to distinguish between 
the different scenarios created. 

Note: when creating a new plan, ProFile creates new T1 plans for the client and spouse, all in the same numbered set. 

 
Transferring data from the current year’s tax return 

To save time entering data on a new plan, you can transfer amounts from the current year's tax return to get you started. 

Open a completed T1 client file. 

Open the tax planner from the “Client” category of the Form Explorer. 

Right-click on a form field and select the “Copy T1 return” option from the menu; the return’s data imports into the tax planner. 

Change any amounts to reflect the client's new projections for the year. 
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Using a Motor Vehicle Expenses form for T1 in ProFile 
 

Form T777 calculates allowable employment expenses.  

Enter the term “T777” into the ProFile search bar in the top toolbar menu 

and select the appropriate result. 

There are four forms related to employment expenses:  

 T777: enter employment expenses 

 T777Details: enter employment expenses for commission and 

non-commission employees 

 T777Other: enter expenses for musicians, forestry workers and 

apprentice mechanics 

 T777Auto: calculate automobile expenses related to earning 

employment income 

 

T777Auto#: Motor vehicle expenses 

This form calculates automobile expenses related to earning 
employment income. 

Create a new “T777Auto” worksheet for each automobile. 

Complete the expense details for the automobile. Any number of 
copies of the form may be created. Right-click on the form and 
select the “New Form” option from the menu. 
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Filing a T1 for a Deceased Taxpayer in ProFile  

 
Complete a return for a deceased taxpayer who is single  

Create a new T1 return in ProFile. 

Navigate to the “Info” sheet. 

Enter the date of the client’s death in the “Date of Death” field under the “Taxpayer 
personal information” section. 

The date of the client’s death in the “Is this return for a deceased person?” section of 
the “T1” sheet updates automatically. 

If the deceased taxpayer is married, the status of the individual’s spouse changes 
 automatically to “Widowed” on the spouse’s form. 
 
 
Completing “Special return” for deceased taxpayer 
 
Enter the date of the client’s death in the “Date of Death” field under the “Taxpayer 
personal information” section. 

Scroll down the “Info” sheet to the “Special return for the deceased taxpayer (Other 
than “final return”)” section. 
 
Review the options in the section and select one if applicable. 
 
 
Carrying forward a coupled deceased return 
 
When carrying forward a coupled file in which a spouse files a 
deceased return for the previous taxation year, ProFile 
automatically carries forward only the return for the surviving 
taxpayer. 
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Managing T2 returns in ProFile 
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Overview of T2 Module in ProFile 
 

A T2 is the federal tax return for incorporated businesses (also called corporations). An incorporated business must complete a T2 return each year, even if 

there is no tax payable. 

The form must be filed within six months of the end of each corporation's fiscal year. 

As of 2009, the CRA requires all T2 returns be filed electronically via their “EFILE” service. 

 

Required information and material for T2 returns 

For the best-possible experience, assemble the following information and materials prior to undertaking the T2 return:  

 prior-year financial statements and T2 return, if applicable 
 articles of incorporation 
 list of product and services provided in percentages 
 obtain backup electronic copies of applicable bookkeeping (e.g., QuickBooks, Simply accounting, MS Excel, etc.), trial balance sheet, income 

statement, general ledger, credit card and bank statements of the last month of the corporation year 
 corporate installment payments made during the year 
 copy of prior years' Notice of Assessment (NOA) 
 correspondence with any government relating to the corporation 
 list of changes to the corporation from last year (e.g., new director, shareholders, new assets, etc.) 
 business number of the corporation (review the incorporation documents or prior-year return) 
 address of corporation, including head office, mailing and location of books, if applicable (you can review the CRA “My Account” feature for this 

information) 
 fiscal year-end date of company 
 enter information and carry-forward the return in ProFile of the prior-year corporation return, if available  
 provide a signed RC59 form to acquire access to the client’s business information through the CRA. Note: a RC59 form is now only to request mail or 

phone authorization. ProFile recommends that preparers follow the instructions here to acquire full online authorization using the CRA's “Represent 
a Client” function.  

  

http://support.intuit.ca/profile/en-ca/document.jsp?product=profile-english&id=INF26873
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Using GIFI Import from Caseware for T2 in ProFile 

 
The General Index of Financial Information (GIFI) is a comprehensive list of financial statement items 
where each item has a unique code. It allows a corporation to report its unique combination of 
accounts to the CRA. 

Importing GIFI from CaseWare to ProFile 
 

In Caseware: 

Open Caseware. 

Open the “Working Papers” client file from which to export. 

Select the “GIFI” option from the “Export” menu; the “Export of Data to GIFI” dialog box displays. 

Complete the fields of the dialog box. 

Click the “OK” button; the export processes and creates the GIFI file. 

 
In ProFile: 

Open a T2 return. 

Select the “Import… ” option from the “File” drop-down menu in the top toolbar. 

Select the location where the Caseware-created GIFI file is stored. 

Select the GIFI file; click the “Open” button. 

Note: the “Import Successful” dialogue box displays an incorrect “X” icon. Click the “OK” button. 

The GIFI information imports to the T2 return. 

 

More information:  

Review the Profile article on GIFI import from QuickBooks Online (QBOA). 

Review the ProFile article on GIFI import from QuickBooks desktop to ProFile. 

Review the Caseware article on exporting GIFI data for imports. 

  

http://support.intuit.ca/profile/en-ca/document.jsp?product=profile-english&id=INF30526
http://support.intuit.ca/profile/en-ca/document.jsp?product=profile-english&id=HOW25297
http://documentation.caseware.com/2015/WorkingPapers/es/Content/Accounting_and_Assurance/Tax/Canada/GIFI/t_Exporting_GIFI_ProFile.htm
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Using GIFI Import from QuickBooks Desktop for T2 in ProFile 

Note: it is necessary to undertake QuickBooks integration prior to importing GIFI 
from QuickBooks Desktop. This guide includes a “QuickBooks Integration” section. 

About GIFI Import 

The General Index of Financial Information (GIFI) is a comprehensive list of financial 
statement items where each item has a unique code. It allows a corporation to 
report its unique combination of accounts to the CRA. 
 

Importing GIFI from QuickBooks desktop 

Open a T2 return in ProFile. 

Ensure that the ProFile T2 taxation year matches the corresponding year entered in 
QuickBooks. 

Select the “Yes” option for the question “Complete return from GIFI?” in the “Filing” 
section of the ProFile T2 return. 

 Select the “QuickBooks Desktop 
Import…” option from the “File” drop-
down menu in the top toolbar. 

Set the “Year start” and “Year 
end” values in the “GIFI Data 
Import” window. 

Click the “Continue” button. 

Review the amounts being imported 
from QuickBooks to ProFile. 

If correct, click the “Import” button. 
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Using GIFI Import from QBOA for T2 in ProFile 

 
The General Index of Financial Information (GIFI) is a comprehensive list of financial statement items where each item has a unique code. It allows a 

corporation to report its unique combination of accounts to the CRA. 

GIFI Import from QBOA 

Login to the QBOA Firm containing the 
data to export. 

Click the hyperlink text under the 
“Workpapers” column, or if logged into 
the client file click here. 

In QuickBooks navigate to the “Workpapers” section for the client’s books. 

Review the “Working Trial Balance” and the “GIFI Mapping” to 
ensure that all the work is completed. If there are any 
unassigned codes, these can be mapped under the GIFI 
mapping section. To assign GIFI Codes review the list and click 
“Assign GIFI Codes”. 

Click “Save GIFI codes” at the top-right corner. 

In Profile 

Select the “QBOA Import…” option from the “File” drop-down 

menu in the top toolbar. 

Navigate to the GIFI file to import. 

Select the GIFI file and click the “OK” button. 

The GIFI information imports. 

  

https://ca.qbo.intuit.com/app/trialbalance
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Using Amendments for T2 in ProFile 
 

T2 amendments are carried out when a new piece of information demands that the 

original T2 be amended to reflect the new data. 

Saving the original T2 return 

ProFile strongly recommends that the file be renamed before amending the return. 

This ensures the original T2 is not lost in the process of being amended. 

Open the T2 return that requires amendment. 

Select the “Save As…” option from the “File” drop-down menu in the top toolbar. 

Save the T2 return as “[Your Corp Name]_amended”.  
 
 
Amending the corporate information page 
  
Select the “Info” tab in the T2 return. 
 
Set the following values in the “Filing” section:  
 

 “Is this an amended return?” is set to “Yes” 

 “Internet file this return?” is set to “Yes” 
 
Select the “Yes” value on line 997 of the “T2 Adjustment worksheet”  

Enter a description of the amendment in the field of line 996. 

 

Restrictions 

The following fields cannot be amended under this process; ProFile displays a 
warning message if an amendment is submitted regarding one of these fields. 
These fields must be amended via the CRA’s website: 

 Head office address change 
 Mailing address change 
 Location of books and records change 
 Direct deposit information 
 Language of correspondence 
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Using EFILE with Web Access Code (WAC) for T2 in ProFile 
 

Corporate returns can undergo EFILE using a Web Access Code 

(WAC). In some cases, a preparer may not have a need to undertake 

a request for an EFILE number and the WAC provides a quick, 

convenient alternative. 

ProFile allows users to apply for and receive a WAC online through a 
ProFile web service, without having to call the CRA Corporation 
Internet Filing Helpdesk. 

Alternatively, users can enter a WAC if already acquired from an 
earlier EFILE effort/request. 

 

Applying for a WAC 

Select the “Transmit this return…” option from the “EFILE” drop-
down menu in the top toolbar. 

ProFile reviews the T2 return for any outstanding warning. If there 
are no auditor warnings, ProFile displays a green checkmark.  

Click the “OK” button. 

The “Corporation Internet Filing” window displays. 

Select the method of filing the return: 

 “I want to request a Web Access Code and file this tax return”. This automatically makes a request to CRA for the specific return to undergo EFILE, 
based on the return’s information. 
 

 “I already have a Web Access code for this tax return”. The user enters their existing WAC from a previous EFILE effort/request. 

Click the “Accept” button; the return transmits using the WAC. 
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T2 Guide and in-product tutorial in ProFile 
 

ProFile provides customers a T2 guide that includes list of steps a user should understand in order to file a corporate return. 

Note: the T2 guide covers basic steps for filing a T2 return, but does not provide any tax-related advice or opinion. ProFile recommends reviewing the CRA 

website, contacting the CRA tax inquiry line, or consulting an accredited CPA firm for information regarding current tax laws. ProFile also recommends 

having any return prepared or reviewed by a professional accountant before filing.    

Click here to view the T2 Guide. 

 

In-product T2 tutorial 

ProFile provides an in-product T2 tutorial that walks a user through the basic functions of 

completing and filing a corporate return. 

 

To access the tutorial 

Open a T2 return. 

Select the “1. Getting Started” option under the “Training” - > 

“T2” drop-down menu in the top toolbar. 

The T2 tutorial opens below the top toolbar. 

Click the “Next” button to proceed through the tutorial. 

  

http://support.intuit.ca/profile/en-ca/document.jsp?product=profile-english&id=INF31726
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Managing T3 returns in ProFile 
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Overview of T3 Module in ProFile 
 

About T3 tax forms 

A T3 Statement of Trust Income Allocations and Designations indicates investment income from mutual funds in non-registered accounts and from certain 

trusts. In Québec, the form is a relevé 16. The income may come from individual investments or from an estate trust as inheritance tax. 

Amounts present in box 51 and/or 39 indicates a dividend tax credit is available. 

T3 slips show income from interest, dividend, and capital gains. All these types of income are taxed at different rates. 

 

Receiving the T3 tax slip 

In most cases, T3 tax slips are received around March 31. 
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Key Forms for T3 in ProFile 
 

There are some key T3 forms to be mindful of when completing a trust return: 

 

Beneficiary form 

Use the “Beneficiary details” form to enter information for trust beneficiaries. Amounts flow from the “Beneficiary details” form to the corresponding T3, 

NR4 and RL16 slips. ProFile also uses the “Beneficiary details” form to complete Schedule 9 in the trust return.  

 
Allocation worksheet 

Use the “Allocation” worksheet to indicate how the trust allocates income to beneficiaries. If the trust is claiming expenses at line 41 of the return, apply 
the expenses to specific types of income before allocating income to the beneficiaries. The trust gets a deduction on the T3 jacket for income that is 
allocated to the beneficiaries.  

Some of the trust income may be taxed in the trust. Specify for each type of income the amount that the trust will retain. ProFile displays the remaining 
income as the amount to be allocated to the beneficiaries.  

On the Allocation form, preparers may also need to enter certain T3 slip amounts, such as a retiring allowance, death benefit, or foreign business income.  
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Data Entry and Flow for T3 in ProFile 

The T3 “Info” form contains sections for general information, trust type, and other 
basic details of the trust. 

Prepares will report the income and deductions of the trust. Enter these details on 
the various income and deductions forms, schedules and on the T3 
Jacket (which has some edit fields with no supporting schedules).  

There are numerous data entry forms, including 
business and rental statements, dispositions on Schedule 1, and T3, T5 
income received by the trust. 

If the trust is allocating income to its beneficiaries, the forms in the Beneficiaries tab 
of the Form Explorer become important. 

Any income not allocated to beneficiaries is taxed on Schedule 11, which transfer 
to page 4 of the T3 jacket. 

 
About the Allocation worksheet 

The “Allocation” worksheet is used to complete the slip amounts for beneficiaries.   

Use this worksheet: 

 to indicate how you wish income to be allocated to the beneficiaries: the 
default is each one gets an equal share of the income. If not the case, 
choose “Other” and enter the percentage applicable to each beneficiary on 
the “Beneficiary details” worksheet. If “Other” is selected, the 
percentage field on each slip of the “Beneficiary worksheet” becomes 
an input field; otherwise, it is calculated based on the equal allocation 
to all beneficiaries. 

 if the trust has claimed expenses at line 41 of the return, the expenses have 
to be applied to specific types of income before the income can be allocated 
to a beneficiary. These expenses must be applied manually: an audit 
message will appear if these expenses have not been entered. 

 to retain some of the income to be taxed in the trust. You can specify which 
type of income and how much is to be retained by the trust. 

 to specify amounts for certain boxes of the T3 slips that is not automatically 
completed by ProFile T3. For example, details related to foreign income and 
tax paid. Also, if the trust is allocating a retiring allowance or death benefits, those amounts have to be specified here. 
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Data Entry and Flow for T3 in ProFile (continued…) 

 
About the Beneficiary worksheet 

On the Beneficiary worksheet, enter details such as name, address and 
residency of the beneficiary. The slip amounts at the bottom of this form 
are calculated using amounts from the “Allocation” worksheet multiplied by 
the percentage applicable to the particular beneficiary (percentage is on the 
“Beneficiary” worksheet). 
 

Navigating on the Beneficiary worksheet 

On forms like “Beneficiary”, where there are an unlimited number of slips, 
navigation is simplified with the following shortcuts: 

 use the horizontal scroll bar at the top of the slip table to navigate. 

 <Ctrl+Enter> takes you to the top of the next slip 

 <Shift+Ctrl+Enter> takes to the previous slip 

 <Ctrl+RightArrow> and <Ctrl+LeftArrow> take you to the next or 
previous column (and scroll to the next or previous slip accordingly) 
 

Using the Beneficiary worksheet 

The information on the “Beneficiary” worksheet transfers to the T3 and NR4 
slips. These slips are for reporting and preview purposes only: data cannot be 
edited on these forms. 

The data from the T3 and NR4 slips is posted to the T3 Summary and 
NR4 Summary.  

Schedule 9 is a summary of the amounts allocated/designated to the 
beneficiaries. ProFile completes this form using the amounts from 
the “Beneficiary” worksheet. The trust gets a deduction for the total income allocated to beneficiaries at line 928 of this schedule. 

Review the T3 jacket and manually enter data into any fields not automatically calculated by ProFile T3 (especially the questions on the first two pages).  
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Using EFILE Slips for T3 in ProFile 
 

About T3 slip EFILE 

A T3 Trust return must still undergo paper filing. However, the “Slips 
Summary” can undergo EFILE with the related slips. 

Note: always print or retain a PDF copy of the CRA confirmation of an EFILE 
when completed. ProFile does not retain a report or record of which slips are 
transmitted. 
 

Transmitting slips 

Prepare the T3 slip in ProFile. 

Open the “Beneficiary details” form and select the “Type of slip” being 
transmitted. 

Select the “Transmit” option under the “EFILE” drop-down menu in the top 
toolbar. 

Select the appropriate option under the “Data type” drop-down menu and click the “OK” button. 

ProFile builds the XML file and automatically launches the CRA transmission 
window. 

Review the CRA disclaimer, login, and submit the .xml file.  

The file submits; click on the “print” icon on the browser window to print the 
confirmation number. 

Click the “Close” button. 
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Early Filing Next Year for T3 in ProFile 
 

The next year’s T3 module in ProFile is not available until the year after: for example, when the 2017 T3 module is the last one released and you need to 
prepare a T3 return with 2018 year-end, the 2018 T3 module is not available until January of 2018.  In this situation, the previous year’s T3 module is used 
for preparing next year’s T3 return. 
 
 
New tax rate implementation 

New tax rates are implemented in the previous year’s T3 module to handle preparation of next year’s T3 returns.  Entering the appropriate year-end on the 
“Info” page initiates the applicable tax rates for that year.  T3 returns filed using the previous year’s tax forms are acceptable to CRA, and they will reassess 
the return if required. 
 
 
Preparing next year’s T3 return using the previous year’s T3 module  

Save a duplicate copy of the previous year’s T3 return to be used as the next year’s T3 return. 

Open the previous year-end T3 return in ProFile. 

Enter the appropriate year-end for the trust return T3 to be prepared; this initiates the applicable tax rates for next year. 

Delete the information pertaining to the previous year-end, keeping what is required for the next year-end. 

Enter the T3 data required for filing the next year’s trust return, allocate income to beneficiaries, and create the T3 slips. 

Print the T3 trust return using “File” -> “Print” and print T3 slips using “File” -> “Print Slips”. 

Save the T3 trust return with a different file name to identify the tax rates for that year. 
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Managing FX module in ProFile 
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Overview of Form Expert (FX) 
 

FX & FX/Q includes a comprehensive set of tax forms that are fully interactive, automatically performing all calculations. 

The forms include: 

 T4, T5, T5018,T5008, T5013, RL1, RL3, RL15, and more. 

 Partnership Information Return and Schedules (T5013 Schedules and TP600 for Québec) 

 Charity & Non-Profit Organization forms (T3010 and TP-985.22 for Québec) 

 Additional GST/HST/QST, TD1, RCA, Non-resident and Recourse forms 

 Federal, Québec and provincial rollover forms (T2057, T2058, T2059, TP529, TP614, AT107, AT108 and AT109) 

 BC Logging Tax Return of Income (FIN542 and FIN571) 

 Other forms (e.g RC199, CPT30, T3D, T3RI, etc.) 

 

Related Articles 

Review the list of ProFile forms and tax slips 

  

http://profile.intuit.ca/professional-tax-software/income-tax-forms-slips.jsp
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EFILE Slips for Form Expert (FX) 
 

Note: ProFile does not retain a report or record of which slips are transmitted. Always print or 
retain a PDF copy of the CRA confirmation of an EFILE when completed. 
  

EFILE original and amended slips 

Navigate to the “Info” tab of the return. 
 
Ensure the “Yes” option is selected for the question “Are you magnetic media or internet filing 
slips?". The option to EFILE slips will not appear unless this option is selected. 

Select the “Properties…” option from the “File” drop-down menu in the top toolbar; the “FX/Q 
File properties” window displays. 

Set the “EFiling” status in the “Slips Status:” section to "Ready to file". 

Select the “Transmit slips or a T5013 return” option from the “EFILE” drop-down menu in 
the top toolbar; the “Internet File Slips” window displays. 

Select the slip to undergo EFILE. 

Select the appropriate option under the “Data type” drop-down menu and click the “OK” button. 

ProFile builds the XML file and automatically launches the CRA transmission window. 

Review the CRA disclaimer, login, and submit the .xml file.  

The file submits; click on the “print” icon on the browser window to print the confirmation 
number. 

Click the “Close” button. 
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Batch EFILE Slips for FX 
 

Multiple FX slips can undergo a “batch” transmit slips at one time using the Client Explorer 

database. 

 

Starting the Client Explorer database 

Select “Database…” from the “Options” drop-down menu in the top toolbar; the 
“Database/Client Explorer Options” window displays. 

Select the “Use Client Explorer” option. 

Click the “OK” button. 

Select the “Client Explorer” option under the “GoTo” drop-down menu in the top toolbar. 

The Client Explorer displays. 
 

Filtering and selecting returns  

Click the “Filter” button; the filter window displays at the bottom of the window. 

 

Select the checkbox on the “FX” tab and clear the other module tabs by unchecking them. 

 

Select the checkbox for the desired tax year (e.g., “2016”) on the “FX” tab and clear the checkboxes for all other years by unchecking them. 

 

Select the appropriate checkboxes in the remaining sections of the “FX” tab to filter for slip details; clear the other options by unchecking them.  

 

Click the “Apply Filters” button; a list of slips that meet the set slip criteria 

displays. 

 

Select the slips to EFILE. 

 

 

Building the EFILE Link 

 

Click the “Build EFILE…” link in the top-left “Actions” menu. 
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Batch File for FX (continued…) 
 

The “Build the XML file” window displays. 

 

Select the slips to undergo EFILE (e.g. “T4”). 

 

Click the “OK” button. 

 

The XML file builds and the CRA “Internet File Transfer” window opens. 

 

 

Transmitting the XML file to CRA 

Log onto the CRA slip transmission website.  

Note: transmission of the XML file requires an FX “Web Access Code” (WAC). If this is the first time internet filing slips, a WAC request must be made to the 
CRA. Ensure that you print a confirmation copy provided by the CRA for your submission records. 

Complete the XML transmission process. 

 

 

 

  

https://apps.cra-arc.gc.ca/ebci/leb0/upload/pub/entry-e.do
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Transmitting Amended Slips for Form Expert (FX) 
 

Preparers can electronically file an amended slip through the FX module. 

Note: ProFile does not retain a report or record of which slips are transmitted. 
Always print or retain a PDF copy of the CRA confirmation of an EFILE when 
completed.  

 

Transmitting an amended slip 

Open the applicable return in ProFile (e.g., a T4). 

Under the "Slip type?" section, set the type to "AMENDED". 

Make all the necessary changes to the slip. 

Select the "Properties…" option under the ProFile "File" drop-down menu in the top toolbar. 

Set the "Slip Status" for "Magmedia" to "Ready to File". 

Select the "Internet File Slips" option under the ProFile "EFILE" drop-down menu.  

Check the box of the slip to be transmitted (e.g., "T4"). 

Change the data type to "Amended" in the “Data Type” drop-down menu. 

Click the "OK" button; the amended slip transmits. 

ProFile builds the XML file and automatically launches the CRA transmission window. 

Review the CRA disclaimer, login, and submit the .xml file.  

The file submits; click on the “print” icon on the browser window to print the 
confirmation number. 

Click the “Close” button. 
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Transmitting a Cancelled Slip for Form Expert (FX) 
 

Preparers can electronically file a cancelled slip through the FX module. 

Note: ProFile does not retain a report or record of which slips are transmitted. 
Always print or retain a PDF copy of the CRA confirmation of an EFILE when 
completed.  

 

Transmitting a cancelled slip 

Open the applicable return in ProFile (e.g., a T4). 

Under the "Slip type?" section, set the type to "CANCELLED". When transmitting, the 
slips automatically revert to a value of "0". 

Select the "Properties…" option under the ProFile "File" drop-down menu in the top toolbar. 

Set the "Slip Status" for "Magmedia" to "Ready to File". 

Select the "Internet File Slips" option under the ProFile "EFILE" drop-down menu.  

Check the box of the slip to transmit (e.g., "T4"). 

Change the data type to "Cancelled" in the “Data Type” drop-down menu. 

Click the "OK" button; the amended slip transmits. 

ProFile builds the XML file and automatically launches the CRA transmission window. 

Review the CRA disclaimer, login, and submit the .xml file.  

The file submits; click on the “print” icon on the browser window to print the 
confirmation number. 

Click the “Close” button. 
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Verifying Client Data for Form Expert (FX) 
 

Verifying Client Data before filing slips in FX module 

Before transmitting a slip or return information with EFILE, ensure that the 
file is complete and accurate. ProFile includes audit and review tools that 
can help. 

FX Module 

Ensure the question “Are you magnetic media or internet filing slips?” 
question on the “Info” form is set to “Yes”. 

Ensure any messages in the Active Auditor, especially those in the “Mag 
Media” tab, are resolved. Double-click the message in the Auditor to identify the area that needs reviewing. 

When undertaking the initial EFILE of a slip, preparers enter the transmitter number in the EFILE wizard. If 
a transmitter number has not been provided, use the default “MM000000”. 

If transmitter information must be changed in the future, select “EFILE” -> “Options” -> “Transmitter” 
under the “T3/FX” section. Information can be updated as required. 
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Verifying Client Data for Form Expert (FX) (continued…) 

When ProFile builds an XML file suitable for transmission, it flags slips and 
information in which there are issues that prevent the XML file from being 
built. View a brief summary of the problems affecting a file by clicking the 
“plus” (+) symbol adjacent to a failed file. Hover the mouse over the message 
to read the full text.  

 A common cause of invalid XML files is the use of overrides on fields that are 
included in the information that is to be sent (e.g. when overriding a field 
instead of using amounts that ProFile calculates or carries from another form.) 
Avoid using the override feature whenever possible. 
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Print Setup for Form Expert (FX) 

 
Select the “Print Setup…” option from the “File” drop-down menu in the top toolbar. 

The “Print Setup” window displays. 

Select the correct year for the module; the available print settings display. 

Applicable forms, jackets, letters, and more that are applicable to the module are listed 

under the “Category” column. 

Select each available category and set/approve the margin settings, font scaling, 

position, duplexing, and other printing values. 

Click the “OK” button to save the print setup settings. 
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Managing printing in ProFile 
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Print Setup in ProFile 

 
Select the “Print Setup…” option from the “File” drop-down menu in the top 

toolbar. 

The “Print Setup” window displays. 

Select the correct year for the module; the available print settings display. 

Applicable forms, jackets, letters, and more that are applicable to the module 

are listed under the “Category” column. 

Select each available category and set/approve the margin settings, font 

scaling, position, duplexing, and other printing values. 

Click the “OK” button to save the print setup settings. 
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Printing: Printing Different Copies 
 

ProFile users can set the print job options for returns and forms. 

Setting print job options 

Open the return in ProFile. 

Select the “Print…” option from the “File” drop-down menu in the top 

toolbar. 

The “Print Selection” window displays. 

The “Print Job” section in the top-left corner of the window displays the 

print job types (e.g. “T1 Paper”). 

Note: the province of residency selected on the return determines the 

available print jobs. For example, setting “Quebec” as the province of 

residency displays TP1 print jobs. 

Set the print job settings along the section on the left side of the 

window. 

Advanced and simplified settings 

Click the “Advanced” button in the bottom-left corner; the advanced print 

job options display. 

To return to the simplified view, click the “Simplified” button in the bottom-left corner. 

Printing jobs 

Click the “Set Defaults” button to set the selected print job options as the default. 

Click the “Print” button to print the print job. 
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Printing to PDF in ProFile 
 

Setting print to PDF options 

Open the return. 

Select the “Print/Email PDF…” option from the “File” drop-down menu in 

the top toolbar. 

The “Print Selection” window displays. 

Several options for PDF printing are available, including: 

 setting the print job type in the top-left menu (“Print Job”) 

 setting print job options under the “Options” section 

 setting the print job resolution under the “Resolution” drop-down 

menu 

 emailing the print job to an email address entered in the email 

field 

Set the necessary options for PDF printing. 

 

Previewing the PDF  

Click the “Preview” button; a preview copy of the PDF displays.  

Review the form for any issues or needed corrections.  

Advanced menu option 

Click the “Advanced” button. 

The window expands to display the advanced print to PDF options. 
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Printing to PDF in ProFile (continued…) 

 
Building the PDF 

If there is an email listed in the “Email Address” field, delete the address. 

The “Build PDF” button activates. 

Click the “Build the PDF” button; the PDF creates and the path/file name displays. 

Click the “OK” button; the build of the PDF completes.  

 

 

Related Articles: 

Review the support article to learn more about the “Archive PDF” functionality. 

  

https://profile-en.community.intuit.ca/articles/1625370-how-to-archive-pdf
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Setting up Duplex Printing in ProFile 
 

Duplex printing allows preparers to print returns on both sides of a single sheet of paper. 

Setting Duplex Printing Options 

Open ProFile. 

Select the “Print Setup” option from the “File” drop-down menu on the top toolbar; the 
“Print Setup” window displays.  

Select the desired tax year and module from the tab menu at the top of the window (e.g., 
“1. 2016 T1/TP1”). 

A list displays below the tabs, detailing available forms, letters, and more. 

Uncheck the “Always use Default Windows Printer” above the “Category” heading. 

Click on the first item under listed under the “Category” heading (e.g., “T1 jacket”). 

Click the “Properties” button under the “Printer” heading. 

The print properties window displays. 

Select the duplex printing option from the options presented; note that this option may 
vary in name based on the individual printer manufacturer. In the example below, the 
duplex printing option is titled as “2 on 1 (2 sided)”. 

Click the “OK” button. On the “Print Setup” window, check the “Use printer duplex 
settings” box; this activates the duplex settings. Repeat the duplex printing configuration 
for each applicable option under the “Category” list (e.g., “T1 forms”, “Letters”, etc.) 
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Printing Slips in ProFile 
 

When sending a slip to print from ProFile, the printout may be cut off, print a blank 
page, or not print at all. This is due to the slips official size conflicting with the printer 
settings.  
 
Changing default slip print settings 

Select the “Print Slips Setup…” option from the “File” drop-down menu in the top 
toolbar. 

The “Slips Print Setup” window displays. 

Select the tax year from the module drop-down menu in the top bar. 

Select the slip type from the tab menu (e.g. “T4PS”). Update and apply the necessary 
print slip settings.  

Click the “Test” button to test print the settings. 

Click the “OK” button; the settings save. 

 

Printing the slip 

There are four printing options available under the “File” drop-down menu in the top toolbar: 

 Print… 

 Print / Email PDF… 

 Print Slips… 

 Print Slips / PDF 

Each option opens a print settings window. Update and apply the necessary print slip settings. 

Click the “Print” or “Build PDF” button; the slip prints or builds a PDF file. 

 

Reviewing the printed slip (if PDF printed) 

Open the generated PDF in the PDF-viewing software (e.g. Adobe Acrobat); ensure that the PDF is set to fit on the page. 

Select the desired paper size under the “Page Setup” option.  

Match the desired paper size under the “Printer Properties” option. 
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Managing software integration in 

ProFile 
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QuickBooks Integration 
 

It is easy and convenient to integrate QuickBooks with ProFile. 

The following support articles detail the process. 
 

Integrate ProFile and QuickBooks 

The integration process allows ProFile to display as an integrated application in QuickBooks.  

https://profile-en.community.intuit.ca/articles/1625439-how-to-integrate-profile-and-quickbooks 

 
 
Importing data from QuickBooks to ProFile (T2) 

The import data process imports amounts from QuickBooks into ProFile. 

https://profile-en.community.intuit.ca/articles/1625388-importing-data-from-quickbooks-to-profile-t2 

 
  

https://profile-en.community.intuit.ca/articles/1625439-how-to-integrate-profile-and-quickbooks
https://profile-en.community.intuit.ca/articles/1625388-importing-data-from-quickbooks-to-profile-t2
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QBOA Software Integration in ProFile 

QBOA integration is undertaken via the Workpapers. 

Workpapers is a collection of tools in QBOA that allows 
accountants/bookkeepers to quickly and efficiently complete year-
end work for their client. 

Accessing Workpapers 

Log in to the QBOA Firm containing the data to be exported: 

https://ca.qbo.intuit.com/app/trialbalance 

Click the hyperlink text under the Workpapers column. 

 
Preparing data to be exported in QBOA  

Open QuickBooks. 

Navigate to the Workpapers section for the client’s books. 

Note: only tax year 2015 and forward are supported. 

Review the “Working Trial Balance” and the “GIFI Mapping” to 
ensure all necessary work is complete. 

Map any unassigned codes under the GIFI mapping section. 

Navigate through the GIFI codes list and click on “Assign GIFI Codes” to assign; a row displays under the line to be mapped. 

Select the GIFI code from the list. 

 

 

 

  

https://ca.qbo.intuit.com/app/trialbalance
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QBOA Software Integration in ProFile (continued…) 

Once complete, click on “Save GIFI codes” in the top right corner; the 
information saves in the GIFI File format. 

Open ProFile. 

Create a T2 return, or open the existing T2 return associated with the 
QBOA firm. 

Importing the GIFI from ProFile  
 
Select the “QBOA Import” option under the “File” drop-down menu in 
the top toolbar. 

Click “OK”; the process completes. 
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Managing One Intuit accounts in 

ProFile 
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Inuit “One Account” log in  
 

The Intuit “One Account” tool allows access to several Intuit products and services with a single log in and 

password. 

 

One Inuit products and services 

The “One Account” tool provides access to the following: 

 ProFile Review  

 ProFile Link  

 ProFile support community 

 QBOA 

 QBO 

 TurboTax online 

 

One Account access 

Customers can create a “One Account” when accessing a supported service for the first time. 

The “One Account” log in window displays when accessing a supported service. 

Select the “New to Intuit? Create an account” link at the bottom of the log in window to create a new 

account. 
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Backing up to Cloud for ProFile Review 
 

How do I first synchronize my returns with ProFile Review?  

There are a few steps you must follow to synchronize your data with ProFile Review. These steps are: 

1. Enable synchronization on ProFile Desktop. 
2. Create or register an account with ProFile Review and associate it with a License Key and Order Number. 
3. In ProFile Desktop, sign in to your online account by clicking the Online menu and choosing Manage Online Account. (Enter the account credentials 

and password that you used to register your account with ProFile Review.) 
4. Select the folder that contains the returns you wish to synchronize with ProFile Review. 

 
Do I have to sign in to my Online Account in ProFile to synchronize with ProFile Review?  
No. Once you complete the initial synchronization with ProFile Review, every time you save a file it automatically synchronizes with ProFile Review. 

 
How do I synchronize my data while within ProFile Review?  
As with ProFile Desktop, synchronizing occurs automatically. Every time you save changes made to the return that you are reviewing, you are synchronizing 
your data with ProFile Desktop. 

 
How do I know that the returns I reviewed in ProFile Review have synchronized with ProFile Desktop?  
When you open ProFile, a pop-up window will appear telling you that changes were made to the return using ProFile Review. You can review these changes 
in ProFile’s Auditor Tool using a new tab called “Online Change”. Every review mark and memo change that was made in ProFile Review will appear in the 
“Online Change?” tab in the Auditor Tool. 

Note: you cannot save a return that has been reviewed using ProFile Review until all of the online changes noted in the Auditor Tool are accepted or 
declined. 

 
Can I edit a client's tax information from online with ProFile Review?  
You cannot edit a client’s tax information. You may add or edit review marks and memos, and create PDFs of returns. 

 
Why don't returns that I have uploaded show up in ProFile Review immediately?  
The Client List is cached (temporarily stored on your computer) to make navigation faster. It should refresh within about 10 minutes. Alternatively, you can 
sign out and back in again, or refresh your browser. 
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Managing OnePay in ProFile 
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Overview of ProFile OnePay 
 

OnePay is a one-time license that allows a ProFile customer to file a 
single T1, T2, or T3 return. It is an alternative to purchasing a full ProFile 
license, which allows for unlimited returns. 

OnePay is best suited for: 

 an existing ProFile customer whose license has expired, but still 
needs to file a return or returns 
 

 a new ProFile customer with a limited number of returns to be 
filed 
 

 a resident of Quebec at the end of the fiscal year, and only the 
Federal module has been purchased and not the Quebec TP1 or 
the Quebec T646 * 
 

 a ProFile customer with a business registered in Quebec* 
 

*In the event of the OnePay purchase for Quebec, the preparer is required to NetFile the TP1 separately from the Federal. They also require a NetFile QC 
Number and Access Code. For more information, visit Revenu Québec. 

Note: if the taxpayer resides in any other Province and has an RL-1, the TP1 return is not necessary. The RL-1 information may be entered in the T4 form. 
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Purchasing ProFile OnePay 
 

Please be aware: an Internet connection is required to complete the purchase via our secure 

web page. OnePay can only be purchased from within ProFile.  

 

Purchasing OnePay 

Open ProFile. 

Open a new return (“File” -> “New” from the top toolbar) or carry forward an existing return 
(“File -> “Carry Forward…”). 
 

The OnePay payment wizard displays, requesting the following information:  

 the social insurance number (SIN) 

 the first/last name of the taxpayer whose return is to be filed 

Click the “Next” button. 

Complete the “Customer Info” information: 

 the necessary company and billing information 

 the necessary payment information 

 a confirmation of the payment and purchase information 

Click the "Place Order" button when all necessary information has been provided. 

The confirmation window displays confirming the OnePay has been successfully purchased.  

Close the confirmation window. 

The preparer is returned to ProFile and to the return to be filed. 
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Troubleshooting ProFile OnePay 
 

I am being prompted to purchase OnePay… 

If a ProFile customer attempts to populate a form for any module (e.g., T1, T2, or T3) without an existing valid ProFile license, the OnePay purchase wizard 

displays. 

 

Can I use Auto-fill my Return (AFR) with OnePay? 

Yes. Prior to using AFR with OnePay the preparer requires: 

 an EFILE account 

 a representative ID 

 EFILE a T1013 form  

To learn more about authorizing or cancelling a representative, please review the CRA article. 

 

 

I downloaded a trial version of ProFile, but when I try to evaluate the software, the OnePay Wizard appears, asking me to purchase a return… 

When installing a ProFile Trial version, make sure you insert the new Product Code and License Key in the License window. 

 

I am seeing a "TRIAL" watermark written through all of the forms when I print the return using a OnePay license. .. 

This happens because the Trial license and the OnePay are both activated in ProFile at the same time and the Trial license is overriding the OnePay. 

In ProFile: 

1. Navigate to the “Help” -> “License” -> “Details” option. 

2. Click on the “Trial License” option 

3. Click on the "Delete Selected License” option. 

4. Close the “Licensing” windows 

5. Open the file to print by navigating to the “File” -> “Open” option. 

6. Print normally. 

  

http://www.cra-arc.gc.ca/E/pbg/tf/t1013/t1013-16e.pdf
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Troubleshooting ProFile OnePay (continued…) 

 
I received an error message at the end of a OnePay purchase transaction… 

When purchasing OnePay through ProFile's OnePay Purchase wizard, the following error may appear: 

"Your online purchase transaction was not completed. Please go back and review your selections". 

This is not a ProFile error, but could be resulting from one of the following situations: 

 high security settings on the computer (see solutions below) 

 a network disruption (check your network is functioning) 

 the transaction timed-out (retry the transaction to completion) 

The following are solutions that may resolve the high security setting issue: 

 check ProFile version is the latest 

 check Windows Update for any recent OS updates 

 set firewall/antivirus exception for ProFile 

 set SSL/TSL security 

 allow pop-ups 

 clear your cache and browsing history 

 check for Proxy settings 

 check .NET version is the latest 

 

Can I purchase more than a single OnePay? 

When purchasing One-Pay, only one unit can be purchased at a time. If a quantity greater than one is entered in the “Quantity” field, you will be charged 

for that quantity but will only receive one license. 
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Managing ProFile security settings  
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Using Options Packages in ProFile 
 

An options package is a file that preserves customized ProFile settings. These can include office details, printing options, database settings, and template 
and module settings.  
 
Creating an options package means that your ProFile settings can be used by you or by others without having to recreate any preferences.  

 

How do I use the option package? 

An options package can be used two different ways:  

 saved on a shared network/server where everyone has access to it 
 saved on a terminal server where everyone has access to it 
 saved locally to a single computer that is not on a shared network/server 

Depending on which use is selected multiple users can work with ProFile in the same consistent manner, or an individual user can work with ProFile in a 

manner specific to themselves.  

 

Types of options packages 

 

There are three types of options packages in Profile, individual, shared, or custom.  

 

Individual options packages save on an individual computer and are loaded when ProFile launches.  

 

Shared options packages save to a network/shared server where one or more individual computers have access to the package. This is the ideal option if 

you are using a network environment, Client Server, or Terminal Server environment.  

 

Custom option packages allow the same ProFile options to be utilized even if an individual computer is disconnected from a network/server/terminal 

server. A Profile user creates custom options packages in different locations and instructs ProFile which to use. 

 

  



 
157 

 

Creating an Options Package in ProFile 
 

Start ProFile.  
 
Select “Options Administration…” from the “Options” menu; the “Options Administration” 
window displays. 

Set the necessary options for the package (e.g., template use, pricing, database, etc.); these 
selections will become the settings in the new options package.  
 
Select the options package type (1, 2, or 3).  
 
Check the option “Include preparer and discounter name with Option packages”, if 
applicable.  
 
Check the option “Prompt to save changes”, if applicable. This feature applies only to 
package types 2, 3, and 4 and selecting the option prompts the user to save any changes 
made to an options package when closing ProFile.  
 
Note: any changes made to an options package prior to ProFile being closed are NOT saved if 
the “Prompt to save changes” feature is not activated. Users must explicitly use the “Save” 
function to save any changes or they will be lost when closing Profile.  
 
Click the “New” button.  
 
The “New Settings” window displays.  
 
Enter the name of the new options package. 
 
Click the “OK” button.  
 
The new options package file saves to the designated location and displays in the “Options 
Packages” list. 
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Managing Options Packages in ProFile 
 

Options package management includes several tasks that can be undertaken, including: 
 

 creating a new options package 

 loading an options packages 

 updating an existing options package 

 deleting an options package 

 transferring an existing options package 

 

Review our full support article to learn more about how option packages are managed. 

  

https://profile-en.community.intuit.ca/articles/1625431-using-the-options-package-on-profile
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Using Multiple, or “Custom”, Options Packages in ProFile 

 
A computer that is utilizing an options package on a network/server/terminal server will lose access to it if the computer disconnects from the 
network/server/terminal server.  
 
However, ProFile can be set to access an alternate local options package (or packages) on the individual computer’s hard drive as a substitute to the 
network/server/terminal server options package. ProFile will first search for the designated options package on the network/server/terminal server; if that 
options package is not available ProFile will search for the next options package on the list.  
 
Note: ProFile does not synchronize changes between options packages. Any changes to a local options package while disconnected from the 
network/server/terminal server are not saved in the network/server/terminal server options package.  
 

Managing files in multiple options packages 

When the laptop is connected to a network/server/terminal server, users should use the options package stored on the network/server/terminal server. 

When the laptop is disconnected from the network/server/terminal server users can specify an options package stored locally on the laptop itself.  

However, be aware that by having two different sets of options you are using two different databases. Files created or changed when you are disconnected 

from the network/server/terminal server will not be listed in the database stored on the network/server/terminal server.  

 

Creating and assigning multiple options packages 

ProFile users who will disconnect at some future time from a network/server/terminal server and continue working will need to create at least two options 
packages: one for connected network/server/terminal server use and one for when disconnected from the network/server/terminal server. This allows the 
disconnected work to use the same options package settings as that on the network/server/terminal server. 
 

Related articles 

Review our full support article to understand more about using multiple options packages. 

  

https://profile-en.community.intuit.ca/articles/1625431-using-the-options-package-on-profile
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Password Protecting Options Packages in ProFile 
 

Any options package can be password-protected. This prevents unauthorized users or other preparers 

from altering the options package. 

 

Password protecting options packages 

 

Select the “Options password…” item from the “Options” drop-down menu in the top toolbar.  

 

The “Set Options/Delete Password” window displays. 

 

Enter a password in the “Password:” field of the “New password” section.  

 

Enter the same password again in the “Confirm:” field.  

 

Click the “OK” button.  

 

The password saves and the options package file is protected from alterations and deletion.  

 

A prompt requesting the password displays any time changes are made to the settings.  
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Data/File Locking in ProFile 
 

Data locking automatically locks a return to prevent any changes from 

occurring after the return’s status is set. 

Setting the data locking options 

Open ProFile. 

Select the “Module…” option from the “Options” drop-down menu in 
the top toolbar menu. 

The “Module Options” window displays. 

Select the appropriate module and year from the tab menu in the top 
of the window (e.g. “2014 T1/TP1”). 

Select the “Data Locking” tab. 

Select the appropriate option under the “Client Status” list. 

Select the appropriate option under the “EFILE Status” list. 

Note: one or more option may be selected from the lists. 

Click the “OK” button.  

The file locks when the selected criteria occur.  
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Security: Data/File Locking (continued…) 

Setting the print locking options 

Select the “Form Selection…” option from the “Options” drop-down menu in the top toolbar menu. 

The “Form Selection” window displays. 

Select the appropriate module and year from the tab menu in the top of the window (e.g. “2014 T1/TP1”). 

Click the drop-down menu arrow in the “Status after printing” section; the menu expands.  

Select the appropriate option from the menu. 

Set the appropriate options for each module. 

Click the “OK” button.  

After the return is printed, the return locks to the selected status. 
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Locking a PDF in ProFile 
 

Data locking automatically locks a return to prevent any changes from occurring 

after the return’s status is set. 

Setting the PDF locking options 

Open ProFile. 

Select the “Environment…” option from the “Options” drop-down menu in the 
top toolbar menu. 

The “Environment Options” window displays. 

Select the “PDF” tab.  

Select the appropriate option under the “PDF Security” option list: 

 None 

 Client Name + SIN/BIN/TAN/PN 

 Client Name + DOB/Fiscal EndDate 

 User Specified 

 
Setting Owner Password 

The “Set Owner Password” option provides an additional level of security to prevent a “locked” PDF from being edited. 

Enter a password in the “Set Owner Password” field; users will require this password to open a file, in addition to any password set in the “PDF Security” 
option list. 

Click the “OK” button; the PDF locking selection applies. 
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Using Keyboard Shortcuts in ProFile 

 
If a preparer processes a large volume of client files, there is an advantage to learn the keyboard shortcuts for common functions in ProFile. 

 

Action Shortcut Command 

Attach tape <Ctrl+F8> 

Back to previous form <Alt+F7> 

Carry forward a file <Ctrl+R> 

Clear highlighter <Ctrl+H> 

Clear review mark on field <Ctrl+Alt+0> 

Close current window <Ctrl+F4> 

Copy field <Ctrl+C> 

Correction required mark <Ctrl+Alt+3> 

Create a new file <Ctrl+N> 

Cut field <Ctrl+x> 

Display jump list <Shift+F6> 

Display previous audit message <Shift+F9> 

Ditto key (back apostrophe) 

EFILE this return <Ctrl+F11> 

Instant SEND <Shift+F11> 

End review <Ctrl+E> 

Exit ProFile <Alt+F4> 

Explorer Keyword view <Shift+F7> 

Explorer Line view <Shift+F4> 

Federal/Quebec toggle <Shift+F5> 

File properties <Ctrl+I> 

Form help <Shift+F1> 

Next checklist form <Ctrl+Alt+PgDn> 

Next Edit window form <Crtl+Tab> 

Next file <Ctrl+F6> 

Next page on form <Ctrl+PgDn> 

Next section on form <Alt+PgDn> 

Non-zero T1 summary <Ctrl+F10> 

Open an existing file <Ctrl+O> 
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ProFile Keyboard Shortcuts (continued…) 

 

Action Shortcut Command 

Open form in new window <Ctrl+Alt+F6> 

Open the Tape dialog box. <=> 

Override format <Ctrl+F2> 

Partner sign-off <Ctrl+Alt+2> 

Paste field <Ctrl+V> 

Pause / start timer <Ctrl+T> 

Preparer sign-off <Ctrl+Alt+1> 

Previous checklist form <Ctrl+Alt+PgUp> 

Previous Edit window form <Ctrl+Shift+Tab>* 

Previous page on form <Ctrl+PgUp> 

Previous section on form <Alt+PgUp> 

Print file(s) <Ctrl+P> 

Question review mark <Ctrl+Alt+4> 

Quick-print audit messages <Alt+F9> 

Quick-print T1 summary <Ctrl+Alt+F10> 

Quick-print T183 form <Alt+F11> 

Quick-print tax summary <Alt+F10> 

Save the file <Ctrl+S> 

Show/hide auditor <Ctrl+F9> 

Snapshot/Variance <Alt+F8> 

Switch to family member <Alt+F5> 

T1, T2, T3 jacket <Ctrl+J> 

Toggle T1/TP1 <Shift+F5> 

Toggle T2/AT1 RSI <Ctrl+F5> 

Top of next slip <Ctrl+Enter> 

Top of previous slip <Ctrl+Shift+Enter> 

ProFile Help F1 

Override F2 

Client Explorer F3 
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ProFile Community and Support Site 

 
The ProFile Community and Support Site has recently undergone a 

redesign in order to serve our customers more effectively. You can now 

search both our support articles and forum questions at the same time, 

in order to return the best possible answer to your product question.  

Available 24-hours a day, our Community and Support Site has more 

than 800 articles designed to improve your ProFile experience. 

https://profile-en.community.intuit.ca/profile-ca-en 

 

 

 

  

https://profile-en.community.intuit.ca/profile-ca-en
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Sending Feedback about ProFile  
ProFile users can conveniently provide feedback on ProFile’s functionality or suggest an enhancement 

to the product. 

 

All feedback is reviewed by the product owner, developer, or analyst. 

 

 

Opening the feedback window in ProFile 

 

Select the “Send Feedback” option under the “Help” drop-down menu in the top toolbar.  

 

The “Post an idea” window displays. 

 

Describe your idea in the feedback field; you can be as specific as you like.  

 

Click the “Next” button when finished. 

 

The “Additional details” window displays. 

 

Enter the idea title (e.g. “New function idea”) and select the related category. If you are unsure which 

category to select, just choose the one closest to matching with your idea/feedback. 

 

Enter your email address; this allows ProFile to follow up with you in the future about your 

idea/feedback. 

 

Click the “Post idea” button. 
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Additional ProFile Resources 

 
Training and Tutorials Site 

Whether you are a new ProFile user or an experienced professional, you can enhance your skills with our training resources, video tutorials, and “Tips & 

Tricks” site. Updated regularly, this site includes both core and advanced information to help throughout the return preparation process. 

http://profile.intuit.ca/professional-tax-software/training.jsp 

 

Webinars Calendar 

Keep learning with our informative webinars, held every Tuesday and Thursday throughout the year. Live webinars take you through the finer points of 

ProFile, and if you have any questions, our experts are there online with you, ready to answer. 

You can join an upcoming webinar through the calendar: 

http://profile.intuit.ca/professional-tax-software/webinars-events.jsp 

 

In-product Help 

The in-product “Help” utility provides an easy way to learn about forms, slips, schedules, ProFile’s functions, and many other topics. Simply press the <F1> 

key from anywhere in ProFile to launch the Help utility. 

 

Live Chat  

Inside the ProFile software (and on many of our support pages) you will find the “Live Chat” option. This quick and convenient tool lets you immediately 

begin speaking to one of our support representatives online, without having to wait on the phone or interrupt your work. Available during our regular 

support hours. 

 

 
 

http://profile.intuit.ca/professional-tax-software/training.jsp
http://profile.intuit.ca/professional-tax-software/webinars-events.jsp

