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Utility Mapping Bootcamp

How To Map & Manage Utility Data using FREE GIS Mapping Software

What you'll learn

e |Install Mapping Software e Digitize and Map Utilities

e Create GIS Shapefiles e Publish Data Layers to Web

e Symbolize Utility Data e Create a Web Map

e Import Field Data to QGIS e Build a Web Mapping Application
Requirements

e Students should have 0 - 10+ years experience with Utilities, GPS, GIS, GPR, & AutoCAD.
e Students should be familiar with various data formats: KML, CSV, DXF, DWG, CAD.
e Students should be eager to learn how to map and manage critical utility data.

Description

In response to the steep learning curve, high cost, and unlimited complexities of building
custom GIS web mapping applications and deliverables, we have created this easy-to-follow,
hands-on Utility Mapping Bootcamp training course. Following these steps, students will
quickly learn how to map utilities and build GIS applications like a professional, without writing
a single line of code.

In this course, you will learn how to install free mapping software, create and manage utility
data using GIS, convert raw field data to GIS, export PDF maps, and build an interactive web
application to visualize and share your maps and data online. You will learn industry-leading
Best Practices for successful utility mapping and data management.

This Utility Mapping Bootcamp will get you up and running with GIS in a very short time.
By the end of the training, you will have the steps and process involved with using GIS software

to map and manage utility data and generate cutting-edge GIS deliverables for new and existing
clients.
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Who this course is for?

Utility Locators, GPR Technicians, CAD Drafters, Surveyors, GIS Technicians, GIS Analysts,
Utility Engineers, Directional Drillers, high school students, and college students.

This course is meant for those looking for hands-on experience mapping and managing
utility data using GIS.

This course is great for students interested in sharpening their GIS, utility mapping, and
data management skills.

This course is perfect for surveying, utility locating, and SUE firms that want to expand
their deliverables and stand apart from the competition by offering GIS as a service.

Anyone interested in learning how to map underground utilities using GIS.

Course Contents
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Introductionto GIS..................... 5
Install Mapping Software........... 7
Create GIS Shapefiles.................. 9
Symbolize Utility Data............... 17
Add GPS Field Data to Map...... 20
Digitize and Map Utilities......... 25
Upload Data to ArcGlIS Online..33
Build Utility Map Viewer........... 37

Explore ArcGIS Capabilities......40
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Legal Disclaimer And Terms of Use

This course is for research and training purposes ONLY. The software, applications, and datasets
used in this course are copyrighted by the original owners.

ArcGIS Online is a proprietary software and is NOT free for commercial use without purchasing a
license. Students agree to read and agree to the Terms of Use for ArcGIS Online before using the
software and application in this course.

This course demonstrates the use of QGIS and ArcGIS Online in a free, public, and educational
manner. ArcGIS Online is copyrighted by Esri. We do not own the rights to and are not responsible for
misuse of any of the software, applications, or data used in this course or in your business processes
outside of this course.

This course is not a part of QGIS, Esri, or Google. Additionally, this course is NOT endorsed by
QGIS, Esri, or Google in any way. QGIS, Esri, and Google are separate trademarks of their respective
entities.

Nothing in this course, or any of our content or curriculum is a promise or guarantee of results
or future earnings. Use caution when implementing these processes in business, and always consult
your accountant, lawyer, or professional advisor before acting on this information or any information
related to a lifestyle or business change.

You alone and/or your business is responsible and accountable for your decisions, actions, and
results in life. By downloading and reading this training, you and any person you share this information
with, agree not to hold, or attempt to hold Centerline Mapping LLC liable for your decisions, actions or
results, at any time, under any circumstances.

Centerline Mapping LLC can not and does not make any guarantees about your ability to learn,
get results, or earn any money with our ideas, information, tools, or strategies mentioned in this
document and online training.

Map and manage underground utility data using GIS mapping software at your own risk.
Redistribution of this course content is unauthorized and prohibited.
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Course Content

1. Introduction to GIS
e Whatis GIS?
o  Benefits of GIS

2. Install Mapping Software
e Download and install
e View user interface
e  Browse various buttons
® (Zoom, Pan, Identify, Save, Measure)

3. Create GIS Shapefiles

e Add an aerial imagery map service
Create point and polyline features
Create attributes for utilities
Reorder layers in Layer box
View shapefile in windows explorer
Save and Open the Map

4. Symbolize Utility Data
e  Edit map layer colors and symbols
e  Save maps and map layer settings
o Add flow arrows to polyline layers

5. Add GPS Field Data to Map

e Import and explore data (KML, CSV)
Zoom to data after adding
Edit, reorder, and symbolize data
Explore attributes
Use measurement tool

6. Digitize and Map Utilities
e  Edit shapefiles using GPS data
e  Map utilities and add attribute info
e  Export data in various formats
e Create map labels

7. Upload Data to ArcGIS Online
e  Organize and zip shapefiles
e Upload data to a web map
e  (Create and save a web map

8. Build Utility Map Viewer
®  Save web map as web application
o  Edit settings of web applications
e Customize and view data

9. ArcGIS Capabilities
o  Explore tools in Utility Map Viewer
®  Print maps from the application

Learn how to build interactive Utility Map Viewers.
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Introduction to GIS

A GIS (Geographic Information System) is a computer-based tool used for
mapping, managing, visualizing, and analyzing various tabular and spatial
information including underground and above ground utilities such as water, gas,
storm, sewer, electrical, steam, telecommunication, sprinkler, condensate, and
much more. GIS is a map tied to a relational database with analytical tools
in-between. The value and capabilities of GIS for utilities are endless.

By using GIS, facilities and asset owners can better manage and operate reliable
utility services using one central database of updated data, rather than a cabinet
or local hard drive full of unorganized and outdated drawings. All of their data is
stored in one location, accessible in a single interactive web-based mapping
application accessible on any device, anywhere.

GIS is nothing new to the utility industry, in fact it’s been around for decades.
Due to new technology breakthroughs, GIS is no longer your single tool for
mapping underground utilities; it’s now a whole platform for understanding and
optimizing system operations, performance, leak detection, and other
maintenance activities.

GIS is used in the planning, construction, design, and maintenance aspect of
operating and managing utilities. Engineers, surveyors, field crew, technicians,
planners, and management personnel all contribute and benefit from the value of
a well-implemented GIS.

GIS gives users the ability to create web-based maps, integrate additional
software platforms (SAP, SCADA, SharePoint), visualize scenarios & risk potential,
solve complicated problems, present powerful ideas, and develop effective
solutions quickly and accurately. Utility locators and surveyors are at the front
lines of this movement, locating and collecting the data to make Geographic
Information Systems achievable.
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Benefits of GIS to Utility Departments & Facility Owners?

Reduce Operational Costs

Save Time Relocating Utilities

Improve Utility Data and Asset Management
Efficiently Manage New & Aging Infrastructure
Achieve Maximum Productivity

Boost Public Relations

GIS is important for the utility industry as people must know where their pipes,
valves, pumps, meters, and other facilities are located and additional information
regarding each asset. It’s important to know where valves are located for
scenarios such as gas and water main breaks, leak isolations, and excavation
operations.

More and more utility departments and private facility owners are turning
towards GIS to help manage and operate utility systems. GIS is becoming a
requirement on several local, and federal RFPs, meaning Surveyors and Utility
Locators are required to deliver these services and data formats. The good news
is that it’s not too late to begin learning and offering GIS as a service. At
Centerline Mapping, we’ve created Utility Mapping Bootcamp to teach you.

Benefits to Utility Locating, Surveying, and Engineering Firms?

Win Multi-Million $SS GIS Contracts
Win Repeat Business with Clients
Blow Past Your Competitors
Sharpen Your Business Blade
Become the 'Go-To' Locating Firm
Grow Your Business and Client Base

In summary, GIS is an extremely important tool used by asset owners and local
goVv't to help maintain infrastructure, deliver services, and inform the community.

Ready to learn how to map utilities using FREE GIS Mapping Software!?

Let’s get started!
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Install Mapping Software

The first step in mapping and managing utility data is installing desktop GIS software. Today,
you will install free, open source mapping software, called QGIS.

1. Browse to https://qgis.org/ and click the green Download Now button to download a

package for your platform (Mac OS, Windows, Linux, Android, etc.).

QGIS

A Free and Open Source Geographic Information System

PROJECT NEWS

2. If you have a Windows 64 bit, download the latest package.

QGIS Standalone Installer Version 3.4 (64 bit)

Download QGIS for your platform

Bin: es (installers) a

Download for Windows

QGIS in OSGeoAW:

& (*)‘ 0SGeoAW Network Installer (64 bit)

et qgis-itr-full

z
N——

s
mds
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https://qgis.org/

3. Run the file. Click Next > Click | Agree. (accept the default destination path). Click Next >
Click Install > Click Finish.

4. Open QGIS!

5. Click Project > click New.

You have successfully installed FREE Open Source GIS mapping software!

Let’s move on to the next lesson and create GIS shapefiles to store spatial and tabular
information for utility assets such as pipes, valves, hydrants, storm mains, laterals and
attributes like pipe diameter, material, depth, etc.

Follow us to the next lesson below.
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Create GIS Shapefiles

Take a moment to get familiar with the QGIS graphical user interface. Hover your cursor over
some of the buttons to get an idea of their functionality. Don’t worry too much about all of
those buttons, you will not use 95% of them in this course.

In this lesson, you will learn how to add aerial imagery to a map and create shapefiles to map
and store the locations of underground utilities and assets.

For additional documentation on QGIS - https://docs.qgis.org/3.4/en/docs/training_manual/index.html
Before you create shapefiles, add aerial imagery to the map as a basemap.
Add Aerial Imagery

1. On the Menu Toolbar, click Layer > Add Layer > Add ArcGIS MapServer Layer...

(@ Untitled Project - QGIS o be
Project Edit View Settings Plugins Vector Raster Database Web Mesh Processing Help
[ iv B F3 (5 @ Data Source Manager Ctrl+L =] ¥ T =-P O
Create Layer 3
LR - . -
Add Layer [\ Add Vector Layer... Ctrl+Shift+V
y o
Embed Layers and Groups... ¥, Add Raster Layer. Ctrl+Shift+R
Browser - Add from Layer Definition File. | B Add Mesh Layer..
oeYmre |
- Copy Style 9., Add Delimited Text Layer.
- Favorites Paste Style | ®, Add PostGIS Layers CtrlaShifts D
+ (6] Home s i o 5
v DI £7, Add Spatialite Layer... Ctrl+Shift+1
@ GeoPackage | B Add MSSQL Spatial Layer. Ctrl+Shift+M
£ Spatialite : 2, Add DB2 Spatial Layer... Ctrl+Shift+2
13 {
@ roscis | @, Add Oradle Spatial Layer.. Ctrl+Shift+0
P MssaL |
@ Orade | WA Add/Edit Virtual Layer...
& os2 » | €8 Add WMS/WMTS Layer... Ctrl+ Shift+ W
& wims/wmTs &% Add ArcGIS MapServer Layer...
v & XYZ Tiles |
@ |
o GoogleMay  S2ve As Layer Defintion File @8 Add WCS Layer..
= I | &2 Add WFS Layer...
B OpenStreet [ Remove Layer/Group cul+d “
P SV " i) Add ArcGIS FeatureServer Layer...
Layers
s A ®T 3
Ctrl+Shift+C
Layer Properties.
Filte Ctrl+F
Labe
Show in Overview
= Show Allin Overview
2 Hide All from Overview

Type to locate (Cirl+K) Ready Coordinate| -0.113,0.943 5 Scale|1:1476801 ~ | (@ Magnifier| 100% % | Rotation 0.0° 2 ||| Render @ EPSGa326 @ &

2. Click New > Provide a Name and URL in the Connection Details Dialog Box. Use the Name
and URL information below.

Name: Imagery

URL: http://services.arcgisonline.com/arcgis/rest/services/World_Imagery/MapServer
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X
\{ Vector Server Connections
* j | @ Create a New ARCGISMAPSERVER Connection ®
Imagery
Raster Connection Detalls
comee |

Mesh Mame ‘Imagary |

Filter URL }erwc&s‘arcgisnnhna.mm,{arcgis,’rest,{senfimesf\'\dorld_lmagary,’MapServer\l
Delimited Text =

Title MName Abstract Authentication
GeoPackage Configurations Basic

o= Choose or create an authentication configuration
Spatialite

| Mo authentication el

Configurations store encrypted credentials in the QGIS authentication
database.

* MS5S0L

Oracle
73
% DB

Virtual Layer

[ Use title for layer name
Image Encoding

‘Coordinate Reference System

3. Click OK > Click Connect (internet connection is required for this step).

4. Keep all the defaults and click Add. Then click Close to close the dialog box.

() Data Source Manager | ArcGIS Map Server X
Server Connections
|1magery =
Connect | MNew | Edt || Remove
Mesh
Filter
Delimited Text
+ Title MName Abstract

ackage 0 World Imagery ~ World Imagery provides one meter or better satellite and aerial imagery in many parts of the...
3 Low Resolution ... World Imagery provides one meter or better satellite and aerial imagery in many parts of the..,
2 High Resolutio.. Waorld Imagery provides one meter or better satellite and aerial imagery in many parts of the...
3
4

Spatialite

High Resolutio... Waorld Imagery provides one meter or better satellite and aerial imagery in many parts of th

Citations World Imagery provides one meter or better satellite and aerial imagery in many parts of t

PostgreSOL

+ Virtual Layer

[] use title for layer name
Image Encoding

@ pPne32 (O pNG24 (O PNG O wc O TIFF O GIF O sve O svez O BMP

e Ea —
EPSG:3857 | Change... |
e | ][ e

You should now see aerial imagery in your map.
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(2 “Untitled Project - QGIS i x
Project Edit View Layer Settings Plugins Vector Raster Database Web Processing Help

DEARRRE OPLL,AHPPALBRIS @@
REV: AR A /B SR-B@ <0 B = % E e E e

bi-5-3® é @ b N = LT .V
Browser £ X :
DerTae
' Favorites ~
&1 Home
0
1D\
TEA

el

L

GeoPackage
Spatialite
PostGlS
MSSQL
Oracle

DB2

B WMS/WMTS

aevans

Layers g X
“B®TE~FTD
v [ ¥ Citations

Citations

Q. Type to locate (Chrl+) Ready Coordinate | -7999022,4442024 | Scale[:87125430 | (@ Magnifier[100% 1] Rotaton [0.0° 2| Mrender @ epsciesy @

Move your mouse cursor over the map and use the mouse scroll to zoom in and out.

Create Shapefiles
Create 3 shapefiles and 3 attributes for each shapefile, as shown below.

e \WaterlLine > Diameter, Material, Depth
e \WaterValve > Diameter, Manufacturer, ID
e \WaterHydrant > Diameter, Manufacturer, ID

1. On the Menu Toolbar, click Layer > Create Layer > New Shapefile Layer.

() *Untitled Project - QGIS
Project Edit View Layer Settings Plugins Vector Raster Database Web Processing Help

D i  Data Source Manager Chrl+L DD Q QMM e @ & -
Create Layer 4 Q‘ New GeoPackage Layer... Ctrl+Shift+N
\/ ane
(! Q 3] lﬁ Add Layer » " New Shapefile Layer... (4]
2 [ D i O G Embed Layers and Groups... £5 New Spatialite Layer... , px
Add from Layer Definition File... @8 New Temporary Scratch Layer... g

Browser
LRAT®O B Copy Style
Paste Style
&1 Copy Layer
0ca Paste Layer/Group
[7 b
O EN Open Attribute Table F&
@ GeoPackage Teggle Editing
f Spatialite Save Layer Edits
' PostGls Current Edits
P mssaL
@ Oracle FEREE
3 pez Save As Layer Definition File...
B WMS/WMTS [1  Remove Layer/Group Ctrl+D
= Duplicate Layer(s)
Layers S
Set Scale Visibility of Layer(s)
1 @ -
LAY G- Set CRS of Layer(s) Ctrl+ Shifts C
x i¥° Citations Set Project CRS from Layer
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2. In the New Shapefile Layer dialog box, for File name, click the small square with 3 dots (top

right corner) to choose a location to store the new shapefile.

id

Type
Length |80

Name

(2 New Shapefile Layer

File name I

File encoding UTF-8

Geometry type 2" Point

Additional dimensions ® None Z (+ M values)

EPSG:3857 - WGS 84 / Pseudo-Mercator

New Field

Name

abe Text data
Precision

Add to Fields List

Fields List

Type Length
Integer 10

Precision

OK

(-

M values

Cancel Help

o

v

Remove Field

3. Browse to a location on your machine and enter WaterLine for File name

& New Shapefile Laye

File name
File encor

Geometr

Name
Type

Length

Fields

Name
id

@ Save Layer As

« K s> ThisPC » Desktop > TrainingData » v @& | Search TrainingData
Qrganize + New folder
- PS
B~ Name Date medified Type
= course-data File folder
gps_data File folder
pics File folder
septic File folder
[ dfw.shp SHP File
|_] ‘WaterLine.shp SHP File
G (
@-
- 2
v <

1KB
1KB

File name: ‘Water\_md

Save astype: | ESRI Shapefile (*.shp *.SHP)

A Hide Folders

Save

Cancel

oK

Remove Field

Cancel Help

. Click Save.

4. Next, within the New Shapefile Layer dialog box, for Geometry Type choose Line.
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(2} Mew Shapefile Layer

File name WaterLine &
File encoding UTF-8 e
Geometry type 4 Line =
[ tndlude Z dimension [ tndude M values
|EPSG: 3857 - WG5S 84 [ Pseudo-Mercator | |
New Field
MName ||

Type | &bcTextdata

Add to Fields List

Fields List
Name Type Length Predision
id Integer 10
Diameter String 10
Material String 10
Depth String 10

Remove Field

Help

5. In New Field section, enter Diameter for Name. Change Length to 10. Click Add to Fields

List.

13

6. In New Field section, enter Material for Name. Change Length to 10. Click Add to Fields List.

7. In New Field section, enter Depth for Name. Change Length to 10. Click Add to Fields List.

8. Click Ok. You should see the layer added to the Layers dialog box to the left.

() *Untitled Project - QGIS
Project Edit View Layer Settings Plugins Vector Raster Datzbase Web Processing Help

DEBRRRH O LL,ANPPRABLIT @

MGV AW /B CR-FT=xa B = o [ =y
M- BORREARPOCRR®:

. 0 ¥ ovE_

Browser B x
OR2TY®O
¢ Favorites ~
[&] Home
> [Jey
> [J DA
> [ B
@ GeoPackage
/7 Spatialite
@ PostGls
P mssaL
@ Oracle
B oz

@ WMSWMTS

Layers 8 x
« @ ® T &~-BAD

] — Waterline
~ [7 ¥ Citations

Citations
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9. Follow the same steps above to create a WaterValve and WaterHydrant shapefile. Make
sure to use Point for the Geometry Type for these 2 shapefiles.

10. To create a WaterValve shapefile - On the Menu Toolbar, click Layer > Create Layer > New
Shapefile Layer

11. In the Dialog Box, enter WaterValve for File name. For Geometry Type choose Point.
(Make sure to save this shapefile in the same location as the others.)

12. In New Field section, enter Diameter for Name. Change Length to 10. Click Add to Fields
List.

13. In New Field section, enter Manufacturer for Name. Change Length to 10. Click Add to
Fields List.

14. In New Field section, enter Type for Name. Change Length to 10. Click Add to Fields List.
15. Click Ok. You should see the layer added to the Layer dialog box to the left.

16. Repeat this process for as many utilities you need to map (i.e. telecommunication, gas,
stormwater, electrical, sprinkler, hydraulic, steam, condensate).

17. To view a map layer’s attribute table, right click the map layer in the Layers dialog box to
the left > click Open Attribute Table.

= *Untitled Project -
(@ “Untitled Proj QGlIs
Project Edit View Layer Settings Plugins Vector Ras

heBRRK O eLp APK
aeV./Ziw B =98

y f/}-_:' Zoom to Layer )
#
FrOWEET Zoom to Selection

&Y & ® |73 Showin Overview

Favorites | Show Feature Count
» [6] Home Copy Layer
e

Rename Layer
& GeoPackag —

/£ Spatialite | ! Duplicate Layer
@ PostGIS [l Remove Layer...
P mssaL Move to Top

Oracl 1
g i B Open Attribute Table
&5 pB2

6 wmspwm| ¢ Toggle Editing

-

v & XYZ Tiles Eilter...
- GOOQI% Change Data Source...
P ‘:l';?penSE Set Layer Scale Visibility...
Layers Set CRS »
“aA®T &~ Export »
VAR Wa'ter\: Styles R
V| @ Waterk

P rties...
Water| ¥ i CRees
bt 2 Citations
Citations
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Notice there are no rows in the attribute table as you have not mapped and added attributes
for any WaterlLines yet.

() Waterline = Features Total: 0, Filtered: 0, Selected: 0 = O X
o & T B & 0] B = T
id Diameter Material Depth

? Show All Features,,

Reorder Map Layers in the Layers Dialog Box

To reorder map layers in the Layers Dialog box, you can simply left mouse click, hold, and drag
the map layer above or below another map layer. The map layers are displayed in the map in
the same order as they are displayed in the Layers Dialog box. If the aerial imagery map layer is
above the shapefiles, you will not see your data as the aerial imagery will be on top of it. It's
also a best practice to put your pipe map layers (line layers) below the valves, hydrants, fittings,
manholes, etc (point layers). Notice for each utility system (Water, Stormwater, Sewer), the
Line map layers are below the Point map layers. Also notice the World Imagery is below all
other map layers, being used as a basemap.

Layers @6
Lo _I‘E_I: Wy ? -E _ﬁ. L_n.lu

® WaterValve

® WaterHydrant
WaterLine

@ StormManhole
StormLine

SIS SIS S

@ SewerManhole
v — Sewerline

v v = World Imagery
World Imagery

Save Your Map
On the Menu Toolbar > click Project > Save As

This saves a QGIS Map file (qgz) to the location you choose. To open your map, simply double
click the file where you saved it, and it will open your map with all of your last saved changes.
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View Shapefiles in Windows Explorer (on windows)

On your machine, browse to the location where you stored the shapefiles to view the shapefiles
you created. Notice that a WaterHydrant shapefile consists of 6 individual files (cpg, dbf, prj,
apj, shp, shx). These all need to be stored and copied together if you move or rename them.
When adding a shapefile to QGIS, you only need to select and add the shp file.

~

~ [] Name Date modified Type 2
| WaterHydrant.cpg 9/5/2019 1:37 PM CPG File
|| WaterHydrant.dbf 9/5/2019 1:37 PM DBF File
| WaterHydrant.prj 9/5/2019 1:37 PM PRJ File
|| WaterHydrant.qpj 9/5/2019 1:37 PM QPJ File
| WaterHydrant.shp 9/5/2019 1:37 PM SHP File
|| waterHydrant.shx 9/5/2019 1:37 PM SHX File
| Waterline.cpg 9/5/2019 1:36 PM CPG File
|| Waterline.dbf 9/5/2019 1:36 PM DBF File
| Waterline.prj 9/5/2019 1:36 PM PRI File
|| Waterline.qpj 9/5/2019 1:36 PM QPJ File
| Waterl ine.shn 9/5/2019 1:36 PM SHP File ~1
N |G >

Lesson Assignment: Create 4 additional map layers and attributes for each.

SewerlLine > Diameter, Material, Depth
SewerManhole> ID, Material, InvertElev
StormLine > Diameter, Material, Depth
StormManhole > ID, Material, InvertElev

Note: for the purpose of time, we’ve included shapefiles in the course training data.

In this lesson, you created shapefiles to map various utility systems and assets. In GIS, each
utility system (Stormwater, Sewer, Water) consists of several different shapefiles. For example,
a Water system consists of a shapefile for pipes, a shapefile for valves, a shapefile for hydrants,
a shapefile for meters, etc. Each shapefile has a set of attributes in order to store information
about each asset and create dynamic map labels. You might store different attributes and
information about a water valve than a water meter or water hydrant. Attributes serve several
purposes (symbolizing, labeling, utility networks, joins, relates) and are a beauty of GIS.

In the next lesson, you will learn how to symbolize shapefiles and add a cartographic touch to
your maps and data.

Utility Mapping Bootcamp
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Symbolize GIS Data

In this lesson, you will learn how to symbolize each map layer created in the previous lesson
Symbolize Shapefiles

First, symbolize the WaterLine map layer.

1. Right click the WaterLine map layer to the left under Layers and click Properties.

(2 *Untitled Project - QGIS
Project Edit View Layer Settings Plugins Vector Raster Database Web Mesh Processing Help

17

NEERRY UL, i HPRPRA RN @c-H-8-5,EE 4
REV. AW @ = o 5 @®

N 1p

=

b

(L;\ Zoom to Layer

Zoom to Selection

Browser % Show in Overview o
RRTHO
i Show Feature Count
7. Favorites c L =
b [&] Home B
» By Rename Layer

@ GeoPacki [-] Duplicate Layer
/ Spatialit [l Remove Layer...

» @ postais | _
’ MSSQL == Open Attribute Table
@ Orade | ¢ Toggle Editing
=i DB2 Filter...
@ wims/w Change Data Source...
v B XYZ Tiles oy
% Goo Set Layer Scale Visibility...
% Opej  SetCRS »
@ wes Export b =
Layers Styles 3 @
o 0 &% T &

Properties...
WaterlLine

b /| = Imagery
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2. To the left, under Symbology, change the Opacity to 80.0%, then change the Color to Blue,
then change the Width to 1.0, Click Ok.

Q *Untitled Project - QGIS

DEERES Ol "EPPR BRI 6 -K-B-GEE#Ia-F M-
m @ V: ﬁ: L m - (2} Layer Properties - WaterLine | Symbology >

N - 12 = px w | v - & Single symbol -

@ Information v == Line
Browser W Source ==imaleding
Oev=®e & Symbology
5. Favorites sl | abels
¢ [&] Home 5
iagrams
» C: 1 -
B e\ S
@ GeoPackage | @ 3D View
/£ spatialite E Source Fields [
» @ postais
P mssaL SPNUSMRUN Unit | Millmeter -
@ Oracle Form Opacity I o
B os2 D .. — -
@ WMS/WMTS
@ XYZTiles | ';'ﬂ_'l'a'y Width ' 1.00000 =
= GoogleMaps Slafage
=" OpenStreetMap & Actions -
= < Favorites
@ wcs s Display =
Layers B

o Rendering
vA®YavE A o o

v — Waterline
» V| i Imagery ' Metadata
™ Dependendies dash black dash blue dash green dash red
Legend

QGIS Server

Variables [ I T T

-

E Save Symbol || Advanced ¥

B Digitizing

» Layer Rendering

Style ~ Cancel Apply Help
3. Next, symbolize the WaterValve map layer. Symbolize valves with a blue circle.

4. Right click the WaterValve map layer to the left under Layers and click Properties.

5. Click Simple Marker > Scroll down until you see a dialog of shapes. Click the Circle icon.

6. Adjust the Offset x to 0 and y to 0. Scroll up and change the Fill color to blue.
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Lesson Assignment: Symbolize the shapefiles you created in the previous lesson.

Sewer Lines > Change the Color to Green.
Sewer Manhole> Change the Shape to a Circle and Color with a Green Fill and Black

outline.

Storm Lines > Change the Color to Brown.

4

Apply

@ 10 @ no @

]

Help

Storm Manhole > Change the Shape to a Circle and Color with a Brown Fill and Black

outline.

Feel free to change the color and symbology to meet your needs and preferences.

In this lesson, you symbolized map layers to distinguish various utility systems and features.

In the next lesson, you will learn how to import and add GPS data to the map. GPS data can be
imported in the form of various types of vector file formats.
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5

Add GPS Field Data to Map

In this lesson, you will learn how to quickly import GPS/GPR field data to a QGIS map. KML s a
standard file format exported from RD8100 and GPR utility locating equipment. Utility data
comes in various file formats including: DWG, DXF, XML, KML, CSV, & GPX. The good news is
QGIS supports over +100 different vector and raster file formats and importing data is usually a
piece of cake.

Sample Data

1. To get started, browse and view the sample data contained in the training package you
received and downloaded. (Utility_Mapping_Bootcamp.zip)

2. The Course_Data folder includes sample GPS data (KML and shapefiles) and public data from
the city of Naperville, IL.

Below is an example of KML data in a code editor (Notepad++). KML is an XML format for
storing and displaying geographic information within internet applications and 2D/3D maps.
When you create a KML file in QGIS, the software is writing this file behind the scenes. You can
edit the file manually to modify the contents then save it, though it is usually easier to let QGIS
do that for you.

L’ \SewerLine.kml - Notepad++ - O X
File Edit Search View Encoding Language Settings Tools Macro Run Plugins Window ?

cHEHBEEREE Gk hy 2% BESTFEENG= B NDE ME
@ SewerLine kml E l

1 <?xml version="1l.0" encoding="utf-8" >

2 [H<kml xmln ttp://www.opengis.net/kml/2.2">

[H<Document id="root_doc">
[ <Schema name="SewerLine" id="SewerLine">
<SimpleField name="id" type="float"></SimpleField>
</Schema>
[ «<Folder><name>SewerLine</name>
—] <Placemark>
= <Styler<LineStyle><color>FFla658b</color><width>3.40157</width></LineStyle>
<PolyStyle><fill>0</fill></PolyStyle></Style>
<MultiGeometry><LineString><coordinates>
-T76.4833370435492,37.0809280261939 -76.4832625394333,
37.0809422998922 -76.4831776207636,37.0809719124815 -76.4830820205002,
37.0810049337007 -76.4830029767071,37.0810322028256
</coordinates></LineString></MultiGeometry>
</Placemark>
</Folder>
</Document></kml>

<

length: 705 lines: 19 Ln:19 Col:1 Sel:0]0 Unix (LF) UTF-8 IN
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Import Data

Import the following KML files to your map. (Utility_Mapping_Bootcamp\Course_Data\kml).

1. To add KML files to the map - On the Menu Toolbar, click Layer > Add Layer > Add Vector

Layer.

sewerlLineGPS.kml
sewerManholeGPS.kml
stormLineGPS.kml
stormManholeGPS.kml
waterLineGPS.kml
waterValveGPS.kml
waterHydrantGPS.kml

() Course-creating - QGIS

Project

sl
ae¢
X

Browser
ORTHe O Coysyle
» [G] Home Paste Style
> O Copy Layer
: E E\\ Paste Layer/Group
é_@ Gleopa(_kage Open Attribute Table
£ Spatialite 4/ Toggle Editing
' PostGIS Save Layer Edits
P mssoL Current Edits
; g;,_de Save As...
B WMS/WMTS Save As Layer Definition File...
v @ XYZTiles [l Remove Layer/Group
Layers L bu plicate Layer(s)
Set Scale Visibility of Layer(s)
CRART S o Layer(s)
® Warcitiydig Set Project CRS from Layer
; x::::‘l’::e Layer Properties...
@ StormManh Filter..
*  Labeling

Edit  View

== StormLine

SewerManhighy
= Sewerline o
e = World Imag \33

Layer Settings

=] =]

q Data Source Manager
Create Layer

Yo Fa

* [12

Add Layer
Embed Layers and Groups...

Add from Layer Definition File...

Show in Overview
Show All in Overview

Hide All from Overview
World Imager

Plugins  Vector

Raster

Database Web

Processing  Help

w PPRARBBNR @S- 5-50E%

v V5
A
,l]
9,
e
»
o,
(=]
F6 3
&)
o
. @
@
Ctrl+D
Ctrl+Shift+C
Ctrl+F

Add Vector Layer...

Add Raster Layer...

Add Delimited Text Layer...
Add PostGIS Layers...

Add Spatialite Layer...

Add MSSQL Spatial Layer...
Add DB2 Spatial Layer...

Add Oracle Spatial Layer...
Add/Edit Virtual Layer...

Add WMS/WMTS Layer...

Add ArcGIS MapServer Layer...
Add WCS Layer...

Add WFS Layer...

Add ArcGIS FeatureServer Layer...

Ctrl+Shift+V
Ctrl+Shift+R

Ctrl+5Shift+D
Ctrl+Shift+L
Ctrl+Shift+M
Ctrl+Shift+2
Ctrl+Shift+0

Ctrl+Shift+W

55 QQR
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2. Choose File for Source Type > For Source, click the small square with three dots > Browse for
the location where you saved the course training data.
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Source Type
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¥ - =
H | waterLineGPS.kml 2019 1:01 PM KML File
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SKB
2KB
14 KB
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Cancel

Il WFs

ArcGlS Map Server

B

ArcGIS Feature Server w

Close Add Help

3. To select and add all the KML files to the map at once, select the top KML file
(sewerLineGPS.kml), hold down the Shift key on the keyboard, and click on the bottom file
(waterValveGPS.kml). After all KML files are selected, click Open > click Add > click Close.

You should see the layers added to the Layer dialog box to the left.

4. Right Click one of the kml map layers you just added, waterLinesGPS, and click Zoom To

Layer. This zooms the map to the extent of that layer.

> [EF E\
@ GeoPackage
f Spatialite : Zoom to Layer
' PostGIS Zoom to Selection
P mssaL 2 Show in Overview
@ Oracle Show Feature Count
@ DB2 Copy Layer

> B WMSWMTS

Rename Layer

v 68 XYZ Tiles

[ Duplicate Layer
e [l Remove Layer...
vB®T &
7 o WaterHy Move to Top
® WaterVal "| Open Attribute Table

== Waterlin /' Toggle Editing
® StormM:

=== StormLin
SewerM:

Filter...

Set Layer Scale Visibility...

sewerlin Set CRS L
M

sewerMa P .

stormMa Styles 1

Properties...

X EEERERE

o
L
°
© stormlin
o
L]
°
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You should now see aerial imagery and GPS data in your map (small point features). This GPS

data represents the location of underground storm lines, water lines, and sewer lines. Also
captured are the location of manholes, water valves, and a hydrant.

@ *Course-creating - QGIS =
Project Edit View Layer Settings Plugins Vector Raster Database Web Processing Help

DEERREH O PPL s HPPRALALWEBINT & ¢
BRQV-AM P /B R-BOxBoe =QAEHSE
@ o e * ¥ =

Browser 8 x
QEYHe
> [& Home ~
0O
> [
OO Een
@ GeoPackage
£ Spatialite
@ post6is
P mssoL
@ Oracle
DE2
@ WMS/WMTS
v @B XVZ Tiles

=]
X

-E-E-EE% E = T
Q@O 2 ¢~ B

Layers 8 x
v e T&-FRA
& StormManhole ~|B

== StormLine

SewerManhole
sewerlineGPS
sewerManholeGPS
stormLineGPS
stormManholeGPS
waterHydrantGPS
waterlineGPS
waterValveGPS.
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v [ ¥ World Imagery o

® o o 00 e 0

KRERFNEREERRE

Q. Type to locate (Chl +) Coordinate | 9813278.1,5126370.6 | Scale[1743 | @ Magnifier [100% 3] Rotaton [0.0¢ | EJRender @ epscizes7 @

If you do not see GPS data you may want to make sure the imagery map layer is below the GPS
layers in the Layers box.

If you are not seeing aerial imagery after you zoom to the extent of the waterLineGPS kml file, it
may be that you are zoomed in too far. The aerial imagery will not show if you are zoomed in
beyond a certain point. You will see “Map data not yet available”.

(2 "Course-creating - QGIS
Project Edit View Layer Settings Plugins Vector Raster Database Web Processing Help
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Lesson Assignment: Import open public data from the City of Naperville, IL.
You can find data in this location (Utility_Mapping_Bootcamp\Course_Data\Naperville_data).

Add an ArcGlS Feature Server to the map.

https.//services.arcgis.com/ue9rwulloeLEI9bj/arcgis/rest/services/Stormwater_Network_FIDA/FeatureServer

This Feature Server consists of a Stormwater Network of Naperville, IL. After adding all of the
map layers, you can select them in the Layers dialog box, right click, and select Group Selected.

(@ “Course-creating - QGIS - x
Proj e layer Settings Plugins Vector Raster Database Web Processing Help

NEBRRE M2 pL P PP ARRI6e & 6 LEEH =0 m-

BV AW 4 /BRR-Z T8 B =aH==2%%% QAR 20N

S ¥ ke + lx Y -

Brow:

o System Valves

Hint: Add this the same way you added the aerial imagery to the map. Instead of choosing

MapServer, choose FeatureServer.

o Add Layer V. Add Vector Layer... Ctrl+Shift+V
2 Embed Layers and Groups... .ﬂ Add Raster Layer... Ctrl+Shift+R
rom Layer inition File... elimited Text Layer...
Add from Layer Definition Fil 9, Add Delimited Text Lay
'D Add PostGIS Layers... Ctrl+5hift+D
) 2] Copy Style
s Pasta St ﬁ, Add Spatialite Layer... Ctrl+Shift+L
aste Style
g ‘E Add MS50L Spatial Layer... Ctrl+5Shift+M
" | @ CopyLayer [, Add DB2 Spatial Layer... Ctrl+Shift+2
Paste Layer/Group @, Add Oracle Spatial Layer... Ctrl+Shift+Q
“ Open Attribute Table Fé VD Add/Edit Virtual Layer..
Toggle Editing @ Add WM/ WMTS Layer... Ctrl+Shift+W
Save Layer Edits @ Add ArcGIS MapServer Layer...
& Current Edits % Add WCS Layer..
07 Add WFS Layer...
save fis.. 47 Add ArcGIS FeatureServer Layer...
Save As Layer Definition File.., ] 5

In this lesson you learned how to import and add GPS field data to QGIS.

In the next lesson, you will learn how to digitize utilities and add data to your empty GIS

shapefiles. You will add geometry (spatial information) and attributes (tabular information).

Utility Mapping Bootcamp



25

6

Digitize and Map Utilities

In this lesson, you will learn how to digitize and convert raw utility GPS data (KML files) to
quality GIS data deliverables (shapefiles).

You will edit the GIS shapefiles and add data to the GIS shapefiles by manually tracing the GPS
data collected in the field and exported from RD8100 locator equipment. You will use the KML
data as a reference to map and digitize utility data. You can then add attributes to the pipe
features, such as Diameter = 12in, Material = Ductile Iron, Depth = 2ft. Attributes will be used
for labels and symbology in later sections.

Map the Water system first using the course sample data.

You will edit the WaterLine, WaterValve, and WaterHydrant shapefiles you created earlier by
tracing the waterLineGPS, waterValveGPS, and waterHydrantGPS kml layers.

1. In the Layers dialog box to the left, uncheck all of the map layers except the water layers
(waterValveGPS, waterLineGPS, waterHydrantGPS, WaterLine, WaterValve, WaterHydrant)
and group the Water GPS kml layers. Name the group WaterGPS.

Layers
o % T &~
® WaterHydrant
® WaterValve
== WaterLine
v [ [ WaterGPS
® waterHydrantGPS
® waterlineGPS
® waterValveGPS

2. Right click the WaterLine layer, click Toggle Editing.
3. Right click the WaterValve layer, click Toggle Editing.
4. Right click the WaterHydrant layer, click Toggle Editing.

This allows you to edit the map layers. Think of those two layers as being in “editor mode.” If
you incorrectly edit or delete data, you can choose not to save the edits and start over.

5. In the Layers box to the left, select the WaterValve layer (left click so that it is highlighted).
The layer that is selected in the Layers box is the layer that you will be editing. Although all 3
map layers are in “editor mode”, you need to select a layer in the Layers box to add, edit, or
remove features.
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6. In the Digitizing Toolbar, look for the Add Point Feature button.

#ﬁ? qaﬁr' B

Note: In order to open the Digitizing Toolbar, right click in the gray area above your map, and
choose Digitizing Toolbar from the list of toolbars. This should show the Digitizing Toolbar and

related tools.
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7. Click the Add Point Feature button on the Digitizing Toolbar, then left click on the map
where you want to add a Valve feature. Add a valve where you see a valve in the
waterValveGPS map layer.

8. After you add the valve, enter the following attributes in the dialog box that appears.
Diameter = 2 Manufacturer = Apollo ID = 1A

9. Add a total of 2 valves for each of the valves located in the waterValveGPS layer.

Use this attribute information for the 2nd valve. Diameter = 2 Manufacturer = Apollo ID = 1A

10. After adding the 2 valves, right click the WaterValve layer in the Layers box to the left, click
Toggle Editing > click Save.
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You should see 2 blue circles in the map and 2 rows in the WaterValve attribute table with the

attributes you entered.

0 WIVIZFWIVEE S
B X¥Z Tiles

= google v

TS
m ® T a6 5 gt
A # WaterHydrant sl
7] @ WaterValve
7] w*= Waterline
A [ WaterGPSs
@ waterHydrantGPS
® waterLineGPS
® waterValveGPS
7] ® StermManhole
"] w—Stormline
7] ® SewerManhole
"] == Sewerline
]l SewerGPS

Right click the WaterValve layer > click Open Attribute Table to view the attributes.

(G} WaterValve :: Features Total: 2, Filtered: 2, Selected... — | >

J 2B R o >€ & DL TERR| -
id Diameter Manufactur D1

1 2 Apolle 1A

2 2 Apolle 1B

Another way to view attributes for features in the map is to use the Identify Features tool.
Click the Identify Features button in the Menu Toolbar and then click on a valve in the map.
The Identify Features tool is a tool on the Attributes Toolbar. If you don’t see this toolbar,
follow the same steps to show this toolbar that you did to show the Digitizing Toolbar.
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Next, let’s map the water lines using the WaterLine layer.

11. In the Layers box to the left, select the WaterLine layer (left click so that it is highlighted).

12. In the Digitizing Toolbar, look for the Add Line Feature button.
B ER B LY Wa |1 \J T &~ o~ 2 g2

%@Vﬂﬁa,
@ : 12 + lpx

Browser (= 4

Add Line Feature
(Ctrl+.)

e _J
In order to open the Digitizing Toolbar right click in the gray area above your map, and choose

Digitizing Toolbar. This should show the Digitizing Toolbar and related tools.

Before you trace the water lines, make sure to enable snapping. Snapping is an editing and
digitizing feature that “snaps” your mouse cursor to points, line end-points, and line vertices
when digitizing to make it easier to add a point to the exact same location as another point (i.e.
a valve, fitting, or hydrant to the end of a pipe). This feature helps enforce data topology rules,
network connectivity, and quality data. More information on utility networks in another
course.

In order to open the Snapping Toolbar right click in the gray area above your map, and choose
Snapping Toolbar. This should show the Snapping Toolbar and related tools.

13. Click the Enable Snapping button on the Snapping Toolbar.

¥ ooz Bl vy XK~

Efﬂws‘ Enable Snapping k =& ' [“

14. Click the Add Line Feature button on the Digitizing Toolbar to begin digitizing the first pipe
segment.

DEERREE OB
REViAawm 4/
@ ' 0"o- 12 [Bex v

Browser g X

() (= (1 w3
6’—;!./ P = ___pl P

15. Left click at the end of a located line, where the locator stopped locating the water pipe,
likely at the edge of the survey project boundary. You are going to digitize a line from the end
of the water line at the edge of the survey project boundary to the first valve.

16. Left click again at the nearest Valve or Tee, ensuring to roughly connect the points shown in
the waterLineGPS layer. If snapping is enabled correctly, your cursor should “snap” to a valve.
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17. Right click to end the tracing of a pipe and then enter the following attributes in the dialog

box that appears for that particular pipe segment. Enter this attribute information for all pipes.

Diameter = 2 Material = HDPE Depth = 3 (ft)
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You have digitized the first WaterLine pipe.
18. Digitize a total of ~5 pipe segments for the WaterLine layer.

The first segment is from the left side of the survey boundary to the first valve. 2nd is from the
valve to the Tee. The 3rd is from the Tee to the right side of the survey boundary. 4th is from
the Tee to the 2nd valve. The 5th segment is from the valve to the red hydrant.
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(2 "Course-creating - QGIS = *
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To delete a pipe segment, use the Select Features by Polygon tool on the Identify Features
Toolbar.

Web  Processing  Help

PRAGENI e &l
3 EH b= ‘% REHEC

24 Select Features Eﬁ

by Polygon

19. Select and highlight the WaterLine layer in the Layer dialog box, click the Select Features by
Polygon button, select the pipe segment so that it is highlighted and selected in the map, and
push Delete on your keyboard.

Remember to select the correct map layer. If both WaterValve and WaterLine map layers are
in “editor mode”, and you have the WaterValve layer selected, you could delete those features
instead of the WaterLine features.

Export Data to Various File Formats

To export your shapefiles to different data formats, right click on the map layer WaterLine in
the Layers box, click Export > click Save Feature As.

For Format, choose the file format you would like to export the data as > choose Keyhole
Markup Language [KML].
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For File name > click the small square with 3 dots, browse to a location, give the file a name >
click Save > click OK.

You just exported the WaterLine shapefile to a KML file.

You can now view the data in Google Earth or Google Maps API.

Create Map Labels

To create map labels for the WaterValve map layer, right click WaterValve > Properties.
On the left side > click Labels > at the top choose Single Labels.

For Label with > choose the Diameter field > Click OK.

You should see a valve diameter label on the map next to the valves.

Try adjusting the colors, sizes, and label placement settings to meet you needs.

Lesson Assignment: Map and digitize the Storm and Sewer systems using the same steps and
process used to map the Water system.

Use the following attributes for these systems.
Storm (Diameter = 18 Material = RCP Depth = 2) Total pipe segments =6 Total manholes = 3
Sewer (Diameter = 8 Material = RCP Depth = 5) Total pipe segments = 1 Total manholes = 1

Next assignment: the city has hired you to update their stormwater shapefiles. Their stormwater data is
a bit out of place from where it was recently located and they have asked you to fix it for them. The
green lines in the map below show where it was located and where it is located, and the red lines are
where their maps and data shows it. They have sent you the shapefiles and asked you to fix it for them.
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Here are the shapefiles in the training data.

\Utility_Mapping_Bootcamp\Course_Data\Naperville_data\Stormwater\shapefile

Remember, you only need to select and add the (.shp) files when adding the data to the map.

Add both the stormwaterPipes.shp and stormwaterStructures.shp to the map to edit the geometry.

Edit these shapefiles to match where the (green) GPS data shows the stormwater pipes and structures
are located.

Hint: you can delete the inaccurate red lines and structures and draw new ones using the GPS data as a
reference.

In this lesson, you used GPS data to digitize GIS data using shapefiles created in an earlier
lesson. You also added attributes for various utility features such as pipes and valves.

This lesson is where lots of work is involved and various procedures and standards are used for
storing attributes and representing a utility system. For example, we did not map any fittings in
this course. You may consider using fittings to represent known fitting connections to store
valuable information about a system. Storing information about elbows, tees, and reducers
along a system can be very helpful for engineers and maintenance teams, while mapping every
single coupling fitting along a 30 mile stretch of 12” water pipe can be a bit excessive to a GIS
program and bog down storage systems.

In the next lesson, you will learn how to upload your data to ArcGIS Online and create a web
map. There are several different cloud GIS platforms to choose from depending on your needs,
requirements, and budget including Mango Map, GIS Cloud, QGIS Cloud, & ArcGIS Online. In
this course, you will use ArcGIS Online.
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7

Upload Data to ArcGIS Online

In this lesson you will learn how to upload utility data to ArcGIS Online and create maps to
share on the web. This lesson uses a free public ArcGIS Online account. Please read and agree
to our Legal Disclaimer and Terms of Use in the beginning of this document before proceeding
with this lesson. Also, please read and agree to Esri’'s Terms of Use before using ArcGIS
software. Ok, now that you have read and agree to the terms, let’s continue.

1. Sign up for a public account here (https://www.arcgis.com/index.html). We highly
recommend keeping this software on your radar!

The first step is to create your account. The second step is to zip your shapefiles. We will zip
each utility system’s shapefiles separately.

The following files are available for uploading to ArcGIS online.

e Shapefile (ZIP archive containing all shapefile files)

e (CSV or TXT files with optional address, place or coordinate locations (comma, semicolon
or tab delimited)

® GPX (GPS Exchange Format)

GeolJSON (open standard format for simple geographical features)

2. First, create a folder called WaterLines and copy all of the WaterLine files to this folder.
Right click the folder and Choose 7-Zip or WinZip. (or whatever Zip software you have installed).

3. These 6 (total) WaterLine files shown below make up the WaterLine shapefile and they all
should be copied to the folder. Copy all 6 files to the new WaterLines folder you created.

WaterLine.cpg
WaterLine.dbf
WaterlLine.prj

WaterlLine.qpj
WaterLine.shp
WaterLine.shx

4. Create a separate folder called WaterValves and copy all of the WaterValve files to this
folder.
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5. Right click the folder and Choose 7-Zip or WinZip. (or whatever Zip software you have
installed).

6. Repeat those steps for the WaterHydrant, Sewer (manhole, lines), and Stormwater
(manhole, lines) shapefiles. You should have 7 zipped folders once complete.

Waterlines.zip
WaterValves.zip
WaterHydrants.zip
StormLines.zip
StormManholes.zip
SewerlLines.zip
SewerManholes.zip

7.Sign In to your ArcGIS Online account, and at the top of the screen, click Map.

ACGIS  Oweniew  Fricing Scene Groups  Content a n Conaring Mipeiss

Country Population Seismic Seafloor Feature Southern Pine Beetle Streets
Estimates, 2015, from Anomalies (Deprecated) Prevention Program
« Apps for Everyone [ Make a Map [ ArcGIS for @ Discover Lessons
Use ArcGIS apps to get the job e DRVl Take hands-on lessons based on
done in a browser, desktop or mobile Build custom web and mobile real-world problems.

8. Click the Add button in the top left and choose Add Layer from File.
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9. Browse to your zipped WaterLine.zip folder and select that folder.
Make sure the Keep original features radio button is selected.
10. Click Import Layer.

You should see your WaterLines added to the Content section on the left, and to the map.

ArcGIS ~ My Map New

Map C
[ElDetails #Add ~ | ~ Edit BFBasemap | Blsave - ©2 Share & Print - | & Measure ol Bookm: Q
Change Styl u
ange Style
WaterLine - WaterLine - WaterLine ﬂ
0 Choose an attribute to show =
Diameter -
9 Selecta drawing style

Location (Single symbol)

SELECT '
DONE CANCEL —2 §
jos . = o I ST
TruatCartar  Logal _ CortactEai __ Repet Ane iy of Napanille, Coury o Duage, SulingPostorniUsh, Ein HERE Garmin INCREVENTF WET. =

You can now change the Style and Color of your water lines.

11. In the left dialog box under the E - Select a drawing style > Choose Location (Single
symbol), click the blue SELECT button > click OPTIONS (the same button).

WaterLine - WaterLine - WaterLine [

0 Choose an attribute to show

Diameter -

g Select a drawing style

Types (Unique symbols)

SNymm A

Jhow the
dpoint locz

12. Click the Symbols button to change the water line symbol. Choose a color, line width,
transparency to meet your needs. Click Ok > Click Ok > Click Done.
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To change the basemap, click Basemap and choose the basemap you would like to see.

ArcGIS © My Map New Map Centerline ¥

[E] Details  # Add ~ ‘ # Efit  BHBasemap ‘ B save~ © Share & Print ~ ‘ & Measure [l Bookmarks |Find

Change Style
WaterLine - WaterLine - WaterL|

Showing Location Only

—5ymbols

Transparency
.
0% 50%

Visible Range
Street ~ Ro!

anves

Navional
Geographic
f = ! EE—E——

OpenStreetiap

14. At the top of the map, click Save > click Save As to save your map, layer settings and
symbology. You can close ArcGIS Online and Log Out at anytime and start off where you last
saved your map. To open your map, when you sign-in, instead of clicking Map, click on
Content, and this is where you can open your saved map. ArcGIS Online stores all of your
maps, data, and content in their cloud.

Lesson Assignment: Add the WaterValves, WaterHydrants, StormManholes, StormLines,
SewerManholes, Sewerlines shapefiles to your map. Change the symbology for each of the
shapefiles to fit your needs and color standards. Remember to Save your map often and
frequently. We have zipped the shapefiles and included them in the course data.

In this lesson, you created an ArcGIS Online account and added utility data to a web map. You
also changed the map layer symbology. There are several layer settings and web map
capabilities for you to explore now. Feel free to take some time to explore the capabilities of
ArcGIS Online and the various mapping features built-in (Print, Measure, Bookmarks). Notice
how you can edit the WaterLine map layer by clicking the Edit button, next to Basemap.

Now that you have a Web Map, you can create a Utility Map Viewer to access and share your
utility maps and data online. A Utility Map Viewer is an out-of-the-box Web Mapping
Application that is accessible online, on any device, anywhere (as long as you have an internet
connection). Next, let’s build a Utility Map Viewer without writing a single line of code!
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8

Build Utility Map Viewer

In this lesson you will learn how to share your Web Map and build a Utility Map Viewer.
1. First, sign-in to your ArcGIS Online account, and click Content at the top.

2. Find the Web Map you saved in the previous lesson and click to open it. Then in the top right
of the next page, click Open in Map Viewer.

This is the Web Map you will use to build a Utility Map Viewer application. You can always
open this Web Map to change symbology, pop-ups, basemaps, and attribute settings to update
your Utility Map Viewer application. Remember to save the web map after making changes.

It is important to note that the Utility Map Viewer is an out-of-the-box application that uses the
web map. When you make changes to your web map, they are automatically updated in the
application (once you reload the application).

So what’s the difference between the Web Map and Utility Map Viewer?

The Utility Map Viewer is how you view the web maps and data, and what you share with your
clients, and team members in the field.

The Web Map is where you upload and edit data, adjust layer settings, apply labeling, and apply
filters. You may have one or two people responsible for editing and creating Web Maps, while
hundreds of customers are using the Utility Map Viewer.

3. At the top of your Web Map, click Share, then click CREATE A WEB APP.

Share

Choose who can view this map.

Currently, only you can view your map. Before you can link to it or embed it, you need teo allow others to view your map.

Link to this map
http://arcg.is/DCDID]

v| Share current map extent

Embed this map
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Now you should see a list of templates to use for your Web App. These templates highlight
various information and tools depending on your specific mapping needs and industry.

4. Click the Basic Viewer option in the top left (but feel free to explore other options), click
Create Web App.

5. Fill out the form and provide a Title, Tags, Summary, and choose the default Save in folder
option.

6. Check the checkbox to share the app. This is basic metadata about your web app.
7. Scroll down and click DONE.

The next page is the configuration page for your application. This is where you update
configuration settings about the application such as the Title, Colors, Theme, Widgets, Labels,
and web map to load. You can change this information later by going to your Content, click
your Web Application, click CONFIGURE APP.

8. First, under the General Tab, provide an application title.

You can add a Splash screen that will popup when you first open the Application to provide
background information, disclaimers, and anything you want to share before someone uses the
application.

9. Next, click Theme at the top. This is where you can style your application using various
layout, color, and logo options. Make sure to click Save after making updates.

10. Click the Options tab. This is where you can add and configure specific out-of-the-box
widgets, also known as mapping tools.

Available widgets:

Basemap Gallery
Legend

Map Details
Measure Tool
Overview Map
Share Tools

11. Once you are ready and happy with your application template, coloring, and widget
configuration, click Save, and then click Launch.

This will build and launch your very own Utility Map Viewer in a web browser.
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Remember, if you have to make changes to the application, you can browse to your web
application under Content, make changes, and Save.

To make changes to symbology, pop-ups, layer names, and map settings, browse to your web
map under Content, makes changes, and Save.

Remember, you created a Web Map, and a Web Application (two separate things).

You do not need to configure an app every time you make changes to the Web Map. Next time
you load your application, you will see changes to the web map in the web application.

As a test, change the color of the WaterLines to red, save your map, reload the web application
and notice the WaterLines are now red. You didn’t change or save anything to the web
application, just the web map.

You should now have a Web Map, and a Web Application in your contents page in ArcGIS
Online.

To download and host the application on a private server, at step 3 of this lesson, instead of
clicking CREATE WEB APP, you would click DOWNLOAD. This downloads all the source code
necessary to host the application on another server. Your application will still use the Web Map

you build and save on ArcGlIS Online, but the application will be hosted on another server.

You WILL need to do some HTML and JavaScript coding to get the application up and running
on a private server.

In this lesson you learned how to share your Web Map and build a web-based and GPS-enabled
Utility Map Viewer.

In the next and final lesson, you will learn more about ArcGIS capabilities and strategy.
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9

Explore ArcGIS Capabilities

ArcGIS Online is a cloud-based GIS mapping software that is being used widely
around the globe. More and more organizations and utility departments are finding
the value in having GIS information and data accessible on the web (in the cloud).
Organizations no longer need to send entire databases via email and FTP to share a
few records of information.

Now, with GIS, they can just share a URL to a web mapping application. All of the
information is stored in a secure central database and utility departments spend less
time finding the most recent and updated site plan about City Water in an old filing
cabinet.

When the utility information needs updating (after several years of project work), we
have an analyst update the GIS and maps, and everyone can see the changes in
real-time within the Utility Map Viewer. Every time a utility locating, surveying firm
provides data or as-builts, we input the information in the GIS. Over-time, the client,
the owner of the utility assets, has an accurate and updated picture of their utilities,
accessible on any device, anywhere.

Data can be converted back to CAD files for engineering and surveying purposes as
well. PDF maps can be printed from GIS software as needed for redlining and field
visits. ArcGIS Online supports 3D map viewers in case your organization is moving
into 3D modeling. ArcGIS also provides a number of tools geared towards utilities
such as valve and network tracing. These tools give users the ability to determine
customers affected during outages, and closest upstream valves to isolate a leak.
Data plugs directly into these tools and they are accessible through your Utility Map
Viewer.

Esri provides APIs and SDKs in order to integrate additional tools and functionality
within your applications. Esri (the company that owns ArcGlIS) provides additional
software that comes with your ArcGIS online license called Collector for ArcGIS. This
is @ mobile application that allows you to collect and update information in the field.
Now, your workforce can use Android, iOS, and tablets to connect to your central
database and provide real-time data updating (upload pictures, add attribution,
verify IDs, valve numbers, etc).
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Key GIS Terminology

GIS - a geographic information system (GIS) is a computer system for viewing, editing, and
analysis of geospatial data.

GPS - a global positioning system (GPS) is a navigation system that provides location and time
information anywhere on or near the Earth where there is an unobstructed line of sight to
satellites.

GPR - a ground-penetrating radar(GPR) is a geophysical method that uses radar pulses to image
the subsurface.

QGIS - a free and open-source cross-platform desktop GIS that supports viewing, editing, and
analysis of data.

Open-source software - software for which the original source code is made freely available to
users.

Open-data - data that is free and open to use by the public.

Basemap - a collection of GIS data and/or imagery that form the background setting for maps
and data.

Map Service - a map service is a standard web protocol for serving maps, images, features, and
attribute data to many different client applications. When you add aerial imagery in Lesson 3,
you are using a map service.

Map Layer - a map layer is used to display a specific dataset in GIS. Map layers represent
vector data (points, lines, polygons) or raster data (digital elevation models, aerial imagery). In
GIS, water pipes are usually stored in one map layer, while water valves are stored another map
layer.

Geospatial data - any data that has a geographic component to it. This means that records in a
dataset have geographic data tied to them in the form of coordinates, address, city, zip, etc.
Geospatial data can be represented on a map.

Vector data - discrete data composed of and represented using points, polylines, and polygons.
Pipes are an example of vector data as we use polylines to represent them. A valve is an
example of vector data as we use points to represent valves.

Raster data - continuous data composed of and represented using pixels and individual cells in
a grid format. Digital elevation models are an example of raster data. Aerial imagery is an
example of raster data.

Digital Elevation Model - DEMs are a form of raster data used to represent ground elevations
and topography of a given area.

Utility Mapping Bootcamp



42
Aerial imagery - photographs of the earth from satellites, drones, airplanes, etc. This imagery is

then georeferenced and added to a GIS usually as a basemap for referencing additional data
such as utilities, light poles, property lines, etc.

Georeference - a geoprocess used to apply coordinate and spatial information to information in
a database.

Digitize - a process of converting geographic data from scanned images, hardcopy drawings, or
other reference data into vector data by tracing the features.

Shapefile - a shapefile is a common data format used in GIS software and applications to store
spatial and attribute information of geographic features. Shapefiles consist of 6 separate files

(cpg, dbf, prj, apj, shp, shx)

KML file - KML (Keyhole Markup Language) uses XML (eXtensible Markup Language) to
represent and store geographic data by storing points, polylines, polygons, shapes, images, in
XML.

CSV file - CSV (Comma-Separated Values) file is a common file used to store tabular data. CSV
files can also store geospatial data in the form of coordinates, addresses, zip codes, and more.

DWG file - DWG file is a drawing file format used for storing two and three dimensional data
commonly used and exported from CAD and used in GIS.

DXF file - DXF (Drawing eXchange Format) file is used for graphic image formats commonly
used in CAD and GIS software to represent utilities.

Geodatabase - a geodatabase is a file format used to store geospatial information in one large
file which can contain points, polylines, and polygons. Rather than create and store hundreds
of shapefiles separately, a geodatabase is used to store and organize data in one container.

Extent - the geometry extent of a feature is the minimum and maximum X and Y coordinates of
the feature.

Spatial information - location information about a feature that is stored as coordinates,
addresses, zip codes, etc. Spatial information about a water valve could be -76.4343, 36.3343.

Tabular information - this is attribute information stored about each record in a database.
Tabular information about a water pipe could be the Size, Diameter, Material, Depth, Install
Date, etc.

Topology - topology is defined as the spatial relationships between adjacent or neighboring
features. In GIS, features such as pipes, and valves can share the same coordinates in order to
meet specific topology rules and reduce errors in data.

Snapping - snapping is an editing tool in GIS that allows users to easily create and edit features
that connect to each other and apply standard topology rules and behavior so that edits are
more accurate with few errors. When digitizing utilities, we use snapping to ensure that valves
are “snapped” to the end points of pipes.
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