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TUTORIAL 2. 
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Summary 
 

 

This Tutorial presents an efficient method of modeling and analyzing a plant 

structure.  

 

The fundamentals and the essential functions of midas Gen are covered in 

“Tutorial 1”. 

 

Some of the functions introduced in “Tutorial 1” will be revisited in ‘Tutorial 2”. 

Additional functions not covered in “Tutorial 1” will be introduced in “Tutorial 2” 

 

The step-by-step modeling and analysis processes presented in this example are 

the following:  

 

 

1. File Opening and Preferences Setting 

2. Enter Material and Section Properties 

3. Structure Modeling using Nodes and Elements 

4. Enter Structure Support conditions 

5. Enter Loading Data 

6. Confirm the status of model data input prepared using Works Tree 

7. Perform Structural Analysis 

8. Verify and Interpret Analysis Results 

 

 

 



 
 
 
 
Tutorial 2 

2 

Analysis Model and Load Cases 
 

The geometric shape, boundary conditions and members for the plant structure are 

shown in Fig.2.1. The load cases commonly encountered in real structures are 

considered for the model. The load combinations are generated in the post-

processing stage. 

 

 Load Case 1 – Self Weight 
 

 Load Case 2 – Dead loads on the floors and the inclined roof 

0.1 ksf on the floors 

0.015 ksf on the inclined roof 
 

 Load Case 3 – Live load, 0.1 ksf on the floors 
 

 Load Case 4 – Live load, 0.02 ksf on the inclined roof 
 

 Load Case 5 – Uniformly distributed load, 0.1 k/f on every 

member in the X-direction 
 

 Load Case 6 – Concentrated load, 5 kips on every node in the Y-

direction 

Material Type       A36 
 
Section Type 

1:  W 16  67 : exterior columns, roof level girders


 

2:  W 14  90 : interior columns 

3:  W 18  65 : floor girders / beams 

4:  W 4  13 : topbottom chords of exterior trusses 

5:  WT 7  24 : topbottom chords of interior trusses 

6:  WT 4  9 : vertical and diagonal members of roof trusses 

7:  L 4  4  5/16 : wind braces 

Figure 2.1  Analysis Model 
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In this example, an 

identical section 

number has been 

attributed to the 

exterior columns and 

roof girders for 

simplicity. However, in 

practice, for efficiency 

in structural analysis 

and design, it is 

advisable to assign 

separate section 

numbers to members 

with different structural 

characteristics such as 

loadings and boundary 

conditions even if the 

sections are the same. 
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File Opening and Preferences Setting 
 

Select File>New Project (or ) to begin modeling and select File>Save (or 

) to save the work in the given file name. 

 

 

Unit System 
 

 

In this example, “ft” and “kip” are the basic units. 

 

 

1. Select Tools>Setting>Unit System in the Main Menu. 
 

2. Select “ft” in the Length selection field. 
 

3. Select “kips(kips/g)” in the Force (Mass) selection field. 
 

4. Click . 

 

 

 

Grid Setup 
 

 

Grid displays reference points or lines in the working window to help the user 

readily enter the nodes or elements. 

 

To execute the grid function in midas Gen, use View>Grids/Snap>Grids>Point 

Grid and Line Grid. If Grid and Snap are used in combination, the mouse cursor 

will automatically snap to the closest grid. 

 

 Point Grid and Line Grid can be used separately or jointly. In this case,  

Point Grid is used. 

 

 

1. Click  Set Point Grid in the Structure>UCS/Plan>Grids. 
 

2. Enter “2, 2” in the dx, dy field.


 
 

3. Click . 

 

Model Boundary 

defines the Grid display 

boundary.  
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User Coordinate System (UCS) Setup 
 

 

The conversion of the GCS X-Z plane into the UCS x-y plane is reviewed in 

“Tutorial 1”. 

 

Similarly, for this example, the GCS X-Z plane is assigned as the UCS x-y plane 

to model the columns and the roof truss on grid ○A  of the structure (see Fig.2.1). 

 

 

1. Click  X-Z in the Structure>UCS/Plan>UCS. 

2. Confirm “0, 0, 0” in the Origin field. 

3. Confirm “0” in the Angle field. 

4. Check () “Change View Direction”.


 

5. Click . 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 2.2  UCS Setup 

 

If you click  

after checking () 

Change View Direction, 

View Point changes 

automatically so that  

the working window 

corresponds to the UCS 

plane. 

Refer to Tutorial 1 for 

positioning Node and 

Element Toolbar. 

UCS 
GCS 

 
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Enter Material and Section Properties 
 

 

Material properties and section data for members may be entered anytime, 

regardless of the generation of elements. However, it is most convenient to define 

such data prior to generating elements. Member sizes and shapes can then be 

viewed by the  Hidden function as the structure is modeled.  

 

Select Geometry>Properties>Material in the Menu tab of the Tree Menu to 

enter the material properties and section data. 

 

The material properties and section data of the structural members are as 

follows: 

 

 Material type    A36 

 

 Section type  

1:  W 16  67  : exterior columns, roof level girders 

2:  W 14  90 : interior columns 

3:  W 18  65 : floor girders/beams 

4:  W 4  13 : topand bottom chords of exterior trusses 

5:  WT 7  24 : topand bottom chords of interior trusses 

6:  WT 4  9 : vertical and diagonal members of roof trusses 

7:  L 4  4  5/16 : wind braces


 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 2.3  Section Data 

 

In the material and 

section types, the part  

in front of “:” represents 

the inherent member 

numbering, and the part 

after  “:” represents the 

member designation. 
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For simplicity, all the member sections are chosen from the AISC sizes stored in 

midas Gen. 

 

 

1. Select Geometry>Properties>Material in the Menu tab of the Tree 

Menu. 
 

2. Click . 
 

3. Confirm “1” in the Material Number field.  
 

4. Confirm “Steel” in the Type selection field. 
 

5. Select “ASTM(S)” in the Standard selection field.


 
 

6. Select “A36” in the DB selection field. 
 

7. Enter “Frame” in the Name field.


 
 

8. Click . 
 

9. Select the Section tab at the top of the Properties dialog box.  
 

10. Click .  
 

11. Confirm the DB/User tab at the top of the Section dialog box. 
 

12. Confirm “1” in the Section ID field. 
 

13. Confirm “I-Section” in the Section selection field. 
 

14. Confirm “AISC” in the DB selection field. 
 

15. Select “W 16  67” in the Sect. Name selection field.


 
 

16. Click . 
 

17. Enter “2” to “4” in Section ID (I-section) by repeating steps 15 and 16 

(Fig.2.3). 
 

18. Enter the remaining section data for T and Angle sections following the 

procedure similar to that for I-sections. 
 

19. Finally, click  in the dialog box.  
 

20. Confirm if there is any error in the member selection and click . 

 

 

By using the Point Grid in the previously defined UCS x-y plane, position the 

elements located on grid A of the structure. Generate the elements by following 

the procedure below and by selecting Geometry>Elements>Create in the Menu 

tab of the Tree Menu. 

 

A default in the 

Standard field can be 

assigned in advance by 

Tools> Preferences. 

Name plays the role 

of Description to 

distinguish the material 

properties. It is not 

related to any physical 

properties. By selecting 

the DB type, an identical 

name is automatically 

attributed to the Name 

field. 

By entering the first part 

of the member’s name 

in the Section Name 

field, the member’s 

name is automatically 

searched from the Drop 

List. Even if the Drop 

List is not opened, the 

lightest member among 

the members matching 

the first part of the 

member’s name is 

selected. 
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Structural Modeling Using Nodes and Elements 
 

Generate Column Elements 
 

 

1. Click  Hidden Surface in the Icon Menu. 

2. Click  Node Number and  Element Number in the Icon Menu 

(Toggle on). 

3. Click  Grid Snap in the Icon Menu (Toggle on). 

4. Select Geometry>Elements>Create in the Menu tab of the Tree Menu. 

5. Confirm “General beam/Tapered beam” in the Element Type 

selection field.  

6. Confirm “1 : Frame” in the Material Name  selection field. 

7. Confirm “1 : W 16  67” in the Section Name selection field. 

8. Confirm “0” in the Beta Angle selection field. 

9. Generate elements 1 & 2 (exterior columns) by linking the positions (0, 
0, 0) and (0, 30, 0) and positions (64, 0, 0) and (64, 30, 0) relative to 

the UCS coordinates noted at the bottom of the screen (Fig.2.4) with 

the mouse cursor.


 

10. Select “2 : W 14  90” in the Section Name selection field. 

11. Select “90” in the Beta Angle selection field. 

12. Assign successively positions (32, 0, 0) and (32, 30, 0) relative to 

UCS to generate element 3.


 

 

While generating 

elements, if the window 

area is too small or the 

position is unsuitable, 

the user may adjust the 

window by using Zoom 

or Pan (Fig.2.4-). 

If the node numbering 

does not operate 

automatically, click the 

Nodal Connectivity field 

once and execute step 

12. 

Figure 2.4  Generation of Column Elements 

  

 
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Generate Roof Truss  
 

 

The procedure for generating the roof trusses in the UCS x-y plane is illustrated 

next. Even if the shape of the structure is complex such as the roof trusses, 

Structure Wizard can be a useful tool for standardized structures.


 

 

The Truss Wizard has 3 dialog boxes that serve the following purposes: 

 

 Input tab: Assign the size and shape of the truss 
 

 Edit tab: Determine whether the member is vertical and assign the 

material properties and sections of the truss 
 

 Insert tab: Assign the position and orientation angles to set the defined 

truss in the model 

 

When a truss is auto-generated by Truss Wizard, top and bottom chords are 

classified as Beam Elements and vertical and diagonal members are classified as 

Truss Elements.  

 

First of all, click  as shown in Fig.2.4 and switch to the Tree Menu. 

Then, execute Geometry>Structure Wizard>Truss to start modeling. 

 

 

 

 

 

 

 

    

(a) Input  (b) Edit (c) Insert 

 

Figure 2.5  Truss Wizard 

midas Gen supports 

Structure Wizard for 

various structures to 

expedite the modeling 

of standardized 

structures. 

 

 Beam 

 Column 

 Arch 

 Frame 

 Truss 

 Plate 

 Shell 

 Suspension Bridge 

 Cable Stayed Bridge 

 Steel House Wall 

 Steel House Truss 

 Steel House Stair 

 

 

 
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1. Click  as shown in Fig.2.4. 
 

2. Click Geometry>Structure Wizard>Truss in the Menu tab of the Tree 

Menu. 
 

3. Select the roof truss shape in the Type of the Input tab (Fig.2.5(a)). 
 

4. Confirm “4” in the Number of Panels field.  
 

5. Enter “32” in the L field (length of truss). 
 

6. Enter “6” in the H2 field (height of truss). 
 

7. Select “Sym.” in the Option selection field.


 

 

 

 

 

1. Select the Edit tab. 
 

2. Check () Verticals in Insertion. 
 

3. Select “1: Frame” in the Material selection field. 
 

4. Select “5: WT 7  24” in the Top (top chord) selection field of 

Section.


 
 

5. Select “5: WT 7  24” in the Bottom (bottom chord) selection field. 
 

6. Select “6: WT 4  9” in the Vertical (vertical members) selection field. 
 

7. Select “6: WT 4  9” in the Diagonal (diagonal members) selection 

field.


 

 

 

 

 

1. Select the Insert tab. 
 

2. Enter (0,30,0) relative to the UCS in the Insert Point field or click the 

field once and node 2 at the top end of element 1 with the mouse. 
 

3. Confirm “1 (0, 0, 0)” in the Origin Point selection field. 
 

4. Click .


 
 

5. Click  Zoom Fit. 
 

6. Click  to exit the Truss Wizard dialog box. 

 

Check () Show 

Dimensions. Then the 

screen displays the 

values of L and H2 

(Fig.2.5(a)-). 

Check () Show 

Member No. to display 

the member numbers in 

the Wizard Model 

Window. 

If the truss data results 

are different from that in 

Fig.2.6, click  Undo 

and modify the data for 

Structure Wizard Truss. 

The material properties 

and section numbers 

can be directly entered 

by moving around the 

entry fields using the 

Tab key. 
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Figure 2.6  Generation of Roof Truss 

 

 

Switch the Direction of Roof Truss Bottom Chords 
 

 

The roof truss generated by Structure Wizard is shown in Fig.2.6. 

 

The T-shape section members are used for the bottom chord of the roof truss 

(Fig.2.7 ) and the section is non-symmetrical about the strong axis. Click  

Iso View,  Shrink, and  Zoom Window to magnify the bottom chord of the 

truss. Observation of the section of the bottom chord will show that the web is 

oriented downward. 

 

The joint detail at the bottom chord to which the vertical or diagonal members 

connect shows that the web of the bottom chord must be oriented upward for 

easier fabrication. The method that revises the section orientation such that the 

web is oriented upward is examined. 

 

The bottom chord is selected by  Group, which selects and saves the entity as 

determined by the user in advance.


 

 

 

During the data entry, 

analysis of results or 

design steps, it is most 

efficient to assign the 

specific elements by 

group. Group is an 

extremely useful tool for 

data entry, results 

interpretation and 

design. Specific 

elements are grouped. 
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1. Click  Select by Window in the Icon Menu and drag the mouse from 

left to right to select only the roof truss bottom chord.


 
 

2. Right-click the mouse in the Structure Group of  Group tab and then 

select New to enter “Roof Bottom Chord”. 
 

3. From the Structure Group drag “Roof Bottom Chord” with the mouse 

and drop it to the model window. 
 

4. Click  Shrink in the Icon Menu (Toggle on). 
 

5. Click  Iso View in the Icon Menu. 
 

6. Click  Zoom Window in the Icon Menu (Toggle on). 
 

7. Magnify  shown in Fig.2.7 to confirm the orientation of the bottom 

chord. 
 

8. Select the “Roof Bottom Chord” group and double-click the mouse.


 
 

9. Execute Geometry>Elements>Change Element Parameters in the Menu 

tab of the Tree Menu. 
 

10. Select Elemental Local Axis in the Parameter Type selection field. 
 

11. Select “180” in the Beta Angle field. 
 

12. Click . 

 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 2.7  Switching the Bottom Chord Beta Angle 

It is easier to select the 

bottom chord if ‘x’ is 

selected in the Filter 

field (Fig.2.7- ). 

Double click the Roof 

Bottom Chord group, 

then the nodes and 

elements assigned as 

Roof Bottom Chord 

group will be selected 

as done in step 8. 

 

 
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Generate Floor Story Girders/Beams 
 

 

Use  Grid Snap to generate the 2 intermediate floor girders. 

 

 

1. Click  Auto Fitting in the Icon Menu (Toggle on). 
 

2. Click  Front View in the Icon Menu. 
 

3. Select Create Elements in the function list (Fig.2.8). 
 

4. Select “3: W 18  65” in the Section Name selection field. 
 

5. Confirm “0” in the Beta Angle field. 
 

6. Check () Elem and Node of Intersect.


 
 

7. Click the Nodal Connectivity field once. 
 

8. Assign positions (0, 10, 0) and (32, 10, 0) relative to the UCS to 

generate the first girder. 
 

9. Assign positions (0, 20, 0) and (32, 20, 0) relative to the UCS to 

generate the second girder. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 2.8  Generation of Floor Girders 

When connecting a 

new element to a 

particular node on a 

column, use Elem in 

the Intersect field to 

divide the column 

member automatically 

at the relevant node. 
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Generate 3-D Frame 
 

 

By using the completed 2-D frame, duplicate 2 frames in the GCS Y-direction at 

an interval of 26 ft.  

 

First, switch the window to the 3-D state. When selecting elements to be 

duplicated, exclude the 2 floor girders. Two floor girders will be duplicated later 

with the small beams simultaneously. 

 

 

1. Select GCS in the Icon Menu. 
 

2. Select  Iso View in the Icon Menu. 
 

3. Click  Select All in the Icon Menu. 
 

4. Click  Select Single in the Icon Menu and click the girders (elements 

33 and 36) so that they are not duplicated. 
 

5. Select Translate Elements in the functions selection field (Fig.2.9). 
 

6. Confirm “Copy” in the Mode selection field.  
 

7. Select “Equal Distance” in the Translation selection field. 
 

8. Enter “0, 26, 0” in the dx, dy, dz field or use Mouse Editor to enter the 

data automatically. 
 

9. Enter “2” in the Number of Times field. 
 

10. Click . 
 

11. Click  Element Number in the Icon Menu (Toggle off). 
 

12. Click  Shrink in the Icon Menu (Toggle off). 
 

13. Click  Select Single in the Icon Menu and select the two girders with 

the mouse 
 

14. Enter “0, 26/3, 0” in the dx, dy, dz field.


 
 

15. Enter “6” in the Number of Times field. 
 

16. Click . 

 

 

In midas Gen, 

numerical values as 

well as equations may 

be used simultaneously. 

Most operators used in 

engineering can be 

used. 
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Figure 2.9  Duplicated 3-D Frame 
 
 
Generate Floor Girders 
 

 

Create the floor girders by connecting the longitudinal sides of the floors as 

shown in Fig.2.10. To avoid confusion between the existing point grid and the 

nodes, toggle off  Point Grid and  Point Grid Snap. 

 

 
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1. Click  Point Grid and  Grid Snap in the Icon Menu (Toggle off). 
 

2. Select Create Elements in the functions selection field. 
 

3. Confirm “General Beam/Tapered Beam” in the Element Type 

selection field. 
 

4. Confirm “1: Frame” in the Material Name selection field. 
 

5. Confirm “3: W 18  65” in the Section Name selection field. 
 

6. Confirm “0” in the Beta Angle selection field. 
 

7. Check () Elem and Node of Intersect. 
 

8. Assign nodes 20 (0, 0, 10) to 48 (0, 52, 10) to generate the lower 

floor girders on grid ○1  of Fig.2.1. 
 

9. Assign nodes 21 (32, 0, 10) to 52 (32, 52, 10) to generate the lower 

floor girders on grid ○2 . 
 

10. Assign nodes 22 (0, 0, 20) to 68 (0, 52, 20) to generate the upper 

floor girders on grid ○1 . 
 

11. Assign nodes 23 (32, 0, 20) to 69 (32, 52, 20) to generate the upper 

floor girders on grid ○2 . 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 2.10  Generation of Floor Story Girders/Beams 



 
 
 
 
Tutorial 2 

16 

Generate Roof Girders and Remove Columns 
 
 

Use  Create Elements to generate the roof-level girders and remove the 

generated column elements unnecessarily duplicated during the copy process. 

 

 

1. Select “1: W 16  67” in the Section Name selection field. 
 

2. Confirm “0” in the Beta Angle selection field. 
 

3. Assign nodes 2 (0, 0, 30) to 53 (0, 52, 30) to generate the roof-level 

girders (Fig.2.11). 
 

4. Assign nodes 16 (32, 0, 36) to 64 (32, 52, 36) to generate the roof-

level girders (Fig.2.11). 
 

5. Select Delete Elements in the functions selection field. 
 

6. Confirm “Picking” in the Type selection field. 
 

7. Click  Rotate Dynamic to rotate the model to the desired orientation 

for a clear view of the model. 
 

8. Confirm that  Snap Element Center is Toggled on. 
 

9. Remove the column elements in Fig.2.11 by assigning with the 

mouse. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 2.11  Generation of Roof Girders and Removal of Columns 

 

 

 

 
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Generate Longitudinal Truss  
 

 

Use Structure Wizard to generate the longitudinal truss on grid  of the structure 

(Fig.2.1). Use  Rotate Left or  Rotate Dynamic to change the view by 

rotating the model to the desired orientation. The generation of the longitudinal 

truss is similar to that of the roof-level truss and the procedure is as follows: 

 

 

1. Click  Rotate Dynamic in the Icon Menu and rotate the model as 

shown in Fig.2.13. 
 

2. Select Structure> Wizard>Base Structures>Truss in the Main Menu. 
 

3. Select the truss shape (Fig.2.12(a)) in the Type selection field of the 

Input tab.  
 

4. Enter “8” in the Number of Panels (number of divisions of Top & Bot. 

Chords) field. 
 

5. Enter “26” in the L field (length of truss). 
 

6. Enter “3” in the H1 field (height of truss). 
 

7. Select “Sym.” in the Option selection field. 
 

8. Check () Show Dimensions and confirm L and H1. 

 

 

 

   

(a) Input (b) Edit (c) Insert 

 

Figure 2.12  Truss Wizard 

 
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1. Select the Edit tab. 
 

2. Select “1: Frame” in the Material selection field. 
 

3. Enter “4: W 4 13” in the Top (top chord) field. 
 

4. Enter “4: W 4 13” in the Bottom (bottom chord) field. 
 

5. Enter “6: WT 4  9” in the Diagonal (diagonal member) field.  
 

6. Check () Merge Straight Members. 

 

 

 

1. Select the Insert tab. 
 

2. Enter “64, 0, 30” in the Insert Point field or use Mouse Editor to 

assign node 4. 
 

3. Enter “90” in the Gamma field of Rotations.


 
 

4. Select “12 (0, 0, 3)” in the Origin Point selection field.


 
 

5. Click .  
 

6. Confirm if the longitudinal truss is correctly generated and click 

 in the Truss Wizard dialog box. 
 

7. Click  Iso View in the Icon Menu.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
 Comment 1. ……………………………………………………………………………………………………………...… 

When using midas Gen, the use of Query is a handy tool to find the distance between nodes or the length of an 

element. Selecting the Query>Query Nodes or Query Elements menus will display the Query dialog box. If the 

Node tab at the top is selected and if two nodes are selected with the mouse, the Message window will indicate the 

positions and the distance between the two nodes.  

Similarly, select Element in the Query dialog box and assign the desired element with the mouse, then the element 

and length data will appear in the Message window. 

If Show No. is 

checked(), the node 

numbers will be 

displayed on the screen 

which will enable the 

user to find the Origin 

Point. 

When Wizard Model is 

inserted into the main 

model, Alpha, Beta and 

Gamma represent the 

rotation angles which 

the partial model is to 

be rotated about GCS 

X, Y and Z-axes, 

respectively. 



 
 
 
 

Structural Modeling Using Nodes and Elements 

 

19 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 2.13  Generation of Longitudinal truss 
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Generate Wind Braces 
 

 

 

1. Select  Create Elements in the functions selection field 

(Fig.2.14). 
 

2. Select “Truss” in the Element Type selection field.  
 

3. Confirm “1 : Frame” in the Material Name selection field. 
 

4. Select “7 : L 4  4  5/16” in the Section Name selection field. 
 

5. If Node and Elem
 of Intersect are already checked (), click once 

again to remove the check. 
 

6. Connect nodes 5 (32, 0, 0) and 4 (64, 0, 30) of the X-Z plane to 

generate the wind brace. 
 

7. Connect nodes 6 (32, 0, 30) and 3 (64, 0, 0) to generate the wind 

brace.


 
 

8. Repeat steps 6 and 7 to generate the remaining wind braces in the roof 

floor and the Y-Z plane as shown in Fig.2.14.


 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 2.14  Generation of Wind Braces 

If Elem of Intersect is 

checked (), remove 

the check to avoid the 

automatic division of 

elements at the 

intersection points of X-

shape wind braces. 

When nodes are to be 

identified for member 

generation, set  

 Hidden to Toggle off 

or use Zoom and 

Rotate to change the 

View Point until it 

becomes easier to 

manipulate the model. 

 
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Complete 3–D Modeling By Mirror Duplication  
The structure is symmetrical about grid ○C  (Fig.2.1). The structure modeled up 

to this point is mirror-duplicated with respect to grid ○C , thereby completing the 

entire model. 

 

1. Click  Node Number in the Icon Menu (Toggle off). 
 

2. Click  Shrink in the Icon Menu (Toggle on). 
 

3. Click  Right View in the Icon Menu. 
 

4. Select Mirror Elements in the functions selection field (Fig.2.15). 
 

5. Click  Select by Window in the Icon Menu. 
 

6. Drag the mouse from right to left as shown in Fig.2.15 to select the 

nodes and elements to be duplicated. 
 

7. Select “Copy” in the Mode selection field.


 
 

8. Select z-x plane in Reflection and assign any node in the plane 

containing grid C to specify “52” automatically. 
 

9. Click . 
 

10. Click  Iso View in the Icon Menu. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 2.15  Selection of Target Elements of Mirror Elements 

When selecting 

members for duplication, 

exclude the elements 

contained in the plane of 

symmetry (Fig. 2.15-). 

When using  Select 

Window, only the 

elements completely 

included in the window 

are selected by dragging 

the mouse from left to 

right, and the elements 

intersecting the 

boundary of the window 

are also selected by 

dragging the mouse 

from right to left. For this 

reason the mouse is 

dragged from right to 

left. 

As Snap cannot be 

executed when  
Select Window is 

Toggled on, switch  
Select Window to 

Toggle off before 

executing step 8.  

 

 

 

 

Mouse Drag Direction 
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Enter Structure Support Conditions 
 

When the entire model is complete, attribute the support conditions to the lower 

ends of the columns. In this example, assume that the lower ends of the columns 

are pinned (pin support). 

 

1. Select the Boundary tab as shown in Fig.2.16. 
 

2. Confirm Supports in the functions selection field. 
 

3. Click  Select by Plane in the Icon Menu. 
 

4. Select “XY Plane”. 
 

5. Enter “0” in the Z Position field (Z-axis coordinate of the lower ends of 

the columns to receive support conditions). Click  or assign any 

node at the lower end of a column with the mouse and click .  
 

6. Confirm “Add” in the Options selection field. 
 

7. Check () “D-ALL” in the Support Type selection field.


 
 

8. Click . 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 2.16  Data Entry of Support Conditions 

When the coordinates 

of a node has been 

defined by Node Local 

Axis, the restraints are 

also defined with 

respect to the Node 

Coordinate.  

 



 
 
 
 

Enter Loading Data 

 

23 

Enter Loading Data 
 

Setup Load Cases 
 

 

Set up load cases before entering the loading data. 

 

 

1. Select the Load tab as shown in Fig.2.16. 
 

2. Click the button  to the right of Load Case Name. 
 

3. Enter the load cases in the Static Load Cases dialog box as shown in 

Fig.2.17.


 

 

 
 

Figure 2.17  Data Entry for Load Cases 
 

Refer to “Load Cases 

Setup” of “Tutorial 1” 

or On-line Manual. 

Separate Roof Live 

Load from normal floor 

Live Load. A different 

live load factor is applied 

to roof live load in LRFD 

or Limit States Design.  
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Define Self Weight 
 

 

The Self Weight of the structure is computed automatically, reflecting the 

densities and the volumes, when the material properties and sections of members 

are defined. The self-weight of the structure is taken into account in the analysis 

with respect to the gravity direction or any other defined direction by the given 

factors through the Self Weight command.  

 

Observe the following procedure to specify the self-weight: 

 

 

1. Select Self Weight in the functions selection field (Fig.2.18). 
 

2. Confirm “Self Weight” in the Load Case Name selection field. 
 

3. Enter “-1” in the Z field of Self Weight Factor. 
 

4. Click  in the Operation selection field. 

 

 
 

Figure 2.18  Data Entry of Self Weight 

 
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Define Floor Load 
 

 

Specify the floor loads. 
 

As the structure configurations and the magnitudes of floor loads are identical in 

this example, the floor loads on both floors are defined simultaneously. 

 

Activate only the loaded planes to avoid any error during the data entry in Assign 

Floor Load. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 2.19  Data Entry for Floor Loads 

 

 

 

 

 

 

 

 

 

The size of Floor Load 

Label may be adjusted in 

the Size tab in  

 Display Option. 

 
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1. Select Assign Floor Loads in the functions selection field 

(Fig.2.19). 
 

2. Click the button  to the right of Load Type. 
 

3. Enter “Floor” in the Name field of Floor Load Type & Description.


 
 

4. Enter “Top and Bottom identical ” in the Description field.  
 

5. Select “DL” in the Load Case 1. selection field of Floor Load & Load 

Case and enter “- 0.1” in the Floor Load field.


 
 

6. Select “LL” in the Load Case 2. selection field and enter “- 0.1” in the 

Floor Load field. 
 

7. Click . 
 

8. Click . 
 

9. Select “Floor” in the Load Type selection field. 
 

10. Select “One Way” in the Distribution  selection field. 
 

11. Check () Copy Floor Load to enter the floor loads of the top and 

bottom floors simultaneously. 
 

12. Confirm “z” in the Axis selection field. 
 

13. Enter “10” in the Distances field.


 
 

14. Click  Front View in the Icon Menu. 
 

15. Click  Select by Window in the Icon Menu and drag the mouse from 

left to right to select only the first level floor. 
 

16. Click  Activate in the Icon Menu. 
 

17. Click  Node Number in the Icon Menu (Toggle on). 
 

18. Click  Isometric View in the Icon Menu. 
 

19. Click the Nodes Defining Loading Area field once and assign 

sequentially the nodes (104, 20, 21, 108, 104) forming an irregular 

polygon plane defining the loaded area.


 
 

20. Click  Shrink in the Icon Menu (Toggle off). 
 

21. Click  Active All in the Icon Menu. 

 

 

If Convert to Beam Load 

Type is not checked (), 

the load data will be 

saved as floor load and 

future modification will 

be easy. 

During the floor load 

generation in midas Gen, 

the user is cautioned to 

properly define Load 

Angle (A1) and Sub-

Beam Angle (A2) in 

specifying the loaded 

area. The angles are 

determined on the basis 

of the line defined by 

the 1st and 2nd nodes. 

(Refer to On-line 

Manual). 

If Sub Beam Weight is 

checked(), the value of 

Unit Self Weight specified 

for the unmodeled sub-

beams are added to the 

floor load of the load 

cases in which the check 

() is marked. 
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Define Inclined Roof Load 
 

 

Apply the dead and live loads of the inclined roof on the top chords of the roof 

trusses (beam elements). 

 

Floor Load may be applied to any plane in the model in midas Gen. Hence, 

dead and live loads acting on an inclined roof as well as snow loads and wind 

loads, may be specified by Floor Load. 

 

Use Floor Load to enter the dead and live loads acting on the inclined roof in the 

example. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 2.20  Data Entry for Inclined Roof Loads 

 
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1. Click  Front View in the Icon Menu. 
 

2. Click  Hidden in the Icon Menu (Toggle off). 
 

3. Confirm Assign Floor Loads in the functions selection field 

(Fig.2.20). 
 

4. Click the button  to the right of Load Type and enter “Inclined 
Roof” in the Name field. 

 
5. Remove the contents in the Description field.  

 
6. Enter “- 0.015” for Floor Load in Load Case 1 from which DL has 

been selected. 
 

7. Select “LR” from Load Case 2. and enter “- 0.02” for Floor Load. 
 

8. Click . 
 

9. Click . 
 

10. Select “Inclined Roof” in Load Type. 
 

11. Confirm “One Way” in the Distribution selection field. 
 

12. Click  Select by Polygon in the Icon Menu and select only the upper 

chords of the roof trusses shown in Fig.2.20


 
 

13. Click  Activate and  Isometric View in the Icon Menu. 
 

14. Enter “3” in No. of Sub Beams of Unmodeled Sub-Beam. 
 

15. Confirm “90” in Sub-Beam Angle (A2). 
 

16. Enter “0.033” in Unit Self Weight. 
 

17. Remove the check () in “Copy Floor Load”. 
 

18. Click the Nodes Defining Loading Area field once and click nodes  

2, 16, 121, 109, 2 sequentially.


 
 

19. Click nodes 16, 4, 117, 121,16 successively. 
 

20. Click  Active All in the Icon Menu. 
 

21. Click  Node Number in the Icon Menu (Toggle off). 

 

 

 

Define X-Direction Wind Load 
 

 

Specify the X-direction wind load as a uniformly distributed load. 

 

In practice, the wind load must be applied to wall and roof planes considering the 

members’ orientation and the tributary areas. To simplify the problem, assume that 

a uniformly distributed load of 0.1 k/f is applied to only the columns and girders 

on grid  of the structure.  

Where a load such as 

snow load is applied 

vertically on a projected 

plane of the roof, select 

‘Yes’ in the Projection 

field. 

When using  Select 

Polygon, double click 

the last node which 

defines the selected 

area for nodes or 

elements. 

If  Fast Query of the 

Status Bar is used, the 

attributes of  

the snapped nodes or 

elements can be easily 

verified. 
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1. Click  Select by Plane in the Icon Menu. 
 

2. Select “YZ Plane”. 
 

3. Click any point on grid ○1  plane of the structure (Fig.2.1) to enter “0” 

automatically in the X Position field. 
 

4. Click . 
 

5. Select “Element Beam Loads” in the functions selection field 

(Fig.2.21). 
 

6. Select “WX” in the Load Case Name selection field. 
 

7. Confirm “Add” in the Options selection field. 
 

8. Confirm “Uniform Loads” in the Load Type selection field. 
 

9. Select “Global X” in the Direction selection field. 
 

10. Confirm “No” in the Projection selection field. 
 

11. Enter “0.1” in the w field. 
 

12. Click . 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 2.21  Data Entry for X-Direction Wind Load 

 
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Click the button  on the right of the functions selection field (Fig.2.22) to 

confirm the loads applied to beam elements in Beam Loads Table.  

 

When confirming the data entries such as load, release, etc. relative to a specific 

element, use Element Detail Table for convenience. 

 

 

1. Click  Select Previous in the Icon Menu. 
 

2. Select Query>Element Detail Table in the Main Menu. 
 

3. Click  as shown in Fig.2.22. 
 

4. Click  Unselect All in the Icon Menu. 

 

 

 

 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
 Figure 2.22  Element Detail Table 

 

 
 
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Define Y-Direction Wind Load 
 

 

Specify the Y-direction wind load simply as concentrated loads. 

 

 

1. Click  Select Plane in the Icon Menu. 
 

2. Select “XZ Plane”. 
 

3. Click any point on plane ○A  of the structure for the Y Position field.  
 

4. Click . 
 

5. Select Nodal Loads in the functions selection field. 
 

6. Select “WY” in the Load Case Name selection field. 
 

7. Confirm “Add” in the Options selection field. 
 

8. Enter “5” in the FY field. 
 

9. Click . 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 2.23  Data Entry for Y-Direction Wind Load 
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Verify the entered nodal loads. 
 

 

1. Click  Select Previous in the Icon Menu. 
 

2. Select Query>Node Detail Table in the Main Menu. 
 

3. Click  as shown in Fig.2.24 
 

4. Click  Unselect All in the Icon Menu. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 2.24  Node Detail Table 
 

 

 

Confirm the status of model data input prepared using 
Works Tree 
 

 

midas Gen provides the state-of-the-art modeling capability, Works Tree, which 

systematically summaries and maintains the process of input data construction. 

 

 
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From the record of data entry process contained in Works Tree, previously 

entered attributes may be modified, deleted, activated or deactivated. Moreover, 

appropriate attributes can be intuitively assigned through Drag & Drop. 

 

 

1. Select the Works tab as shown in Fig.2.25. 
 

2. Select “Type 1[111000]” in Boundaries>Supports and right-click the 

mouse. 
 

3. Select “Display” From the context menu of Works Tree. 
 

4. Confirm the entered support condition of the model as shown in Fig.2.26. 
 

5. Select “Floor Loads: 4” in Static Loads>Static Load Case2 

[DL:Dead Load]. 
 

6. Select “Display” from Context Menu. 
 

7. Confirm the entered floor load as shown in Fig.2.27. 
 

8. Click  Display and uncheck Support under the Boundary tab. 
 

9. Click . 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 2.25  Selection of the Works tab of Tree Menu 
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Figure 2.27  Confirmation of Floor Load input using Works Tree 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 2.26  Confirmation of Support Condition using Works Tree 
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Perform Structural Analysis 
 

 

Click  Analysis in the Icon Menu or select Analysis>Perform Analysis in the 

Main Menu to analyze the model. Once the analysis is completed, the program 

switches automatically to the post-processing mode, which provides access to 

the analysis and design results.  

 

Click  Preprocessing Mode in the Icon Menu or select Mode> Preprocessing 

Mode in the Main Menu when the preprocessing mode has to be restored to 

modify the data. 

 

 

 

 

Verify and Interpret Analysis Results 
 

 

Load Combinations 
 

 

Use Results>Combinations in the Main Menu to specify the load combinations 

prior to verifying the analysis results. 

 

The load combinations, in conformity with the Limit State Design Method, are 

auto-generated by Auto Generation. Additional Service Load combinations may 

be entered to examine displacements and reactions. 
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1. Select the Results>Combinations in the Main Menu. 
 

2. Select the Steel Design tab. 
 

3. Click . 
 

4. Confirm “Add” in the Option selection field. 
 

5. Select “AISC(14th)-LRFD10” in the Design Code field. 
 

6. Click . 
 

7. Click the Name field below sLCB31 in Load Combination List. 
 

8. Enter additionally sLCB32 as shown in Fig.2.28.


 
 

9. Click  in the Load Combinations dialog box. 

 

 

 

Figure 2.28  Load Combinations 

For details concerning 

the data entry, refer to 

“Load Combination” of 

“Tutorial 1”. 

During the auto-

generation of load 

combinations, the load 

combination description 

reflects the load case 

names assigned by the 

user such as wind and 

earthquake. 
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Verify Reactions 
 

 

 

1. Select Results>Reactions>Reaction Forces/Moments in the Main 

Menu. 
 

2. Select “CBS: sLCB1” in the Load Cases/Combinations selection 

field. 
 

3. Select “FZ” in the Components selection field. 
 

4. Check () Values and Legend in the Type of Display selection field. 
 

5. Click .  

 

 

 

 

Figure 2.29  Reactions due to Vertical Loads 

It will be more 

convenient to place the 

Result Toolbar in the 

post-processing mode. 

Refer to Tutorial 1 for 

the placing of Result 

Toolbar. 
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Displacement Contour 
 

 

 

1. Click  Hidden (Toggle on) in the Icon Menu. 
 

2. Select Deform in the post-processing functions tab (Fig.2.30). 
 

3. Select Displacement Contour in the functions selection field. 
 

4. Select “CBS: sLCB8” in the Load Cases/Combinations selection 

field. 
 

5. Confirm “DXYZ” in the Components selection field. 
 

6. Check () Contour, Deform and Legend in the Type of Display 

selection field. 
 

7. Click the button  on the right of Contour. 
 

8. Select “18” in the Number of Colors selection field. 
 

9. Check () “Gradient Fill”. 
 

10. Click “Apply upon OK” to remove the check (). 
 

11. Click . 
 

12. Click the button  to the right of Deform. 
 

13. Select “Real Deform” in the Deformation selection field and click 

. 
 

14. Select “in” in the unit conversion window of Status Bar and click 

. 
 

15. Click  Perspective in the Icon Menu. 
 

16. Click  Render View in the Icon Menu. 

 

 

With the appropriate use of  Render View and  Perspective in the post-

processing stage, diversified and interesting displays may be viewed on the screen. 
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Figure 2.30  Contour of the Deformed Shape 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  

 Figure 2.31  Rendering View of the Deformed Shape
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Figure 2.32  “Walk through” the Deformed Shape 

 

 

 

1. Click  Render View in the Icon Menu (Toggle off). 
 

2. Select Forces in the post-processing functions tab (Fig.2.33). 
 

3. Select Beam Diagrams in the functions selection field. 
 

4. Confirm “Myz” in the Components selection field. 
 

5. Select “Exact” and “Line Fill” in the Display Options selection field. 
 

6. Check () Contour, Values and Legend in Type of Display. 
 

7. Click the button  to the right of Values. 
 

8. Enter “1” in Decimal Points and click . 
 

9. Select “ft” in the unit conversion window and click . 
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If there are many elements as is the case shown in Fig.2.33, the verification of 

bending moments from the diagram becomes next to impossible. In such a case 

use  Select Plane to selectively activate only the plane of interest. 

 

 

1. Click  Select Plane in the Icon Menu. 
 

2. Select “XZ Plane”. 
 

3. Click any point on plane ○A  to enter “0” automatically in the Y Position 

field. 
 

4. Click  in the Plane & Volume Select dialog box. 
 

5. Click  Activate in the Icon Menu. 
 

6. Click  Front View in the Icon Menu. 

 

 

 

Figure 2.33  Bending Moment Diagram of the Total Model 

 
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Figure 2.34  Bending Moment Diagram of Grid  plane of the Structure (Fig.2.1) 

 

Verify Member Stresses and Process Animation 
 
 

1. Click  Iso View in the Icon Menu. 

2. Click  Perspective (Toggle on) in the Icon Menu. 

3. Click  Active All in the Icon Menu. 

4. Select the Stresses in the post-processing functions tab (Fig.2.35). 

5. Select Beam Stresses in the functions selection field. 

6. Select “CBS: sLCB12” in the Load Cases/Combinations selection 

field. 

7. Confirm “Combined” in the Components selection field.  

8. Check () Contour, Deform and Legend in Type of Display. 

9. Select “in” in the unit conversion window. 

10. Click . 

 

 

1. Check () Animate in Type of Display (Fig.2.36) and remove the 

check in Legend. 

2. Click . 

3. Click  Record as shown in Fig.2.36. 
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Figure 2.35  Combined Stress Diagram of Beams 

 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 2.36  Animation Window 
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As explained in Tutorial 1 and Tutorial 2, the structural analysis results may be 

verified by Graphic window or by text format using Text Output. 

 

Use Results>Text Output in the Main Menu to execute Text Output. Text 

Output is organized such that the user may directly select the Load Set (Load 

Combinations for output), the output contents (reaction, displacement, member 

force, stress, etc.), the entities to output (type of element, element number, 

section number, material property number, story, etc.) and the output format 

(maximum/minimum values by sectional properties, etc.). 

 

The output file (fn.ANL) may be printed by the Text Editor in midas Gen, 

which enables the user to add appropriate headings and footings as necessary for 

documentation. 

 


