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งจากการออก
อกแบบได้สม
 Section ID /

2015 

 ธนพิศทุธ์ิวงศ์ 

นิดคือ C240 

crete and Stee

กบัแบบสถาป
กแบบ) โดยขั ้
มมตุิขึน้ เพ่ือเป็
/ Name / Us

0 สําหรับคอน

el  

ปัตยกรรม (ข
ขัน้ตอนแรกจ
ป็นเส้นร่างขอ
ser /D 

13 

นกรีต และ 

ขนาดของ
ะกําหนด
อง โมเดล

 



 

 
จากนัน้ใ
เส้นร่าง 
โปรแกรม
เสา : ID 
คาน : ID
 

ู

ให้กําหนดขนา
: ID 1 / Nam
มคํานวณคณุ
 100 / Name

D 200 / Nam

TRA

ผู้จดัทําหนงัสื

รูปท่ี 20 ขัน้ตอ

าดเพิม่เตมิทัง้
me / Solid Ro
ณสมบตัหิน้าตั
e / Solid Rec
e / Solid Re

AINING WOR

สือ: คณุ วิโรจน์

นการกําหนด M

ัง้ เส้นร่าง เสา
ound / Dumm
ดั) 

ctangle / C1
ctangle / C1

RKSHOP ON M

น์ ลชินะเธียร แล

Material /Sect

า คาน พืน้ บนั
my / D=0.00

(P) / H=0.21
1(P) / H=0.4

MIDAS GEN 2

ละ คณุ ธชัชาย 

tion ของ Conc

นัได ตามลําด
001 (ใสเ่ลขศนู

1 / B=0.21(เพ
4 / B=0.20 

2015 

 ธนพิศทุธ์ิวงศ์ 

crete and Stee

ดบัตวัเลขสีนํา้
นย์ให้มากกว่

พ่ือให้ผา่นข้อกํา

el  

า้เงินบนรูป ดั
า 3 ตวัขึน้ไป

าหนดขัน้ต่ําขอ

14 

งันี ้: 
เพ่ือไมใ่ห้

อง ACI ) 

 



 

รูปท่ี 21

 
1.2.11 ท
กําหนดค
ตามรูปป

 

 ขัน้ตอนการกํา

ทําการ Rand
คณุสมบตัิหน้
ประกอบท่ี 22
1. Ctrl + E 
2. คลกิ Disp
3. คลกิหน้าต
4. เลือก Sec
5. คลกิ Ran
6. คลกิ App

TRA

ผู้จดัทําหนงัสื

าหนด Thickne

dom Color ี
น้าตดัและควา
2 ซึง่ประกอบด

play Option 
ตา่ง Draw 
ction / Thickn
dom Color (

ply 

AINING WOR

สือ: คณุ วิโรจน์

ess ของ Conc

สีของชิน้ส่วน
ามหนาใหม่ ท
ด้วยขัน้ตอนต

ness Color 
(ระบบจะทําก

RKSHOP ON M

น์ ลชินะเธียร แล

rete and Stee

น เพ่ือการจําแ
ทกุครัง้ท่ีมีกา
ตา่งๆดงันี ้

การสุม่สีตา่งๆ

MIDAS GEN 2

ละ คณุ ธชัชาย 

el โดยทัว่ไป พืน้

แนกสีของหน้
ารเพิ่มเติมชิน้

ๆให้) 

2015 

 ธนพิศทุธ์ิวงศ์ 

นห้องนํา้ t= 0.1

น้าตดัของชิน้ส
นส่วน ดงัแสด

10 m. บนัได t=

ส่วนทกุครัง้ห
ดงขัน้ตอนราย

15 

=0.15 m. 

หลงัจากท่ี
ยละเอียด

 



 

รูปท่ี 22 ขั ้

1.3) ขัน้
1.3.1 โม

ขัน้ตอนการทํา 
จะใช้กรณีนีก็้ต

นตอนการสร้
มเดลตอมอ่ด้ว

รูปท่ี 23

TRA

ผู้จดัทําหนงัสื

Random Colo
ตอ่เม่ือเรียกคืนส

ร้างโมเดล   
วยการยืดวตัถ

3 ขัน้ตอนการกํ

AINING WOR

สือ: คณุ วิโรจน์

or ของแตล่ะชิน้
สภาพสีเดิมตอน

ถ ุโดยใช้คําสัง่

าหนดการยืด ห

RKSHOP ON M

น์ ลชินะเธียร แล

นสว่นโครงสร้าง
นเร่ิมต้น) 

 

งัยืด Node / 

หด วตัถ ุโดยใช้

MIDAS GEN 2

ละ คณุ ธชัชาย 

งประกอบด้วยขั

 Element / E

ช้คําสัง่ยืด Nod

2015 

 ธนพิศทุธ์ิวงศ์ 

ขัน้ตอนสําคญัๆ

xtrude 

e / Element / E

ๆข้างต้น (Defa

Extrude  
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ult Item   

 



 

ขัน้ตอนนี
เห็นมมุที

1.3.2 เป

นีจ้ะทําการปรั
ท่ีจะโมเดลคา

รู

ปลี่ยนเสาให้เป็

รูปท่ี 25 ขัน้

TRA

ผู้จดัทําหนงัสื

รับมมุมองด้ว
นขัน้ตอ่ไป 

รปท่ี 24 ขัน้ตอน

ป็น เส้น Dum

นตอนการสร้าง

AINING WOR

สือ: คณุ วิโรจน์

วยการกดปุ่ ม 

นการปรับมมุมอ

mmy Line ด้ว

ง Element โดย

RKSHOP ON M

น์ ลชินะเธียร แล

 Ctrl+เมาส์ปุ่

  

องโมเดลด้วย F

 
ยการ Drag a

ยการลากเส้น D

MIDAS GEN 2

ละ คณุ ธชัชาย 

มกลาง แล้วห

Function Ctrl +

and Drop 

Dummy Line แ

2015 

 ธนพิศทุธ์ิวงศ์ 

หมนุโมเดล โด

+ Score Mous

และวางลงในกร

ดยจะทําการห

se  

รอบสีเหลือง  

17 

หมนุให้

 

 



 

1.3.3 วา

 
1.3.4 ทํา

 
1.3.5 เพิ่

าดเส้นร่างโดย

าการวาดเส้น

พิม่ความหนา 

TRA

ผู้จดัทําหนงัสื

ยใช้ Dummy 

รูปท่ี 26 คํ

นร่าง Dummy

รูปท่ี 2

 t = 0.20 m เ

รูปท่ี 28

AINING WOR

สือ: คณุ วิโรจน์

 Line เพ่ือวา

คําสัง่ Create E

y Line เพ่ือเต ี

7 ทําการวาดเส้

เพ่ือสร้างเป็น

8 การกําหนดคว

RKSHOP ON M

น์ ลชินะเธียร แล

ดเส้นผนงัลฟิ

Elements สําหรั

รียมยืดเป็นผ

ส้นร่าง Dummy

นผนงัลฟิต์ 

วามหนาของผน

MIDAS GEN 2

ละ คณุ ธชัชาย 

ฟต์ Node/Ele

รับวาดเส้น Du

ผนงัลฟิต์ 

y Line ตามรูป

นงัลฟิต์ ตามรูป

2015 

 ธนพิศทุธ์ิวงศ์ 

ment /Creat

mmy Line   

ด้านบน 

ปด้านบน 

te Element 

 

18 

 

 



 

Note: ท
กําหนดค
 
1.3.7 เลื

 
1.3.8 ยืด

 
 

ทําการ Rand
คณุสมบตัหิน้

ลอืกเส้นร่างบ

ดเส้นร่างด้วย

TRA

ผู้จดัทําหนงัสื

dom Color 
นาตดัและควา

บริเวณด้านลา่

รูปท่ี 2

คําสัง่ Node 

รู

AINING WOR

สือ: คณุ วิโรจน์

 สีของชิน้ส่วน
ามหนาใหม ่

างเพ่ือจะยืดเ

29 การเลือกกรอ

 / Element / 

รูปท่ี 30 การกํา

RKSHOP ON M

น์ ลชินะเธียร แล

นเพ่ือการจําแ

เป็นเส้นผนงัลิ

อบสีเหลืองด้วย

 Extrude 

าหนดการ Extru

MIDAS GEN 2

ละ คณุ ธชัชาย 

แนกสีของหน้

ลฟิต์ 

ย Select by W

ude จากเส้นร่า

2015 

 ธนพิศทุธ์ิวงศ์ 

น้าตดัของชิน้ส

Window 

าง  

ส่วนทกุครัง้ห

19 

หลงัจากท่ี

 

 



 

 
1.3.9 ทําาการวาดแนว

รู

TRA

ผู้จดัทําหนงัสื

รูปที

วคานตามรูปแ

รปท่ี 32 การวาด

AINING WOR

สือ: คณุ วิโรจน์

ท่ี 31 การกําหน

แบบสถาปัตย

ดคานตามแนว

RKSHOP ON M

น์ ลชินะเธียร แล

นดการ Extrude

ยกรรม 

วสถาปัตยกรรม

MIDAS GEN 2

ละ คณุ ธชัชาย 

e จากเส้นร่าง (

มโดยลากตามแ

2015 

 ธนพิศทุธ์ิวงศ์ 

(ตอ่) 

กน Global Axxis 
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1.3.10 ส

 
 

สร้างแนวคาน

TRA

ผู้จดัทําหนงัสื

นเพิ่มเตมิด้วย

รูปท่ี 33 ก

AINING WOR

สือ: คณุ วิโรจน์

ยคําสัง่ Trans

การ Translate 

RKSHOP ON M

น์ ลชินะเธียร แล

slate และทําก

 คานใหมตํ่าแห

MIDAS GEN 2

ละ คณุ ธชัชาย 

การ Translat

หน่ง Y= -2 m แ

2015 

 ธนพิศทุธ์ิวงศ์ 

te สร้างคานตั

และ X = 1 

ตวัใหมท่ัง้สอง

21 

งแห่ง 

 

 



 

1.3.11 
ตรวจสอ

 
1.3.12 ส

 

กดปุ่ มใช้ Ctr
บก่อนโมเดล

สร้างชัน้ 2 แล

TRA

ผู้จดัทําหนงัสื

ri+J  และ C
ขัน้ตอ่ไป 

รูปท่ี 34 กา

ละ 3 ด้วยการ

รูปท่ี 35 การใช้

AINING WOR

สือ: คณุ วิโรจน์

Ctrl+H เพ่ือป

รใช้คําสัง่ Ctrl+

รขึน้โมเดลด้วย

ช้คําสัง่ Buildin

RKSHOP ON M

น์ ลชินะเธียร แล

ปรับมมุมอง 

+H & Ctrl+J เปิ

ยคําสัง่ Build

g Generation

 
 

MIDAS GEN 2

ละ คณุ ธชัชาย 

และ Ctrl + 

ปิด-ปิด มมุมอง

ding Genera

 เพ่ือช่วยสร้างช

2015 

 ธนพิศทุธ์ิวงศ์ 

เมาส์กลาง เ

งตรวจโมเดล 

ation ตามคําส

ชัน้อ่ืนๆเพิ่มเติม

เพ่ือให้เป็นรูป

สัง่ท่ีแสดงดงั ู

ม 

22 

ปดงัแสดง 

รูป 

 

 



 

TRA

ผู้จดัทําหนงัสื

รู

รูปท่ี 37 รูป

AINING WOR

สือ: คณุ วิโรจน์

รูปท่ี 36 การกํา

ปแบบ Story หล

RKSHOP ON M

น์ ลชินะเธียร แล

าหนด Story ตา

 

ลงัจากการใช้คํา

MIDAS GEN 2

ละ คณุ ธชัชาย 

ามลําดบัเลข 1-

าสัง่ Building G

2015 

 ธนพิศทุธ์ิวงศ์ 

-6  

Generation 
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1.3.13 เ
โดยเพิ่ม 
การจําแน

 
1.3.14 เ

รูปท่ี 3

เพิ่มชิน้สว่น ข
 BST No.2 (
นกสีของหน้า

รูปท่ี 3

ปล่ียนคาน G

39 การเปล่ียน

TRA

ผู้จดัทําหนงัสื

ขนาด 0.20 x
(โปรแกรมกํา
าตดัของชิน้สว่

38 การกําหนด 

GB1 ท่ีชัน้ 2 แ

เบอร์คานทัง้ชัน้

AINING WOR

สือ: คณุ วิโรจน์

x 0.40 โดยตั ้
หนดอตัโนมตัิ
วนทกุครัง้หลงั

 Section เพิ่มเติ

และ 3 ให้เป็น

น โดยไปท่ี Sec

RKSHOP ON M

น์ ลชินะเธียร แล

ตัง้ช่ือคาน B1
ติ) จากนัน้ N
งัจากท่ีกําหน

ติมไปท่ี Sectio

น B1 และ RB

ction by Plane

MIDAS GEN 2

ละ คณุ ธชัชาย 

 และ RB 1 
Note: ทําการ 
นดคณุสมบตัหิ

on/ Properties/

B1 โดยใช้การ

/ XY-Plane/  Z

2015 

 ธนพิศทุธ์ิวงศ์ 

กําหนดเป็น 
 Random Co
หน้าตดั และ 

/ Add/ Section

เลือกแบบตา

Z-Position/ คลกิ

 No.300 และ
olor สีของชิน้
 ความหนา ใ

n Data 

ามลําดบั 

กเมาท์ท่ีตําแห

24 

ะ No.400 
นสว่นเพ่ือ
หม ่

 

 
น่ง B1 



 

1.3.15 ทํ

รูป

 
1.3.16 C

ทําการ Drag 

ปท่ี 40 การเปล่ีย

Copy คานมา

รูปที

TRA

ผู้จดัทําหนงัสื

 และ Drop ร่ว

ยนเบอร์คานทัง้

ายงัตําแหนง่ด

ท่ี 41 การ Copy

AINING WOR

สือ: คณุ วิโรจน์

วมกบั Selec

งชัน้ โดยไปท่ี S

ดงัรูปสร้างคา

y คาน GB1 ตา

RKSHOP ON M

น์ ลชินะเธียร แล

ct by Plane 

Section by Pla

าน BST จากน

ามรูปและ Tran

MIDAS GEN 2

ละ คณุ ธชัชาย 

ne/ XY-Plane/

นัน้ Drag และ

nslate ขึน้มาแก

2015 

 ธนพิศทุธ์ิวงศ์ 

/  และทําการล

ะ Drop เพ่ือเป

กน Z ระยะ 1.7

าก Section มา

เปล่ียน GB1 

75 m 
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าใส ่

เป็น BST 

 



 

1.3.17 แ

1.3.18 ยื

แบง่ชิน้สว่นเป็

ยืดคาน BST 

TRA

ผู้จดัทําหนงัสื

ป็นสองชิน้ด้วย

รูปท่ี 42 

ออกเป็นระย

รูปท่ี 43 เต ี

AINING WOR

สือ: คณุ วิโรจน์

ยเคร่ืองมือ D

ตวัอยา่งการแบ

ะทาง 1.5 m 

ตรียมการยืดคา

RKSHOP ON M

น์ ลชินะเธียร แล

Divide ตามตํา

บง่ Element ตา

 
 เพ่ือเป็นบนัไ

นออกเป็นระยะ

MIDAS GEN 2

ละ คณุ ธชัชาย 

าแหน่งท่ีแสด

ามจํานวนท่ีต้อ

ด 

ะ -1.5 m เตรีย

2015 

 ธนพิศทุธ์ิวงศ์ 

ดง 3 ตําแหนง่

งการแบง่ 

มเป็นบนัได 

ง 
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1.3.19 ว

1.3.20 ทํ

วาดบนัไดตาม

รูปท่ี 44

ทําการ Trans

รูปท่ี

TRA

ผู้จดัทําหนงัสื

มรูปโดยใช้คว

4 กําหนด Thick

slate บนัไดชัน้

 45 การใช้คําสั

AINING WOR

สือ: คณุ วิโรจน์

วามหนาของ 

kness เทา่กบั t

น 1 เช่ือมตอ่ขึ

สัง่ Translate E

RKSHOP ON M

น์ ลชินะเธียร แล

 Plate โดย t =

t = 0.15 m ด้ว

 
ขึน้ 2 เพ่ือปรับ

Elements เพ่ือท

MIDAS GEN 2

ละ คณุ ธชัชาย 

= 0.15 m. 

ย การปรับ Ele

บไปเป็นบนัได

ทําบนัไดทางขึน้

2015 

 ธนพิศทุธ์ิวงศ์ 

ement Type เป็

ดของ ชัน้ 2 เชื

นชัน้ 1 เช่ือมตอ่

ป็น Plate  

ช่ือมตอ่ขึน้ชัน้

อชัน้ 2 
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น 3 

 



 

1.3.21 ใ

รูปท

รูปท่ี

ใช้คําสัง่ Build

ท่ี 47 การสร้าง

TRA

ผู้จดัทําหนงัสื

 46 การใช้คําสั

ding Genera

งผนงัลฟิต์จากชั

AINING WOR

สือ: คณุ วิโรจน์

สัง่ Translate E

ation สร้างผน

ชัน้ 1 ท่ีทําไว้แล้

RKSHOP ON M

น์ ลชินะเธียร แล

Elements เพ่ือท

 
นงัลฟิต์ขึน้มา

ล้วก่อนหน้าขึน้ไ

MIDAS GEN 2

ละ คณุ ธชัชาย 

ทําบนัไดทางขึน้

าอีก 1.5 m. 

ไปชัน้ 2 และ 3 

2015 

 ธนพิศทุธ์ิวงศ์ 

นชัน้ 2 เช่ือมตอ่

 ด้วยคําสัง่ Bui

อชัน้ 3 

 
lding Genera
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tion  



 

1.3.22 ทํ

 
1.3.23 
คาน จาก
หลงัจาก

ทําช่องเปิดโด

เลือกตําแหน
กนัน้ Note: ท
กท่ีกําหนดคณุ

TRA

ผู้จดัทําหนงัสื

ยใช้เคร่ืองมือ

รูปท่ี 48 ก

น่งท่ีจะทําประ
ทําการ Rand
ณสมบตัหิน้าตั

รูปท่ี 49 ขัน้ตอ

AINING WOR

สือ: คณุ วิโรจน์

อ Wall Open

การใช้คําสัง่ Wa

ะตชู่องเปิด แ
dom Color สี
ตดัและความห

อนการทําช่องเ ิ

RKSHOP ON M

น์ ลชินะเธียร แล

ning 

all Opening เพื

และ เม่ือเปิดช
สีของชิน้สว่นเ
หนาใหม ่

เปิดของปลอ่งลิ

MIDAS GEN 2

ละ คณุ ธชัชาย 

พ่ือเตรียมทําช่อ

ช่องเปิดแล้ว 
เพ่ือการจําแน

ลฟิต์โดยทําตาม

2015 

 ธนพิศทุธ์ิวงศ์ 

องเปิดลฟิต์ 

Wall เหนือช
นกสีของหน้า

มลําดบัเลข 1-6

ช่องเปิดจะเป
ตดัของชิน้สว่

6  

29 

 

ปลี่ยนเป็น
วนทกุครัง้

 



 

1.3.24 แ

1.3.25 เ

แบง่ผนงัช่องเ ิ

รูปท่ี 50 ขัน้ต

ม่ือแบง่เสร็จแ

TRA

ผู้จดัทําหนงัสื

เปิดด้วยคําสัง่

ตอนการทําช่อง

แล้ว โปรแกรม

รูปท่ี 51ภาพโ

AINING WOR

สือ: คณุ วิโรจน์

ง Divide เพ่ือ

เปิดผนงัลฟิต์ โ

มจะสร้างช่อง

โมเดลหลงัจาก

RKSHOP ON M

น์ ลชินะเธียร แล

อให้แนวช่องเปิ

โดยกําหนด Ele

 
งเปิด และคาน

กท่ีทําการแบง่ W

MIDAS GEN 2

ละ คณุ ธชัชาย 

ปิด เป็นแนวเ

ement Type เป็

นอตัโนมตั ิตา

Wall Opening 

2015 

 ธนพิศทุธ์ิวงศ์ 

สมอกนัตลอด

ป็น Wall และใส

ามปรากฏใน 

 เรียบร้อยแล้ว 

ดตามผนงัลฟิ

 
สร่ะยะตามรูป 

น Tree Menu 

 
30 

ฟต์ 

 

 

 



 

1.3.26 เ

 
1.3.27 ชิ
ของชิน้ส่

รู

พิ่มหน้าตดัให

รูปท่ี 52 สร้

ชิน้สว่นใหมที่
สว่นทกุครัง้หล

รูปท่ี 53 การ R

TRA

ผู้จดัทําหนงัสื

หมโ่ดยเลือกจ

ร้างหน้าตดัเหล็

ท่ีสร้างเพิ่ม No
ลงัจากท่ีกําหน

Random Color 

AINING WOR

สือ: คณุ วิโรจน์

จากตารางท่ีโป

กขึน้มาใหมจ่า

ote: ทําการ 
นดคณุสมบตัิ

 ของชิน้สว่น (ค

RKSHOP ON M

น์ ลชินะเธียร แล

ปรแกรมมีมา

ก Properties /

 Random C
ตหิน้าตดั และ

ควรท่ีจะทําการ

MIDAS GEN 2

ละ คณุ ธชัชาย 

าให้ เพิ่มเตมิอี

/Section Prop

olor สีของชิน้
ะความหนาให

ร Random ทกุค

2015 

 ธนพิศทุธ์ิวงศ์ 

อีก 4 หน้าตดั 

erties /H and 

นสว่นเพ่ือกา
หม ่

ครัง้เพ่ือให้การโ

 

 P Sections 

รจําแนกสีขอ

โมเดลไม่สบัสน

31 

 

 

องหน้าตดั

 
น) 



 

1.3.28 โ
วตัถขุึน้ไ

รูปท่ี 54

 
 
 
 
 

โครงสร้างเสา
ไป 1.5 เมตร (

4 การ Extrude

TRA

ผู้จดัทําหนงัสื

าหลงัคาเหลก็
(ความสงูปลอ่

 Node => Lin

AINING WOR

สือ: คณุ วิโรจน์

กด้วยคําสัง่ E
องลฟิต์ 1.5 มี

e Element เพ่ือ

RKSHOP ON M

น์ ลชินะเธียร แล

Extrude ใช้คํ
มีอยูแ่ล้วเพิ่มอี

อเตรียมการขึน้

MIDAS GEN 2

ละ คณุ ธชัชาย 

าสัง่ยืดวตัถ ุขึ
อีก 1.5 เมตร 

นเสารองรับโครง

2015 

 ธนพิศทุธ์ิวงศ์ 

ขึน้ไป 3 เมต
 จะได้ความสู

งาสร้างหลงัคา

ตร ยกเว้นหลงั
สงูเสาเหลก็ต้น

า (เลือก Node 

32 

งลิฟต์ ยืด
นอ่ืนๆ) 

ท่ีจะยืด) 

 

 



 

1.3.29 ส

 

 

สร้างเส้นสมมุ

รูปท่ี 5

TRA

ผู้จดัทําหนงัสื

มตุด้ิวยเส้น D

รูปท่ี 55 การ

56 การ Divide 

AINING WOR

สือ: คณุ วิโรจน์

ummy Line 

รสร้างเส้น Dum

 เส้น Dummy L

RKSHOP ON M

น์ ลชินะเธียร แล

 เพ่ือทําโครงห

mmy Line เพ่ือ

Line เป็นสองส

MIDAS GEN 2

ละ คณุ ธชัชาย 

หลงัคา โดยแบ

อเตรียมขึน้โครง

สว่นเพ่ือเตรียมที

2015 

 ธนพิศทุธ์ิวงศ์ 

บง่เส้น Dumm

สร้างหลงัคา 

ท่ีจะ Translate

my Line เป็น

e Node  

33 

น 2 ชิน้ 

 

 



 

1.3.30 C

 
1.3.31 ก

 

 
 
 

Copy Node ขึ

รูปท่ี 57 กา

การวาดโครงส

รูปท่ี 5

TRA

ผู้จดัทําหนงัสื

ขึน้ไปทางแน

าร Translate N

สร้างหลงัคาโ

58 การใช้คําสัง่

AINING WOR

สือ: คณุ วิโรจน์

วแกน    Z = 

Node ในแนวด่ิง

โค้ง ด้วยคําสัง่

ง Create Line 

RKSHOP ON M

น์ ลชินะเธียร แล

 1.5 เมตร เพ่ื

งเป็นระยะ 1.5 

งัเส้นโค้ง โดย

 Elements on 

MIDAS GEN 2

ละ คณุ ธชัชาย 

พอสร้างสว่นบ

 m เพ่ือนเป็นเป็

ยเลือกหน้าตดั

Curve เพ่ือขึน้โ

2015 

 ธนพิศทุธ์ิวงศ์ 

นของโค้ง 

ป็นแกนกึง่กลาง

ดเหลก็ท่ี 502 

โมเดลเป็นหลงั

งของหลงัคา 

 โดยดจูากรูป

คาโค้ง 

34 

ปด้านลา่ง 

 

 

 



 

1.3.32 ก

 
1.3.33 ทํ
ความลกึ

การใช้คําสัง่ A

รูปท่ี 59 

ทําการ Trans
กของ Truss โ

TRA

ผู้จดัทําหนงัสื

Arc by 3 Poi

 การขึน้รูปแบบ

slate ชิน้สว่นที
โดยประมาณ

รูปท่ี 60 ก

AINING WOR

สือ: คณุ วิโรจน์

nts สําหรับก

บโค้งด้วยการลา

ท่ี 502 ขึน้ไปท
) 

การประมาณคว

RKSHOP ON M

น์ ลชินะเธียร แล

ารวาดเส้นโค้

ากจากจดุเร่ิม ไ

ทางแนวแกน

วามลกึท่ีเหมาะ

MIDAS GEN 2

ละ คณุ ธชัชาย 

ค้ง 

ไปยงัจดุจบ จะไ

น Z = L/16 จะ

ะสมของโครงถกั

2015 

 ธนพิศทุธ์ิวงศ์ 

ได้เส้นโค้งตามท

ะได้ 8/16 = 0

กด้วย L/16  

ท่ีกําหนด 

0.50 เมตร (ป

35 

 

ประมาณ

 



 

1.3.34 ใ

รูป

1.3.35 

 
 
 
 

ใช้ Create Ele

ท่ี 61 การสร้าง

ใช้คําสัง่ Tran

รูปท่ี 

TRA

ผู้จดัทําหนงัสื

ement สร้างชิ

ง Create Elem

nslate สร้าง 

62 การ Transl

AINING WOR

สือ: คณุ วิโรจน์

ชิน้สว่น Trus

ent ในสว่นของ

 Truss ท่ีเหลือ

ate Element ใ

RKSHOP ON M

น์ ลชินะเธียร แล

ss ตามรูปท่ีแ

ง Web โดยลา

 

อ ทกุๆ หวัเสา

ในสว่นของ Tru

MIDAS GEN 2

ละ คณุ ธชัชาย 

สดง 

กจาก Node-N

า 

uss ตามระยะหั

2015 

 ธนพิศทุธ์ิวงศ์ 

Node เช่ือมในทิ

หวัเสาโครงสร้าง

ทิศทาง Local A

งเหลก็  

36 

 

 
Axis  

 



 

 

1.3.36 

รูปท่ี 62 การ 

ใช้คําสัง่ตา่งๆ

TRA

ผู้จดัทําหนงัสื

 Translate Ele

ๆ ท่ีได้ศกึษาเ

รูปท่ี 63 ตวัอ

AINING WOR

สือ: คณุ วิโรจน์

ment ในสว่นข

เบือ้งต้น โดยส

อยา่งโมเดลท่ีทํา

RKSHOP ON M

น์ ลชินะเธียร แล

ของ Truss ตาม

สามารถโมเด

ามาตัง้แตข่ัน้ตอ

MIDAS GEN 2

ละ คณุ ธชัชาย 

มระยะหวัเสาโค

ดลออกมาเป็น

อนแรกจนถงึขัน้

2015 

 ธนพิศทุธ์ิวงศ์ 

ครงสร้างเหลก็ต

นรูปด้านลา่ง 

นตอนสดุท้าย 

ตามรูปด้านบน 

37 

 
 

 



 

1.3.38 
BOX จา
ท่ีกําหนด

 

1.3.39 

สร้างชิน้สว่น

กนัน้ทําการ 
ดคณุสมบตัหิ

วาดแปเหลก็

รูปท่ี 65 การ

TRA

ผู้จดัทําหนงัสื

นใหม่เพิ่ม โดย

Random Co
น้าตดั และค

รูปท่ี 64 การส ้

ตามรูปท่ีแสด

รวางแปท่ีตําแห

AINING WOR

สือ: คณุ วิโรจน์

ยเลือกจากตา

olor สีของชิน้ส
วามหนาใหม

ร้าง Section ขึ ้

ดงโดยใช้เหลก็

หน่ง Top Chord

RKSHOP ON M

น์ ลชินะเธียร แล

ารางท่ีโปรแก

สว่นเพ่ือการจ
ม ่

น้มาใหมเ่พ่ือเต

กกลอ่งท่ีสร้า

d ตรงบริเวณท่ี

MIDAS GEN 2

ละ คณุ ธชัชาย 

กรมมีมาให้ใช้

จําแนกสีของห

ตรียมการโมเดล

งจากขัน้ตอน

ท่ีเป็นจดุเช่ือมตอ่

2015 

 ธนพิศทุธ์ิวงศ์ 

โดย DB/USE

หน้าตดัของชิ ้

ลแปเหลก็กลอ่ง

นก่อนหน้านี ้

อระหวา่ง Web

ER / KS เลือ

ชิน้สว่นทกุครัง้

ง 

b-Top Chord  

38 

กหน้าตดั 

งหลงัจาก

 

 



 

 

 

TRA

ผู้จดัทําหนงัสื

AINING WOR

สือ: คณุ วิโรจน์

RKSHOP ON M

น์ ลชินะเธียร แล

MIDAS GEN 2

ละ คณุ ธชัชาย 

2015 

 ธนพิศทุธ์ิวงศ์ 
39 
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ผู้จดัทําหนงัสือ: คณุ วิโรจน์ ลชินะเธียร และ คณุ ธชัชาย ธนพิศทุธ์ิวงศ์ 

 

 

 

 

 

 

 

 

 

ASSIGNING LOAD 
STEP BY STEP 

 

 



 

2) คาํ

2.1) สร้า

 
2.2) ใสนํ่

าส่ังเบือ้ง

าง Static Loa

นํา้หนกัจากข้อ

รูปที

TRA

ผู้จดัทําหนงัสื

งต้นในก

ad Case จาก

รูปท่ี 66 การส

อมลูวสัดมุงุ 

ท่ี 67 การเตรียม

AINING WOR

สือ: คณุ วิโรจน์

การใส่นํา้

กคําสัง่ดงัรูป 

สร้าง Static Loa

เป็นนํา้หนกับ

มข้อมลูระบบโค

RKSHOP ON M

น์ ลชินะเธียร แล

าหนักบร

 

ad Cases ตาม

บรรทกุตายตวั

ครงหลงัคา เพ่ือ

MIDAS GEN 2

ละ คณุ ธชัชาย 

รรทุกแล

มรูป เพ่ือเตรียม

ว DL.และ นํา้

อเตรียมทําการป้

2015 

 ธนพิศทุธ์ิวงศ์ 

ละวเิครา

มการ Analysis

หนกั บรรทกุ

ป้อนคา่ในโปรแ

าะห์โครง

s  

จร LL.จากข้อ

แกรม  

41 

งสร้าง 

อกําหนด 

 

 



 

2.3) การ

DL = 5 
AUTO 
สมมตุใิห้

รกําหนดนํา้ห

จากข้อมลูระ
kg. /m และ 
จะไม่ถกูต้อ

ห้ใช้เป็นแบบ 
 
 
 
 

TRA

ผู้จดัทําหนงัสื

นกับรรทกุจร

รูปท่ี 68 กําหน

ะบบหลงัคาด้
 นํา้หนกับรรท
งตามหลกักา
 AUTO เพ่ือค

AINING WOR

สือ: คณุ วิโรจน์

รองค์อาคารต

นดนํา้หนกับรรท

านบน ดงันัน้
ทกุจร LL = 3
าร ควรจะทํา
ความรวดเร็วใ

RKSHOP ON M

น์ ลชินะเธียร แล

ามข้อกําหนด

ทกุจร เพ่ือเตรีย

 
นใช้ระยะแปทุ
30 kg./m (ก
การคิดแบบ 
ในการแสดงต

MIDAS GEN 2

ละ คณุ ธชัชาย 

ดกฎกระทรวง

ยมทําการป้อนค

ทกุๆ 1.00 เม
ารกําหนดแร
 Manual ในท
ตวัอยา่งเท่านั

2015 

 ธนพิศทุธ์ิวงศ์ 

งฉบบัท่ี 6 

คา่ในโปรแกรม 

มตร โดยจะมีน
งลมนัน้ ถ้าผู้
ทุกกรณี แต่สํ
นัน้) 

  

นํา้หนกับรรทุ
ู้ออกแบบใช้เ
สําหรับในตวัอ

42 

ทกุตายตวั  
เป็นระบบ 
อย่างนีจ้ะ

 



 

2.4) การ

รูปท่ี 6

 
2.5) การ

รูปท่ี 7

รใสนํ่า้หนกับร

69 เลือก Sectio

รใสนํ่า้หนกัจร

70 เลือก Sectio

TRA

ผู้จดัทําหนงัสื

รรทกุคงท่ี DL

on ทัง้หมดของ

ร LL. = 30 kg

on ทัง้หมดของ

AINING WOR

สือ: คณุ วิโรจน์

L. = 5 kg. /sq

งแป แล้วไปท่ี L

g./ sqm. (or 

แป แล้วไปท่ี Lo

RKSHOP ON M

น์ ลชินะเธียร แล

qm. (or 5 kg

Load /Element

 30 kg /m² *

oad /Element 

MIDAS GEN 2

ละ คณุ ธชัชาย 

g /m² *1 m =

t Beam Loads

1 m = 30 kg

 Beam Loads

2015 

 ธนพิศทุธ์ิวงศ์ 

= 5 kg/m)  

s /DL /Uniform

g/m) 

 /LL /Uniforme

med Loads /-5

ed Loads /-30

43 

 
 kgf/m 

 
0 kgf/m 



 

2.6) สร้า

รูปท่ี 

รูปท่ี 

 

างนํา้หนกับรร

 71 การสร้าง F

 72 การสร้าง F

TRA

ผู้จดัทําหนงัสื

รทกุของพืน้ด

Floor Load Typ

Floor Load Typ

AINING WOR

สือ: คณุ วิโรจน์

าดฟ้าและพืน้

pe ตามภาพด้า

pe ตามภาพด้า

RKSHOP ON M

น์ ลชินะเธียร แล

นทัว่ไป จากข้

านบน ประกอบ

 

านบน ประกอบ

MIDAS GEN 2

ละ คณุ ธชัชาย 

ข้อกําหนดตาม

บด้วย SW=2,4

บด้วย SW=2,4

2015 

 ธนพิศทุธ์ิวงศ์ 

มกฎกระทรวง

400*0.1, DL=2

400*0.1, DL=2

งฯ 

2400*0.05, LL

2400*0.05, LL
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2.7) ใสนํ่

รูปท่ี 7

 
2.8) ใสนํ่
180 kg./

รูปท่ี 7

นํา้หนกับรรทกุ

73 การใสนํ่า้หน

นํา้หนกับรรทกุ
/m (ผนงัสงู 1

74 การใสนํ่า้หน

TRA

ผู้จดัทําหนงัสื

กท่ีหลงัคา Ro

นกั Floor Load

กผนงัชัน้เดียว
1 เมตร) โดยใ

นกั Wall Load

AINING WOR

สือ: คณุ วิโรจน์

oof Load 10

d Type ตามภา

ว DL. = 180
ใช้วิธีเลือกทัง้ห

 Type ตามภาพ

RKSHOP ON M

น์ ลชินะเธียร แล

00 และ พืน้ทัว่

าพด้านบน โดย

0xH = 180x3
หมดแล้วปลด

พด้านบน โดยก

MIDAS GEN 2

ละ คณุ ธชัชาย 

วไป Floor Lo

กําหนดให้การก

3.5 = 630 kg
ดออกจะรวดเ

กําหนดให้การก

2015 

 ธนพิศทุธ์ิวงศ์ 

oad 200 

กระจายตวัเป็น

./m ทัง้ 2 ชัน้
เร็วกวา่ 

กระจายตวัเป็น

นแบบ Two-wa

น และ หลงัคา

นแบบ Two-way
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y Slab 

าใช้ DL = 

 
y Slab 



 

2.9) นํา้ห

2.10) แส

หนกับรรทกุต

สดง นํา้หนกับ

รูปท่ี 76

TRA

ผู้จดัทําหนงัสื

ตายตวั DL. ก

รูปท่ี 75 รูปแบ

บรรทกุตายตวั

6 การแสดงนํา้ห

AINING WOR

สือ: คณุ วิโรจน์

ระทําแบบ El

บบการใสนํ่า้หน

วั DL. นํา้หนกั

หนกับรรทกุ ทกุ

RKSHOP ON M

น์ ลชินะเธียร แล

lement Beam

นกับรรทกุ DL ต

 
กับรรทกุ จร L

กรณีด้วยคําสัง่

MIDAS GEN 2

ละ คณุ ธชัชาย 

m Load 

ตัง้แต่หลงัคาจน

LL. กระทําแบ

ง Floor Load a

2015 

 ธนพิศทุธ์ิวงศ์ 

นถงึพืน้ชัน้ลา่ง 

บบ Floor Loa

and Floor Loa

 
 

ad (Ctrl+E) 

 
d Name  
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2.11) นํา้

 

รูปที

า้หนกับรรทกุ

TRA

ผู้จดัทําหนงัสื

ท่ี 77 ตวัอยา่งนํ ้

ท่ีปลอ่งลฟิต์ 

รูป

AINING WOR

สือ: คณุ วิโรจน์

นา้หนกับรรทกุห

 500 kg./sqm

ปท่ี 78 การใสนํ่

RKSHOP ON M

น์ ลชินะเธียร แล

หลงัใช้คําสัง่ Flo

 
m. 

นํา้หนกับรรทกุบ

MIDAS GEN 2

ละ คณุ ธชัชาย 

oor Load and 

บริเวณปลอ่งลฟิ

2015 

 ธนพิศทุธ์ิวงศ์ 

 Floor Load N

ฟต์ 

 
Name 
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2.12) ใส

2.13) สร้

 
 
 
 
 
 

สนํ่า้หนกั ของ

รูปท่ี 79

ร้าง Story Dia

รูปท่ี 80

TRA

ผู้จดัทําหนงัสื

งชิน้สว่นโครง

9 การใสนํ่า้หนั

aphragm เพ่ื

0 การสร้าง Sto

AINING WOR

สือ: คณุ วิโรจน์

สร้าง Self-W

กั Self- weight

พ่ือเตรียม ใสแ่

ory จากโมเดลเ

RKSHOP ON M

น์ ลชินะเธียร แล

Weight โดยให้

t Z = -1 บริเวณ

 
แรงลมและแผ

เพ่ือเตรียมข้อมู

MIDAS GEN 2

ละ คณุ ธชัชาย 

ห้นํา้หนกัทิง้ตวั

ณ Load /Static

ผน่ดนิไหวแบบ

ลสําหรับคํานว

2015 

 ธนพิศทุธ์ิวงศ์ 

วัตามแรงดงึด

c Loads /Self 

บ AUTO 

ณแรง Lateral 

ดดูของโลก 1

Weight    

 Forces  
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 เทา่ 

 

 

 



 

2.14) กํา

 

าหนดระดบั พื

รูปท่ี 82 กา

TRA

ผู้จดัทําหนงัสื

พืน้ดนิท่ีอาคา

รูปท่ี 81 รูปกา

ารใช้ Auto Ge

AINING WOR

สือ: คณุ วิโรจน์

ารนัน้ปลกูสร้า

ารเลือกข้อมลูท่ี

neration Story

RKSHOP ON M

น์ ลชินะเธียร แล

าง (มีผลกบัก

ท่ี GL = 0 เพ่ือตั

y Data เพ่ือให้โ

 
 

MIDAS GEN 2

ละ คณุ ธชัชาย 

การคดิแรงลม

ตัง้แต่พฤติกรรม

โปรแกรมคํานว

2015 

 ธนพิศทุธ์ิวงศ์ 

และแผน่ดนิไ

มท่ีระดบัพืน้ดิน 

ณระดบัชัน้ตา่ง

ไหว) 

 

งๆในโมเดล 

49 

 

 



 

2.15) เลื

 
2.16) ทํา

ลอืก Story ท่ีต้

าการลบชัน้ท่ี

TRA

ผู้จดัทําหนงัสื

ต้องการให้รับ

รูปท่ี 83 เลือกช

ไมมี่ผลตอ่กา

รูปท่ี 84

AINING WOR

สือ: คณุ วิโรจน์

แรงลมและแ

ชัน้เฉพาะท่ีเป็น

ารคํานวณพฤ

 การเลือกชัน้ท่ี

RKSHOP ON M

น์ ลชินะเธียร แล

แผน่ดนิไหว 

นโครงสร้างหลกั

ฤตกิรรมของอ

ท่ีเป็นโครงสร้างห

MIDAS GEN 2

ละ คณุ ธชัชาย 

กกบัสว่นของระ

องค์อาคารแล

หลกัพร้อมทัง้ตั ้

2015 

 ธนพิศทุธ์ิวงศ์ 

บบโครงหลงัคา

ะตัง้ช่ือใหม ่

ตัง้ช่ือใหม ่

า 
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2.17) แบ
ท่ีสร้าง S

 
2.18) ใช้

 

บง่พืน้บนัได t
Story เพ่ือให้ก

รูปที

ช้คําสัง่ Press

TRA

ผู้จดัทําหนงัสื

t=0.15 เพ่ือนํ
การสร้าง Sto

ท่ี 85 ทําการเลื

sure Load เพื

AINING WOR

สือ: คณุ วิโรจน์

นํานํา้หนกั DL
ry แบบ AUT

อกโมเดลบนัได

พ่ือใสนํ่า้หนกับ

RKSHOP ON M

น์ ลชินะเธียร แล

L และ LL เข้า
TO ข้ามขัน้ตอ

ด โดยปรับจาก 

บรรทกุท่ีบนัไ

MIDAS GEN 2

ละ คณุ ธชัชาย 

าท่ีบนัได โดย
อนการคดิจําน

 Planar เป็น M

ได DL=120 k

2015 

 ธนพิศทุธ์ิวงศ์ 

ยใช้คําสัง่ Aut
นวนชัน้ ในขัน้

Mesh ดงัรูปด้าน

kg/Sqm. และ

to Mesh (ทํา
น้ตอนนีไ้ป) 

นบน 

ะ LL = 300 k
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าหลงัจาก

kg./Sqm. 

 

 

 



 

รูปท่ี 

 
86 การใสนํ่า้ห

TRA

ผู้จดัทําหนงัสื

นกั DL บนัไดแ

รูปท่ี 87 การ

AINING WOR

สือ: คณุ วิโรจน์

แบบ Pressure 

รใสนํ่า้หนกั LL 

RKSHOP ON M

น์ ลชินะเธียร แล

 Load (2400 k

บนัไดแบบ Pre

MIDAS GEN 2

ละ คณุ ธชัชาย 

kgf/m³*0.05m 

essure Load =

2015 

 ธนพิศทุธ์ิวงศ์ 

 = 120 kgf/m²

= 300 kgf/m² 

², Topping Su
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rface)  
 

 



 

2.19) ป
Disconn
ท่ีเลือกให

 
2.20) เลื

(เลือก เส

ปลดไดอะแฟ
nect โดยเลือ
ห้รับแรง 

ลือกใส ่Diaph

สา C1 , ผนงัลิ

รูปท่ี 89 เ

TRA

ผู้จดัทําหนงัสื

ฟรมโครงสร้าง
กชิน้สว่นโครง

รูปท่ี 88 เลือ

hragm กลบัด้

ลฟิต์ , Main 

เลือกใสโ่ครงสร้

AINING WOR

สือ: คณุ วิโรจน์

งทัง้หมดก่อน
งสร้างหมด แ

อกโครงสร้างทัง้

ด้วยคําสัง่ De

Truss ) คําสัง่

ร้างกลบัเฉพาะ

RKSHOP ON M

น์ ลชินะเธียร แล

นท่ีจะใส่แรงล
แล้วปลด ไดอ

ัง้หมดและปลด

elete เฉพาะ 

งัจะกระทํากบั

สว่นท่ีเป็นโครง

MIDAS GEN 2

ละ คณุ ธชัชาย 

ลม และ แผ่น
อะแฟรมออก 

ด Diaphragm D

 ชิน้สว่น และ

บั Node ดงันั

งสร้างหลกัท่ี La

2015 

 ธนพิศทุธ์ิวงศ์ 

ดินไหว โดย
โดยใสก่ลบัภ

Disconnect 

ะ Story ท่ีต้อง

นัน้การเลือกวั

ateral Forces 

ยใช้คําสัง่ Dia
ภายหลงัเฉพา

งการให้แรงเข้

ตัถตุ้องให้ตดิ

มากระทํา 
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aphragm 
าะชิน้สว่น

 

 

ข้ากระทํา 

ด Node  

 



 

2.21) เม่ื

 
2.22) กํา
 

ของ มยผ
ตามกรา

ม่ือใส ่Diaphra

ู

าหนดแรงลม
 ตามมาตรฐ
ผ. (ประเทศไ
ฟ ข้างลา่งนี ้

1.52 

TRA

ผู้จดัทําหนงัสื

agm กลบั แร

รูปท่ี 90 การแส

ตอ่โครงสร้าง
าน IBC2009
ไทย) นัน้เก็บข้

รูปท่ี 91 กราฟ

V3 

AINING WOR

สือ: คณุ วิโรจน์

รงลมและแผน่

สดงลกัษณะกา

ทัง้หมด 
9(ASCE7-05
ข้อมลูลมท่ี 3

ฟ Logarithm ข

RKSHOP ON M

น์ ลชินะเธียร แล

นดนิไหว จะก

ารใส ่Diaphrag

) นัน้เก็บข้อมู
600 วินาที (V

ของแรงลม Gus

MIDAS GEN 2

ละ คณุ ธชัชาย 

กระทําผา่น D

gm ท่ีถกูต้องบน

มลูลม ท่ี 3 วิน
V3600) จึงต้

st Duration (s)

2015 

 ธนพิศทุธ์ิวงศ์ 

Diaphragm ต

นโครงสร้างหลกั

นาที (V3) แต่
ต้องแปลงค่าโ

) vs Vt/V3600 

ตามเส้นสีฟ้าด

กั 

ตเ่น่ืองจากคว
โดยการคณูด้
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ดงัรูป 

 

ามเร็วลม
ด้วย 1.52 



 

กรุงเทพม

  
   

  

 
 
 
 
 
E

B






I
 

มหานคร 

                        
                        

          
          
          
          

Exposure Cate
- ลกัษณ
- ลกัษณ
- ลกัษณ

Basic Wind Sp
 พายุไต้ฝุ่น 

ไป 
 พายุโซนร้อ

หรือ 62 กิโ
 พายุดเีปรส

 61 กโิลเมต

mportance 

TRA

ผู้จดัทําหนงัสื

                        
                        
                        
                        
                        
                        

egory : ใหก้าํห
ณะภมิูประเทศ B
ณะภมิูประเทศ C
ณะภมิูประเทศ D
peed : ใหก้าํหน
 เม่ือพายท่ีุมีกาํล

อน พายโุซนร้อ
โลเมตรต่อชัว่โม
สช่ัน พายดีุเปรส
ตรต่อช่ัวโมง  
Factor (I) : ใ

AINING WOR

สือ: คณุ วิโรจน์

                      ค
              ( แปลง
                        
                        
                        
                        

นดลกัษณะภมิูป
B ไดแ้ก่ พื้นท่ีซ่ึ
C ไดแ้ก่ ท่ีราบแ
D ไดแ้ก่ ท่ีราบติ
นดความเร็วลมที
ลงัขนาดไตฝุ้่ น 

นมีความรุนแร
มงข้ึนไป แต่ไม่
สชัน่เป็นพายท่ีุมี

ให้กําหนดควา

RKSHOP ON M

น์ ลชินะเธียร แล

ความเร็วลมอ้าง
งหน่วยจาก เมต
    กลุ่มท่ี1, V= 
    กลุ่มท่ี2, V= 
    กลุ่มท่ี3, V= 
    กลุ่มท่ี4A&4

ประเทศ 
ซ่ึงมีส่ิงกีดขวาง
และทุ่งโล่งทัว่ไ
ติดชายฝ่ังทะเล
ท่ี 92 mile/h (14
 คือ กาํลงัความ

รงนอ้ยกวา่พายไุ
ม่เกิน 63 น็อต ห
มีกาํลงัอ่อน ควา

ามสําคญัของ

แต่สภาวะที

= 1.TF  , Tf 

Say 92 MP

MIDAS GEN 2

ละ คณุ ธชัชาย 

งองิ 
ตร/วนิาที เป็น ไ
 25*1.52*2.237
 27*1.52*2.237
 29*1.52*2.237

4B, V= 25*1.52

ดว้ยอาคาร, ป่า
ไป จดัเป็นภมิูป
หรือแม่นํ้า จดัเ

48.06 กิโลเมตร
เร็วของลมตั้งแ

ไตฝุ้่ น ความเร็ว
หรือ 117 กโิลเม
ามเร็วของลมใก

งอาคารใช้งาน

ท่ีตอ้งออกแบบ

.08  ดงันั้น V 
PH (148.06 K

2015 

 ธนพิศทุธ์ิวงศ์ 

ไมล์ต่อขั่วโมง) 
7= 85 MPH 
7= 91.81MPH 
7= 98.61MPH 
2*2.237= 85 M

ไมสู้งตั้งแต่ 6 ม
ระเทศท่ีเส่ียงต่
ป็นภมิูประเทศ
รต่อชัว่โมง) 
ต่ 65 น๊อต หรือ

วของลมบริเวณ
ตรต่อช่ัวโมง 
กลบ้ริเวณศนูยก์

นทัว่ไปมีคา่เท

บ แบบกาํลงัจ

 = 85x1.08 = 
MPH ) 

 

MPH 

ม.ข้ึนไป 
ต่อแรงลมเช่นกนั
ศท่ีเส่ียงต่อแรงล

อ 118 กโิลเมตร

ณใกลศู้นยก์ลางต

กลางไม่เกิน 33

ท่ากบั 1.0 แล

จะคูณดว้ย 

= 91.8 MPH 
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น 
ลม 

รต่อช่ัวโมง ข้ึน

ตั้งแต่ 34 น็อต 

3 น็อต หรือ 

ละ Kd : 0.85 



 

 G

F
 

  
 
 

Gust Effect Fa

Force Coeffic

 

TRA

ผู้จดัทําหนงัสื

actor :  

cients, Cf :  B

AINING WOR

สือ: คณุ วิโรจน์

B = 10    ,  S 

RKSHOP ON M

น์ ลชินะเธียร แล

 = 8    ,   h = 

MIDAS GEN 2

ละ คณุ ธชัชาย 

 
13  ,  B/S = 1

2015 

 ธนพิศทุธ์ิวงศ์ 

 

10/8 = 1.25  ,   S/h = 8/13 =
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= 0.62   

 



 

2.23) กา

2.24) กา

ารกําหนดแรง

ารกําหนดแรง

TRA

ผู้จดัทําหนงัสื

งลมในทิศทาง

รูปท่ี 

งลมในทิศทาง

รูปท่ี

AINING WOR

สือ: คณุ วิโรจน์

ง WxN  

92 การตัง้คา่แ

ง WxP 

 93 การตัง้คา่แ

RKSHOP ON M

น์ ลชินะเธียร แล

แรงลมในทิศ X-

 

แรงลมในทิศ X

MIDAS GEN 2

ละ คณุ ธชัชาย 

Negative Dire

-Positive Dire

2015 

 ธนพิศทุธ์ิวงศ์ 

ection  

ction 
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2.25) กา

 
2.26) กา

ารกําหนดแรง

ารกําหนดแรง

TRA

ผู้จดัทําหนงัสื

งลมในทิศทาง

รูปท่ี 

งลมในทิศทาง

รูปท่ี

AINING WOR

สือ: คณุ วิโรจน์

ง WyN 

94 การตัง้คา่แ

ง WyP 

 95 การตัง้คา่แ

RKSHOP ON M

น์ ลชินะเธียร แล

แรงลมในทิศ Y-
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16 การเพ่ิมหน้

RKSHOP ON M

น์ ลชินะเธียร แล

ล้ายๆ กนั โด

กรุ๊ปคานท่ีมีลกัษ

 
กลุ่มท่ีได้จดัไว้
ของชิน้ส่วนเพ
มหนาใหม ่

น้าตดัคาน เสา 

MIDAS GEN 2

ละ คณุ ธชัชาย 

ดยดจูาก Con

ษณะพฤติกรรม

ว้ สร้างชิน้ส่ว
พ่ือการจําแน

ตามกลุม่ท่ีได้ถู

2015 

 ธนพิศทุธ์ิวงศ์ 

ntour เป็นหลั

มใกล้เคียงกนั 

นใหม่เพิ่ม โด
นกสีของหน้าต

ถกูจดัไว้ 

ลกั และ ใช้ S

ดยเลือก DB/
ตดัของชิน้ส่ว

77 

Structure 

 

/USER / 
วนทุกครัง้

 



 

3.8) เปลี

3.9) กําห

ลี่ยนคานตาม

หนดคา่พืน้ฐา

TRA

ผู้จดัทําหนงัสื

ท่ีจดักลุม่ไว้ ด

รูปท่ี 117 

านในการออก

รูปท่ี 118 ก

AINING WOR

สือ: คณุ วิโรจน์

ด้วยการ Dra

ตวัอย่างการเป

กแบบตา่งๆ 

การกําหนดคา่พ

RKSHOP ON M

น์ ลชินะเธียร แล

g และ Drop

ปล่ียนคาน เสา 

 

พืน้ฐานการออ

 

MIDAS GEN 2

ละ คณุ ธชัชาย 

 เพ่ือเปล่ียน G

ตามกลุม่คานที

กแบบคอนกรีต

2015 

 ธนพิศทุธ์ิวงศ์ 

GB1 เป็น GB

ท่ีจดักลุม่ไว้ 

ตเสริมเหลก็ 

B2 หรือ B1 เป

78 

ป็น B2... 

 

 



 

 
รูปท่ี 119 ก

รูปท่ี 1

TRA

ผู้จดัทําหนงัสื

การกําหนดคา่พ

120 การกําหน

AINING WOR

สือ: คณุ วิโรจน์

พืน้ฐานการออก

ดคา่พืน้ฐานขอ

RKSHOP ON M

น์ ลชินะเธียร แล

กแบบคอนกรีต

องเหลก็เสริมคอ

 

MIDAS GEN 2

ละ คณุ ธชัชาย 

ตเสริมเหลก็โดย

อนกรีตโดยอ้าง

2015 

 ธนพิศทุธ์ิวงศ์ 

ยอ้างอิงตาม TH

อิงตาม THAI C

HAI CODE  

CODE 

79 

 

 



 

3.10) กา

 
3.11) ออ
Rebar แ

ารกําหนดคา่ 

รูปที

อกแบบโดยใช้
และ ปรับแตง่

รูป

TRA

ผู้จดัทําหนงัสื

 dT และ dB 

ท่ี 121 การกําหน

ช้คําสัง่ Conc
 ให้เหมาะ 

ปท่ี 122 การเช็ค

AINING WOR

สือ: คณุ วิโรจน์

นดคา่ระยะหุ้ม

crete Code D

คคา่การออกแบ

RKSHOP ON M

น์ ลชินะเธียร แล

เหลก็เสริมคอน

Design / Bea

บบคอนกรีตเสริ

MIDAS GEN 2

ละ คณุ ธชัชาย 

นกรีตโดยอ้างอิง

am / Column

ริมเหลก็ หลงักา

2015 

 ธนพิศทุธ์ิวงศ์ 

งตาม THAI CO

n Wall ตามลํ

ารกําหนดคา่ตา่

ODE  

ลาํดบั และ U

างๆ 

80 

 

pdate 

 



 

 
รูปท่ี 

รู

TRA

ผู้จดัทําหนงัสื

123 ตรวจสอบ

รูปท่ี 124 ตรวจ

AINING WOR

สือ: คณุ วิโรจน์

บการออกแบบข

จสอบการออกแ

RKSHOP ON M

น์ ลชินะเธียร แล

ของ Ground B

แบบของ Colum

MIDAS GEN 2

ละ คณุ ธชัชาย 

Beam (GB) ตา่

mn (C) ตา่งๆห

2015 

 ธนพิศทุธ์ิวงศ์ 

งๆหลงัจากออก

ลงัจากออกแบบ

กแบบ 

บ 

81 

 

 



 

 
3.12) ห
ตามลําดั
ดงันัน้เม่ื

หลงัจากทํากา
ดบัเพ่ือตรวจส
อออกแบบเส

รูป

TRA

ผู้จดัทําหนงัสื

รูปท่ี 125 ต

ารปรับแต่งห
สอบ (หากใช้ค
สร็จต้องใช้คํา

ปท่ี 126 ตรวจส

AINING WOR

สือ: คณุ วิโรจน์

ตรวจสอบการออ

น้าตดัใช้คําสั
คําสัง่ Design
สัง่ Concrete

สอบเหลก็เสริม

RKSHOP ON M

น์ ลชินะเธียร แล

อกแบบของ W

สัง่ Concrete
n โปรแกรมจ
e Code Che

มของหน้าตดัขอ

MIDAS GEN 2

ละ คณุ ธชัชาย 

Wall ตา่งๆหลงัจ

 Code Ch
ะออกแบบเห

eck) 

องคาน เสา ตาม

2015 

 ธนพิศทุธ์ิวงศ์ 

ากออกแบบ 

eck / Bea
ลก็เสริมใหมโ่

มท่ีได้ออกแบบ

am / Colum
โดยจะลบคา่

ไว้  

82 

 

mn Wall 
ท่ีปรับแก้ 

 



 

 
รูปที

รูปที

TRA

ผู้จดัทําหนงัสื

ท่ี 127 ตรวจสอบ

ท่ี 128 ตรวจสอบ

AINING WOR

สือ: คณุ วิโรจน์

บเหลก็เสริมขอ

บเหลก็เสริมขอ

RKSHOP ON M

น์ ลชินะเธียร แล

องหน้าตดัของค

องหน้าตดัของค

 

MIDAS GEN 2

ละ คณุ ธชัชาย 

คาน เสา ตามท่ี

คาน เสา ตามท่ี

2015 

 ธนพิศทุธ์ิวงศ์ 

ได้ออกแบบไว้ 

ได้ออกแบบไว้ 

 (ตอ่) 

 (ตอ่) 

83 

 

 



 

3.13) โป

 

ปรแกรมสามา

รูปท่ี 

TRA

ผู้จดัทําหนงัสื

ารถทํารายกา

รูปท่ี 129 ตวั

 130 ตวัอย่างร

AINING WOR

สือ: คณุ วิโรจน์

รคํานวณและ

วอย่างการเลือก

รายการคํานวณ

RKSHOP ON M

น์ ลชินะเธียร แล

ะพิมพ์ จากคํ

ก Members เพื

ณ Status ของ M

 

MIDAS GEN 2

ละ คณุ ธชัชาย 

าสัง่ Checkin

พ่ือเตรียมทําราย

Members ตา่ง

2015 

 ธนพิศทุธ์ิวงศ์ 

ng ได้ 

ยการคํานวณ 

ตามท่ีได้ออกแบแบบไว้ 

84 

 

 



 

3.14) สํา
คํานวณ 

รูปท่ี 131 

าหรับการออก
 /เขียนแบบ / 

 เปิดโปรแกรม 

TRA

ผู้จดัทําหนงัสื

กแบบ ฐานรา
 ประมาณรา

 Design Plus จ

AINING WOR

สือ: คณุ วิโรจน์

าก สามารถใช้
คาได้ในขัน้ตอ

จาก Midas Ge

RKSHOP ON M

น์ ลชินะเธียร แล

ช้โปรแกรม D
อนเดียว Too

 

 

en /สร้าง New 

MIDAS GEN 2

ละ คณุ ธชัชาย 

Design Plus ใ
ols / Design 

 Project จาก D

2015 

 ธนพิศทุธ์ิวงศ์ 

ในการออกแบ
Plus 

Design Plus แ

บบ / ทํารายก

และตัง้ช่ือให้อยู่

85 

การ

 

 

 
ใน Folder 



 

3.15) ก่อ
Plus (เม่ื

3.16) กา

อนท่ีจะทํากา
มอเช่ือมเสร็จ 

รู

ารตัง้คา่ข้อมลู

TRA

ผู้จดัทําหนงัสื

รออกแบบด้ว
link จะเป็นสี

รูปท่ี 132 การเชื

ลหนว่ยตา่งๆ 

รูปท่ี 

AINING WOR

สือ: คณุ วิโรจน์

วย Design P
เขียว) 

ช่ือมข้อมลูโปรแ

 ใน Design P

133 การตัง้คา่ข้

RKSHOP ON M

น์ ลชินะเธียร แล

Plus ต้องเช่ือม

แกรมระหวา่ง M

 
Plus  

ข้อมลูการออกแ

 

MIDAS GEN 2

ละ คณุ ธชัชาย 

มโปรแกรม M

Midas Gen แล

แบบใน Design

2015 

 ธนพิศทุธ์ิวงศ์ 

Midas Gen 20

ละ Design Plu

n Plus 

015 และ De

us 

86 

esign 

 

 



 

 

 

TRA

ผู้จดัทําหนงัสื

รูปท่ี 134

รูปท่ี 135

AINING WOR

สือ: คณุ วิโรจน์

4 การตัง้คา่ข้อม

5 การตัง้คา่ข้อม

RKSHOP ON M

น์ ลชินะเธียร แล

มลูการออกแบ

มลูการออกแบ

MIDAS GEN 2

ละ คณุ ธชัชาย 

บใน Design P

บใน Design P

2015 

 ธนพิศทุธ์ิวงศ์ 

Plus (ตอ่) 

Plus (ตอ่) 

87 

 

 



 

 
3.17) ในนตวัอยา่งนีใ้ห้

TRA

ผู้จดัทําหนงัสื

รูปท่ี 135

ห้เลือกหวัข้อ F

รูปท่ี 1

AINING WOR

สือ: คณุ วิโรจน์

5 การตัง้คา่ข้อม

Footing เพ่ือ

136 ตวัอยา่งกา

RKSHOP ON M

น์ ลชินะเธียร แล

มลูการออกแบ

ทําการออกแ

ารออกแบบฐาน

MIDAS GEN 2

ละ คณุ ธชัชาย 

บใน Design P

แบบ ฐานราก 

นรากใน Desig

2015 

 ธนพิศทุธ์ิวงศ์ 

Plus (ตอ่) 

 

n Plus  

88 

 

 



 

3.18) กล
และสง่ค่

 

 
 

ลบัไปท่ีโปรแก
คา่ไปออกแบบ

รูปท่ี 

รูปท่ี 138 โ

TRA

ผู้จดัทําหนงัสื

กรม Midas G
บฐานรากใน D

137 ตวัอย่างก

โปรแกรมจะลงิค

AINING WOR

สือ: คณุ วิโรจน์

Gen 2015 แล้
Design Plus

ารเลือกจดุบริเว

ค์จดุบริเวณฐาน

RKSHOP ON M

น์ ลชินะเธียร แล

ล้วเลือกฐานร
s 

วณฐานรากเพ่ือ

นรากเพ่ือนําข้อ

MIDAS GEN 2

ละ คณุ ธชัชาย 

รากท่ีจะออกแ

อออกแบบฐาน

อมลูมาออกแบบ

2015 

 ธนพิศทุธ์ิวงศ์ 

แบบ โดยโปร

นรากใน Design

บฐานรากใน D

แกรมจะลงิค์

n Plus  

Design Plus  

89 

์คา่ตา่งๆ 

 

 



 

3.19) ปรั

 

 
 
 
 
 

รับแตง่คา่ตา่ง

รูปท่ี 1

รูป

TRA

ผู้จดัทําหนงัสื

งๆและตัง้ช่ือชิ

139 ปรับแตง่คา่

ท่ี 140 ทําการ 

AINING WOR

สือ: คณุ วิโรจน์

ชิน้สว่น เพ่ือทํ

า Material บริเ

 Check บริเวณ

RKSHOP ON M

น์ ลชินะเธียร แล

ทําการออกแบ

เวณฐานรากเพื

ณฐานรากเพ่ืออ

MIDAS GEN 2

ละ คณุ ธชัชาย 

บบ 

พ่ือออกแบบฐาน

อกแบบฐานรา

2015 

 ธนพิศทุธ์ิวงศ์ 

นรากใน Desig

กใน Design P

gn Plus  

Plus 

90 

 

 



 

3.20) โป

 

 

ปรแกรม Desi

TRA

ผู้จดัทําหนงัสื

ign Plus เขีย

รูปท่ี 141

รูปท่ี 142 ตั

AINING WOR

สือ: คณุ วิโรจน์

ยนแบบและป

 ตวัอย่างการ E

วัอย่างการ Exp

RKSHOP ON M

น์ ลชินะเธียร แล

ระมาณราคา

Export ข้อมลูเป

port ข้อมลูเป็น

MIDAS GEN 2

ละ คณุ ธชัชาย 

าชิน้สว่นท่ีออ

ป็น .dwg, .dxf

น .dwg, .dxf, o

2015 

 ธนพิศทุธ์ิวงศ์ 

กแบบ ได้ตาม

f, or BOQ  

or BOQ (ตอ่) 

มหวัข้อแถบสี

91 

สด้ีานบน 

 

 



 

3.21) สา

 

 

ามารถจะสง่อ

รูป

TRA

ผู้จดัทําหนงัสื

ออกเป็น DXF

รูปท่ี 144 ตวัอ

ปท่ี 144 ตวัอย่า

AINING WOR

สือ: คณุ วิโรจน์

F File or IFC 

อย่างการ Expo

างการ Export 

RKSHOP ON M

น์ ลชินะเธียร แล

 File เพ่ือสร้า

ort ข้อมลูเป็นไฟ

 ข้อมลูเป็นไฟล์

MIDAS GEN 2

ละ คณุ ธชัชาย 

างเป็น Sketch

ฟล์ตา่งๆเพ่ือสง่

์ตา่งๆเพ่ือสง่ตอ่

2015 

 ธนพิศทุธ์ิวงศ์ 

hUP 

งตอ่ไปยงั SKU 

อไปยงั SKU (ต่

 

ตอ่) 

92 

 

 



 

3.22) สา

รูปที

ามารถทําเป็น

TRA

ผู้จดัทําหนงัสื

ท่ี 145 ตวัอยา่ง

น VDO ร่วมกั

AINING WOR

สือ: คณุ วิโรจน์

งการตัง้คา่ Lay

บัโปรแกรมอ่ื

RKSHOP ON M

น์ ลชินะเธียร แล

yer ตา่งๆหลงัจ

 
นๆ เพ่ือนําเส

MIDAS GEN 2

ละ คณุ ธชัชาย 

าก Import File

สนอ 

2015 

 ธนพิศทุธ์ิวงศ์ 

e จาก Midas GGen 

93 

 

 



 

4) คาํ
เลือกผนั

ลฟิต์ โดย

เลือกทัง้ห

ท่ีปุ่ มขวา

(Unsele

าส่ังเบือ้ง
นงัลฟิต์(Wall) 

ย สร้างกลุม่ ใ

หมดเพ่ือลบโ

า บริเวณ Gro

ect) 

TRA

ผู้จดัทําหนงัสื

งต้นออก
 โดยเลือกแบ

ใหมโ่ดยตัง้ช่ือ

โมเดลให้เหลือ

oup Wall แล้ว

AINING WOR

สือ: คณุ วิโรจน์

กแบบชิน้
บ Select By

อวา่ Wall / จา

อแต ่Group W

วทําการคลกิ 

RKSHOP ON M

น์ ลชินะเธียร แล

นส่วนโค
y Windows เฉ

ากนัน้ Drag 

Wall /เลือกทัง้

 เมาส์ท่ีปุ่ มขว

MIDAS GEN 2

ละ คณุ ธชัชาย 

ครงสร้าง
ฉพาะบริเวณ

And Drop ใน

ัง้หมดโดยใช้ค

วา เพ่ือยกเลกิ

2015 

 ธนพิศทุธ์ิวงศ์ 

ฐานราก
ณท่ีจะทําฐานร

น Group เพ่ือ

คําสัง่ select 

กการเลือก G

กรับผนัง
รากฐานรากรั

อตัง้ช่ือกลุม่ใ

 all/จากนัน้ค

Group Wall 

94 

งลิฟต์ 
ับผนงั

หม ่

 

ลกิเมาส์

 



 

กดปุ่ ม D

โฟลเดอร์

เรียง No

เป็นเลข 

Delete ท่ีแป้น

ร์ใหม ่new fo

de Number 

1-6) 

TRA

ผู้จดัทําหนงัสื

นพิมพ์ ให้เหลื

older 

 ใหมด้่วยคําส

AINING WOR

สือ: คณุ วิโรจน์

อเพียง Wall 

สัง่ RE Numb

RKSHOP ON M

น์ ลชินะเธียร แล

ท่ีได้จดักลุม่ไ

ber Element 

MIDAS GEN 2

ละ คณุ ธชัชาย 

ไว้ จากนัน้ทํา

 ID โดยเลือก

2015 

 ธนพิศทุธ์ิวงศ์ 

การ save as

กท่ีด้านบนสดุ

s เป็นช่ือ โดย

ดของผนงัลฟิต

95 

สร้าง

 

ต์ (ทําให้

 



 

ตัง้ช่ือผนั

ทําการ ล

Story Da

นงัใหมด้่วยคํา

ลบ Story เก่า

ata 

TRA

ผู้จดัทําหนงัสื

าสัง่ Change

าทิง้ และ Upd

AINING WOR
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ขออนญุาตทา่น อจ.โยง่ ครบัผม...ขอรว่มเสรมิแรงอีกนิดครบั...Centroid หรอื Geometric 

Center...เบื Êองตน้มองไปทีÉระบบทีÉเกีÉยวเนืÉองกบั Plane(2D) เช่น รูปทรง/หนา้ตดั ลฯ...สว่น 

Center of Mass เบื Êองตน้มองไปทีÉระบบทีÉเกีÉยวเนืÉองกบั Space(3D) เชน่ การกระจายมวล(เป็น

ตน้วา่ นาํไปประยกุตใ์นกบักรณีทีÉเป็นตาํแหน่งของตน้กาํเนิดแหง่แรงเฉือย อนัเนืÉองมาจากผลของ

แรง Simulate Force ทีÉเกิดจากการกระจายของแรง Base Shear อนัเนืÉองมาจาก EQ. 
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Seismic Design for Reinforced Concrete 
Building 

 
 

Overview 
 

This example problem is meant to demonstrate the design of a Reinforced Concrete building structure 
subjected to floor loads, wind loads and seismic loads. 

 
Description  

Seismic Design Data 
- Dual system (special reinforced concrete structural walls with special moment frame) in the 

transverse direction 
- Special moment frame in the longitudinal direction 
- Assigned to a high seismic zone 

 
Methodology 

- Response spectrum analysis 
- P-Delta analysis 

 
Model 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 1 : Reinforced Concrete Building Model 
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Figure 2 : Typical Floor Plan 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 3 : Longitudinal Section 

22’-0” 
22’-0” 

22’-0” 

26’-0” 26’-0” 26’-0” 26’-0” 26’-0” 26’-0” 26’-0” 

Roof 

12F 

11F 

9F 

8F 

6F 

7F 

5F 

4F 

1F 

3F 

2F 

11@
12’-0” = 132’-0” 

16’-0” 

10F 



 
 
 
 

Seismic Design for Reinforced Concrete Building 

3 

 
Design Procedure 
 
1. Material & Section Properties Input 

 
Material 
- Concrete fc’ = 4,000 psi 
- Reinforcement fy = 60,000 psi 

 
Section 
- Edge columns 24×24 in. 
- Interior columns 30×30 in. 
- Beams 20×24 in. 
- Walls 18 in. (In-plane & Out-of-plane) 

 
 
 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 4 : Material & Section Properties Input 
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2. Create Model 
 

Units : Length > ft 
 

Set UCS to X-Y Plane 

Origin : 0, 0, 16 

Change View Direction > (on) 

 
 
 

 Set Line Grid 

     Grid Name = 2F 

X-Grid Lines    

Relative > (on) 

‘7@26’  

Y-Grid Lines       

Relative > (on) 

     ‘3@22’ 

     Add/Modify Grid Lines     

     Define Grids  

       Line Grid, Line Grid Snap (toggle on) 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 5 : Create Grid Lines 
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Figure 5 : Grid Lines in X-Y Plane 
 
Generate Floor Plan 

 Hidden,  Node Number,  Element Number (toggle on) 

 Create Elements 

Element Type = General Beam / Tapered Beam 

Section Name = 3 : Beam 

Draw Elements as shown (Refer Figure 6) 

 

 
 

Figure 6 : Floor Plan 
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Generate Columns 
 

Change to GCS 

Select All 

Extrude Element 

Node  Line Element 

Reverse I-J > (on) 

Element Type = Beam 

Material =  1 : Grade C4000 

Section = 1 : Edge column 

dx, dy, dz = 0, 0, -16 

  

 

 
 

Figure 7 : Generate Columns 

 

Change Properties of Interior Columns 

Work  Properties  Section : 1 : Edge column = Active 

      Display  Property  Property Name > (on) 

                 

 Isometric View (Refer Figure 8) 

Top View >    Select Window > Select Interior Columns  
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Work  Properties  Section = 2 : Interior column 

Drag & Drop (Refer Figure 9) 

 
 

 
Figure 8 : Inactivate Beams 

 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 9 : “Drag & Drop” Interior Column Properties 

 

Drop 

Assign 

 

 

Drag 
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Generate Walls 

Hidden (toggle off) ;  Node Number (toggle on) 

      Display  Property  Property Name > (off) 

 Select Window (Refer Figure 10) 

     Active 

Create Elements 

Element Type : Wall 

Membrane > (on) 

Wall ID > Auto Inc. > 1 

Material Name > 1:Grade C4000 

Thickness > 1:1.5000 

Intersect Node > (on) 

Nodal Connectivity > 50, 42, 10, 18 (Refer      on Figure 11) 

Select Single > Wall Element 1 

Translate Element > Copy 

Equal Distance (dx, dy, dz) > 130, 0, 0   

Wall ID Increment = 1   

 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Figure 10 : Location of Wall Element 

 
 

 

 

 
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Figure 11 : Nodal Connectivity of Wall Element 

 

 
 

 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 12 : Generation of Wall Element 

1 

 
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Building Generation 

 

Select All 

Structure > Building > Control Data > Building Generation 

Number of Copies = 11 

Distance(Global Z) = 12         

 

 

 

 

 

 

 

 

 

 

 

 

 

 
 

Figure 13 : Building Generation 
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Generate Story Data 

 

Structure > Building > Control Data > Story 

 

 

 

 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 14 : Generation of Story Data 
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3. Boundary Conditions Input 
The lower ends of the columns are assumed fixed. 
 
Boundary > Supports > Define Supports 
D – All > (on) 
R – All > (on) 

  Select Window 
 

 
 

 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 15 : Boundary Supports 
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4. Loading Data Input 

 
Load > Static Load > Create Load Cases > Static Load Cases 
 
- Dead Load 
- Live Load 
- Wind Load (X-direction) 
- Wind Load (Y-direction) 
- Earthquake Load (X-direction, Eccentricity direction-Positive) 
- Earthquake Load (X-direction, Eccentricity direction-Negative) 
- Earthquake Load (Y-direction, Eccentricity direction-Positive) 
- Earthquake Load (Y-direction, Eccentricity direction-Negative) 

 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 16 : Loading Data Input 
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Self Weight 
 
Load > Static Loads > Structure Loads/Masses > Self Weight 
 
Z =  -1   

 
 

Figure 17 : Self Weight Load 
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Floor Load 
 

Load > Initial Forces/Misc. > Assign Floor Loads > Define Floor Load Type 
- Name > Typical Floor : DL = -30 psf, LL = -75 psf  
- Name > Roof Level : DL = -10 psf, LL = -20 psf 
 
Load > Initial Forces/Misc. > Assign Floor Loads > Assign Floor Load 
- Load Type > Typical Floor 
- Two Way Distribution 
- Copy Floor Load  > (on) 
- Axis > z (on) 
- Distance > 10@12 
- Assign Nodes Defining Loading Area > (1, 8, 32, 25) 

 
Similarly, assign floor load at roof level : 
- Load Type > Roof Level 
- Copy Floor Load  > (off) 
- Assign Nodes Defining Loading Area > (386, 387, 417, 410) 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 18 : Assign Floor Loads 

 
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Figure 19 : Floor Load Distribution 
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Wind Loads 
 

Load > Static Loads > Lateral > Wind Loads 
 

- Load Case Name > WX 
- Wind Load Code > IBC2012 (ASCE7-10) 
- Alternate Method > (on) 
- Basic Wind Speed > 85 mile/h 
- Exposure Category > B 
- Scale Factor in Global X > 1 
- Scale Factor in Global Y > 0    

 
- Load Case Name > WY 
- Scale Factor in Global X > 0 
- Scale Factor in Global Y > 1    

 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
 

Figure 20 : Input Wind Loads 
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Convert Model Weight & Loads to Masses 
 
Structure > Type > Structure Type 
- Structure Type > 3-D (on) 
- Convert Self-weight into Masses (on) 
- Convert to X, Y (on) 
- Gravity Acceleration > 32.1719 (ft/sec2) 
-  

           
 

Figure 21 : Convert Model Weight to Masses 
 
Load > Static Loads > Structure Loads/Masses > Nodal Masses > Loads to Masses 
- Mass Direction > X, Y (on) 
- Load Type for Converting > All (on) 
- Gravity > 32.1719 (ft/sec2) 
- Load Case > DL 
- Scale Factor > 1 

 
- Load Case > LL 
- Scale Factor > 0.25 

 

 
 

Figure 22 : Covert Model Loads to Masses 
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Static Seismic Loads 
 
Load > Static Loads > Lateral > Seismic Loads 

 
- Load Case Name > EXP 
- Seismic Load Code > IBC2012 (ASCE7-10) 
- Seismic Design Category > E 
- Site Class > C 
- Ss = 1.0 
- S1 = 0.3 
- Importance Factor (I) = 1 
- Period (Code) > X-Dir. = 1.2 ; Y-Dir. = 0 
- Response Modification Coef. (R) > X-Dir. = 8 (Special moment frame), 

Y-Dir. = 8 (Dual system: special reinforced concrete 
structural walls with special moment frame) 

- Scale Factor in Global X = 1 
- Scale Factor in Global Y = 0 
- Accidental Eccentricity in X-direction > Positive (on) 
- Accidental Eccentricity in Y-direction > Positive (on) 

 
 

- Load Case Name > EXN 
- Period (Code) > X-Dir. = 1.2 ; Y-Dir. = 0 
- Scale Factor in Global X = 1 
- Scale Factor in Global Y = 0 
- Accidental Eccentricity in X-direction > Negative (on) 
- Accidental Eccentricity in Y-direction > Negative (on) 

 
 

- Load Case Name > EYP 
- Period (Code) > X-Dir. = 0 ; Y-Dir. = 1.2 
- Scale Factor in Global X = 0 
- Scale Factor in Global Y = 1 
- Accidental Eccentricity in X-direction > Positive (on) 
- Accidental Eccentricity in Y-direction > Positive (on) 

 
 

- Load Case Name > EYN 
- Period (Code) > X-Dir. = 0 ; Y-Dir. = 1.2 
- Scale Factor in Global X = 0 
- Scale Factor in Global Y = 1 
- Accidental Eccentricity in X-direction > Negative (on) 
- Accidental Eccentricity in Y-direction > Negative (on) 
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Figure 23 : Input Static Seismic Loads 
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Response Spectrum Load 
 
Load > Seismic > Response Spectrum Data > Response Spectrum Functions 

 
 
Design Spectrum 
- Design Spectrum > IBC2012 (ASCE7-10) 
- Site Class > C 
- Ss = 1.0 
- S1 = 0.3 

 
 
 
 
 
 

 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 24 : Response Spectrum Loads 
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Load > Response Spectrum Analysis Data > Response Spectrum Load Cases 
- Load Case Name > RX 
- Direction > X-Y 
- Excitation Angle = 0 (deg.) 
- Scale Factor (I/R) > 1/8 = 0.125 
- Period Modification Factor = 1 
- Function Name (Damping Ratio) > IBC2012(ASCE7-10) (0.05) > (on) 
- Interpolation of Spectral Data > Linear (on) 
- Accidental Eccentricity > (on) 
- Modal Combination Type > SRSS 

 
 

- Load Case Name > RY 
- Excitation Angle = 90 (deg.) 
- Modal Combination Type > SRSS 

 
 

 
 
 

                    
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 25 : Response Spectrum Analysis 
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5. Analysis 
 
Analysis > P-Delta Analysis Control 
- Number of Iterations = 5 
- Convergence Tolerance = 1e-005 
- P-Delta Combination > Load Case > DL ; Scale Factor > 1 

   
- P-Delta Combination > Load Case > LL ; Scale Factor = 0.25 

 
 

 
Analysis > Eigenvalue Analysis Control 
- Type of Analysis > Eigen Vectors (on) > Subspace Iteration (on) 
- Number of Frequencies = 10 
- Number of Iterations = 20 
- Subspace Dimension = 0 
- Convergence Tolerance = 1e-010 

 
 

 
 
Perform Analysis 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 27 : P-Delta and Eigenvalue Analysis Control 
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6. Design Input 

Results > Combinations 
Concrete Design > Auto Generation 
- Option > Add (on) 
- Design Code > ACI318-11 
- Scale Up Factor = 1.48 ; RX  
- Scale Up Factor = 1 ; RY 

 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 28 : Generation of Load Combinations for Concrete Design 

Bi-directional combination 
needs to be investigated, but 
omitted in this tutorial.  
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Compare RX (RY) with EX (EY) 

 
RX (RY): 
Results > Tables > Result Tables > Story > Story Shear (Response Spectrum Analysis) 
- Spectrum Load Cases > RX(RS) (on) & RY(RS) (on)  
- Shear Force (Without Spring) 

 
 

 
 
 
 
 
 
 
 
 
 
 
 
                      
 

Figure 29 : Story Shear (Response Spectrum Analysis) 
 

EX (EY): 
Load > Static Loads > Lateral > Seismic Loads 
Load Case > EXP > Modify > Seismic Load Profile 
- Story Shear (on) 

 
Similarly, select Load Cases EXN, EYP & EYN 

 

 
 

Figure 30 : Story Shear (Static Seismic Loads) 
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Design > General > General Design Parameter >Definition of Frame 
- X-direction > Unbraced | Sway (on) 
- Y-direction > Braced | Non-Sway (on) 
- Design Type > 3-D 
- Auto Calculate Effective Length Factors > (on) 

 

 
 

Figure 31 : Definition of Frame 
 

Design > General > General Design Parameter > Modify Live Load Reduction Factor 
General Tab 
 
- Option > Add/Replace (on) 
- Applied Components > Axial Force (on) 
- Top View > Select Window 
 
- Interior columns: Reduction Factor = 0.56 
 
 
- Edge column: Reduction Factor = 0.69 
 
 
- Corner column: Reduction Factor = 0.88 

 
 

 
 

Figure 32 : Modify Live Load Reduction Factor 
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- Unbraced Length (L, Lb) 
- Option > Add/Replace (on) 
- Unbraced Length > Ly=0 ; Lx=0 
- Laterally Unbraced Length > Do not consider (on) 
- Select All   

 
 

- Equivalent Moment Correction Factor (Cm) 
- Option > Add/Replace (on) 
- Moment Factor > Calculate by Program (on) 
- Select All 

 
 
 
 
 
 
 
 

 
 
 

 
 
 
 

              Figure 34 : Equivalent Moment Correction Factor 
Figure 33 : Unbraced Length 

 
Design > Design > RC Design > Design Code 
- Design Code > ACI318-11 
- Apply Special Provisions for Seismic Design > (on) 
- Select Frame Type > Special Moment Frames (on) 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

                                    Figure 35 : Concrete Design Code 
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Design > Design > RC Design > Strength Reduction Factors 
Update By Code 

 
 
 
 
 
    
 
 
 
 
 
 
 
 

Figure 36 : Strength Reduction Factors 
 

 
Design > Design > RC Design > Design Criteria for Rebars (Refer Figure 37) 

 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 Figure 37 : Design Criteria for Rebars 
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Design > Design > RC Design > Modify Concrete Materials 
 
Select material ID #1 
Rebar Selection 
- Code > ASTM (RC) 
- Grade of Main Rebar > Grade 60 
- Grade of Sub-Rebar > Grade 40 
 

 
 

 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Figure 38 : Modify Concrete Materials 
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7. Design Output 

 
Design > Design > RC Design > Concrete Code Design > Beam Design  

Sorted by > Member (on)  
 

Figure 39 : Concrete Beam Design 
 
Design > Design > RC Design > Concrete Code Design > Column Design 
Sorted by > Member (on)  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Figure 40 : Concrete Column Design 
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Design > Design > RC Design > Concrete Code Design > Wall Design 
Sorted by > Wall ID + Story (on)  
SEL (Select) > WID (Wall ID) = 1 ; Story = 1F 
Graphic 

 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Figure 41 : Concrete Wall Design 
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Figure 42 : Typical Output of Concrete Wall Design 
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