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INTRODUCTION
Excel is a spreadsheet program that allows you to store, 
organize, and analyze information.

When you open Excel for the first time, the Excel Start 
Screen will appear. From here, you'll be able to create a 
new workbook, choose a template, and access your 
recently edited workbooks.

From the Excel Start Screen, locate and select Blank 
workbook to access the Excel interface.



TO CREATE A NEW BLANK WORKBOOK:
● Select the File tab. Backstage view will appear.
● Select New, then click Blank workbook.
● A new blank workbook will appear.



TO OPEN AN EXISTING WORKBOOK:
● Navigate to Backstage view, then click Open.
● Select Computer, then click Browse. You can also 

choose OneDrive to open files stored on your 
OneDrive.

● The Open dialog box will appear. Locate and select 
your workbook, then click Open.



TO SAVE A WORKBOOK:
● Locate and select the Save command on the Quick 

Access Toolbar.
● If you're saving the file for the first time, the Save As 

pane will appear in Backstage view.
● You'll then need to choose where to save the file and 

give it a file name. To save the workbook to your 
computer, select Computer, then click Browse. You can 
also click Drive to save the file to your Drive.

● Enter a file name for the workbook, then click Save.



TO SHARE A WORKBOOK:
● Click the File tab to access Backstage view, then click 

Share.
● Excel will return to Normal view and open the Share panel 

on the right side of the window. From here, you can invite 
people to share your document,see a list of who has 
access to the document, and set whether they can edit or 
only view the documents



UNDERSTANDING CELL: Every worksheet is made up of 
thousands of rectangles, which are called cells. A cell is 
the intersection of a row and a column. In other words, it's 
where a row and column meet.

TO SELECT A CELL: To input or edit cell content, you'll first 
need to select the cell.

● Click a cell to select it.
● A border will appear around the selected cell, and the 

column heading and row heading will be highlighted.



TO SELECT A CELL RANGE: Sometimes you may want to 
select a larger group of cells, or a cell range.

● Click and drag the mouse until all of the adjoining 
cells you want to select are highlighted.

● Release the mouse to select the desired cell range



TO MODIFY COLUMN WIDTH:

● Position the mouse over the column line in the 
column heading so the cursor becomes a 
double arrow.

● Click and drag the mouse to increase or 
decrease the column width.

● Release the mouse. The column width will be 
changed.



TO MODIFY ROW HEIGHT:

● Position the cursor over the row line so the 
cursor becomes a double arrow

● Click and drag the mouse to increase or 
decrease the row height.

● Release the mouse. The height of the selected 
row will be changed.



TO MODIFY ALL ROWS AND COLUMN

Instead of resizing rows and columns individually, 
you can modify the height and width of every row 
and column at the same time. This method allows 
you to set a uniform size for every row and 
column in your worksheet.

● Locate and click the Select All button just 
below the name box to select every cell in the 
worksheet.



TO MODIFY ALL ROWS AND COLUMN

● Position the mouse over a row line so the 
cursor becomes a double arrow.

● Click and drag the mouse to increase or 
decrease the row height, then release the 
mouse when you are satisfied. The row height 
will be changed for the entire worksheet.



FORMATTING CELLS
All cell content uses the same formatting by 
default, which can make it difficult to read a 
workbook with a lot of information.

TO CHANGE FONT SIZE:

● Select the cell(s) you want to modify.
● On the Home tab, click the drop-down arrow 

next to the Font Size command, then select the 
desired font size.

● The text will change to the selected font size.



FORMATTING CELLS

TO CHANGE FONT:

● Select the cell(s) you want to modify.
● On the Home tab, click the drop-down arrow 

next to the Font command, then select the 
desired font.

● The text will change to the selected font.



TO CHANGE FONT COLOUR

● Select the cell(s) you want to modify.
● On the Home tab, click the drop-down arrow next to 

the Font Color command, then select the desired font 
color.

● The text will change to the selected font color.



TO USE THE BOLD, ITALIC AND UNDERLINE 
COMMAND
● Select the cell(s) you want to modify.
● Click the Bold (B), Italic (I), or Underline (U) command 

on the Home tab.
● The selected style will be applied to the text.



UNDERSTANDING NUMBERS FORMAT

Number formats tell your spreadsheet exactly 
what type of data you're using, like percentages 
(%), currency ($), times, dates, and so 
on.Number formats not only make your 
spreadsheet easier to read, but they also make it 
easier to use. When you apply a number format, 
you're telling your spreadsheet exactly what 
types of values are stored in a cell



APPLYING NUMBER FORMAT

● Go to the Home tab, click the Number Format drop-down 
menu in the Number group, and select the desired format.

● Click one of the quick number-formatting commands below 
the drop-down menu.

You can also select the desired cells and press Ctrl+1 on your 
keyboard to access additional number-formatting options



WORKING WITH MULTIPLE WORKSHEETS
Every workbook contains at least one worksheet by 
default. When working with a large amount of data, you 
can create multiple worksheets to help organize your 
workbook and make it easier to find content. You can 
also group worksheets to quickly add information to 
multiple worksheets at the same time.

TO INSERT A WORKSHEET:

● Locate and select the New sheet button near the 
bottom-right corner of the Excel window.

● A new blank worksheet will appear.



USING FIND AND REPLACE
When working with a lot of data in Excel, it can be difficult and 
time consuming to locate specific information. You can easily 
search your workbook using the Find feature.

TO FIND CELL CONTENT:

● From the Home tab, click the Find and Select command, 
then select Find from the drop-down menu.

● The Find and Replace dialog box will appear. Enter the 
content you want to find.



USING FIND AND REPLACE
● Click Find Next. If the content is found, the cell containing 

that content will be selected.
● Click Find Next to find more instances or Find All to see 

every instance of the search term.
● When you are finished, click Close to exit the Find and 

Replace dialog box.



CHECKING SPELLING

TO USE SPELL CHECK:

● From the Review tab, click the Spelling 
command.

● The Spelling dialog box will appear. For each 
spelling error in your worksheet, it will try to 
offer suggestions for the correct spelling.



CHECKING SPELLING

● Choose a suggestion, then click Change to 
correct the error

● A dialog box will appear after reviewing all 
spelling errors. Click OK to close spell check.

If there are no appropriate suggestions, you can 
also enter the correct spelling manually.



PAGE LAYOUT AND PRINTING

There may be times when you want to print a 
workbook to view and share your data offline. 
Once you've chosen your page layout settings, 
it's easy to preview and print a workbook from 
Excel using the Print pane.



TO ACCESS THE PRINT PANE:

● Select the File tab. Backstage view will 
appear.

● Select Print. The Print pane will appear.

TO PRINT A WORKBOOK:

● Navigate to the Print pane, then select the 
desired printer.

● Enter the number of copies you want to print.
● Click Print.



INTRODUCTION TO FORMULAS

MATHEMATICAL OPERATORS: Excel uses standard 
operators for formulas: a plus sign for addition (+), minus 
sign for subtraction (-), asterisk for multiplication (*), 
forward slash for division (/), and caret (^) for exponents.

All formulas in Excel must begin with an equals sign (=). 
This is because the cell contains, or is equal to, the 
formula and the value it calculates.



UNDERSTANDING CELL REFERENCE

While you can create simple formulas in Excel using 
numbers (for example, =2+2 or =5*5), most of the time 
you will use cell addresses to create a formula. This is 
known as making a cell reference. Using cell references 
will ensure that your formulas are always accurate 
because you can change the value of referenced cells 
without having to rewrite the formula.



● Cell A3 adds the values of cells A1 and A2 by making 
cell references:

● When you press Enter, the formula calculates and 
displays the answer in cell A3

● If the values in the referenced cells change, the 
formula automatically recalculates:

By combining a mathematical operator with cell 
references, you can create a variety of simple formulas 
in Excel.



TO CREATE A FORMULA
● Select the cell that will contain the formula.
● Type the equals sign (=). Notice how it appears in 

both the cell and the formula bar.
● Type the cell address of the cell you want to reference 

first in the formula:
● Type the mathematical operator you want to use.
● Type the cell address of the cell you want to reference 

second in the formula.
● Press Enter on your keyboard. The formula will be 

calculated, and the value will be displayed in the cell.



If the result of a formula is too large to be displayed in a 
cell, it may appear as pound signs (###) instead of a 
value. This means the column is not wide enough to 
display the cell content. Simply increase the column 
width to show the cell content.



TO CREATE A FORMULA USING POINT AND 
CLICK METHOD

Instead of typing cell addresses manually, you 
can point and click the cells you want to include 
in your formula. This method can save a lot of 
time and effort when creating formulas.



● Select the cell that will contain the formula.
● Type the equals sign (=).
● Select the cell you want to reference first in 

the formula.
● Type the mathematical operator you want to 

use.
● Select the cell you want to reference second 

in the formula.
● Press Enter on your keyboard. The formula will 

be calculated, and the value will be displayed 
in the cell.



TO EDIT A FORMULA
● Select the cell containing the formula you 

want to edit.
● Click the formula bar to edit the formula. You 

can also double-click the cell to view and 
edit the formula directly within the cell.

● A border will appear around any referenced 
cells

● When you're finished, press Enter on your 
keyboard or select the Enter command in the 
formula bar.



TO EDIT A FORMULA

● The formula will be updated, and the new 
value will be displayed in the cell.

If you change your mind, you can press the Esc 
key on your keyboard or click the Cancel 
command in the formula bar to avoid 
accidentally making changes to your formula.



RELATIVE AND ABSOLUTE CELL 
REFERENCES

There are two types of cell references: relative 
and absolute. Relative and absolute references 
behave differently when copied and filled to 
other cells. Relative references change when a 
formula is copied to another cell. Absolute 
references, on the other hand, remain constant 
no matter where they are copied.



RELATIVE AND ABSOLUTE CELL 
REFERENCES

RELATIVE REFERENCES: By default, all cell 
references are relative references. When copied 
across multiple cells, they change based on the 
relative position of rows and columns



TO CREATE AND COPY A FORMULA 
USING RELATIVE REFERENCES

● Select the cell that will contain the formula.
● Enter the formula to calculate the desired 

value.
● Press Enter on your keyboard. The formula 

will be calculated, and the result will be 
displayed in the cell.

● Locate the fill handle in the bottom-right 
corner of the desired cell.



● Click and drag the fill handle over the cells 
you want to fill.

● Release the mouse. The formula will be 
copied to the selected cells with relative 
references, displaying the result in each cell.

You can double-click the filled cells to check 
their formulas for accuracy. The relative cell 
references should be different for each cell, 
depending on their rows.



ABSOLUTE REFERENCE

There may be a time when you don't want a cell 
reference to change when copied to other cells. 
Unlike relative references, absolute references 
do not change when copied or filled. You can 
use an absolute reference to keep a row and/or 
column constant.

An absolute reference is designated in a formula 
by the addition of a dollar sign ($). It can 
precede the column reference, the row 
reference, or both.



CREATE AND COPY A FORMULA 
USING ABSOLUTE REFERENCE

● Select the cell that will contain the formula.
● Enter the formula to calculate the desired value.
● Press Enter on your keyboard. The formula will 

calculate, and the result will display in the cell.
● Locate the fill handle in the bottom-right corner of 

the desired cell.
● Click and drag the fill handle over the cells you 

want to fill.



CREATE AND COPY A FORMULA 
USING ABSOLUTE REFERENCE

● Release the mouse. The formula will be copied to 
the selected cells with an absolute reference, and 
the values will be calculated in each cell.

You can double-click the filled cells to check their 
formulas for accuracy. The absolute reference should 
be the same for each cell, while the other references 
are relative to the cell's row.



BASICS TIPS FOR WORKING WITH DATA
Excel workbooks are designed to store a lot of 
information. Whether you're working with 20 cells 
or 20,000, Excel has several features to help you 
organize your data and find what you need.

FREEZING ROWS AND COLUMNS

You may want to see certain rows or columns all 
the time in your worksheet, especially header 
cells. By freezing rows or columns in place, you'll 
be able to scroll through your content while 
continuing to view the frozen cells.



BASICS TIPS FOR WORKING WITH DATA

SORTING DATA:

You can quickly reorganize a worksheet by 
sorting your data. Content can be sorted 
alphabetically and numerically

https://edu.gcfglobal.org/en/excel/sorting-data/1/


FILTERING DATA

Filters can be used to narrow down the data in 
your worksheet, allowing you to view only the 
information you need.

SUMMARIZING DATA: The Subtotal command
allows you to quickly summarize data.

https://edu.gcfglobal.org/en/excel/filtering-data/1/


FILTERING DATA

USING FIND AND REPLACE: When working 
with a lot of data, it can be difficult and time 
consuming to locate specific information. You 
can easily search your workbook using the FIND 
FEATURE,which also allows you to modify content 
using the Replace feature.



FREEZE PANE AND VIEW OPTION

TO FREEZE ROW: You may want to see certain 
rows or columns all the time in your worksheet, 
especially header cells. By freezing rows or 
columns in place, you'll be able to scroll through 
your content while continuing to view the frozen 
cells.



● Select the row below the row(s) you want to 
freeze. E.g we want to freeze rows 1 and 2, so 
we'll select row 3.

● On the View tab, select the Freeze Panes 
command, then choose Freeze Panes from 
the drop-down menu.

● The rows will be frozen in place, as indicated 
by the gray line. You can scroll down the 
worksheet while continuing to view the frozen 
rows at the top.



TO FREEZE COLUMN
● Select the column to the right of the 

column(s) you want to freeze.Example, we 
want to freeze column A, so we'll select 
column B.

● On the View tab, select the Freeze Panes 
command, then choose Freeze Panes from 
the drop-down menu.



● The column will be frozen in place, as 
indicated by the gray line. You can scroll 
across the worksheet while continuing to 
view the frozen column on the left.

● If you only need to freeze the top row (row 1) 
or first column (column A) in the worksheet, 
you can simply select Freeze Top Row or 
Freeze First Column from the drop-down 
menu.



OTHER VIEW OPTION
If your workbook contains a lot of content, it can 
sometimes be difficult to compare different 
sections. Excel includes additional options to 
make your workbooks easier to view and 
compare. For example, you can choose to open 
a new window for your workbook or split a 
worksheet into separate panes.

Excel allows you to open multiple windows for a 
single workbook at the same time.



TO OPEN A NEW WINDOW FOR THE CURRENT 
WORKBOOK:
● Click the View tab on the Ribbon, then select the New 

Window command.
● A new window for the workbook will appear.
● You can now compare different worksheets from the 

same workbook across windows

If you have several windows open at the same time, you can 
use the Arrange All command to rearrange them quickly



TYPES OF SORTING

When sorting data, it's important to first decide if 
you want the sort to apply to the entire worksheet or 
just a cell range. Sort sheet organizes all of the data 
in your worksheet by one column. Related 
information across each row is kept together when 
the sort is applied.  Sort range sorts the data in a 
range of cells, which can be helpful when working 
with a sheet that contains several tables. Sorting a 
range will not affect other content in the worksheet.



TO SORT SHEET:
● Select a cell in the column you want to sort
● Select the Data tab on the Ribbon, then click the 

A-Z command to sort A to Z, or the Z-A 
command to sort Z to A.

● The worksheet will be sorted by the selected 
column



TO SORT RANGE:
● Select the cell range you want to sort. E.g  we'll select 

cell range G2:H6.
● Select the Data tab on the Ribbon, then click the Sort 

command.
● The Sort dialog box will appear. Choose the column 

you want to sort.
● Decide the sorting order (either ascending or 

descending).
● Once you're satisfied with your selection, click OK.
● The cell range will be sorted by the selected column.



TO FILTER DATA

● In other for filtering to work perfectly, your 
worksheet should a header row which is use 
to identify the name of each column.

● Select the Data tab, then click the Filter 
command.

● A drop-down arrow will appear in the 
header cell for each column.

● Click the drop-down arrow for the column 
you want to filter



TO FILTER DATA

● The Filter menu will appear.
● Uncheck the box next to Select All to quickly 

deselect all data.
● Check the boxes next to the data you want to 

filter, then click OK.
● The data will be filtered, temporarily hiding 

any content that doesn't match the criteria.



GROUPS AND SUBTOTALS

TO GROUP ROWS AND COLUMNS:
● Select the rows or columns you want to group. E.g  select 

columns B, C, and D
● Select the Data tab on the Ribbon, then click the Group 

command.
● The selected rows or columns will be grouped.

To ungroup data, select the grouped rows or columns, then 
click the Ungroup command.



CREATING SUBTOTALS
The Subtotal command allows you to automatically create 
groups and use common functions like SUM, COUNT, and 
AVERAGE to help summarize your data.

TO CREATE A SUBTOTAL:
● First, sort your worksheet by the data you want to 

subtotal
● Select the Data tab, then click the Subtotal command.



TO CREATE A SUBTOTAL:
● The Subtotal dialog box will appear. Click the drop-

down arrow for the At each change in: field to select 
the column you want to subtotal.

● Click the drop-down arrow for the Use function: field to 
select the function you want to use. E.g select COUNT to 
count the number of items in your sheet.

● In the Add subtotal to: field, select the column where 
you want the calculated subtotal to appear.



TO REMOVE SUBTOTAL

Sometimes you may not want to keep subtotals 
in your worksheet, especially if you want to 
reorganize data in different ways. If you no 
longer want to use subtotaling, you will need 
remove it from your worksheet.

● Select the Data tab, then click the Subtotal 
command

● The Subtotal dialog box will appear. Click 
Remove All.



TO REMOVE SUBTOTAL

● All worksheet data will be ungrouped, 
and the subtotals will be removed.

To remove all groups without deleting the 
subtotals, click the Ungroup command drop-
down arrow, then choose Clear Outline.



TO VIEW GROUPS BY LEVEL

When you create subtotals, your worksheet it is 
divided into different levels. You can switch 
among these levels to quickly control how much 
information is displayed in the worksheet by 
clicking the Level buttons to the left of the 
worksheet.



TO VIEW GROUPS BY LEVEL

● Click the lowest level to display the least 
detail.

● Click the next level to expand the detail.
● Click the highest level to view and expand all 

of your worksheet data.

You can also use the Show Detail and Hide Detail 
buttons to show and hide the groups within the 
outline.



TO FORMAT DATA AS A TABLE:
● Select the cells you want to format as a 

table. In our example, we'll select the cell 
range A2:D9

● From the Home tab, click the Format as Table 
command in the Styles group.

● Select a table style from the drop-down 
menu.



TO FORMAT DATA AS A TABLE:
● A dialog box will appear, confirming the 

selected cell range for the table.
● If your table has headers, check the box next 

to My table has headers, then click OK.
● The cell range will be formatted in the 

selected table style.



CHARTS

It can be difficult to interpret Excel workbooks 
that contain a lot of data. Charts allow you to 
illustrate your workbook data graphically.

It can be difficult to interpret Excel workbooks 
that contain a lot of data. Charts allow you to 
illustrate your workbook data graphically,



TYPES OF CHARTS
● Column bars use vertical bars to represent data
● LINE charts are good for showing trends
● PIE charts makes it easy to compare proportion
● BAR charts use horizontal bars to represent data
● AREA charts are similar to LINE charts except that 

the areas under the are filled in.
● SURFACE Charts allow you to display data across 

a 3D landscape

,



6 TO INSERT A CHART

● Select the cells you want to chart, including the column 
titles and row labels. These cells will be the source data for 
the chart.

● From the Insert tab, click the desired Chart command
● Choose the desired chart type from the drop-down menu.
● The Selected chart will be inserted into the worksheet.

If you're not sure which type of chart to use, the Recommended 
Charts command will suggest several charts based on the 
source data.



CONDITIONAL FORMATTING

Conditional formatting allows you to automatically 
apply formatting such as colors, icons, and data bars, 
to one or more cells based on the cell value. To do this, 
you'll need to create a conditional formatting rule. For 
example, a conditional formatting rule might be: If the 
value is less than 2000, color the cell red. By applying 
this rule, you'd be able to quickly see which cells contain 
values less than 2000.



TO CREATE A CONDITIONAL 
FORMATTING RULE

● Select the desired cells for the conditional formatting rule.
● From the Home tab, click the Conditional Formatting

command. A drop-down menu will appear.
● Hover the mouse over the desired conditional formatting 

type, then select the desired rule from the menu that 
appears.

● A dialog box will appear. Enter the desired value(s) into the 
blank field.



TO CREATE A CONDITIONAL FORMATTING 
RULE

● Select a formatting style from the drop-down menu. 
Example choose Green Fill with Dark Green Text, then click 
OK.

● The conditional formatting will be applied to the selected 
cells

You can apply multiple conditional formatting rules to a cell 
range or worksheet,this allows you to visualize different trends 
and patterns in your data.



TO CREATE A CONDITIONAL FORMATTING 
RULE

● Select the desired cells for the conditional formatting 
rule.

● From the Home tab, click the Conditional 
Formatting command. A drop-down menu will 
appear.

● Hover the mouse over the desired conditional 
formatting type, then select the desired rule from the 
menu that appears.



● A dialog box will appear. Enter the desired value(s)
into the blank field.

● Select a formatting style from the drop-down menu. 
Example choose Green Fill with Dark Green Text, then 
click OK.

● The conditional formatting will be applied to the 
selected cells. You can apply multiple conditional 
formatting rules to a cell range or worksheet,this
allows you to visualize different trends and patterns in 
your data.



PROTECTING WORKBOOK
By default, anyone with access to your workbook will be able to 
open, copy, and edit its content unless you protect it. There are 
several ways to protect a workbook, depending on your needs.

TO PROTECT YOUR WORKBOOK:

● Click the File tab to access Backstage view
● From the Info pane, click the Protect Workbook

command
● In the drop-down menu, choose the option that best 

suits your needs, E.g select Mark as Final.



PROTECTING WORKBOOK
● Marking your workbook as final is a good way to 

discourage others from editing the workbook, while the 
other options give you even more control if needed.

● A dialog box will appear, prompting you to save. Click 
OK.

● Another dialog box will appear. Click OK.
● The workbook will be marked as final.



THANK YOU
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