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คาํนาํ 
SAP2000 คือโปรแกรมวิเคราะหและออกแบบโครงสรางซึ่งถือไดวาไดรับความนิยมในการใชงานมากที่สุดในโลก
โปรแกรมหนึ่ง โปรแกรมมีการพัฒนาตอเนื่องมายาวนานจนถึงเวอรชั ่นลาสุดคือ SAP2000 V24 โปรแกรมมี
ความสามารถในการสรางโมเดลไดหลากหลายรูปแบบทั้งสองมิติ สามมิติ ระบบพิกัดฉาก ระบบพิกัดวงกลม และ
ระบบพิกัดกําหนดเอง นอกจากนั้นยังมีฟงชั่นชวยในการสรางโมเดลอีกมากมายเพื่อใหผูใชสามารถสรางโมเดล
โครงสรางที่ซับซอนไดอยางสะดวกรวดเร็ว 

 การกําหนดคุณสมบัติองคอาคารจะมีวัสดุใหเลือกคือ เหล็ก คอนกรีต ไม และอลูมิเนียม ถาเปนหนาตัด
เหล็กจะมีตารางหนาตัดใหเลือกหรือผูใชอาจกําหนดหนาตัดเอง สวนหนาตัดคอนกรีตจะมีหนาตัดหลายรูปแบบให
เลือกเพ่ือกําหนดขนาดตามตองการ การกําหนดนํ้าหนักบรรทุกจะมีทั้งแบบอัตโนมัติและแบบใสคาโดยผูใชโดยจะมี
นํ้าหนักบรรทุกใหเลือกใชมากมายเชน แรงกระทําเปนจุด แรงกระจายบนคาน แรงกระจายบนพื้น แรงดานขางเชน
แรงลม และแรงแผนดินไหว และแรงเชิงพลศาสตรอ่ืนๆ  

การวิเคราะหโครงสรางใน SAP2000 จะมีใหเลือกทั้งแบบปกติ และแบบพิเศษเชน การวิเคราะห P-Delta 

หรือการวิเคราะหเชิงพลศาสตร ในโหมดหลังการวิเคราะหจะแสดงผลการคํานวณในรูปแบบตารางและกราฟก
อยางละเอียดและผูใชสามารถสรางรายงานตามองคประกอบที่ตองการได ในสวนของการออกแบบไมวาจะเปน
การเลือกหนาตัดเหล็กหรือออกแบบเหล็กเสริมในคอนกรีตจะมีทั้งแบบรันภายใน SAP2000 โดยสามารถทําการ
ออกแบบปฏิสัมพันธเพ่ือความสะดวกรวดเร็ว 

 เนื่องจากความสามารถที่มากมายของ SAP2000 นี้เอง การอธิบายรายละเอียดของเนื้อหาทั้งหมดแบบ
ปกติอาจทําใหผูเริ่มเรียนรูมีความยุงยากในการทําความเขาใจจนหมดความสนใจในการใชงานโปรแกรมนี้ไป คูมือ
การใชงาน SAP2000 ฉบับนี้เปนคูมือขั้นพ้ืนฐาน เนนการเรียนรูจากการใชงาน นั่นคือจะมีตัวอยางใหผูอานทําตาม
ขั้นตอน โดยจะคอยๆอธิบายเนื้อหาแทรกเขาตามหัวขอท่ีใชงาน เพ่ือใหผูอานคอยๆซึมซับเนื้อหา ทําความเขาใจใน
การใชงาน จนสามารถใชงานโปรแกรมไดอยางมีประสิทธิภาพ และมีศักยภาพในการเรียนรูเพื่อใชงาน SAP2000 

ในระดับชั้นสูงตอไป ผูเขียนหวังวาคูมือฉบับนี้จะเปนประโยชนตอวิศวกร นักศึกษา และผูสนใจ ไมมากก็นอย หาก
มีขอผิดพลาดหรือคําแนะนําประการใด สามารถติดตอผูเขียนโดยตรงทางอีเมลเพื่อทําการปรับปรุงแกไขตอไป 
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แนะนำโปรแกรม SAP2000 
SAP2000 คือโปรแกรมวิเคราะหและออกแบบโครงสรางที่มีการใชงานกันมาอยางยาวนานและ
แพรหลาย SAP ยอมาจาก Structural Analysis Program ไดถ ูกพัฒนาขึ ้นโดยมหาวิทยาลัย 
Berkeley แคลิฟอรเนีย ประเทศสหรัฐอเมริกา บริษัท Computers and Structures, Inc. (CSI), 

Berkeley, California, USA ไดทำการพัฒนา SAP มาอยางตอเนื่องจนเปน SAP2000 ซึ่งรันบน
ระบบปฏิบัติการ Windows มีการสั่งงานแบบกราฟก (Graphical User Interface: GUI) เพื่อความ
สะดวกรวดเร็วและประสิทธิภาพในการทำงาน การสรางและแกไขโมเดล, การวิเคราะหโครงสราง, 
การตรวจสอบและปรับเปลี่ยนความเหมาะสมในการออกแบบ  ตลอดจนการแสดงผลทั้งหมดจะใช 
GUI ตัวเดียวกันทั้งหมด 

 

รุนลาสุดของ SAP2000 คือ เวอรชั่น 24 สำหรับขอมูลขาวสารตางๆของ SAP2000 สามารถ
เขาไปดูไดท่ีเวบไซตของ CSI : http://www.csiamerica.com/sap2000 
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การสรางโมเดล  

SAP2000 เปนโปรแกรมที่มีระบบการทำงานแบบครบวงจร เริ่มตั้งแตสรางโมเดลโครงสราง ทำการ
วิเคราะห ออกแบบโครงสราง และตรวจสอบผลลัพธไดภายในระบบการติดตอกับผูใชเดียวกัน 

ในการสรางโมเดล SAP2000 มีเคร่ืองมือชวยสรางโครงสรางรูปแบบตางๆไดอยางมีประสิทธิภาพ 

 เครื่องมือวาดในลักษณะเดียวกับ AutoCAD ชวยสรางโมเดลอยางสะดวกรวดเร็ว 

 การปรับมุมมองทั้งแบบ 3D และระนาบ XY, XZ, YZ รวมถึงการซูมยอขยาย 

 แสดงไดหลายหนาจอกราฟกไดพรอมกัน สามารถไปมาระหวางหนาจออยางงายดาย 

 

 ระบบพิกัดและกริด สามารถเลือกกำหนดไดทั้งแบบพิกัดฉาก (Cartesian), ระบบทรงกระบอก 
(Cylindrical) และระบบทั่วไป (Generalized System) ซึ่งผูใชสามารถกำหนดเสนกริดเอียงได
ตามตองการ นอกจากน้ันในโมเดลเดียวกันยังสามารถมีไดหลายระบบพิกัดและกริด 

        



 

SAP2000  C1 Introduction Mongkol  JIRAVACHARADET 3 
 

 การสรางโมเดลใหมใน SAP2000 จะมีรูปแบบโครงสรางใหเลือกเพ่ือความสะดวกรวดเร็วในการ
วาด หรือผูใชอาจเลือกท่ีจะวาดโมเดลเอง 

 

 SAP2000 มีเครื่องมือชวยในการวาดวัตถุรูปแบบตางๆมากมายเพื่อชวยใหการวาดอยางมี
ประสิทธิภาพและสะดวกรวดเร็วเชนเดียวกันในโปรแกรม CAD 
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การแสดงผลกราฟก  

การแสดงผล DirectX ไดรับการพัฒนาทั้งดานคุณภาพและความเร็วในมุมมอง 2D และ 3D เมื่อมี
หนวยความจำและประสิทธิภาพกราฟกการดที่ดีเพียงพอ การเรงความเร็วกราฟกโดยฮารดแวรจะ
ทำใหการหมุนและซูมมุมมองเพ่ือตรวจสอบโมเดลทำไดอยางรวดเร็วและตอเนื่องไมกระตุก 

 

หนาตัดองคอาคารเชิงเสน  

ใน SAP2000 จะแบงองคอาคารออกเปนแบบเชิงเสนมีหนาตัดมาตรฐานของเหล็กรูปพรรณ 
คอนกรีต อลูมินั่ม และเหล็กรีดเย็นใหเลือกใชงานหลากหลายรูปแบบ 
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การกำหนดคุณสมบัติหนาตัดทำโดยการใสขนาดตางๆเพื่อสรางหนาตัดใหม หรือเลือกจาก
ตารางหนาตัดเปนไฟลนามสกุล .pro (Property file) โดยผูใชสามารถสรางตารางหนาตัดเปนไฟล
นามสกุล .pro ไดเอง 

Section Designer  

ใชในการสรางหนาตัดพิเศษซึ่งผูใชสามารถวาดรูปหนาตัดและกำหนดวัสดุไดเอง โปรแกรมจะทำการ
คำนวณคุณสมบัติหนาตัดใหโดยอัตโนมัติ สรางแผนภูมิปฏิสัมพันธในกรณีเสาคอนกรีตรับการดัดสอง
แกน หรือแผนภูมิโมเมนตดัดสำหรับคาน 

 

Built-up Steel 

 

Composite Section  
 

ชิ้นสวนเฟรม (Frame Elements)  

 

ชิ้นสวนเฟรมใน SAP2000 ที่ใชเปนองคอาคารที่เปน
เสนเชน เสา คาน และทอนยึดโยง จะมีทั ้งแบบ
เสนตรงและและเสนโคง โดยจุดตอจะถูกสรางขึ้น
อัตโนมัติที่จุดตัดระหวางองคอาคารและชิ้นสวนเฟรม 
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ชิ้นสวนแผน (Shell Elements)  

 ชิ้นสวนแผนจะแบงเปน membrane, plate และ shell ซึ่งจะถูกใชเปนองคอาคารที่เปนแผน
เชน ผนัง และ พื้น 

 SAP2000 จะมีทางเลือก แผนหนา(Thick Shell/Plate) ใหเลือกในกรณีที่การเสียรูปทรงจาก
แรงเฉือนมีความสำคัญ ในขณะที่การใช แผนบาง ตามปกติจะคิดเฉพาะการเสียรูปทรงจากการ
ดัด และละเลยการเสียรูปทรงจากการเฉือน มักจะใชในกรณีท่ีความหนามากกวา 1/10 ของชวง
ความยาว เชนในกรณีของฐานราก 

 

 ชิ ้นสวนแผนยอยแบงเปนแบบสี ่เหลี ่ยม (Quadrilateral element) และแบบสามเหลี ่ยม 
(Triangular element) 

 

Quadrilateral Element 

 

Triangular Element 

 แตละจ ุดต อจะมีด ีกร ีอ ิสระทั ้งหมดหกดีกร ี โดยเราสามารถเลือกใหม ีพฤติกรรมแบบ 
membrane, plate, shell หรือ thick plate/shell  

ชิ้นสวนวัตถุ (Solid Elements)  

ชิ้นสวนวัตถุสามมิติมี 8 โหนด สำหรับโมเดลวัตถุสามมิติที่อาจมี
การรับน้ำหนักบรรทุก สภาวะขอบเขต หรือคุณสมบัติหนาตัด 
แปรเปลี่ยนไปตามความหนา 
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ชิ้นสวนลวดอัดแรง (Tendon Elements)  

 เราสามารถวาดเสนลวดอัดแรงไดเหมือนเปนวัตถุอิสระ โดยสามารถกำหนดโปรไฟลเปนเสนตรง 
พาราโบลา สวนโคงวงกลม หรือรูปทรงอิสระ 

 SAP2000 จะตอเสนลวดอัดแรงเขากับชิ้นสวน frame, shell หรือ solid ที่มีเสนลวดอัดแรงอยู
ภายใน โดยเราสามารถกำหนดแรงดึงในเสนลวดไดอยางงายดาย 

 
  

นํ้าหนักบรรทุก  

การใสน้ำหนักบรรทุกมีทั้งแบบกระทำเปนจุด 
(Point Load) น้ำหนักตามแนวเสนมีทั้งแบบ
คงที่ (Uniform Load) และแบบรูปสี่เหลี ่ยม
คางหม ู  (Trapezoidal Load) การอ ั ดแรง 
(Prestress) และผลจากการเปล ี ่ยนแปลง
อุณหภูมิ 
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แรงลม : SAP2000 คำนวณแรงลมอัตโนมัติไดตามมาตรฐานตางๆดังนี้ 
 UBC 94, UBC 97 

 BOCA 96 

 ASCE 7-95, 02, 05, 10 

 NBCC 95, 2005, 2010 

 Chinese 2002 

 BS 6399-95 

 API 4F 2008 

 Eurocode1 2005 

 AS/NZS 1170.2:2 

 User Define 
 

 

แรงแผนดินไหว : SAP2000 คำนวณแรงแผนดินไหวอัตโนมัติไดตามมาตรฐานตางๆดังนี้ 
 IBC 2003, 2006, 2009, 2012 

 NEHRP 97 

 NBCC 95, 2005, 2010 

 Chinese 2010 

 IS1893 2002 

 Eurocode8 2004 

 User Coefficient 

 User Loads 
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น้ำหนักบรรทุกเคล่ือนท่ี (Moving Load) 

: SAP2000 สามารถจำลองน้ำหนักบรรทุก
เคลื ่อนที ่ไปบนองคอาคาร เพื ่อพิจารณา
สภาวะที่เกิดแรงมากที่สุด โดยมีรถบรรทุก
ขนาดตางๆตามมาตรฐาน AASHTO 

 
 

 

น้ำหนักบรรทุกจากคลื่น (Wave Load) 

: SAP2000 สามารถจำลองน ้ ำหนั ก
บรรทุกเคลื่อนที ่ไปบนองคอาคาร เพ่ือ
พิจารณาสภาวะที่เกิดแรง 

 

การวิเคราะห  

CSI Solver มี ไ ด  ร ั บการ ใช  ง า นทดสอบ ใน
อุตสาหกรรมความนาเชื่อถือมากเนื่องจากไดถูก
ใชงานมากวา 45 ปแลว 
 Advanced SAPFire Analysis Engine 

 Multiple 64-Bit Solvers 

 Eigen Analysis (Autoshifting for ill-

conditioned problems) 

 Ritz Analysis 

 

การวิเคราะหผลตอบสนองเชิงสเปคตรัม 
เปนการวิเคราะหเชิงพลศาสตรวิธีหนึ่งที่นิยมใชในการพิจารณาผลตอบสนองของโครงสรางภายใต
แรงกระทำแผนดินไหว โดยเราสามารถใสขอมูลกราฟสเปคตรัมคือคาบการสั่นไหวและความเรง
ตามท่ีมาตรฐานกำหนด 
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การวิเคราะหการโกงเดาะ (Buckling 

Analysis) 

นอกจากจะวิเคระหการโกงเดาะเชิงเสนในโครงสราง
ตามปกติแลว ยังสามารถวิเคราะหการโกงเดาะหแบบ
ไมเปนเสนตรง ในสถานะการณรับน้ำหนักตางๆ  

การวิเคราะหแบบประวัติเวลา (Time History Analysis) 

เปนการวิเคราะหเชิงพลศาสตรโดยหาการตอบสนอง
หรือการสั่นไหวของโครงสรางตอแรงพลศาสตรที่มา
กระทำ เชน ความเรงที่พ้ืนดินจากแผนดินไหว โดยจะ
ทำการวิเคราะหอยางละเอียดในทุกขณะเวลาที ่เกิด
การสั่นไหวของโครงสราง 
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การออกแบบ  

การออกแบบโครงสรางเหล็ก 

 

 สามารถเลือกหนาตัดโดยอัตโนมัติโดยแยก
หนาตัด หรือจัดเปนกลุม 

 การวิเคราะหความเหมาะสมของหนาตัดตาม
หลักงานเสมือนสำหรับการโยกตัวดานขาง 

 มาตรฐาน AISC360-05/IBC2006, AISC 

LRFD99, AISC ASD01 

 ออกแบบสำหรับแรงสถิตและแรงพลศาสตร 
 กำหนดกรณีบรรทุกรวมหรือผูใชกำหนดเอง 
 คำนวณแฟกเตอร K และ P-Delta อัตโนมัติ 
 รวมตัวออกแบบหนาตัดสำหรับหนาตัดคอม
โพสิตและหนาตัดประกอบ 

 ออกแบบเชิงปฎิสัมพันธ 
 ออกแบบโดยคิดผลของการบิด 

การออกแบบคอนกรีตเสริมเหล็ก 

 

 

 มาตรฐาน ACI 318-14, ACI 318-11, ACI 

318-08/IBC2009, ACI 318-05/IBC2003, 

ACI 318-02, ACI 318-99 

 ออกแบบสำหรับแรงสถิตและแรงพลศาสตร 
 เสารับการดัดสองแกน 

 คำนวณแฟกเตอรการขยายคาโมเมนต 
 คำนวณผลของ P-Delta 

 ออกแบบเชิงปฎิสัมพันธ 
 ออกแบบโดยคิดผลของการบิด 

การออกแบบโครงอลูมินั่ม 

 

การออกแบบโครงเหล็กรีดเย็น 
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การแสดงผล  

การเสียรูปทรง 
 สามารถแสดงการเสียรูปทรงจากน้ำหนัก
บรรทุกแยกตามกรณีบรรทุก 

 แสดงภาพเคล่ือนไหวของการเสียรูปทรง 
 แสดงโหมดการสั่นไหวและภาพเคล่ือนไหว 

 

 

แผนภูมิแรงภายใน 

 แผนภูมิแรงเฉือนและโมเมนตแสดงแรง
ภายในที่ตำแหนงตางๆตามความยาว
องคอาคาร 

 มีตัวเลื่อนใหลากไปตามความยาวองค
อาคารเพ่ือดูคาตางๆที่เปลี่ยนไปหรือไป
ยังตำแหนงที่มีคามากท่ีสุด 

 

การสรางรายงาน  

 สรางรายงานที่จัดรูปแบบโดยอัตโนมัติ ซึ่งจะมีทั้งขอมูลโมเดล ผลจากการรันวิเคราะห และผล
จากการออกแบบ 

 รายงานจะประกอบดวยขอมูลในรูปของตารางและรูปกราฟก 

 สามารถกำหนดใหอยูในรูปของไฟล RTF (Rich Text Format) สำหรับไมโครซอฟทเวิรด หรือ
ในรูปแบบ HTML เพ่ือการนำเสนอทางเวบ 
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การนําเขาและสงออก  

SAP2000 สามารถนำเขาและสงออกขอมูลสำหรับอุตสาหกรรม ท่ีหลากหลายไมวาจะเปน 
AutoCAD (DXF/DWG), Revit, Tekla, IFC นอกจากน ั ้ นย ั งสามารถส  งออกข อม ูลไปยั ง 
Microsoft Access และ Excel ไดอีกดวย 

 
 

 

 Microsoft Access 

 Microsoft Excel 

 SAP2000 Text File(.s2k) 

 CIS/2 STEP 

 Steel Detailing Neutral File 

(SDNF) 

 AutoCAD (.dxf/.dwg) 

 Frameworks Plus 

 IGES 

 IFC 

 Prosteel 

 Other analysis software 

text files 
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เริ่มตนใชงาน SAP2000 
ในบทนี้จะแนะนําขั้นตอนการทํางานของ SAP2000 ในเบื้องตน โดยเริ่มจากการเริ่มตนโปรแกรม 
สภาวะแวดลอมของโปรแกรม การปรับมุมมอง โดยใชตัวอยางโครงสรางสําเร็จรุปอยางงาย  

ขั้นตอนการทํางาน  

ขั้นตอนการทํางานในโปรแกรม SAP2000 แบงเปน 4 ขั้นตอนคือ การสรางโมเดล การกําหนด
นํ้าหนักบรรทุก การวิเคราะห และการออกแบบ 

 

ในการสรางโมเดลจะประกอบดวยการกําหนดวัสดุ เสนกริด หนาตัดองคอาคาร การวาดองค
อาคาร และกําหนดจุดรองรับ จากนั้นจะมาสูขั้นตอนการใสนํ้าหนักบรรทุก แลวจึงทําการวิเคราะห
และออกแบบ บางครั้งเมื่อตรวจสอบผลการวิเคราะหหรือออกแบบแลวตองการแกไข ก็สามารถ
กลับมาแกไขโมเดลใหมไดโดยการปลดล็อกโมเดล  

 

Create
Model

Assign
Loads

Run
Analysis

Design
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เริ่มตนโปรแกรม  

 หนาจอเร ิ ่มต นของโปรแกรม SAP2000 จะมีล ักษณะดังในร ูป สั ่งเมนู Help > About 

SAP2000…. เพ่ือตรวจสอบเวอรชั่นและจํานวนวันคงเหลือในการใชงานโปรแกรม 

 

หนาจอ SAP2000 จะปรากฏข้ึนมาโดยมีลักษณะดังในรูป โดยจะมีสวนประกอบหลักคือ 

หนาตางแสดงผล (Display Windows) เปนพื้นที่สวนใหญของหนาจอโปรแกรมมีไวเพื่อแสดง
โมเดลในมุมมองตางๆเชนแบบแปลน รูปดานขาง หรือรูปสามมิติ โดยมักจะแบงเปนสองหนาตางซึ่ง
ผูใชจะคลิกเลือกหนาตางให active เวลาตองการแกไขมุมมอง 
เมนูบาร (Menu Bar) เมนูบารจะมีเกือบทุกคําสั่งของ SAP2000 โดยจัดแบงเปนกลุมใหผูใชเลือก
หรือคนหาไดโดยสะดวก ในคูมือฉบับนี้การใชคําสั่งผานเมนูจะเขียนเปน Menu > Command  
กรณีมีเมนูยอยจะใช  Menu > Sub-menu > Command 

ทูลบาร (Toolbars) ปุมบนทูลบารจะทําใหการสั่งงานทําไดอยางรวดเร็ว เมื่อเลื่อนตัวชี้ของเมาท
ผานบนปุมเหลานี้จะมีคําอธิบายแสดงขึ้นมา โดยจะมีทั้งดานบนในแนวนอน และดานขางซายใน
แนวด่ิง 
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หนวยวัด (Units)  

SAP2000 ทํางานโดยใชหนวยวัดพ้ืนฐานสี่ตัวคือ แรง, ความยาว
, อุณหภูมิ และ เวลา เราสามารถเลือกหนวยไดอยางหลากหลาย
เชน Kip, in, F หรือ N, mm, C โดยจะแสดงหนวยที่กําลังใชอยู
ที่มุมขวาลางของหนาจอ ซึ่งเราสามารถเปลี่ยนแปลงหนวยได
ตลอดเวลา ในขณะใชงานโปรแกรม 

 การวัดมุมโดยทั่วไปเชนทิศทางของแกนตางๆจะวัดเปน
องศา แตการเคลื่อนตัวแบบหมุนมักจะใชหนวยเรเดียน เวลาจะ
ใชหนวยเปนวินาที และความถ่ีจะวัดเปน รอบ/วินาที (Hz)  

 

การสรางโมเดลใหม  

 เลือกหนวย Kgf, m, C แลวสั่งเมนู File > New หรือ คลิกปุม  บนทูลบาร หรือ กด Ctrl+N 

เพ่ือเริ่มสรางโมเดลใหม หนาตาง New Model จะแสดงข้ึนมาดังในรูป 
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ในหนาตางจะแบงเปน 3 กรอบคือ New Model Initialization, Project Information และ 
Select Template 

 

เราสามารถบันทึกการตั้งคาเปนไฟลเก็บไวเพื่อใชกับโมเดลใหมโดยเลือก Initialize Model 

from Saved Settings เลือก Initialize Model from Defaults with Units จะเริ่มตนโมเดลโดย
ใชคาตางๆตามที่กําหนดมากับตัวโปรแกรมตามหนวยที่ระบุ แตถาเปน Initialize Model from an 

Existing File จะเริ่มตนโปรแกรมโดยใชคาที่กําหนดตามไฟลเดิมที่มีอยู ไมวาจะเปนหนาตัด นํ้าหนัก
บรรทุก และอ่ืนๆ 

 

ในกรอบ Project Information จะเปนขอมูลตางๆของ
โครงการ คลิกปุม Modify/Show Info… เพื่อใหแสดง
ขอมูลและแกไข 

 

โดยขอมูลที่มีเครื่องหมาย * จะปรากฏบนหนาปกรายงาน 

ในกรอบ Select Template จะเปนแบบรางซึ่งเปนรูปแบบโมเดลโครงสรางทั่วไปที่มีใหเลือก
เพื่อใหการสรางโมเดลทําไดอยางสะดวกรวดเร็วโดยผูใชใสคาตัวแปรตางๆเขาไป  มีรูปแบบ
โครงสรางหลายรูปแบบใหเลือกดังนี้ 
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Blank เปนการเปดขึ้นมาเปนพื้นที่วางโดยไมมีการสรางอะไร
ขึ้นมาเลย 

 

Grid Only เร ิ ่มต นด วยการสร างเส นกร ิดเท าน ั ้น โดย
โปรแกรมจะใหเรากําหนดระบบพิกัด จํานวนและระยะหาง
ของเสนกริดในแตละทิศทาง 

 

Beam สรางโมเดลคานโดยจะใหเรากําหนดจํานวนชวง ความ
ยาวชวง และหนาตัดคาน 

 

2D Trusses สรางโมเดลโครงถักสองมิติ มีทั้งโครงถักเอียง 
โครงถักแนวดิ่ง และโครงถักแพร็ต โดยผูใชสามารถกําหนด
ขนาดและหนาตัด 

 

3D Trusses สรางโมเดลโครงถักสามมิติ มีทั้งโครงถักหลังคา 
เสาสงสัญญาณ และเสาสัญญาณแบบมีเคเบิ ้ลยึด โดยผูใช
สามารถกําหนดขนาดและหนาตัด 

 

2D Frames สรางโมเดลโครงขอแข็งสองมิติ มีทั้งแบบโครง
พอรทัล และโครงยึดโยง(แบบตรงศูนย หรือแบบเยื้องศูนย) 
โดยผูใชสามารถกําหนดขนาดและหนาตัด 

 

3D Frames สรางโมเดลโครงขอแข็งสามมิติ มีทั้งโครงเปด 
อาคารโครงรอบ อาคารแบบคาน-พื้น และอาคารแบบพื้นไร
คาน โดยผูใชสามารถกําหนดขนาดและหนาตัด 

 

Wall สรางโมเดลผนังเฉือน โดยผูใชสามารถกําหนดขนาด
และหนาตัด 

 

Flat Slab สรางโมเดลพื้นไรคาน โดยผู ใชสามารถกําหนด
ขนาดและหนาตัด 
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Shells สร  างโมเดลโครงสร  าง เปล ือกแข ็ ง  ม ีท ั ้ งแบบ
ทรงกระบอก ทรงโคงชวงเดี่ยว ทรงโคงหลายชวง ทรงไฮเปอร
โบลิก โดมทรงกลม และทรงพาราโบลิก โดยผู ใชสามารถ
กําหนดขนาดและหนาตัด 

 

Staircases สรางโมเดลบันไดมีทั้งแบบขาเดียวตอชั้น สองขา
ตอชั้น และแบบเกลียว โดยผูใชสามารถกําหนดขนาดและหนา
ตัด 

 

Storage Structures สรางโมเดลถังสูงทั้งแบบแทงนํ้า และ
ไซโลทรงกระบอก โดยผูใชสามารถกําหนดขนาดและหนาตัด 

 

Underground Concrete สรางโมเดลคอนกรีตใตดิน โดย
ผูใชสามารถกําหนดขนาดและหนาตัด 

 

Solid Models สรางโมเดลวัตถุมีทั ้งแบบโคงหนาคงที่ โคง
หนาแปรเปลี่ยน ปริซึม และบล็อก โดยผูใชสามารถกําหนด
ขนาดและหนาตัด 

 คลิกรูป 3D Frames เพื่อสรางโครงสามมิติ หนาตาง 3D Frames จะแสดงขึ้นมาใหเลือกชนิด
ของ Frame จํานวนชั้น จํานวนชอง และระยะหางในแตละทิศทาง 
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 เลือกโครงชนิด Beam-Slab Building และกําหนดคาตางๆดังในรูปขางลาง 

 

เมื่อคลิกปุม OK โมเดลจะถูกสรางขึ้น และปุมตางๆบนทูลบารทั้งดานบนและดานขางจะมีสสีัน
ขึ้นหมายถึงใชงานไดดังในรูป 

 

ในพื้นที่กราฟกแสดงโมเดลจะแบงเปนสองมุมมองคือ 3-D View แสดงรูปสามมิติ และ X-Y 

Plan แสดงรูปแปลนบนระนาบราบ X-Y ที่ระดับความสูง @ Z = 0 
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สภาวะแวดลอมของโปรแกรม (Graphical User Interface, GUI)  

ระบบการทํางานทุกขั้นตอนของ SAP2000 จะอยูในสภาพแวดลอมเดียวกัน โดยจะแสดงผลบน
หนาจอกราฟฟกในลักษณะตางๆ เชนในขั้นตอนการสรางโมเดลจะแสดงรูปโครงสรางโมเดลดังที่เห็น
ในรูป เมื่อรันการวิเคราะหแลวออกแบบก็จะแสดงผลการวิเคราะหและออกแบบในหนาจอเดิม 

หนาจอของโปรแกรมคาย CSI ไมวาจะเปน SAP2000, ETABS และ SAFE จะมีรูปแบบ
เดียวกันทําใหผูใชที่ใชเปนตัวหนึ่งแลวจะเรียนรูตัวที่เหลือไดอยางรวดเร็ว โดยหนาจอจะแบงเปน 
เมนู(Menu) ที่แถวบนสุดซึ่งจะมีทุกคําสั่งที่ใชงานแบงตามกลุมและเรียงตามการใชงาน เพื่อความ
สะดวกในการเรียกใชงาน ทูลบาร(Toolbar) แถบของปุมคําสั่งตางๆซึ่งเราใชงานบอย โดยจะมีทูล
บารดานบนอยูถัดลงมาจากเมนู และทูลบารในแนวดิ่งดานขางซาย 

 
เราสามารถปรับเปลี่ยนทูลบารโดยคลิกขวาบนพื้นที่วางของ
ทูลบาร แลวเลือกชุดของทูลบารที ่ตองการ เชนลองเลือก 
Display ชุดของปุ มคําส ั ่งที ่ เก ี ่ยวของจะแสดงขึ ้นมาเปน
หนาตางเล็กๆ  

เมื่อดับเบิ้ลคลิกท่ีหนาตางปุมคําสั่งจะถูกใสลงบนทูลบาร  

 

แถบสถานะ(Status bar) ดานลางจะแสดงสถานะตางๆ เชนในขณะสรางโมเดลทางขางซายจะ
แสดงวาหนาหนาตางไหน แอคทีฟ(active) คือใชงานอยู  โดยเราสามารถคลิกที ่ชื ่อมุมมองให
หนาตางแอคทีฟเพ่ือทํางานในหนาตางนั้น 

ลองคลิกหนาตาง 3-D View แลวเลื่อนตัวชี้มาที่จุดตอที่มุมอาคาร ในหนาตาง Plan View ก็
จะแสดงตําแหนงที่เราชี้เชนกัน สวนแถบสถานะดานลางซายจะแสดงวาตอนนี้อยูในหนาตาง 3 -D 

สวนทางฝงขวาจะแสดงพิกัดท่ีตัวชี้อยู ในชองถัดมาแสดงระบบกริดซึ่งตอนน้ีมีหนึ่งระบบคือ Global 

 

และชองขวาสุดจะแสดงหนวยท่ีใช ณ ขณะนี้ โดยผูใชสามารถเปลี่ยนหนวยไดตลอดเวลา ซึ่งก็เปนจุด
ที่เสี่ยงตอการผิดพลาด ดังนั้นจึงควรสังเกตหนวยในชองนี้เปนประจําขณะทํางาน 
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สัญลักษณ แกนพิกัดรวม(Global Coordinate) ของระบบกริดที ่ใชอยู ตอนนี้คือ 
Global จะมีลักษณะเปนลูกศรสามทิศทางโดยมีตัวอักษร X, Y และ Z กํากับ ซึ่งสําหรับ
โปรแกรมของคาย CSI แกน Z จะอยูในแนวดิ่ง โดยมีแกน X, Y อยูในระนาบราบ โดยมี
ทิศทางตามกฎมือขวา  

การเปลี่ยนมุมมอง 2D  

มุมมองใน SAP2000 จะแบงเปนมุมมองสามมิติ (3D) และแบบ (2D) ซึ่งตอนน้ีหนาตางซายเปน 3-D 

View เปนมุมมองแบบ 3D สวนหนาตางขวาจะเปน X-Y Plane ซึ่งเปนมุมมองแบบ 2D  

 คลิกหนาตาง X-Y Plane @ Z=0 ทางขวาใหแอค
ทีฟ โดยคลิกพื้นที่ภายในหนาตาง ชื่อหนาตางจะ
ดานบนจะถูกไฮไลท ตอนน้ีเราอยูที่ระดับ Z=0 ซึ่ง
จะเห็นเฉพาะเสนกริดและฐานราก 

 สั ่งเมนู View > Set 2D View… หรือกด Ctrl+ 

Shift+F2 หนาตาง Set 2D View จะแสดงขึ้นมา 
ใหเปลี่ยนคาเปน Z=3 หรือคลิกที่จุดในจอเล็กให
เสนสีแดงขยับขึ้นมาท่ีระดับความสูงที่ตองการ 

 คลิกปุม OK ในหนาตางทางขวาจะกลายเปน X-Y 

Plane @ Z=3 จะเห็นคานท่ีระดับความสูง 3 m 
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เราสามารถใชการกําหนดระนาบในสองทิศทาง และระยะในทิศทางที่สาม แสดงมุมมองดานขางได
ในลักษณะเดียวกันเชนลองเลือกเปน X-Z plane @ Y=0 ก็จะไดรูปดานขาง 

 

นอกจากนั้นยังสามารถกําหนดทิศทางการมองวาจะมองจาก ดานหนา (Front Face) หรือจาก
ดานหลัง (Back Face) ไดอีกดวย  

อีกวิธีหนึ่งในการกําหนดมุมมอง 2D คือคลิกปุมระนาบ xy, xz, yz บนทูลบาร ซึ่งถายังไมมีให
เลือกใสเพิ ่มเขามากอน โดยคลิกที ่ปุ ม  ปลายแถวของปุ มในทูลบาร รายการปุ มที ่แสดงอยู มี
เครื่องหมายถูกอยูดานหนา ซึ่งเราสามารถเปดปดการแสดงปุมตางๆบนทูลบารไดอยางงายดายใน
ลักษณะเชนเดียวกันนี้ 
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เมื่อเลือกรายการ xy, xz และ yz แลว จะมีปุมปรากฏบนทูลบารดังในรูป 

 

นอกจากนั้นเมื่อกดปุมลูกศรขึ้นลง จะเปนการยายไปตามระยะเสนกริดตางๆ เชนลองกด yz แลวกด
ปุมขึ้นลง สังเกตการณแสดงเสนกริดที่เปลี่ยนไป ซึ่งวิธีนี้จะทําใหเราปรับเปลี่ยนมุมมอง 2D ไดอยาง
สะดวกรวดเร็ว 

การจัดการหลายหนาตางแสดงผล  

SAP2000 ตั้งแตเวอรชั่น 17 มีความสามารถในการเปดหนาตางแสดงผลไดมากกวาสองหนาตาง โดย
ผูใชสามารถจัดวางหนาตางไดตามตําแหนงและขนาดท่ีตองการ 

 คลิกรูปสามเหลี่ยมที่มุมขวาบนของหนาตาง X-Z Plane @ Y=0 

 

หนาตางใหม 3-D View จะถูกสรางขึ้นซอนทับหนาตางเดิมดังในรูป 
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 คลิกลากที่ชื่อหนาตาง 3-D View ออกมา จะมีแผงควบคุมการวางตําแหนงแสดงขึ้นมาใหเรา
เลือกวางหนาตางตามตองการ 

 

 คลิกปุม    เปลี่ยนเปนมุมมอง X-Y Plane จะไดหนาตางดังในรูป 

 

การเปลี่ยนมุมมอง 3-D  

การปรับมุมมอง 3-D จะทําไดหลากหลายกวา 2-D กอนอื่นใหคลิกเลือกหนาตางทางซายที่แสดงรูป 
3-D View ใหเปนหนาตางแอคทีฟกอน 
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 สั่งเมนู View > Set 3D View… หรือกด Ctrl+Shift +F3 หนาตาง Set 3D View จะแสดง
ขึ้นมาใหเรากําหนดมุมตางๆในการแสดงรูปสามมิติ 

 

ทิศทางมุมมองมีดังนี้ : 
- Plan angle: มุมราบในระนาบ XY วัดจากแกนบวก X ในทิศทวนเข็มนาิกา 
- Elevation angle: มุมยกจากระนาบ XY ขึ้นไปยังแกนบวก Z 

- Aperture angle: ความแคบกวางของมุมหรือระยะหางจากสายตาถึงวัตถุ 

เมื่อคลิกปุม    จะไดมุมมอง Default 3D จะถูกตั้งคา Plan angle = 225o, Elevation angle 

= 35o และ Aperture angle = 60o 

  

XY
Z

Plan angle = 225o

Elevation angle = 35o

Aperture angle = 60o

Default 3D View

Plan
angle

225o

X

Y

View
direction

Eye
point

Target
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การเปลี่ยนมุมมอง 3D สามารถสั่งไดจากบนทูลบารโดยคลิกปุม Rotate 3D View 

 

 เลื่อนตัวชี้เขามาในหนาตาง 3-D View กดเมาสปุมซายคางไว แลวขยับเมาสเพ่ือหมุนโมเดล 

 ถาตองการกลับมายังมุมมองดั้งเดิม คลิกปุม    Set Default 3D View 

การปรับมุมมอง Zoom & Pan  

Zoom & Pan เปนคําสั่งซูมขยายและเคลื่อนยายซึ่งใชมากในการวาดโมเดลและตรวจสอบโมเดล 
สามารถไดจากเมนู View หรือคลิกปุมบนทูลบารไดโดยตรง มีคําสั่งใหใชดังนี้ 

 

Rubber Band Zoom  [ F2 ] 

ซูมแบบตีกรอบหนาตาง โดยคลิกมุมซายบนแลวลากทแยงลงมา
ที่มุมขวาลางของบริเวณท่ีตองการซูมขยาย 

Elevation
angle

35o

X

Z View
direction

Eye
point

Target
point

Elevation Angle Aperture Angle

Aperture
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point

XY
Z
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Restore Full View  [ F3 ] 

แสดงมุมมองของทั้งโมเดล มักใชหลังจากซูมขยาย แลวตองการ
กลับมาแสดงมุมมองทั้งหมดเหมือนเดิม 

 

Previous Zoom 

ซูมยอขยายยอนกลับตามคร้ังกอนหนา  

 

Zoom In One Step [ Shift+F2 ] 

ซูมขยายหน่ึงระดับคือ 10%  

 

Zoom Out One Step [ Shift+F3 ] 

ซูมยอหนึ่งระดับคือ 10%  

 

Pan [ Shift+F4 ] 

ตัวชี้จะกลายเปนรูปมือ ใหเราจับโมเดลเคลื่อนยายมุมมองไดตาม
ตองการ  

 

การใชเมาสในการปรับมุมมอง  

การใชเมาสในการควบปรับเปลี ่ยนมุมมองจะชวยใหทํางานไดอยาง
สะดวกรวดเร็ว โดยใน SAP2000 จะมีเทคนิคการใชงานเมาสเหมือนกับ
ใน AutoCAD โดยใช ลอกลิ้ง (scholl wheel) ของเมาส ดังนี้คือ 

 

Zoom 

กลิ้งออกจากตัวเราจะซูมขยาย กลิ้งเขาหาตัวจะซูมยอ 

 

Pan 

กดลูกกลิ้งคางไว  แลวขยับเมาสจะเปนการขยับภาพวาด 

 

Rotate 3D View 

กดปุม Shift และลูกกลิ้งคางไว แลวขยับเมาสจะเปนการ 
ปรับมุมมองสามมิติ 

Shift
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การตั้งคาแสดงผล (Set Display Options)  

เปนการกําหนดคาในการแสดงผลของวัตถุในรูปแบบตางๆ การสั่งทําโดยการเลือกเมนู View > Set 

Display Options หรือกด Ctrl+W หรือคลิกปุม    บนทูลบาร 

 

 สั ่ง Set Display Options ในหนาตางที ่แสดงขึ ้นมาใหเลือกแถบ General Options เลือก 
View Type > Extrude และ General > Fill Objects และเลือก Apply to All Windows  

 

โมเดลจะถูกแสดงโดยมีขนาดหนาตัด (Extrude View) และแสดงพ้ืน (Fill Object) ในทุกหนาตาง 
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 สั่งเมนู File > Save หรือกด Ctrl+S เพ่ือบันทึกขอมูล ตั้งชื่อไฟลวา EX1 Simple Frame 

การตั้งคาสีวัตถ ุ  

 เลือกเมนู Options > Colors > Display หนาตางกําหนดคาสีสําหรับวัตถุตางๆจะแสดงข้ึนมา 

 

 ในชอง Quick Color Scheme เปนการเลือกชุดสีแบบรวดเร็ว ที่ใชอยูตอนนี้จะเปนชุด White 

Background อาจเลือกเปน Black Background เพื่อถนอมสายตา หรือเลือกเปนชุด Blue-

scale เพ่ือใหสีออนลงดังในรูป 

 

 สั่งเมนู Options > Colors > Display > Quick Color Scheme > White Background 
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 สั่งเมนู Options > Graphics Mode > DirectX จะไดรูปโมเดลที่คมชัดขึ้น หรือ เลือก Classic 

Plus เพ่ือใหการทํางานรวดเร็วขึ้น 
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การสรางโมเดล 
ในบทนี้จะแนะนําขั้นตอนการสรางโมเดลใน SAP2000 โดยเริ่มจากโมเดลบานพักอาศัยคอนกรีต
เสริมเหล็ก เพื่อแนะนําขั้นตอนการกําหนดกริด การกําหนดคุณสมบัติวัสดุ การกําหนดหนาตัดเสา
และคาน การกําหนดพื้นตามชนิดของวัตถุพื้นที่ และการใชคําสั่งในการวาดวัตถุ ตอจากนั้นจะเปน
โมเดลโครงสรางเหล็ก ซึ่งจะกลาวถึงการกําหนดหนาตัดเหล็ก และการกําหนดจุดตอปลายคาน 

โมเดลอาคารบานพักอาศัย 2 ชั้น  

ตัวอยางแรกของการสรางโมเดลคือบานพักอาศัยคอนกรีตเสริมเหล็ก 2 ชั้น มีแปลนพื้นชั้นที่ 1 และ
ชั้นที่ 2 ดังแสดงในรูป 
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เสา: 0.20 x 0.20 ม.  คาน: 0.20 x 0.40 ม. 
พ้ืน:  S1 =  พ้ืนหลอในท่ีสองทาง หนา 0.12 ม. 
 S2  =  พ้ืนหลอในท่ีสองทาง หนา 0.10 ม. 
 ST  =  พ้ืนบันได หนา 0.12 ม. 
ในการสรางโมเดลจะประกอบดวยการกําหนดวัสดุ เสนกริด หนาตัดองคอาคาร การวาดองค

อาคาร และกําหนดจุดรองรับ จากนั้นจะมาสูขั้นตอนการใสนํ้าหนักบรรทุก แลวจึงทําการวิเคราะห
และออกแบบ บางครั้งเมื่อตรวจสอบผลการวิเคราะหหรือออกแบบแลวตองการแกไข ก็สามารถ
กลับมาแกไขโมเดลใหมไดโดยการปลดล็อกโมเดล  

กําหนดระบบกริด  

ในตัวอยางนี้เราจะสรางโมเดลดวยการวาดองคอาคารขึ้นเองโดยไมใชเทม
เพลตสําเร็จรูป 

 เริ่มตนโปรแกรม SAP2000 เปลี่ยนหนวยเปนหนวย Kgf, m, C 

 เริ่มตนโมเดลใหม โดยสั่งเมนู File > New Model… หรือกด Ctrl+N 

เมื่อหนาตาง New Model แสดงขึ้นมา คลิกปุม Grid Only 
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 ในหนาตาง Quick Grid Line เลือกระบบ Cartesian 

ใสจํานวนเสนกริด, ระยะหางและตําแหนงเสนกริดแรก
ในทิศทาง X, Y และ Z ดังนี้ 

จํานวน:  X = 3, Y = 4, Z = 2 

ระยะหาง:  X = 4, Y = 4, Z = 3 

ตําแหนง:  X = 0, Y = 0, Z = 0.3 

เสนกริดในแตละทิศทางจะมีระยะหางเทากันโดยจะทํา
การปรับเปลี่ยนในภายหลัง  

ระบบกริดจะถูกสรางขึ้นโดยแสดงเปนหนาตาง X-Y 

Plan และ 3-D View 

สังเกตสัญลักษณแกนรวม Global ที่แสดงเปนลูกศร
สามทิศทาง โดยแกนบวก Z จะเปนทิศชี้ขึ้น 

 

 

 สั่งเมนู File > Save หรือกด Ctrl+S เพ่ือบันทึกขอมูล ตั้งชื่อไฟลวา EX2 House2F 

ควรเก็บไวในโฟลเดอรแยกตางหาก เพราะระหวางรันโปรแกรมจะมีไฟลถูกสรางขึ้นมากมาย 

 ปรับเปลี ่ยนระบบกริดโดยเลือกเมนู Define > Coordinate Systems/Grids… ในหนาตาง 
Coordinate/Grid Systems ที่แสดงขึ้นมาจะมีหนึ่งรายการคือระบบ GLOBAL  
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 คลิกปุม Modify/Show System… เพื่อแกไขระบบกริด หนาตาง Define Grid Data จะแสดง
ขอมูลตารางของขอมูลกริดทั้งสามแกน  

 เปลี่ยนการแสดงกริดเปนแบบ Spacing แลวแกไขขอมูลกริด Y ดังในรูป 

 

เมื่อคลิกปุม OK จนกลับมาที่หนาจอหลัก ระบบกริดจะเปลี่ยนไปตามท่ีกําหนด 
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 เราสามารถตรวจสอบระยะหางกริดโดยใชเครื่องมือวัดจากเมนู View > Measure > Line แลว
คลิกลากเสนระหวางจุดที่ตองการรูระยะทาง 

 

กําหนดคุณสมบัติวสัด ุ  

 คลิกเปลี่ยนหนวยที่มุมลางขวาของหนาจอ เลือกเปนหนวย Kgf, cm 

 

 คลิกขวาในพ้ืนที่วางบนทูลบาร เลือกรายการ Define ชุดเครื่องมือท่ีเลือกจะแสดงเพ่ิมข้ึนมาบน
ทูลบารดานบน 
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 สั่งเมนู Define > Materials… หรือคลิกปุม    หนาตางวัสดุจะแสดงขึ้นมา โดยมีสอง
รายการที่โปรแกรมกําหนดมาใหเปนตัวอยางไดแก 4000Psi คือคอนกรีต และ A992Fy50 คือ
เหล็กรูปพรรณ 

 เราจะทําการปรับเปลี่ยนวัสดุเหลานี้ใหมีคุณสมบัติตามที่ตองการ และสรางเพ่ิมใหมอีกหนึ่งวัสดุ
คือ เหล็กเสริม (Rebar) 

 เลือกรายการ 4000Psi แลวคลิกปุ ม Modify/Show Material ใหแสดงคุณสมบัติวัสดุเพ่ือ
ตรวจสอบหรือทําการแกไข 

  

 หนาตาง Material Property Data จะแสดงข้ึนมา โดยระบุชนิดวัสดุเปนคอนกรีต 

 เปลี่ยนชื่อวัสดุเปน Fc240 เกรด f’c 240 ksc 

 เปลี่ยนคาโมดูลัสยืดหยุน  2E 15,100 240 233,928 kg/cm   

 เปลี่ยนคาในชองกําลังอัดคอนกรีตเปน f’c  240 kg/cm2 
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 คลิกปุม OK กลับมาที่หนาตาง Define Materials รายการ Fc240 ถูกแสดงแทนท่ีวัสดุเดิม 

 

 เล ือกรายการ A992Fy50 คลิกปุ ม Modify/Show Material ใหแสดงคุณสมบัติว ัสดุเพ่ือ
ตรวจสอบหรือทําการแกไข ดังในรูป 
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คา Effective Yield Stress, Fye และ Effective Tensile Stress, Fue หาไดจากการคูณ
กําลัง Fy และ Fu ดวยแฟกเตอรตามมาตรฐานออกแบบ เชน FEMA 356 ตารางที่ 5-3 ซึ่ง
โดยปกติจะอยูที่ประมาณ 1.1 คา Fye และ Fue จะใชในการสรางคุณสมบัติของจุดตอหมุน 
(hinge) โดยอัตโนมัติสําหรับจุดตอหมุน P-M2-M3 และ P-M  

 รายการวัสดุจะกลายเปน Fc240 และ Fy2400 ดังในรูป 
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 เพิ่มวัสดุใหมคือเหล็กเสนเสริมคอนกรีต (Rebar) คลิกปุม Add New Material หนาตาง Add 

Material Property จะแสดงข้ึนมาใหเลือกเหล็กตามมาตรฐานท่ีใกลเคียงคือ ASTM A615 

 

 เมื่อมีรายการ A615Gr60 เพ่ิมเขามา ใหกดปุม Mofify/Show Material เพ่ือแกไขขอมูล 

 

 ใสขอมูลเหล็กเสริมคอนกรีต SD40 ซึ่งมีคุณสมบัติตาม มอก. 24-2548 ดังนี้ 

ตารางท่ี 7 ความตานทานแรงดึง ความตานทานแรงดึงท่ีจุดคราก และความยืดหยุน 

ชั้นคุณภาพ ความตานแรงดึง 
MPa 

ความตานแรงดึงท่ีจุดคราก 

MPa 

ความยึด 

% 

SD 30 480 295 17 

SD 40 560 390 15 

SD 50 620 490 13 

 ดังนั้นใช   Fy  =  390 x 106 / (9.81 x 104)  =  3,976   USE 4,000 kg/cm2 

 Fu  =  560 x 106 / (9.81 x 104)  =  5,708   USE 5,700 kg/cm2 
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เมื่อใสขอมูลเสร็จแลวคลิก OK เราจะมีวัสดุสามรายการคือ คอนกรีต Fc240, เหล็ก Fy2500 

และ เหล็กเสริม SD40 
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กําหนดหนาตัดเฟรม Define Frame Sections  

 สั่งเมนู Define > Section Properties Frame Sections… หรือคลิกปุม    บนทูลบาร  

 คลิกปุม Add New Property เลือกหนาตัด Concrete แบบ Rectangular 
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 ในหนาตาง Rectangular Section ที่แสดงขึ้นมา ตั้งชื่อเปนหนาตัดเสา C20X20 วัสดุ Fc240

ขนาด 20 x 20 cm แลวคลิกปุม Concrete Reinforcement 

 ในหนาตาง Reinforcement Data ที่แสดงขึ้นมาจะใหเราเลือกชนิดองคอาคารวาจะเปน เสา 
หรือ คาน และกําหนดขอมูลการเสริมเหล็ก  

 

จะเห็นวาขนาดเหล็กเสริมจะมีหลายรูปแบบ 
ใหลองคลิกปุมเครื่องหมาย + หนาชองเพื่อให
แสดงขนาดเหล็ก  

 

 

 

 

 

 

 

 

 

 เมื่อคลิก OK กลับมาที่หนาตาง Rectangular Section จะไดหนาตัดดังในรูป 

 

 คลิกปุ ม Add New Property เล ือกชนิดหนาตัด Concrete แลวเล ือกหนาตัดสี ่ เหลี ่ยม 
Rectangular สรางหนาตัดคาน B20X40 

 คลิกปุม Concrete Reinforcement เลือกชนิดการออกแบบ Beam (M3 Design Only) 
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เมื่อใสขอมูลเสร็จจะมีรายการ 2 หนาตัดคือ 
เสา C20X20 และ คาน B20X40 
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แกนเฉพาะท่ี (Local Axis) ของเฟรม  

ในการใสขนาดหนาตัดเสาและคานจะเห็นวามีการระบุขนาดหนาตัด
ตามทิศทาง 2 และ 3 ซึ่งเปนแกนเฉพาะที่ (Local Axis) ของแตละ
องคอาคาร โดยจะมีท้ังหมดสามแกนคือ 1, 2 และ 3 

ความเขาใจเรื่องแกนองคอาคาร 1-2-3 มีความสําคัญมากใน
การใชงานโปรแกรมทั้งในข้ันตอนของการสรางโมเดล และการในการ
แสดงผลการรันวิเคราะหโครงสราง 

แกนองคอาคาร 1  
แกน 1 จะเปนแกนตามแนวยาวขององคอาคารเสมอ โดยมีทิศทางช้ีจากปลายตั้งตน i ถึงปลายสิ้นสุด 
j ทิศทางของแกน 1, 2 และ 3 จะตั้งฉากกันโดยเปนไปตามกฎมือขวา เชนเดียวกับแกนรวม X-Y-Z 
ดังนั้นถากําหนดแกน 2 ได แกน 3 ที่เหลือก็จะหาไดจากกฎมือขวา 

แกนองคอาคาร 2 และ 3 

ทิศทางของแกน 2 และ 3 พิจารณาไดจากลักษณะของแกน 1 และแกนบวก Z คือ 

 ระนาบแกน 1-2 จะอยูในแนวดิ่งขนานแกน Z 

 แกน 2 จะชี้ในทิศข้ึน (+Z) ยกเวนในกรณีที่องคอาคารอยูในแนวดิ่ง แกน 2 จะอยูในแนวราบ 
ชี้ไปทางแกน +X  

 แกน 3 จะอยูในแนวราบ ระนาบ X-Y 

สําหรับองคอาคารในแนวดิ่งหรือเสา แกน 1 จะชี้ตามแกนเสาในทิศบวก Z, แกน 2 ตั้งฉากกับเสาชี้
ไปทางแกนบวก X และแกน 3 จะชี้ไปตามกฎมือขวาโดยใชทิศของแกน 1 และ 2 ในกรณีที่หนาตัด
เสาไมเปนสี่เหลี่ยมจัตุรัส ตองพิจารณาดูใหดีวาตองการใหหนาเสาหันไปทิศทางใด 
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สําหรับองคอาคารในแนวราบหรือคาน ไมวาแกน 1 จะชี้ในทิศทางไหนในระนาบราบ X-Y แกน 2 
จะชี้ขึ้นตามแกน +Z และแกน 3 จะชี้ไปตามกฎมือขวาโดยใชทิศของแกน 1 และ 2 ดังนั้นความกวาง
คานจึงเปน t2 และความลึกเปน t3 เสมอ เชนเดียวกับเวลาดูคาแรงภายใน แรงเฉือนในคานจะเปน 
V2 และโมเมนตดัดเปน M3 เสมอ 

การวาดเสา Draw Column 

ในขั้นตอนน้ีเราจะวาดเสา C20X20 ที่ไดสรางไวลงในโมเดล โดยใชเครื่องมือวาดรูปแบบตางๆ 

 คลิกเลือกหนาตาง X-Y Plane แลวคลิกปุม    เปลี่ยนเปนระนาบ X-Z ที่เสนกริด 1 ดังรูป 

 
 

Select Mode v.s. Draw Mode 

คําสั่งวาดจะอยูในเมนู Draw หรือสั่งแบบรวดเร็วโดยคลิกบนทูลบารดิ่งขางซาย 
โดยปกติตัวชี้จะเปนลูกศร    หมายถึงอยูในโหมดเลือกวัตถุ (Select Mode)  

เมื่อใชคําสั่งวาดตัวชี ้จะเปลี ่ยนเปนรูป  คืออยูในโหมดวาด (Draw 

Mode) เมื่อวาดเสร็จใหคลิกปุม    เพ่ือกลับเขาโหมดเลือกวัตถุ 

Draw Frame 

 คลิกปุม    Snap to Grid Intersection แลวคลิกปุม    Draw 

Frame สั่งเกตตัวชี้จะเปลี่ยนเปนรูป  และมีหนาตางแสดงขึ้นมาใหเรา
กําหนดองคอาคารที่จะทําการวาด 

 วาดเสาที่เสนกริด 1-A โดยคลิกที่จุดตัดกริดลางแลวลากมาท่ีจุดตัดกริดบน 
แลวกด Esc เพ่ือจบการวาด กลับมาโหมดเลือกวัตถุ 
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Quick Draw Frame 

 คลิกปุม    Quick Draw Frame เปนการวาดเฟรมอยางรวดเร็ว โดยคลิกที่เสนกริดที่
ตองการวาดที่เหลือคือ 1-B และ 1-C แลวกด Esc เพ่ือจบการวาด 

 

การเลือกวัตถ ุ Select 

การเลือกวัตถุเมื่อจะใชคําสั่งกับวัตถุที่ตองการไมวาจะเปน ปรับเปล่ียน ทําซํ้า หรือลบ ใน SAP2000 

มีเทคนิกในการเลือกหลายวิธี ในตอนนี้เรายังมีวัตถุคือเสาเพียง 3 ตนเทานั้น จึงเหมาะที่จะลองฝก
เลือกวัตถุแบบงายๆในเบื้องตน 

Select > Pointer/Window 

การเลือกวัตถุโดยใชตัวชี้มีสามวิธีคือ  

1) คลิกเมาสซายเลือกโดยตรง  

2) ตีกรอบคลุมจากมุมซายบน 

3) ตีกรอบตัดจากมุมขวาบน  

ถาตองการยกเลิกการเลือกใหกด Esc 
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แถบสถานะดานลางจะแสดงชนิดและจํานวนวัตถุท่ีถูกเลือก 

 

 คลิกท่ีวัตถุอีกคร้ังเพื่อยกเลิกการเลอก หรือกดปุม Esc เพ่ือยกเลิกการเลือกวัตถุท้ังหมด 

ในกรณีที่มีหลายวัตถุซอนกันอยูใหกด Ctrl แลวคลิกซาย จะมีรายการวัตถุแสดงข้ึนมาใหเลือก 

 
 

ปุมควบคุมการเลือก อยูบนทูลบารดิ่งดานขางมี 4 ปุมคือ 

 
Ctrl + A 

Select All 

เลือกวัตถุท้ังหมดในโมเดล (แมแตวัตถุท่ีสั่งไมแสดง) 

 
Ctrl + J 

Get Previous Selection 

เลือกวัตถุท่ีเคยถูกเลือกครั้งกอนหนา 

 
Ctrl + Q 

Clear Selection 

ยกเลิกการเลือกวัตถุท้ังหมดในโมเดล (เทากับกด Esc) 

 
Ctrl + Shift + L 

Select using Intersecting Line 

เลือกวัตถโุดยการลากเสนตัดผาน 
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การคัดลอกวัตถ ุ Copy & Paste & Replicate  
การคัดลอกวัตถุสามารถไปวางอีกท่ีหนึ่งสามารถทําไดอยางงายดายเชนเดียวกับโปรแกรมท่ัวไปคือ  

 เปลี่ยนเปนหนวย Kgf, m, C แลวเลือกเสาท้ังหมด แลวกด Ctrl+C เพ่ือก็อปป แลวกด Ctrl+V 
เพ่ือวาง จะมีหนาตางแสดงขึ้นมาใหเราระบุระยะหาง 

       

Replicate   จะเปนคําสั่งในการทําซํ้าอยางมีประสิทธิภาพ โดยสามารถทําซํ้าไดครั้งละหลายวัตถุ 
เมื่อจุดตอหรือวัตถุถูกคัดลอก สิ่งที่กําหนดใหแกจุดตอหรือวัตถุ เชน หนาตัด นํ้าหนักบรรทุก หรือ 
การยึดรั้งจุดตอ จะถูกคัดลอกมาดวย ซึ่งตางจาก Ctrl+C & Ctrl+V ซึ่งจะคัดลอกเฉพาะวัตถุ 

 เลือกวัตถุ แลวสั่งเมนู Edit > Replicate หรือกด Ctrl+R หนาตาง Replicate ที่แสดงข้ึนมาจะ
มีทางเลือกในการทําซํ้าไดหลายรูปแบบ ไดแก 

 

Linear จะทําซํ้าในแนวเสนตรง โดยจะใสระยะหางในแตละทิศทาง dx, dy และ dz และใส
จํานวนที่ตองการทําซํ้าในชอง Increments หรือคลิกปุม Pick Two Points on Model แลว
คลิกสองจุดที่มีระยะหางตามตองการ 
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 ใสระยะหาง dy = 4 และจํานวนทําซํ้า Increment Data > Number = 1  

 คลิกปุม Modify/Show Replicate Options เพ่ือตรวจสอบทางเลือกในการทําซํ้า 

 

Radial จะทําซํ้าตามแนวรัศมีวงกลม โดยกําหนดแกนหมุนในทิศทางขนานแกน X, Y, Z หรือ
เสนตรงในสามมิติ แลวกําหนดจํานวนที่ตองการทําซํ้าและมุมในชอง Increment Data 
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Mirror จะทําซํ้าแบบกระจกเงาโดยกําหนดระนาบกระจกเงาในทิศทางขนานแกน X, Y, Z 

หรือระนาบในสามมิต ิ

 

 เมื่อสั่งทําซํ้าแบบเสนตรง dy = 4 แลวคลิกปุม Apply สังเกตในมุมมอง 3D จะเห็นเสาที่เพิ่มขึ้น 

 ทําซํ้าอีกสองคร้ังโดยคลิกปุม   หรือกด Ctrl+J เพ่ือเลือกวัตถุเดิม ใชระยะ dy = 6.5 แลว
ทําอีกครั้งใชระยะ dy = 10 แลวคลิกปุม OK จะไดเสาครบทุกตําแหนงดังในรูป 
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การวาดคาน Draw Beam 

ในขั้นตอนน้ีเราจะวาดคาน B20X40 โดยจะวาดผังคานในแตละชั้นซึ่งอยูในระนาบ X-Y ที่ความสูง Z 
@ 0.3 m และ 2.8 m 

 คลิกเลือกหนาตาง X-Z Plane แลวคลิกปุ ม    เปลี ่ยนเปนระนาบ X-Y แลวคลิกปุม 

  จนไดระนาบ X-Y @ Z = 0.3 

 

 คลิกปุม    Quick Draw Frame เลือกหนาตัด B20X40 แลวตีกรอบคลุมทั้งหมด 

 

 คลิกปุม    หรือกด Esc เพ่ือออกจากโหมดวาด กลับมาโหมดเลือกวัตถุ 
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 คลิกเลือกและลบคานระหวางจุด A1-A2 และ A1-B1 จะไดผังคานชั้นที่หนึ่ง 

 

 คลิกเคร่ืองหมาย    จนไดระนาบ X-Y @ Z = 3.3  

 วาดคานโดยคลิกปุม    เลือกหนาตัด B20X40 แลวตีกรอบคลุมเชนเดิม 

 คลิกปุม    หรือกด Esc เพ่ือออกจากโหมดวาด กลับมาโหมดเลือกวัตถุ 

 จากนั้นคลิกเลือกคานระหวางจุดตัดกริด A2-A3 สั่งทําซํ้า Replicate ไประยะ dx = 2 m 

 

 เล ือกหนาตางสามมิต ิ คลิกปุ ม  คลิกเลือก Apply to All Windows แลวคลิกแถบ 
General Option เลือกใหแสดง View Type แบบ Extrude เพ่ือใหแสดงขนาดหนาตัด 
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 เลือก View by Colors of > Sections ใหแสดงสีตามหนาตัด ซึ ่งเราสามารถกําหนดไดใน
หนาตางกําหนดหนาตัด  

 

 ถาตองการเปลี่ยนสี เลือกเมนู Define > Section Properties > Frame Sections เลือกหนา
ตัดแลวคลิกปุม Modify/Show Property แลวคลิกเปลี่ยน Display Color ตามตองการ 

 ลองเปลี่ยนคานเปนสีเขียวและเสาสีนํ้าเงิน โมเดลในหนาตาง 3D จะมีลักษณะดังในรูป 

  

 คลิกปุม  เลือกแถบ General Option > View Type > Standard ใหกลับมาแบบเดิม 
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 สั่งเมนู File > Save หรือกด Ctrl+S เพ่ือบันทึกขอมูล  

กําหนดหนาตัดพื้น Define Area Sections  

 สั่งเมนู Define > Section Properties > Area Sections… หรือคลิกปุม    บนทูลบาร 
หนาตาง Area Properties จะแสดงข้ึนมา 

 เลือกชนิดวัตถุเปน Shell แลวคลิกปุม Add New Section… 

 

ในหนาตางที่แสดงขึ้นมาจะมีพ้ืนใหเลือกหลายชนิดเชน Shell, Plate และ Membrane 
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สําหรับหนาตัด Shell มีแผน 4 ชนิดใหเลือกดังนี้ 
 Shell รับไดทุกแรง มีทั้งแบบ Thick และ Thin ใหเลือก 

 Plate จะรับเฉพาะโมเมนตดัดและแรงทางขวางมีท้ังแบบ Thick และ Thin 

 Membrane จะรับเฉพาะแรงในแนวระนาบและโมเมนตในทิศตั้งฉากกับแผน 

 Thick & Thin พฤติกรรมแบบแผนหนาหรือบาง แผนบางคิดเพียงการเสียรูปทรงจากการ
ดัด แผนหนาจะคิดผลของการเสียรูปทรงจากแรงเฉือนดวย มักใชกับแผนที่หนาเกิน 1/10 
ของขนาด 

ในตัวอยางนี้เรามีพื้นคอนกรีต S1 และ S2 ซึ่งเปนพื้นหลอในที่สองทางอาจเลือกเปน Shell-

Thin หรือ Membrane ก็ได ถาเลือกเปน Shell-Thin จะคิดสติฟเนสการดัดของพื้นมาชวยคานรับ
นํ้าหนัก ทําใหแรงในคานลดลง สําหรับบานที่อยูอาศัยซึ่งมีชวงสั้นและรับนํ้าหนักบรรทุกไมมากมักใช
พ้ืน Membrane 

ทิศทางแกนองคอาคารของแผน 

แตละแผนจะมีแกนองคอาคารเฉพาะที่คือแกน 1, 2 และ 3 โดยแกน 1 และ 2 จะอยูในระนาบของ
แผน และแกน 3 ตั้งฉากกับระนาบแผน 

 ระนาบแกน 3-2 จะอยูในแนวดิ่ง ขนานแกน +Z 

 แกน 2 จะชี ้ไปทิศ +Z นอกเสียจากวา แผนอยู ใน
แนวราบแกน แกน 2 จะชี้ไปทาง +Y 

 แกน 1 จะอยูในแนวราบ ในระนาบ X-Y 

ในกรณีของพื้นซึ่งระนาบอยูในแนวราบ แกน 2 ชี้ไปทิศ 
+Y, แกน 1 จะอยูในทิศ X และแกน 3 ในทิศ Z ดังในรูป 

 สรางพ้ืน S1 เปนชนิด Membrane หนา 0.12 ม. ดังในรูป 

 

Z

XY

12

3
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 เมื่อกด OK กลับมาในหนาตาง Area Sections จะมีรายการ S1 ถูกสรางข้ึนมา ใหคลิกปุม Add 

Copy of Section เพ่ือทําซํ้า ตั้งชื่อเปน S2 แลวเปลี่ยนความหนาเปน 0.1 m 

 

การวาดพ้ืน Draw Slab  

 ในหนาตาง X-Y Plane คลิกปุม    จนไดระนาบ X-Y @ Z = 0.3 

 คลิกปุม  คลิกแถบ General Options เลือก View Type > Standard และ General > 

Fill Objects เพ่ือใหแสดงพื้น และคลิกเลือก Apply to All Windows 

 คลิกปุม    จะเปนการวาดแผนอยางรวดเร็ว เลือกหนาตัด S1 แลวคลิกในชองกริดเพ่ือวาด
พ้ืน S1 ดังในรูป 
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 คลิกปุม    ในแถบ Object Options เลือกใหแสดง Areas > Sections และ Local Axes 

  

 

จะเห็นวาลูกศรสีแดงคือแกน 1 ชี้ไปทางแกน +X ลูกศรสีเขียว
คือแกน 2 ชี้ไปทางแกน +Y และลูกศรสีฟาคือแกน 3 ชี้ไปทาง
แกน +Z 

 คลิกเคร่ืองหมาย  จนไดระนาบ X-Y @ Z = 3.3 
แลววาดพ้ืน S1 และ S2  

 สําหรับ S2 ใหคลิก    ลากตีกรอบจนไดดังในรูป  

 

 

ในหนาตาง 3-D View จะมีลักษณะดังในรูป (Extrude View) 

 

 สั่งเมนู File > Save หรือกด Ctrl+S เพ่ือบันทึกขอมูล  
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การวาดบันได Draw Stair 

บันไดระหวางชั้นหน่ึงและสองจะเปนชองพ้ืนที่วางเวนไวระหวางเสนกริด 2-3 และ B-C โดยจะมีชาน
พักกลางความสูงชั้นที่ระดับ +1.80 m 

 
 คลิกปุม    เลือกเอาการแสดงผลตางๆออกเหลือเพียงท่ีจําเปน และ Fill Objects 

 สั่งเมนู Define > Coordinate Systems/Grids หรือคลิกขวาในพื้นที่วาง เลือกรายการ Edit 

Grid Data… แลวคลิกปุม Modify/Show System 

 คลิกปุม Add เพื่อเพิ่มแถวของตาราง Z Grid Data, ใสขอมูลเสนกริด Z1.5 ที่ระดับความสูง 
+1.80 m คลิกชองอ่ืนแลวคลิกปุม Reorder Ordinates เพ่ือจัดเรียงขอมูลตามตําแหนง 

 

เมื่อคลิก OK จนกลับมายังหนาจอโมเดลจะเห็นใน
หนาตาง 3-D View วามีเสนกริดเพิ่มขึ้นระหวางชั้น 

 คลิกหนาต าง X-Y Plane แลวเปล ี ่ยนเปน
ระนาบ Y-Z ที่เสนกริด C  

 คลิกเลือกคานชั้นลางระหวางจุด C2-C3 กด 
Ctrl+R หร ือ ส ั ่ ง เมน ู  Edit > Replicate ใส
ระยะ dz = 1.5 m 

4 m

3 m

1.5 m

2 m

+0.30 m

+3.30 m

+1.80 m

4 m

3 m

1.5 m

2 m

+0.30 m

+3.30 m

+1.80 m
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 เปลี่ยนมุมมองเปน X-Y Plane @ Z = 1.8 แลวคลิกเลือกคานชานพัก 

 สั่งเมนู Edit > Extrude > Extrude Lines to Areas กําหนดคาดังในรูป 

 

 คลิกเลือกคานชานพักอีกครั้ง กด Ctrl+R สั่งทําซํ้ามาท่ีระยะ dx = -2 m 

 คลิกเลือกคานท่ีถูกทําซํ้า สั่งเมนู Edit > Edit Lines > Divide Frames 

เพ่ือแบงคานออกเปนสองสวนเทากัน 
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 เลือกคานทอนลาง สั ่ง Extrude Lines to Areas ดวยระยะ dx = -2, dz = -1.5 และเลือก 
Delete Source Object เพ่ือใหลบคาน 

 

 เลือกคานทอนบน สั่ง Extrude Lines to Areas ดวยระยะ dx = -2, dz = 1.5 

 ในหนาตาง 3-D View จะเห็นบันไดดังในรูป 

 

 สั่งเมนู File > Save หรือกด Ctrl+S บันทึกขอมูล 
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โมเดลอาคารโครงเหล็ก  

ตัวอยางนี้จะเปนการสรางโมเดลโครงสรางเหล็ก โดยมีองคอาคารไดแก เสา คาน และ bracing เปน
หนาตัดเหล็กรูปพรรณดังแสดงในรูป 

 

 

 

 

 

 

 

 

 เทมเพลต 3D Frame  

 เริ่มตนโปรแกรม SAP2000 เปลี่ยนหนวยเปนหนวย Kgf, m, C 

 เริ ่มตนโมเดลใหม โดยกด Ctrl+N เลือกเริ ่มตนโมเดลจากไฟลที่มีอยู 
แลวคลิกปุม 3D Frames 

 

ป
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 เลือกไฟลจากตัวอยางท่ีแลวคือ EX2 House2F.sdb เพ่ือใชเปนตนแบบ 

 ในหนาตาง 3D Frames จะใหเลือกชนิดโครง และขอมูลตางๆดังในรูป 

 

เมื่อกด OK โมเดลจะถูกสรางขึ้นดังในรูป 

 

 กด Ctrl+S เพ่ือบันทึกขอมูล ตั้งชื่อไฟลวา EX3 Steel Frame 

 ลองคลิกปุ ม    หนาตางวัสดุจะแสดงขึ้นมา จะมีรายการที ่เราเคยกำหนดไวแลวสาม
รายการ คือ Fc240, Fy2500 และ SD40  
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กําหนดหนาตัดเฟรม Define Frame Sections  

 เปลี่ยนหนวยเปน Kgf-mm แลวคลิกปุม    บนทูลบาร หนาตาง Frame Properties จะ
แสดงขึ้นมา โดยจะมีหนาตัดของไฟลเดิมที่เคยสรางไว 

 คลิกปุม Add New Property เลือกชนิดหนาตัด Steel แลวเลือกหนาตัด I / Wide Flange 

 ใสขอมูลของหนาตัด W300X94 โดยใสคาขนาดตางๆลงตามชองที่กำหนดดังในรูป 

 

 

 

 

 

 กดปุม Section Properties… เพ่ือดูคุณสมบัติตามที่โปรแกรมคำนวณจากขอมูลที่ใสเขาไป 
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 เมื่อคลิก OK จนกลับมาที่หนาตาง Frame Properties จะมีรายการหนาตัด W300X94 แสดง
ขึ้นมา ดังในรูป 

 

ในการออกแบบโดยใหโปรแกรมเลือกหนาตัดเหล็กโดยอัตโนมัติเรียกวา Auto Select จะตองสราง
รายการเหล็กจำนวนมาก ซึ่งอาจไมสะดวกที่จะมาใสขอมูลทีละหนาตัด ถึงแมวาจะสามารถดึงขอมูล
จากไฟลที่มีอยูเดิมก็ตาม 

เราสามารถนำเขาขอมูลหนาตัดจากภายนอกโดยมีใหเลือกทั้งแบบ Property Files (*.xml), 
(*.pro) และ FWP Sections File (*.ssc) โดยคลิกปุม Import New Property… คลิกเลือกหนาตัด
ที่ตองการ แลวเลือกไฟลหนาตัดที่อยูในโฟลเดอร ของโปรแกรม SAP2000 ซึ่งจะมีใหเลือกตาม
มาตรฐานของประเทศตางๆมากมาย แตไมมีประเทศไทย หรือญ่ีปุน 
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เพื่อใหสามารถใชหนาตัดไทยไดโดยสะดวก ผูเขียนจึงไดจัดสรางตารางหนาตัดไทยตาม
มาตรฐาน มอก. ซ่ึงเปนไฟล Property Files (*.pro) โดยจะมีไฟลดังนี้ 

 

TH_WF.PRO 

หนาตัดเหล็กตัวเอชหรือ Wide Flange 

 

TH_CHNL.PRO  หนาตัดเหล็กรูปรางน้ำ 
TH_C.PRO  หนาตัดเหล็กรูปตัวซี 

 

TH_WT.PRO 

หนาตัดเหล็กรูปตัวที 

 

TH_ANGLE.PRO 

หนาตัดเหล็กฉาก 

 

TH_2ANGLE.PRO 

หนาตัดเหล็กฉากคู 

 

TH_2CHNL.PRO 

หนาตัดเหล็กรางน้ำคู 

 

TH_PIPE.PRO หนาตัดทอกลม 

TH_ROUNDBAR.PRO หนาตัดเหล็กเสนกลม 

 

TH_SQRT.PRO  หนาตัดกลองสี่เหลี่ยมจัตุรัส 

TH_RECT.PRO  หนาตัดกลองสี่เหลี่ยมผืนผา 
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 นำไฟลหนาตัดมาวางในโฟลเดอรของโปรแกรม SAP2000 

 

 คลิกไอคอนเพ่ือ import หนาตัด WF จากไฟล TH_WF.PRO เลือกนำเขาหนาตัดดังในรูป 

 

ไฟลหนาตัด *.pro เปนไฟลรูปแบบเกาที่ใชกันมานานแลว SAP2000 เวอรชั่น 24 ยังคงใชได
อยู แตมีการแจงเตือนใหเปลี่ยนไปใชไฟลหนาตัด *.xml โดยไฟล *.pro จะคอยๆลดการใชงานลงใน
เวอรชั่นตอไป อยางไรก็ตามใน SAP2000 V24 ยังไมสามารถสงออกหนาตัดเปนไฟล *.xml ได แต
สามารถใชไฟลหนาตัดที่สรางและสงออกจากโปรแกรม ETABS ได ซึ่งผูเขียนจึงไดจัดสรางตาราง
หนาตัดไทยตามมาตรฐาน มอก. ซึ่งเปนไฟล Property Files (*.xml) โดยจะมีไฟลดังนี้ 
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TH_WF.XML 

หนาตัดเหล็กตัวเอชหรือ Wide Flange 

 

TH_CH.XML  หนาตัดเหล็กรูปรางน้ำ 

 

TH_PIPE.XML หนาตัดทอกลม 

 

TH_SQRT.XML  หนาตัดกลองสี่เหลี่ยมจัตุรัส 

TH_RECT.XML  หนาตัดกลองสี่เหลี่ยมผืนผา 

 นำไฟลหนาตัดมาวางในโฟลเดอรของโปรแกรม SAP2000 > Property Libraries > Sections 

 

 สั่งเมนู Define > Section Properties > Frame Sections คลิกปุม Import New Property 

 คลิกปุมหนาตัด I / Wide Flange เลือกไฟล TH_WF.xml 
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 คลิกปุม Open เลือกหนาตัดที่จะนำเขาไดแก (กดปุม Ctrl เพ่ือคลิกเลือกหลายหนาตัด) 

W200X200X49.9 

W300X300X94  และลบหนาตัด W300X94 เนื่องจากซ้ำกัน 

W350X350X106 
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กําหนดหนาตัด Assign Frame Sections  
 คลิกขวาท่ีเสาและคานในหนาตาง 3D จะเห็นวาถูกกำหนดเปนหนาตัด C20X20 และ B20X40 

 

ในการเปลี่ยนเสามาเปนหนาตัดเหล็ก W300X300X94 เราจะเลือก (select) เสาท้ังหมดกอน 
จากนั้นจึงกำหนด (assign) ใหมีคุณสมบัติตามตองการ ซึ่งการเลือกวัตถุที่มีจำนวนมากอาจใชคำสั่ง
ชวยในการเลือกในเมนู Select ซึ่งในกรณีนี้เราตองการเลือกเสาซ่ึงเปนองคอาคารในแนวดิ่ง 

  สั ่งเมนู Select > Select Select Lines Parallel To Click Straight Line Object แลว
คลิกท่ีเสาตนหนึ่ง เสาทุกตนซึ่งขนานกับเสาตนนี้จะถูกเลือกหมด 
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 สั่งเมนู Assign > Frame Frame Sections 

เลือกหนาตัด W350X350X106  

 

 

 

 

 

 

 

 

 สั่งเมนู Assign > Clear Display of Assigns เพ่ือปดการแสดงหนาตัด 

 คลิกปุม    หรือกด Ctrl+J เพื่อเลือกเสาอีกครั้ง สั่งเมนู Assign > Assign to Group หรือ

คลิกปุม  บนทูลบารดานบน หรือกด Ctrl+Shift+G  

 ในหนาตาง Assign to Group คลิกปุม Define Groups เพ่ือต้ังกลุมใหม 

 ในหนาตาง Define Group Names คลิกปุม Add New Group  

 

 ตั้งชื ่อวา All Columns ในหนาตาง Group Definition ที่แสดงขึ้นมา โดยเราสามารถเลือก
หัวขอที่จะใชงานกลุมได เชนเลือกรายการ Selection เพ่ือใชในการเลือกเปนกลุม 

6
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 เมื่อคลิกปุม OK ในหนาตาง Assign to Groups จะมีชื่อกลุม All Columns ที่เราตั้งไวแสดง
เพ่ิมเขามา จากนั้นคลิกเลือกรายการ All Columns กดปุม Apply แลวกด OK 

 

 ในครั้งตอไปที่ตองการเลือกเสา ใหสั่งเมนู Select > Select Groups หรือกด Ctrl+G เลือก
กลุมท่ีตองการคือ All Columns แลวคลิกปุม Select 
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 เลือกคานทั้งหมดซึ่งจะอยูในระนาบราบ X-Y โดยสั่งเมนู Select > Select Select Lines 

Parallel To Coordinate Axes or Plane เลือก X-Y Plane 

 

 คลิกปุม Select แลวตามดวย Close คานทั้งหมดจะถูกเลือกดังในรูป 

 

 กด Ctrl+Shift+G คลิกปุม Define Groups > Add New Group สรางกลุม All Beams แลว
กดปุม Apply 
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 กด Ctrl+G เล ือกกลุ มคาน All Beams แลวสั ่งเมนู Assign > Frame Frame Sections 

กำหนดใหเปนหนาตัด W300X300X94 

 คลิกปุม    เลือกใหแสดง Extrude View, Color by Sections และเลือก Apply to All 

Windows และสั่งเมนู Options > Graphic Mode > Direct X ใหแสดงโมเดลแบบสวยงาม 

 

ถาสังเกตจะเห็นวาทิศทางแกน 2 ของหนาตัดเสาจะชี้ไปทางแกน +X 

 สั่งเมนู Options > Graphic Mode > Classical Plus ใหแสดงกราฟกแบบเดิม 

 คลิกปุ ม    เล ือก General Options > View Type > Standard และ Apply to All 

Windows 
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 เลือกใหแสดง Frames > Local Axes แลวคลิกปุม Apply  

 

แกนองคอาคารจะถูกแสดงโดยลูกศร สีแดง = แกน 1, สีเขียว = แกน 2 และ สีฟา = แกน 3 

  

 ปดการแสดง Frame Local Axes เลือก Apply to All Windows แลวกดปุม OK 

การเปลี่ยนทิศทางแกนเฉพาะท่ี Change Local Axes 
 

Z

Y X

1

3 2
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 เราสามารถเปลี่ยนทิศทางของหนาตัดไดโดยเลือกเสา กด Ctrl+G เลือกกลุม All Columns กด
ปุม Select แลวตามดวย Close เพ่ือเลือกเสาท้ังหมด 

 

 สั่งเมนู Assign > Frame Local Axes ใสคามุมหมุนทิศทวนเข็มนาิกา 90 องศา 

 

 

2

3
90o CCWX

Y

2

3

Default Direction Rotate 90o CCW
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 สั่งเมนู Assign > Clear Display of Assigns เพ่ือปดการแสดงแกนเฉพาะที่ 

 เราสามารถดูทิศทางหนาตัดเสาที่ชัดเจนขึ้นโดย คลิกเลือกหนาตาง 3-D View กด Ctrl + J 

หรือคลิกปุม    เพ่ือเลือกเสาอีกครั้ง 

 สั่งเมนู View > Show Selection Only หรือกด Ctrl+Shift+J เพ่ือใหแสดงเฉพาะเสา 

 คลิกปุม    คลิกแถบ General Options คลิกเลือก View Type > Extrude  

 สั่งเมนู View > Set 3D View คลิกปุม xy เพ่ือใหแสดงมุมมองระนาบ X-Y 

 

 คลิกปุม    กลับมามุมมองสามมิติเดิม แลวสั่งเมนู View > Show All ใหแสดงทุกองค

อาคารดังเดิม และคลิกปุม    เปลี่ยน View Type กลับมาเปนแบบ Standard 
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การปลดยึดรั้งของจดุตอ Assign Frame Release 

 ลองคลิกขวาที่คานจะพบวาหนาตัดเปน W300X300X94 รายการถัดลงมาในชอง Release 

และ Partial Fixity จะเปน None แสดงวาจุดตอท่ีปลายคานเปนแบบตอเนื่อง  

 

จุดตอระหวางคานและเสาในโครงสรางจะมีทั้งแบบจุดหมุน (Simple Connection) และ
แบบโมเมนต (Moment Connection) ในตัวอยางนี้ สมมุติวาเราตองการใหคานในทิศทาง X 
ใชจุดตอแบบจุดหมุน และคานในทิศทาง Y ใชจุดตอแบบโมเมนต ดังแสดงในรูป 

 

 เล ือกคานทั ้งหมดในทิศทาง X โดยส ั ่ งเมน ู Select > Select Select Lines Parallel 

To Click Straight Line Object แลวคลิกท่ีคานทิศทาง X 

 กด Ctrl+Shift+G คลิกปุม Define Groups… คลิกปุม Add New Group ตั้งชื ่อกลุมวา All 

Beams X เลือกรายการ แลวคลิกปุม OK 

Simple connection

Moment connection
X

Y
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 กด Ctrl+G เล ือกกลุ ม All Beams X สั ่งเมนู Assign > Frame Releases/Partial Fixity 

หนาตาง Assign Frame Releases ที่แสดงขึ้นมาจะใหเรากำหนดดีกรีที่ตองการปลดปลอยที่
ปลายคาน หรือใสคาคงท่ีสปริงสำหรับจุดตอแบบก่ึงแข็ง (Semi-rigid Joint) 

 

Moment 33 (Major)  คือโมเมนตดัดรอบแกน 3 ขององคอาคาร เปนแกนหลัก
ซ่ึงรับน้ำหนักในแนวดิ่งจากแรงโนมถวง 

Moment 22 (Minor)  คือโมเมนตดัดรอบแกน 2 ขององคอาคาร เปนแกนรอง
ซึ่งรับแรงในแนวราบจากแรงลมหรือแรงแผนดินไหว  

Torsion  คือโมเมนตบิดรอบแกน 1 ขององคอาคาร จะปลดปลอยเพียงปลายเดียว
เพ่ือหลีกเลี่ยงการเสียเสถียรภาพเม่ือรับน้ำหนักไมสมดุล เชนในกรณีของคานขอบ 

เมื่อกด OK ในหนาตาง X-Y Plane จะแสดงเปนสัญลักษณจุดหมุนที่ปลายคาน 

2

3
Torsion

2

3
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 ลองคลิกขวาที่คานทิศทาง X ตัวหนึ่งดู ในหนาตางขอมูลจะเห็นวามีการปลดปลอยที่ปลาย 

 

 

ในการวาดคาน หนาตางที่ใหเลือกหนาตัดจะมีทางเลือก Moment Releases ใหเลือกวาเปน 
แบบตอเนื่อง (Continuous) หรือแบบจุดหมุน (Pinned) ซึ่งจะทำไดสะดวกกวา 

การวาดคานยอย Draw Secondary Beam 

ผังคานของเราตอนนี้แตละชองมีขนาด 6 m x 6 m สมมุติวาเราตองการวาดคานยอย 1 ตัวใน
แนวด่ิงลงที่ก่ึงกลางทุกชอง 
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 คลิกปุม    เลือกหนาตัดคาน W300X300X94 เลือก Moment Releases แบบ Pinned 

แลวตีกรอบคลุมทั้งหมดในระนาบ X-Y Plane @ Z = 3  

 

คานยอยจะถูกสรางขึ้นในทุกชองของผังคานดังในรูป  

 

 กด Esc ออกจากโหมดวาด แลวคลิกขวาท่ีคานยอยตัวหนึ่ง จะเห็นในหนาตางขอมูลคือ 
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Releases End-I T, M2, M3 

Releases End-J M2, M3 

เชนเดียวกับท่ีเราไดเคยกำหนดมากอนหนานี้ 

 คลิกปุม    เปดการแสดง Frames > Releases  

 

 ปดการแสดง Releases แลวคลิกปุม    ขึ้นมาท่ีระนาบ X-Y Plane @ Z = 6 เพ่ือวาดคาน
ยอยโดยวิธีการเดิม 

การวาดแกงแนง Draw Braces 

เนื่องจากเราปลดปลอยปลายคานในทิศทาง X เปนจุดหมุน ดังนั้นจึงตองใชแกงแนง (Bracing) มาค้ำ
ยันไวเพื่อใหโครงมีเสถียรภาพและตานทานแรงดานขาง 

 คลิกปุม    เพ่ือเปลี่ยนมุมมอง แลวคลิกปุม  จนไดระนาบ Plane X-Z @ Y = -6 

บนเสนกริด 1  

 คลิกปุม    เลือกหนาตัด ชนิดของแกงแนง แลวตีกรอบคลุมชองที่ตองการวาด 
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 คลิกปุ ม  จนไดระนาบ Plane X-Z @ Y = 6 บนเสนกริด 3 แลววาดแกงแนงโดย
วิธีการเดิม 

 

 กด Ctrl+S บันทึกขอมูลไฟล EX3 Steel Frame.sdb 

การวาดหลังคาโครงถัก Draw Roof Truss 

สมมุติวาเราตองการวาดหลังคาโครงถักเพิ่มขึ้นบนโครงเหล็กเดิม  โดยจะเพิ่มขึ้นมาอีกหนึ่งชั้นแลว
วาดเสาและโครงถักขางซายขึ้นมากอนดังในรูป 

 

 ในโมเดล EX3 Steel Frame เดิม สั่ง File > Save As ตั้งชื่อใหมวา EX3 Roof Truss 
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 แกไขเสนกริดโดยคลิกขวาในพ้ืนที่วางในหนาตางแสดงโมเดล เลือก Edit Grid Data… 

 ในหนาตาง Coordinate/Grid Systems คลิกปุม Modify/Show System… 

 

 ในตาราง Z Grid Data เพ่ิมเสนกริด Z ที่ระดับ 9 และ 11.5 เมตร ดังในรูป 

 

 เมื่อกด OK แลวเปลี่ยนมุมมองเปน Y-Z Plane @ X = -9 บนเสนกริด A จะมีเสนกริดเพ่ิมขึ้นท่ี
ดานบนของโครงสรางดังในรูป 

Z = +9.75

Y = -6.0 Y = 0.0

0.75

1.0 6.0

1.5

1.0

3.0

Z = +6.0

Z = +9.0

Z = +11.5
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 คลิกปุม    เลือก Import New Property  

คลิกปุมหนาตัด Pipe โดยเลือกไฟล TH_PIPE ที่มีหนาตัดทอกลมอยู 

 เลือกนำเขาหนาตัด PIPE2-1/2(65)X3.2 และ PIPE3(80)X3.2 (กด Ctrl คางเพื่อเลือกหลาย
หนาตัด) 

 

 คลิกปุม Import New Property  

คลิกปุมนำเขาหนาตัด Tube 
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 อาจมีขอความเตือนวาไมมีหนาตัดเนื่องจากโปรแกรมไปหาในไฟลทอกลมเดิม 

 

 เมื่อกลับมาหนาตาง Box/Tube Section คลิกปุม Open File เพ่ือเลือกหนาตัดไฟลใหม 

 

 เลือกไฟลนำเขาใหม TH_SQ แลวเลือกหนาตัด HSS200X200X8.0 จะไดรายการดังในรูป 

 

 คลิกปุม    เลือกหนาตัด HSS200X200X8.0 คลิกวาดเสาขางซาย 

 คลิกปุม    เขาโหมดเลือกวัตถุ แลวคลิกเลือกจุดที่ปลายบนหัวเสาดังในรูป 
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 สั่งเมนู Edit > Extrude > Extrude Points to Frames เลือกหนาตัด PIPE3(80)X3.2 ใสระยะ 
dy = -1 m แลวคลิกเลือกปลายเสนยื่น สั่งอีกครั้งดวยระยะ dz = 0.75 

       

 คลิกปุม    เลือกหนาตัด PIPE3(80)X3.2 วาดจันทันเอียงดังในรูป 
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 คลิกเลือกเสนจันทันเอียง สั่งเมนู Edit > Edit Lines Divide Frames เลือกแบงเปน 7 ชวง
เทาๆกัน  

 

 คลิกปุม    ไมเลือกชอง Joints > Invisible เพ่ือเปดการแสดงจุดตอปลายองคอาคาร 

 

 ตีกรอบเลือกบางสวนดังในรูปขางบน กด Ctrl+R เพ่ือทำซ้ำลงมา dz = -1 จะได 

 

 คลิกปุม    เลือกหนาตัด PIPE2-1/2(65)X3.2 แบบ Pinned วาดสวนทอนถักดิ่งและทแยง 

 

 เลื่อนตัวชี้มาท่ีจุดยอดโครงถักบนเสนกริด A-2 จะไดพิกัด Y = 0 ซึ่งเราจะใชเปนกระจกเงา 

 ตีกรอบเลือกเสาและโครงถักยกเวนทอนดิ่งบนเสนกริด A-2 
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 สั่งเมนู Edit > Replicate หรือกด Ctrl+R เลือกแบบ Mirror เปนระนาบขนานแกน X และ
กำหนดพิกัด Y = 0 

 

โครงถักจะถูกทำซ้ำแบบกระจกเงากับระนาบท่ีเสนกริด A-2 ดังในรูป 
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 คลิกปุ ม    เปลี ่ยนมุมมองเปนระนาบ X-Z แลวกดปุ ม    มา @ Y = 0 บน
เสนกริด 2 เพื่อวาดโครงถักรอง 

 คลิกปุม    แลวเลือกหนาตัด PIPE 3(80)X3.2 แบบ Pinned วาดเสนนอนบนสุดจาก A-2 

ไปยัง B-2 แลว Ctrl+R ลงมา dz = -1  

 

 คลิกเลือกท้ังสองเสน สั่งเมนู Edit > Edit Lines Divide Frames เลือกแบงเปน 6 ชวง 

 คลิกปุม    แลวเลือกหนาตัด PIPE 2-1/2(65)X3.2 แบบ Pinned วาดเสนดิ่งและทแยง 
(คลิกซายลากเสน, คลิกขวาหยุดวาด และ กด Esc ออกจากโหมดวาด) 

 

 ตีกรอบเลือกโครงถักรองที่สรางข้ึน กด Ctrl+R เพ่ือทำซ้ำออกไปท้ังสองขางโดยใชระยะ dy = 6 

และ -6 ระยะ dz = -1.5 (ในเวอรชั่นเกาหามกดปุม  เพ่ือเลือกซ้ำ จะทำใหเกิดจุดตอลอยๆ 
แตสำหรับ V21 สามารถกด Ctrl+J ได)  
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 คลิกปุม    เลือกชอง Joints > Invisible เพ่ือปดการแสดงจุดตอปลายองคอาคาร 

 

 คลิกหนาตาง 3-D View สั่งเมนู View > Set 3D View คลิกปุม xz ใหแสดงมุมมองสามมิติใน
ระนาบ X-Z เพ่ือใหตีกรอบเลือกโครงถักทั้งหมดท่ีสรางขึ้นได 
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 สั่ง Replicate โดยกด Ctrl+R ใสระยะ dx = 6 , จำนวนที่ทำซ้ำ = 3 จะไดโครงดังในรูป 

 

 กดปุม Shift และลูกลอของเมาส หมุนโมเดลเล็กนอย เพ่ือตีกรอบเลือกโครงรองสวนที่เกิน 

 

 กด Delete เพ่ือลบโครงสวนเกินท่ีเลือก แลวคลิกปุม  ใหแสดงมุมมองสามมิติ 

 คลิกปุม    เลือกใหแสดง View Type แบบ Extrude  

 สั่งเมนู View เลือกเอา Show Axes และ Show Grid ออกจะไดโครงถักดังในรูป 

 

 กด Ctrl+S บันทึกขอมูลไฟล EX3 Roof Truss 
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การวาดโครงหลังคาจันทัน Draw Roof Rafter 

สมมุติวาเราตองการวาดโครงหลังคาจันทันของตัวอยางบานพักอาศัยเดิมดังในรูป 

 

 เปดโมเดล EX2 House2F เดิม สั่ง File > Save As ตั้งชื่อใหมวา EX2 House Roof 

 แกไขเสนกริดคลิกขวาในพื้นที่วางเลือก Edit Grid Data แลวคลิกปุม Modify/Show System 

ในหนาตาง Coordinate/Grid Systems ที่แสดงขึ้นมา เพ่ิมเสนกริด X, Y และ Z ดังในรูป โดย
คลิกปุม Add ใสคาแลวคลิกชองอ่ืน จากนั้นกดปุม Reorder Ordinates ใหเรียงพิกัด 
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 คลิก OK จนกลับมาที่หนาจอหลัก ระบบกริดที่เปลี่ยนแปลงจะเปนดังในรูป 

 

 คลิกปุ ม    เล ือก Import New Property เล ือกหนาตัด Tube เพื ่อนําเขาหนาตัด 

HSS125X50X3.2 จากตารางหนาตัดไทยคือ TH_RECT จนไดรายการหนาตัดดังในรูป 

 

 ปรับมุมมองหนาตางสองมิติ มาที ่ X-Y Plane @ Z = 6.3 คลิกปุ ม    เลือกหนาตัด 
HSS125X50X3.2 วาดโครงจันทันดังในรูป 
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 คลิกเลือกตะเฆสัน(เสนเอียง)ท้ังสอง สั่ง Replicate โดยกด Ctrl+R แบบ Mirror ที่ระยะ Y = 5 

 

 คลิกปุม    เลือกหนาตัด HSS125X50X3.2 วาดเสนดิ่งเชื่อมมุมแหลมทั้งสองขาง กด Esc 

ออกจากโหมดวาด แลวคลิกเลือกจุดทีต่ัดทั้งสองจุดดังในรูป 
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 สั่งเมนู Edit > Move หรือกด Ctrl+M ยายจุดทั้งสองขึ้นไป dz = 2 สันหลังคาจะถูกยกขึ้นดัง
จะเห็นไดจากในมุมมอง 3-D View  

 

 คลิกปุม    Set Display Options… คลิกไมเลือกชอง 
Joint > Invisible เพ่ือใหแสดงจุดตอ 

 แบงแตละทอนของโครงหลังคาเปนสวนๆเพื่อวางจันทัน
ระยะหาง 1 m โดยคลิกองคอาคารแลวสั่ง Edit > Edit 

Lines > Devide Frames แลวกําหนดจํานวนที่จะแบง
ดังนี้ 

X-Y Plane @ Z = 6.3 

- องคอาคารในทิศทาง X (แนวนอน) แบงเปน 10 สวน 

- องคอาคารในทิศทาง Y (แนวนอน) แบงเปน 12 สวน 
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Y-Z Plane @ X = 4 

- สันหลังคา (เสนนอนบนสุด) แบงเปน 2 สวน 

 

3-D View 

- สั่งเมนู View > Set 3D View ใชมุม Aperture = 0 กดปุม yz 

- ตีกรอบเลือกโครงขางลาง  
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- สั ่งเมนู View > Remove Selection From View เพื ่อปดการแสดงโครงอาคาร
ขางลางเพื่อความสะดวกในการวาดโครงหลังคา 

 

- สั่งเมนู View > Set 3D View กดปุม xy  

- สั่งเมนู View > Show Grid หรือกด Ctrl+D เพ่ือปดการแสดงกริด 

- เลือกตะเฆสัน (เสนเอียงท้ัง 4 เสน) แบงเปน 5 สวน 
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 คลิกปุม    เลือกหนาตัด HSS125X50X3.2 วาดจันทัน บางสวนดังในรูป 

 

 คลิกเลือกจันทันที่วาด ยกเวนเสนดิ่งตรงกลาง สั่ง Replicate โดยกด Ctrl+R ไปขางขวา  
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 คลิกเลือกจันทันที่วาด ยกเวนเสนนอนตรงกลาง สั่ง Replicate โดยกด Ctrl+R ไปขางบน 

   

 วาดอะเสโดยคลิกปุม    เลือกหนาตัด HSS125X50X3.2 แลววาดเสนเปนสี่เหลี่ยม ระหวาง
จุดตอภายในจุดแรกจากขอบนอกบนตะเฆสัน  
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 ตีกรอบคลุมเลือกทั ้งหลังคา สั ่งเมนู Edit > Edit Lines > Divide Frames เลือก Break at 

intersections with selected Joints, Frames, Area Edges and Solid Edges 

 ลบเสนส่ีเหลี่ยมกรอบนอกออก โดยการตีกรอบคลุมจากซายไปขวาทีละดานแลวกด Delete ลบ
เสนขอบทั้งสี่ดาน 

 

 คลิกปุม    Set Display Options… คลิกเลือกชอง Joint > Invisible ปดการแสดงจุดตอ 

 คลิกปุม    เพ่ือเปลี่ยนเปนมุมมองสามมิติดั่งเดิม 

 สั ่งเมนู View > Show Grid, View > Show Axes และ View > Show All เพื ่อใหกล ับมา
แสดงทุกอยางเหมือนเดิม 

 คลิกปุม    Set Display Options เลือกใหแสดง Fill Objects และ Extrude View 
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การวาดเสาช้ันท่ีสองรับโครงหลังคา Draw 2nd Floor Column 

 เปดการแสดงจุดตอและปดการแสดงหนาตัด คลิกหนาตางสองมิติแลวกดปุม    และ  

  จนไดมุมมอง Y-Z Plane @ X = 0 แลวคลิกปุมสแนปต้ังฉาก    

 คลิกปุม    เลือกหนาตัดเสา C20X20 ลากเสนวาดเสาชั้นที่สองดังในรูป 

 

 ตีกรอบจากขวาไปซายเลือกเสาท้ัง 4 ตนที่เพิ่งวาด  

 

 ใชคําสั่ง Replicate โดยกด Ctrl+R เพื่อทําซํ้าไปยังตําแหนงที่เหลือ โดยใชระยะ dx = 4 และ
จํานวนทําซํ้า = 2 
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 เสาจะถูกทําซํ้าจนครบทุกตน เมื่อปดการแสดงจุดตอแลวเปด Extrude View ในมุมมองสามมิติ
จะเปนดังในรูป 

 

 ในหนาตางสองมิติคลิกปุม    จนไดมุมมอง Y-Z Plane @ X = 4 

 

จะเห็นวาปลายบนของเสาท่ีกริด B-2 และ B-3 ยังไมรองรับหลังคา 
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 คลิกปุม    เลือก Import New Property เลือกหนา
ตัด Tube คลิก Cancel แลวกด Open File เลือกไฟล 
ตารางหน  าต ัด ไทย  TH_SQ เพ ื ่ อน ํ า เข  าหน  า ตั ด 

HSS100X100X3.2 

 คลิกปุม    เลือกหนาตัด HSS100X100X3.2 ลากเสนวาดคานและดั้งดังในรูป 

 

 ในมุมมอง 3-D View จะไดรูปโมเดลบานพักอาศัยสองชั้นและหลังคาดังในรูป 
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จุดรองรับและน้ำหนักบรรทุก 
ในบทนี้จะกลาวถึงการใสน้ำหนักบรรทุกรูปแบบตางๆไดแกน้ำหนักกระทำเปนจุด น้ำหนักแผเชิงเสน 
และน้ำหนักแผบนพ้ืนที่ นอกจากน้ันยังมีการใสน้ำหนักบรรทุกแบบอัตโนมัติ ไดแก แรงลม และ แรง
แผนดินไหว เพื่อความสะดวกเราจะสรางโมเดลอาคารอยางงายขึ้นมาโดยใชขอมูลวัสดุและหนาตัด
จากไฟล EX2 House2F ซึ่งไดกำหนดไวในบทที่แลว 

 เริ่มตน SAP2000 ใชหนวย Kgf, m, C สรางโมเดลใหม โดยกด Ctrl+N  

 ในหนาตาง New Model เลือก Initialized Model from an Existing File กดปุม 3D Frames 
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 เลือกไฟล EX2 House2F แลวกำหนดขนาดตางๆและหนาตัดดังในรูป 

 

 คลิกปุม    เลือกใหแสดงจุดรองรับ  Joints > Restraints และ Apply to All Windows 

 

การกําหนดจุดรองรับ Support 

จะเห็นวาจุดรองรับในมุมมองสามมิติเปนรูปสามเหลี่ยมซึ่งเปนจุดรองรับแบบจุดหมุน 

 ในหนาตาง X-Y Plane @ Z=0 คลิกขวาท่ีจุดรองรับจุดหนึ่งเพื่อใหแสดงขอมูลของจุด 
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ดูที่รายการ Restraint จะแสดงวา u1, u2, u3 หมายถึงการเคล่ือนที่ในทิศทาง 1, 2 และ 3 ถูกยึดรั้ง
ไว โดยปกติแลวแกนของจุดตอ 1-2-3 จะตรงกับแกนระบบ X-Y-Z ดังจะเห็นในรายการ Local Axes 

ถัดมาแสดงวา Default ซึ่งเราสามารถกำหนดแกนจุดตอได เชนในกรณีท่ีจุดตอ Roller เอียง  

 สมมุติวาเราตองการเปลี่ยนใหเปนจุดรองรับแบบ Fixed ใหตีกรอบเลือกจุดรองรับทั้งหมด 

 สั่งเมนู Assign > Joint > Restrains… หนาตาง Joint Restraints จะแสดงข้ึนมาใหกำหนดจุด
รองรับ ซึ่งจะเห็นวาการยึดรั้งมีท้ังหมด 6 ดีกรี ที่ถูกยึดไวคือ Translation 1-2-3  

 

 

ในกรอบ Fast Restraints จะมีปุมใหเรากดเลือกชนิดของจุดรองรับแบบรวดเร็วคือ 

 

Fully supported 
จุดรองรับแบบ fixed ที่ทุกดีกรีถูกยึดรั้ง 

 
Pinned 
จุดรองรับแบบจุดหมุน ทุกดีกรีการเคล่ือนที่ถูกยึดรั้ง 

X

Z

Y

1

2

3

u2
r2

u3
r3

u1

r1
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Roller 
จุดรองรับลอหมุน ยึดรั้งเฉพาะดีกรีการเคล่ือนที่ Z 

 
Fully free 
จุดอิสระ ทุกดีกรีไมมีการยึดรั้ง 

 คลิกปุม    เพื่อเลือกจุดรองรับแบบยึดแนน แลวกด OK สังเกตจุดรองรับในมุมมองสาม
มิติจะเปลี่ยนเปนรูปสี่เหลี่ยม 

 

 คลิกขวาดูขอมูลจุดรองรับใหมจะเห็นวามีการยึดรั้งเพ่ิมข้ึนคือ r1, r2, และ r3 

 

 กด Ctrl+S เพ่ือบันทึกขอมูลตั้งชื่อไฟลวา EX4 Simple RC 
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การโมเดลฐานราก SAP2000 V22 

SAP2000 V22 เพ่ิมคำส่ังสรางฐานรากไดอยางสะดวกรวดเร็วโดยผูใชใสคาพารามิเตอรตางๆ 

 สั่งเมนู File > Save As ตั้งชื่อไฟลใหมวา EX4 RC Footing 

 สั่งเมนู Define > Foundation Properties  

 

 ในหนาตางชนิดฐานรากใหคลิกเลือกฐานรากเด่ียว (Isolated Footing) แลวคลิกปุม OK 

 

 ตั้งชื่อและใสขนาดตางๆของฐานราก 

F1 = 2.0 x 2.0 x 0.5 m 
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 จากนั้นคลิกที่หลังรายการ Layer Properties 

 กำหนดคา Subgrade Modulus และคา Shear Factor ของพ้ืนดิน 
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 คลิก OK จนกลับมาที่หนาตาง Define Foundation Properties จะมีรายการ F1 ถูกสรางข้ึน 

 

 คลิกปุม Add Copy of Foundation สรางฐานราก F2 และ F3 ดังนี้ 
F2 = 2.5 x 2.5 x 0.5 m และ F3 = 3.0 x 3.0 x 0.5 m 

  

 คลิกหนาตาง Plan View กดปุม    ลงมาที่ชั้นจุดรองรับ Z = 0 ตีกรอบคลุมเลือกท้ังหมด 
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 สั่งเมนู Assign > Joints > Restraints… ปลดลอคทุกดีกรีอิสระ 

 

 เลือกหนาตาง 3-D View กด Ctrl+A เลือกทั้งหมด สั่งเมนู View > Remove Selection from 

View เพ่ือซอนโครงสรางทั้งหมดชั่วคราว 

 สั่งเมนู View > Set 3-D View คลิกปุม xy ใสคามุม Aperture = 0 deg 

 



 

SAP2000  C4 Supports & Loadings Mongkol  JIRAVACHARADET 115 
 

 สั่งเมนู Draw > Draw Isolated Foundation เลือกฐานราก F1 แลวคลิกวาดฐานรากที่มุมทั้ง
สี่ของแปลนอาคาร 

 

 วางฐานราก F2 ที่จุดตัดกริดที่เหลือตามขอบอาคาร และวาง F3 ที่จุดติดกริดภายใน 

 

 คลิกปุม    แสดงมุมมองสามมิติดั้งเดิม สั่งเมนู View > Show All 
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 คลิกปุม    เลือกใหแสดง General Options > Extrude 

 

 กด Ctrl+S เพ่ือบันทึกขอมูล 

การกําหนดรูปแบบและกรณีบรรทุก Load Patterns & Load Cases 

 เริ่มตน SAP2000 เปดไฟล EX4 Simple RC ที่ไดสรางเอาไว 

 สั่งเมนู Define > Load Patterns เพื่อกำหนดรูปแบบน้ำหนักบรรทุก ซึ่งจะมีหนึ่งรายการคือ 
น้ำหนักบรรทุกคงท่ี DEAD ซึ่งจะใช Self Weight Multiplier = 1 หมายถึงคิดน้ำหนักตัวเอง 

 

 เพิ่มน้ำหนักบรรทุกจร LIVE โดยพิมพและกำหนดคาในชองแถวบนสุด แลวคลิกปุม Add New 

Load Pattern เพ่ือสรางรายการ 
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 ลองสรางอีกรายการคือ SDL เลือกเปนแบบ Super Dead คือน้ำหนักบรรทุกคงท่ีเพ่ิมเติม 

รูปแบบบรรทุกแผนดินไหวอัตโนมัต ิ  

ใน SAP2000 แรงแผนดินไหวในแตละทิศทางจะตองกำหนดเปนรูปแบบบรรทุกแยกกัน เมื่อเลือก
ชนิดน้ำหนักบรรทุกเปน QUAKE ในชอง Auto Lateral Load Pattern จะทำงานโดยมีมาตรฐาน
ตางๆใหเลือก ซ่ึงแตละมาตรฐานจะมคีาพารามิเตอรท่ีใชในการคำนวณแตกตางกันไป 

 สรางรายการแรงแผนดินไหว EQKY เลือกแบบ QUAKE ในชอง Auto Lateral Load Pattern 

จะมีรายการใหเลือก User Coefficient ซึ่งจะใหผูใชกำหนดสัมประสิทธิ์เอง 

 

 คลิกรายการ EQKY แลวกดปุม Modify Lateral Load Pattern กำหนดคาดังในรูป 

-  ทิศทางแผนดินไหว  =  Global Y Direction 

-  สัมประสิทธิ์แรงเฉือนที่ฐาน  =  0.05 
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Global X & Y Direction  คือทิศทางของแรงแผนดินไหว ใหเลือกทิศทาง Y 

Ecc. Ratio (All Diaph.)  คือการกำหนดใหแรง
แผนดินไหวที่มากระทำเยื้องศูนย เชน 0.05 เทา
ของขนาดดานที ่ต ั ้งฉากกับแรงคือดาน X โดย
จะตองกำหนดพื้นเปนไดอะแฟรมดวย การเยื้อง
ศูนยที่ระบุจึงจะมีผล 

Override Diaph. Eccen. คือการกำหนดระยะเยื้องศูนยเพิ ่มในกรณีที ่อาคารมีรูปทรงไม
สม่ำเสมอในแนวราบเชน รูปตัว L  

Lateral Load Elevation Range คือชวงที่จะทำการคำนวณแรงดานขาง โดยใหโปรแกรม
คำนวณให หรือกำหนดชวงระดับความสูงเอง 

Base Shear Coeffient, C  คือคาสัมประสิทธิ์ที่คำนวณตามมาตรฐานคือ V = CW เมื่อ V คือ
แรงเฉือนที่ฐาน และ W คือน้ำหนักโครงสราง ดังนั้นคา C คือสัดสวนของแรงแผนดินตอน้ำหนัก
โครงสราง ตัวอยางเชน C = 0.05 หมายความถึง แรงเฉือนที่ฐานจากแผนดินไหวคือ 5% ของ
น้ำหนักโครงสราง 

กฎกระทรวง 2550 : V  =  Z I K C S W  =  C W,  ดังนั้น  C = Z I K C S 

มยผ. 1302 :  V  =  Cs W,  ดังนั้น  C = Cs 

Building Height exp., K  คือสัมประสิทธิ์การกระจายแรงแผนดินไปตามระดับชั้นตางๆ 

   Fx  =  CvxV เมื่อ   
k

x x
vx n k

i i
i 1

w hC =
w h

 

EQKY

Lx

0.05Lx

X

Y
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รูปแบบบรรทุกแรงลมอัตโนมตัิ  

เมื ่อเลือกชนิดน้ำหนักบรรทุกเปน WIND ในชอง Auto Lateral Load Pattern จะทำงานโดยมี
มาตรฐานตางๆใหเลือก ซึ่งแตละมาตรฐานจะมีใหกำหนดทิศทางลมและคาพารามิเตอรที่ใชในการ
คำนวณแตกตางกันไป สำหรับเมืองไทยจะใชมาตรฐานการคำนวณแรงลม มยผ. 1311-50 ของกรม
โยธาธิการและผังเมือง ซึ่งอางอิงตามมาตรฐาน National Building Code of Canada (NBCC) 

 สรางรายการแรงลม WINDY เลือกแบบ WIND เลือกมาตรฐาน NBCC 2005 คลิกปุม Add 

New Load Pattern แลวคลิกปุม Modify Lateral Load Pattern 

 

 กำหนดคาพารามิเตอรในการคำนวณแรงลมตามมาตรฐานดังนี้ 
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Exposure from Extents of Rigid Diaphragms จะคิดแรงดานขางท่ีกระทำตอไดอะแฟรม
(พ้ืน)แตละชั้นแยกกัน แรงลมที่คำนวณท่ีระดับชั้นใดๆจะข้ึนกับระดับความสูง, ความสูงของช้ันที่
เหนือกวาและต่ำกวา, ความกวางของพื้นที่รับลมของไดอะแฟรม และคาสัมประสิทธิ์ความดัน
ตามท่ีมาตรฐานกำหนด สำหรับทางเลือกนี้จะตองกำหนดพ้ืนเปนไดอะแฟรม  

Exposure from Area Objects  จะคิดแรงลมบนผนังรับแรงลม ซึ่งอาจสรางเปนผนังดัมมี่ 
(dummy) ที่ไมมีสติฟเนสขึ้นมา แรงลมที่คำนวณไดจะกระทำที่กึ่งกลางผนังดัมมี่แตละผนัง
แรงลมจะกระทำบนพ้ืนผิวด่ิงและพ้ืนผิวราบตามพ้ืนวัตถุที่กำหนด 

Wind Exposure Parameters  พารามิเตอรการเปดรับลมไดแกทิศทางลมกำหนดเปนมุม
โดย 90 องศาจะมีทิศไปทางแกน Y และสัมประสิทธิ์แรงดัน Cp ดานปะทะลม (Windward) 

และดานหลบลม (Leeward) สำหรับอาคารสูงปานกลางจะเทากับ 0.8 และ 0.5 ตามลำดับ 

 อัตราสวนความสูงตอความกวางดานแคบท่ีสุด  

H/Ds = 6/8 = 0.75 < 1.0  เปนอาคารเตี้ย 

คา CpCg บนผนัง 1E และ 4E = 1.15 และ -0.8 

คา Cg = 2.0 ดังนั้น Cp = 0.6 และ -0.4 

Exposure Height  คือชวงความสูงที่จะทำการคำนวณแรงดานขาง โดยใหโปรแกรมคำนวณ
ให หรือกำหนดชวงระดับความสูงเอง 

Wind Coefficients  คือคาพารามิเตอรที ่คำนวณตามมาตรฐาน สำหรับเมืองไทยจะใช
มาตรฐานการคำนวณแรงลม มยผ. 1311-50 ของกรมโยธาธิการและผังเมือง ซึ่งประยุกตมาจาก
มาตรฐาน National Building Code of Canada (NBCC) 2005 

Velocity Pressure คือหนวยแรงลมอางอิงเนื่องจากความเร็วลม (q) นั้นจะคำนวณไดจาก
ความเร็วลมอางอิง V  เชนถาความเร็วลมอางอิงคือ 25 เมตรตอวินาที 

2 21 1q = V = 1.25 25 = 390.6
2 2

 นิวตัน/ม.2  =  0.4 kPa 

 สั่งเมนู Define > Load Cases เพื่อตรวจสอบกรณีบรรทุกซึ่งจะถูกสรางขึ้นโดยอัตโนมัติตาม
รูปแบบบรรทุกท่ีเรากำหนดขึ้นเปนชนิด Linear Static และมีกรณีบรรทุก Modal เพ่ิมข้ึนมาซึ่ง
เปนการวิเคราะหโหมดการสั่นไหวของโครงสราง 

 ลองเลือกรายการ WINDY แลวคลิกปุม Modify/Show Load Case… 
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ตรวจสอบวาเปนกรณีบรรทุกชนิด Static และมีรูปแบบบรรทุก WINDY สเกลเทากับ 1 

การใสนํ้าหนักบรรทุกผนัง  Line Load 

 เปลี่ยนไปใชหนวย Kgf, m, C  

 เลือกคานทั้งหมดโดยสั่งเมนู Select > Select > Select Lines Parallel To > Coordinate 

Axes or Plane  

 เลือกระนาบ XY แลวกดปุม Select ตามดวย Close 
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 สั่งเมนู Assign > Frame Loads > Distributed  
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 เลือกกรณีบรรทุก DEAD ใสคาในชอง Uniform Load = 500 kgf/m แลวคลิกปุม OK 

 คลิกหนาตางมุมมองสามมิติ สั่งเมนู Display > Show Object Load Assigns > Frame เลือก
กรณีบรรทุก DEAD และ Span Loading (Forces) 

 

การใสนํ้าหนักบรรทุกพ้ืน  Area Load 

 สั่งเมนู Assign > Clear Display of Assigns เพ่ือปดการแสดงน้ำหนักผนังทั้งสองหนาตาง 

 เลือกพ้ืนทั้งหมดโดยกด Ctrl+A ซึ่งจะเลือกทั้งหมด สั่งเมนู Assign > Area Loads > Uniform 

(Shell) กำหนดคาดังในรูป เพ่ือใสน้ำหนักจร LIVE = 300 kg/m2 คลิกปุม Apply 
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 คลิกเลือกหนาตาง 3-D View กด Ctrl+J เพื่อเลือกเชนเดิม เปลี่ยนเปนกรณีบรรทุก SDL ใสคา 
100 kgf/m2 คลิกปุม OK 

 

 คลิกหนาตางมุมมอง X-Y Plane สั ่งเมนู Display > Show Object Load Assigns > Area 

เลือกกรณีบรรทุก LIVE และรูปแบบการแสดงดังในรูป แลวคลิกปุม Apply 
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 เปลี่ยนเปนน้ำหนัก SDL แลวคลิกปุม Apply 

 ลองคลิกขวาภายในพื้นเปดหนาตางขอมูลพื้น เลือกแถบ Load ตรวจสอบคาน้ำหนักบรรทุก
กรณ ีLIVE และ SDL 

 

 

 

 

 คลิกหนาตาง 3-D View สั ่งเมนู Display > Show Object Load Assigns > Load Case… 

หรือสั่งเมนู Display > Show Load Case Tree แลวกดปุม Expand All ในหนาตางที่แสดง
ขึ้นมาเพ่ือใหแสดงแผนผังกรณีบรรทุกท้ังหมด  
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ซึ่งจะสามารถสลับเปลี่ยนการแสดงน้ำหนักบรรทุกไดรวดเร็วกวา และสามารถแสดงหลาย
น้ำหนักบรรทุกท่ีอยูในกรณีบรรทุกเดียวกันได 

 สั่งเมนู Display > Show Undeformed Shape หรือกด F4 เพ่ือปดการแสดงน้ำหนักบรรทุก 

การสรางไดอะแฟรม  

ในการใสแรงลมกระทำตออาคารนั้น กอนอ่ืนเราจะสราง ไดอะแฟรม ซึ่งจะยึดจุดตอทุกจุดในแตละ
ชั้นเขาดวยกัน โดยระยะจากทุกจุดถึงจุดศูนยกลางคงที่ทำใหแผนพ้ืนทั้งชั้นโยกทางดานขางไปพรอม
กันเหมือนเปนแผนแข็ง  

 เลือกหนาตาง 3-D View สั่งเมนู Display > Show Undeformed Shape หรือกด F4 

 กดปุม Shift และลูกกลิ้งเมาส เพื่อหมุนโมเดลในหนาตางสามมิติดังในรูป แลวตีกรอบเลือกจุด
ตอในชั้นหนึ่งและสอง 
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 สั่งเมนู Define > Joint Constraints… เลือกชนิด Diaphragm คลิกปุม Add New 

Constraint… 

 

 กำหนดแกน Constraint เปนแกน Z Axis  

 เลือกไดอะแฟรมเปนแบบ Semi-rigid และ 

 เลือกแยกไดอะแฟรมสำหรับระดับ Z ที่
ตางกัน 

 เสร็จแลวคลิกปุ ม OK ในหนาตาง Define Constraints จะมีรายการไดอะแฟรม 

DIAPH1 เพ่ิมข้ึนมา 

 

 สั่งเมนู Assign > Joint > Constraints… เลือกรายการ DIAPH1 คลิกปุม Apply แลว
กด Close (ถาตองการปลดใหเลือกจุดตอแลวเลือก None) 
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 คลิก OK กลับมาที่หนาตาง Assign Joint Constraints จะมีรายการ DIAPH1 ที่สรางใหม ให
คลิกเลือกแลวกดปุม Apply  

 ลองคลิกขวาที่จุดตอเพ่ือดูขอมูลการยึดรั้งในแถบ Assignments > Constraint 

  

 ลองตรวจสอบโดยการสั่งเมนู Define > Load Patterns เลือกรายการ WIND กดปุม Modify 

Lateral Load Pattern แลวกดปุม Modify/Show Exposure Widths… 

 

 กด Ctrl+S เพ่ือบันทึกขอมูลไฟล EX4 Simple RC เพ่ือใชในบทตอไป  

นํ้าหนักบรรทุกบนโครงสรางเหล็ก   

 สั่งเมนู File > Open หรือกด Ctrl+O เลือกเปด
ไฟล EX3 Steel Frame ที่สรางไวในบทที่แลว
ขึ้นมาเพ่ือใสน้ำหนักบรรทุก  

 

 สั่งเมนู Define > Load Patterns… สรางรูปแบบบรรทุก LIVE, EQKY และ WINDY ดังในรูป 
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 คลิกเลือกรายการ EQKY แลวกดปุม Modify Lateral Load Pattern กำหนดคาพารามิเตอร
แผนดินไหวดังในรูป 

 

 คลิกเลือกรายการ WINDY แลวกดปุม Modify Lateral Load Pattern กำหนดคาพารามิเตอร
แรงลมดังในรูป สำหรับตัวอยางนี้เราจะเลือก Exposure from Area Objects 
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แรงลมบนผนังเสมือน  Wind on None Wall 

ในการใสแรงลมกระทำตออาคารน้ัน กอนอื่นเราจะสราง ผนังเสมือน ซึ่งไมมีน้ำหนักและสติฟเนส ซึ่ง
จะไมมีผลตอการวิเคราะหแรงในโครงสราง ผนังเสมือนนี้จะทำหนาที่รับแรงดันลมที่จะคำนวณตาม
พารามิเตอรมาตรฐานแรงลมที่เรากำหนดไว 

 คลิกหนาตางสองมิติ กดปุม    มาท่ีระนาบ X-Z Plane @ Y = -6 บนเสนกริด 1 

 

 คลิกปุม    เลือกใหแสดง Fill Objects เพ่ือใหเห็นผนังเวลาวาด 

 สรางผนังโดยกดปุม    Quick Draw Area เลือกหนาตัดเปน None คือเปนวัตถุพื้นที่ไมมี
คุณสมบัติซึ่งจะใชในการรับแรงดันลม แลวตีกรอบคลุมทั้งหมด แลวกด Esc ออกจากโหมดวาด 

 

 คลิกเลือกผนังทั้ง 6 ทีละแผน แลวกด Ctrl+R ทำซ้ำโดยใชระยะ dy = 12 
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 ในมุมมองสองมิติ X-Z Plane @ Y = -6 ตีกรอบเลือกท้ังหมด สั่งเมนู Assign > Area Loads > 

Wind Pressure Coefficients เลือกชนิด Windward  ใสคา Cp = 0.6 
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 ปรับมุมมองมาที่ X-Z Plane @ Y = 6 ตีกรอบเลือกทั้งหมด สั่งเมนู Assign > Area Loads > 

Wind Pressure Coefficients  

 เลือกกรณีบรรทุก WINDY ใสแรงลมเปนผนังดานหลบลม (Leeward) เลือกแรงดันแบบ Other 

ใสคา Cp = 0.4 

 

 

สังเกตวงเล็บดานหลัง (O) หมายถึง Other ดานอื่นที่ไมใชดานปะทะลม โดยหนวยแรงดันลมที่
เกิดข้ึนบนพื้นผิวจะถูกสงผานมาเปนแรงลงที่มุมของแตละแผน 

 ในมุมมอง 3-D View ลองคลิกขวาที ่ผน ังด านตานลมและหลบลม เล ือกแถบ Load ดู
องคประกอบแรงวาไปในทิศทางเดียวกันหรือไม (ในรูปไปทาง +Y) 
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 กด Ctrl+S เพ่ือบันทึกขอมูลตั้งชื่อไฟลเปน EX3 Steel Frame เพ่ือใชในบทตอไป  
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การวิเคราะหโครงสราง 
ในบทนี้จะกลาวถึงการวิเคราะหโครงสรางอาคารคอนกรีตและโครงเหล็กที่ไดสรางไวในบทที่ผานมา 
เมื่อรันการวิเคราะหผานจะสามรถดูผลการวิเคราะหไดแก การเสียรูปทรง และแรงภายในตางๆ 
ภายใตกรณีบรรทุกตางๆ นอกจากน้ันยังจะไดเปรียบเทียบผลของการกำหนดโมเดลที่ตางกัน 

อาคารคอนกรีต Simple RC 

ในตัวอยางนี้เราจะใชไฟล EX4 Simple RC ที่เคยสรางไวในบทที่แลว เมื่อเปดขึ้นมาใหสั่ง Save As 

บันทึกเปนชื่อ EX4 Simple RC 2 แลวคลิกหนาตาง 3-D View ใหแอคทีฟ 

 

กอนสั่งรันการวิเคราะหเราควรตรวจสอบโครงสรางดูวามีการกำหนดคุณลักษณะและการรับ
น้ำหนักบรรทุกตามท่ีตองการหรือไม 
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 คลิกขวาท่ีพ้ืนเพ่ือดูขอมูลจะพบวาเปนพ้ืน S1 แบบ Shell (Membrane) และคลิกแถบ Loads 

เพ่ือตรวจสอบน้ำหนักบรรทุก 

 

 

การแบงพ้ืนยอยอัตโนมัต ิ

 กด Ctrl+A เพ่ือเลือกทั้งหมด สั่งเมนู Assign > Area > Automatic Area Mesh… ทางเลือกที่
ใชอยูคือ 4X4 ดังในรูป แลวคลิกปุม OK 

 

การแบงพ้ืนยอยอัตโนมัติจะเกิดขึ้นเม่ือทำการวิเคราะหโดยแรงจากพ้ืนจะถูกสงไปยังคานผานจุด
ตอพ้ืนยอย ยิ่งพ้ืนยอยถูกแบงละเอียดก็จะไดผลท่ีแมนยำมากข้ึน จำนวนที่แบงไมควรนอยกวา 4 
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 เลือกหนาตาง 3-D View คลิกปุม    เลือกใหแสดง Show Analysis Model  

 

การวิเคราะหโครงสราง Analysis 
 เลือกเมนู Analyze > Set Analysis Options เพ่ือกำหนดทางเลือกในการวิเคราะห คลิกเลือก 

Plane Frame ซึ่งจะวิเคราะหแรงในระนาบ X-Z โดยคิดดีกรีอิสระ UX, UZ และ RY 
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 เลือกหนาตาง 3-D View สั่งเมนู Analyze > Run Analysis หรือกด F5 เพื่อรันการวิเคราะห
โครงสราง หนาตาง Set Load Case to Run จะแสดงข้ึนมาเพ่ือใหกำหนดกรณีบรรทุกที่จะทำ
การวิเคราะห  

 คลิกรายการ MODAL แลวกดปุม Run/Do Not Run Case เพื่อไมใหโปรแกรมคำนวณโหมด
การสั่นไหว ซึ่งจะทำใหเสียเวลาถาเราไมไดทำการวิเคราะหพลศาสตร  

 

 คลิกปุม Run Now โปรแกรมจะเริ่มทำการวิเคราะหโครงสราง จะมีหนาตางแสดงคำเตือน 
(Warning ซึ่งในเวอรชั่นกอนหนา V22 ไมมีปญหา) ถาเปลี่ยนพื้นเปนชนิด Shell-Thin จะไมมี
การแจงเตือนเกิดข้ึน 

 

 คลิกปุม Done เมื่อทำเสร็จจะแสดงภาพการเสียรูปทรงของภายใตกรณีบรรทุก DEAD  
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หลังการรันวิเคราะห โมเดลจะถูก “ล็อค” ไมใหทำการแกไข โดยสังเกตไดจากปุมแมกุญแจบน
ทูลบารดานบน ถาเราตองการแกไขใหกดปุมนี้เพื่อ “ปลดล็อค” กอน ซึ่งโปรแกรมจะแสดง
ขอความเตือนวาจะผลการวิเคราะหทั้งหมดจะถูกลบทิ้งไป  

การแสดงผลการเสียรปูทรง  

 คลิกขวาในพ้ืนที่วางหลังทูลบารดานบนเลือกรายการ Display จัดทูลบารใหเปนดังในรูป 

 

 เราสามารถดูรูปแบบการเสียรูปทรงไดโดยสั่งเมนู Display > Show Deformed Shape หรือ

คลิกปุม    บนทูลบาร แลวเลือกกรณีบรรทุกและรูปแบบการแสดงผลดังในรูป  
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 เลือกกรณีบรรทุก DEAD และใหแสดงชั้นความสูงตามคา Uz (การเคลื่อนตัวในแนวดิ่ง) แลวกด
ปุม Apply ในหนาจอกราฟกจะแสดงตามท่ีเลือกโดยหนาตางตั้งคายังเปดอยูทำใหสามารถเลือก
ปรับเปล่ียนใหแสดงคาอ่ืนๆไดสะดวกข้ึน 

 เลือกใหแสดงผลของกรณีบรรทุกแผนดินไหว EQKY โดยเลือกไมแสดงเสนชั้นความสูง แลวกด
ปุม Apply 

 คลิกหนาตางสองมิติแลวกดปุม    ใหแสดงมุมมองระนาบ Y-Z @ X = -6 บนเสนกริด A 

แลวกดปุม Apply แลวสั่งใหแสดงการเสียรูปทรงเชนเดียวกัน 

 ลองเลื่อนตัวชี้ไปที่จุดตอที่เคลื่อนตัวไปจะมีคาระยะและการหมุนในแตละทิศทางแสดงข้ึนมา 

 

 คลิกหนาตางสามมิติ เลือกกรณี WINDY กดปุม Apply แลวคลิกหนาตางสองมิติทำเชนเดียวกัน 
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การแสดงผลแบบตาราง  

 คลิกปุม    ปดการแสดง Analysis Model และ Apply to All Windows 

 คลิกหนาตางสองมิติ สั่งเมนู Display > Show Undeformed Shape หรือคลิกปุม    ให

กลับมาไมเสียรูปทรง แลวคลิกปุม    ใหแสดงระนาบ X-Y @ Z = 6 

 คลิกปุม    เลือกใหแสดงหมายเลขจุดตอ Joint > Label 

 

 เปลี่ยนหนวยเปน Kgf, cm, C สั่งเมนู Display > Show Table… หรือกด Ctrl+T เลือกตาราง
ที่ตองการใหแสดงตามในรูปขางลาง 
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เมื่อคลิก OK หนาตางตารางจะแสดงขึ้นมา โดยคาในตางรางจะอางอิงตามหมายเลขจุดตอ 

 

 เราสามารถสั่งใหแสดงผลเฉพาะเจาะจงโดยเลือกเมนู Format-Filter-Sort > Filter Table… 

 กำหนดเงื่อนไขในการกรองเชนสมมุติวาตองการใหแสดงผลการโยกตัวจาก EQKY 

 

 เมื่อกด OK กลับมาที่ตารางจะแสดงผลของ EQKY ดังในรูป 

 



 

SAP2000  C5 Analysis Mongkol  JIRAVACHARADET 143 
 

 สงออกตารางไปยัง Excel จากเมนู File > Export Current Table > To Excel หรือ 

 คลิกท่ีตารางชองมุมซายบน กด Ctrl+C แลวนำไปวางใน Excel โดยกด Ctrl+V จะไดดังในรูป 

 

แรงภายในเสาและคาน  
แรงภายในองคอาคารที่เปนวัตถุแบบเสนเชนเสาและคานจะมี
การอางอิงทิศทางตามแกนองคอาคาร 1-2-3 ดังนี้ 

Axial Force  =  แรงตามแนวแกน 1 

Shear 2-2, 3-3  =  แรงเฉือนตามแกน 2 และ 3 

Torsion  =  โมเมนตบิดรอบแกน 1 

Moment 2-2, 3-3  =  โมเมนคดัดรอบแกน 2 และ 3 

 เปลี่ยนหนวยเปน Kgf-m คลิกปุม    เอา Joints > Labels และ Fill Objects ออกโดย
เลือก Area > Not in View และ Apply to All Windows เพ่ือใหแสดงเฉพาะเฟรม 

 

1
2

3
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 คลิกหนาตางสองมิติ แลวปรับมุมมองใหแสดงระนาบ X-Z @ Y = 0 

 คลิกปุม    บนทูลบารดานบนหรือ สั่งเมนู Display > Show Forces/Stresses เลือก 
Frames/Cables/Tendons  

 ในหนาตางที่แสดงขึ้นมา เลือกกรณีบรรทุก LIVE, โมเมนตดัด Moment 3-3 และแสดงแบบ 
Show Values แลวคลิกปุม Apply 

 

 คลิกหนาตางสามมิติ สั่ง Moment 3-3 เชนเดียวกันแตใหแสดงแบบ Fill Diagram 
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แผนภูมิโมเมนตจะถูกแสดงข้ึนมาดังในรูป จะเห็นวาโมเมนตเปนลบกลางชวงคาน และเปนบวก
ที ่บริเวณจุดรองรับ การพล็อตแบบนี ้เรียกวา Moment diagram on tension side ซึ่ง
ตรงกันขามกับที่ใชในเมืองไทย 

 สั่งเมนู Options เลือกเอาเครื่องหมายถูกหนารายการ Moment Diagram on Tension Side 

ออก จะไดแผนภูมิโมเมนตในแบบที่เราคุนเคย 

 

 คลิกขวาท่ีคาน จะมีหนาตางแสดงรายละเอียดผลการวิเคราะหแสดงขึ้นมา 

 

จะเห็นวาคาโมเมนตดัดมากที่สุดคือ -411 Kgf-m เราจะใชคานี้ในการเปรียบเทียบกับแบบอ่ืน 
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ผลของชนิดพ้ืน Membrane v.s. Shell 

 กดปุม    เพื่อปลดล็อคโมเดล แลวกด    เอา Areas > Not in View ออก เลือกให
แสดง Fill Objects และ Apply to All Windows 

 ในหนาตาง X-Y Plane ลองคลิกขวาที่พ้ืน หนาตางขอมูลจะแสดงขึ้นมา 

 

 

 คลิกแถบ Assignments จะเห็นวาพื้นที่ใชอยูคือหนาตัด S1 เปนแบบ Shell (Membrane) 

และมีการแบงพ้ืนยอยแบบ 4x4 

 สั ่งเมนู Define > Section Properties > Area Sections เลือก S1 แลวกด Modify/Show 

Section จะเห็นวาถูกเลือกเปน Membrane อยู ใหเปลี่ยนเปน Shell – Thin 
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 คลิกหนาตางสามมิติ สั ่งเมนู Analyze > Run Analysis หรือกด F5 เพื ่อรันการวิเคราะห
โครงสรางอีกครั้ง จะเห็นวาไมมีการเตือนเหมือนในกรณีพ้ืนเมมเบรน 

 คลิกปุม    เลือกใหแสดงการเสียรูปทรงภายใตกรณีบรรทุก DEAD จะไดดังในรูป 

 

จะเห็นวาพ้ืนบบ Shell มีการเสียรูปทรงทีใ่กลเคียงความเปนจริงกวาแบบ Membrane 

 ในหนาตางสองมิตทิี่ระนาบ X-Z @ Y = 0 คลิกขวาท่ีคานชั้นบนดานซายเชนเดิม 

 

ผลของการแบงพ้ืนยอย  

 กดปุ ม    เพื ่อปลดล็อคโมเดล แลวสั ่งเมนู Select > Select > Properties > Area 

Sections เลือกหนาตัด S1 เพ่ือเลือกพ้ืนทั้งหมด 

 สั่งเมนู Assign > Area > Automatic Area Mesh เพ่ือกำหนดเง่ือนไขการแบงพ้ืนยอย เปลี่ยน
จากแบบ 4x4 มาเปน 8x8 
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 คลิกหนาตางสามมิติ สั ่งเมนู Analyze > Run Analysis หรือกด F5 เพื ่อรันการวิเคราะห
โครงสรางอีกครั้ง  

 

จะเห็นวามีการแบงพื้นยอยละเอียดขึ้นทำใหไดการเสียรูปทรงที่ดีขึ้นแตจะเสียเวลาในการ รัน
นานขึ้น ในเบื้องตนควรแบงอยางหยาบเชน 4x4 ไปกอน เมื่อตรวจสอบจนมั่นใจแลว ตองการ
ผลท่ีแมนยำขึ้น คอยมาเพ่ิมความละเอียดภายหลัง 

  คลิกปุม    สั่งใหแสดงโมเมนตดัด M 3-3 แลวคลิกขวาเชนเดิมเพื่อดูความแตกตางของ
คาท่ีคำนวณได 

 

จะเห็นวาทั้งสามครั้งมีคาไมเทากัน ซึ่งคำนวณดวยมือตามปกติตามปกติสำหรับคานรับน้ำหนัก
จร 300 กก./ตรม. จากพ้ืนขนาด 4X4 เมตร สองขางจะได 

น้ำหนักพ้ืนลงคาน : 

w  =  2 x 300 x 4 / 3  =  800 กก./ม. 

โมเมนตลบมากท่ีสุด : 

M  =  - (1/10) x 800 x 42  =  -1,280 กก.-ม. 

จะเห็นวาพื ้นแบบ Shell ใหผลใกลเคียงกวาแบบ 
Membrane และยิ่งแบงแผนยอยละเอียดจะใหผลท่ี
ใกลเคียงมากขึ้น แตจะใชทรัพยากรและเวลาในการ
คำนวณมากข้ึน 

 

4 m
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 คลิกหนาตางสามมิติ แลวคลิกปุม    เลือกรายการ Shells เพื่อใหแสดงการกระจาย
หนวยแรงในพ้ืน โดยกำหนดคาดังในรูป 

 

จะไดรูปการกระจายของหนวยแรงในพ้ืนดังแสดงในรูป 

 

 ปร ับความหนาเส นได  จ าก เมน ู  Options > Dimensions/Tolerances > Screen Line 

Thickness 
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ผลของแรงดานขาง  

 ปดการแสดงพื้นโดยคลิกปุม    เลือก Areas > Not in View เอา Fill Objects ออกและ
คลิก Apply to All Windows 

 คลิกหนาตางสามมิติ แลวคลิกปุม    เลือก Frames ใหแสดงโมเมนตดัด M-33 ภายใต
กรณีบรรทุก EQKY หรือ WINDY แบบ Fill Diagram แลวกดปุม Apply 

 คลิกหนาตางสองมิติเปลี่ยนเปนระนาบ Y-Z แลวกดปุม Apply จะไดดังในรูป 

 

เราจะไมเห็นโมเมนตดัดในเสา เนื่องจากเสาในอาคารถูกโยกไปทางแกน Y โมเมนตดัดที่เกิดขึ้น
จะมีทิศไปทางแกน X ซึ่งจะตรงกับแกนเฉพาะของเสาคือแกน 2 

 

 เลือกใหแสดง M-22 เพ่ือแสดงโมเมนตในเสา แลวคลิกปุม Apply ทั้งสองหนาตาง 

 

Z

X Y

1

2 3

M-22
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ถามีแรงแผนดินไหวในทิศทาง X โมเมนตดัดในเสาจะแสดงในทิศทาง M-33 เชนเดียวกับคาน 

 คลิกปุม    ปลดลอคโมเดล สั่งเมนู Define > Load Patterns สรางกรณีบรรทุก EQKX 

แบบ User Coefficient ดังในรูป (คลิกรายการ EQKY แลวเปลี่ยนชื่อเปน EQKX แลวคลิก 
Add New Load) 

 

 คลิกปุม Modify Lateral Load Pattern… กำหนดเปนทิศทาง X 

 

 สั่งเมนู Analyze > Run Analysis หรือกด F5 เพ่ือรันการวิเคราะหโครงสรางอีกคร้ัง  

 คลิกปุม    เลือกกรณีบรรทุก EQKX ใหแสดง M-33 ในหนาตางสามมิติและระนาบ X-Z 

ดังในรูป ซึ่งจะเห็นทั้งโมเมนตดัดในเสาและคาน 

 

 สั่งเมนู File > Save บันทึกไฟลเพื่อใชในบทตอไป  
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นํ้าหนักบรรทุกพื้นแผลงโครง Area Loads - Uniform to Frames 

เปนวิธีการใสน้ำหนักบรรทุกแบบแผสม่ำเสมอบนพื้นลงโครงอาคารที่รองรับโดยรอบ โดยสามารถ
กำหนดทิศทางของน้ำหนักบรรทุกตามแกนหลักหรือแกนเฉพาะก็ได เหมาะสำหรับใชกับพื้นแบบ 
None ในกรณีที่ไมตองการโมเดลพื้นในโมเดลแตตองการใหถายน้ำหนักบรรทุกลงโครงเชน ในกรณี
ของพ้ืนสำเร็จในอาคารคอนกรีต และพื้นคอมโพสิตในอาคารเหล็ก นอกจากนั้นยังนำไปใชกับการ
ถายน้ำหนักจากหลังคาและผนังเหล็กรีดลอนไดอีกดวย 

 เริ ่มตน SAP2000 ใชหนวย Kgf, m, C สรางโมเดลใหม โดยกด Ctrl+N เลือกเทมเพลต 3D 

Frames โดยใชขอมูลจากไฟลที่มีอยู 

 

 เลือกไฟล EX2 House2F เปนตนแบบเพื่อใหมีหนาตัดคาน B20X40 และเสา C20X20 ใหเลือก
สำหรับโครงชนิด Open Frame Building และกำหนดขอมูลดังในรูปขางบน 

 

 คลิกหนาตางสองมิติ X-Y Plane @ Z = 3 กดปุม    เลือกพ้ืนชนิด None แลวคลิกภายใน
เสนกริดเพ่ือวาดพ้ืนแบบรวดเร็วดังในรูป 



 

SAP2000  C5 Analysis Mongkol  JIRAVACHARADET 153 
 

 

สมมุติวาเราตองการใชพ้ืนสำเร็จรูปดังในรูป 

Hollow Core: 

 

น้ำหนักพ้ืน 191 กก./ม.2 
คอนกรีตเททับหนา 5 ซม. 120 กก./ม.2 
รวมน้ำหนัก DEAD 311 กก./ม.2 
น้ำหนัก LIVE 300 กก./ม.2 

 สั่งเมนู Define > Load Pattern สรางกรณีบรรทุก LIVE ตามปกติ 

 

 คลิกเลือกพ้ืน สั่งเมนู Assign > Area Loads > Uniform to Frame  

 เลือกรูปแบบบรรทุก DEAD การกระจายน้ำหนักแบบ One Way 

 ใสน้ำหนักของพ้ืนคือ 311 kgf/m2 

 คลิกปุม Apply เพ่ือใสน้ำหนักโดยยังเปดหนาตางคางไว 

 

120 MM

600 MM

120 MM

600 MM
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 คลิกเลือกพ้ืนอีกครั้งใสน้ำหนัก LIVE :  One-Way  =  300 kg/m2 

 

 คลิกขวาดูขอมูลพื้น ในแถบ Load จะมีขอมูลน้ำหนักบรรทุกกรณี DEAD และ LIVE แสดงเปน
น้ำหนักชนิด Uniform to Frames กระจายแบบ One way ดังในรูป 
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 สั่งเมนู Analyze > Run Analysis หรือกด F5 เพื่อรันการวิเคราะหโครงสราง เลือก Do Not 

Run กรณีบรรทุก MODAL และบันทึกโมเดลเปน EX5 Uniform2Frame 

 ดูการแสดงผลของการเสียรูปทรงและโมเมนตดัดของกรณี LIVE จะไดดังในรูป 

 

แมจะไมมีพื้นอยูในโมเดล แตจะเห็นไดจากโมเมนตดัดและการเสียรูปทรงวามีการถายน้ำหนัก
จากพื้นในทิศทางตามแกน X การคิดน้ำหนักจากพื้นโดยวิธีนี้ทำไดสะดวกกวาเนื่องจากไมตอง
คำนึงถึงการแบงพ้ืนยอย และโปรแกรมจะรันการคำนวณไดเร็วกวา แตถาตองการกำหนดใหพ้ืน
ถายน้ำหนักไปอีกทิศทางจะยุงยากข้ึน โดยตองระบุโดยใชแกนเฉพาะของพ้ืนดังนี้ 

 คลิกปุม    ปลดล็อคโมเดล กด    เลือกใหแสดงแกน Local Axes ในพื้น จะเห็นวา
การถายน้ำหนักทางเดียวไปตามแกน 1 ซึ่งปกติจะชี้ไปทางแกน Global X ดังในรูป 



 

SAP2000  C5 Analysis Mongkol  JIRAVACHARADET 156 
 

 

 คลิกเลือกพื้น สั่งเมนู Assign > Area > Local Axes ใสคามุม 90 องศาซึ่งจะทำการหมุนแกน 
Local รอบแกน 3 ในทิศทวนเข็มนาิกา 

 

แกน Local ของพ้ืนจะหมุนไป 90 องศา แกน 1 จะชี้ไปทางแกน Global Y ดังในรูป 
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 สั่งเมนู Analyze > Run Analysis หรือกด F5 เพ่ือรันการวิเคราะหโครงสราง 

 

จะเห็นวาการถายน้ำหนักจากพ้ืนเปลี่ยนมาเปนตามทิศทาง Y  

 ถาตองการหมุนกลับคืนใหสั่ง Assign > Area > Local Axes อีกครั้ง โดยใชมุม 0 องศา

การใชคำสั่ง Area Uniform Loads to Frames นี้ถึงแมจะยุงยากในการกำหนดทิศทาง
อยูบาง แตก็มีประโยชนในการประยุกตใชงานไดอยางหลากหลาย คือทั้งพื้น, ผนัง และหลังคา 
ที่เราตองการเพียงการถายน้ำหนักบรรทุก โดยไมตองโมเดลวัตถุเขาไปจริงๆ แตตองไมลืมใส
น้ำหนักบรรทุก DEAD ของพ้ืน, ผนัง และ หลังคาเขาไปดวย 

 สั่งเมนู File > Save เพ่ือบันทึกขอมูล  

 สั่งเมนู File > Open เปดไฟลเดิม EX4 Simple RC แลวสั่งเมนู File > Save As ตั้งชื่อวา EX4 

Simple RC2 

 

 สั่งเมนู Select > Select > Properties > Area Section เลือกพ้ืน S1 



 

SAP2000  C5 Analysis Mongkol  JIRAVACHARADET 158 
 

 สั่งเมนู Assign > Area > Sections เลือกเปลี่ยนเปนพ้ืน None 

 ลองคลิกขวาที่พื้นจะเห็นวาน้ำหนักบรรทุกยังคงอยูคือ LIVE และ SDL ซึ่งเราจะเอาออกแลว
เปลี่ยนเปนน้ำหนัก Uniform to Frame 

 

 คลิกปุม    หรือกด Ctrl+J เพื่อเลือกพื้นทั้งหมดอีกครั้ง สั่งเมนู Assign > Area Loads > 

Uniform เลือกน้ำหนัก LIVE และ Delete Existing Loads 

 

 

 

 ทำเชนเดิมเพื่อเอาน้ำหนักน้ำหนัก SDL ออก 
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 คลิกขวาท่ีพ้ืนเพื่อตรวจสอบน้ำหนักบรรทุกวาไมมีเหลือแลว 

 

 คลิกปุม    เพื่อเลือกพื้นทั้งหมด สั่งเมนู Assign > Area Loads > Uniform to Frame 

เลือกน้ำหนัก DEAD ใสน้ำหนักเทากับน้ำหนักพ้ืน S1 คือ 0.12x2400 = 288 กก./ม.2 

 

 โดยวิธีการเดิมใสน้ำหนัก Uniform to Frame สำหรับ
น้ำหนัก LIVE = 300 กก./ม.2 และ SDL = 100 กก./ม.2 
ใชการกระจายแบบ Two-Way 

 คลิกขวาที่พื้นเพื่อตรวจสอบน้ำหนักบรรทุกจะไดดังในรูป
คือมีน้ำหนัก DEAD, LIVE และ SDL 
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 คลิกหนาตาง 3-D View คลิกปุ ม  ปดการแสดงพื้น สั ่งเมนู Display > Show Object 

Load Assigns > Load Pattern… 

 เล ือกกรณ ีบรรท ุก  LIVE คล ิกแถบ  Area เล ือกให แสดง  Uniform Load to Frame > 

Resultants 
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 สั่งเมนู Analyze > Run Analysis หรือกด F5 เพ่ือรันการวิเคราะหโครงสราง 

 คลิกหนาตางสามมิติ คลิกปุม    ใหแสดงการเสียรูปทรงของน้ำหนัก LIVE 

 คลิกหนาตางสองมิติ แลวปรับมุมมองใหแสดงระนาบ X-Z @ Y = 0 

 คลิกปุม    เลือกใหแสดงโมเมนต M33 ของน้ำหนัก LIVE 

 เลือกเมนู Options > Moment Diagram on Tension Side ปรับการแสดงโมเมนต 

 

 ในหนาตางสองมิติท่ีระนาบ X-Z @ Y = 0 คลิกขวาท่ีคานชั้นบนดานซาย 
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 เมื่อเปรียบเทียบคาโมเมนตมากที่สุดกับการคำนวณมือและพ้ืนแบบ Shell ในตัวอยางที่แลว 

วิธีการคำนวณ โมเมนตดัด (กก.-ม.) 

คำนวณมือ 1,280 

Shell Element (8 x 8) 1,023 

Uniform to Frame 1,106 

จะเห็นวาคาท่ีไดจากการใช Uniform to Frame ใกลเคียงกับการคำนวณมือมากกวา เนื่องจาก
การใชพื้นแบบ Shell นั้น สติฟเนสของพื้นไปชวยคานในการรับน้ำหนักบางสวน ทำใหโมเมนต
ในคานมีคาลดลง 
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อาคารเหล็กรูปพรรณ Steel Frame 

 สั่งเมนู File > Open เปดไฟล EX3 Steel Frame ที่เคยสรางไวในบทที่แลว  

 

ในตัวอยางนี้เรายังไมมีพ้ืน โดยสมมุติวาจะใชพ้ืนสำเร็จรูปทางเดียววางในทิศทาง X คือ 
Hollow Core: 

 

น้ำหนักพ้ืน 191 กก./ม.2 
คอนกรีตเททับหนา 5 ซม. 120 กก./ม.2 
รวมน้ำหนัก DEAD 311 กก./ม.2 
น้ำหนัก LIVE 300 กก./ม.2 

 คลิกหนาตางสองมิติ X-Y Plane @ Z = 3 กดปุม    เลือกพ้ืนชนิด None แลวตีกรอบวาด
พ้ืนคลุมพ้ืนที่ทั้งชั้นดังในรูป 

 

 วาดพ้ืนที่ระดับ X-Y Plane @ Z = 6 โดยวิธีการเดิม 

 เลือกพ้ืนทั้งสองชั้น สั่งเมนู Assign > Area Loads > Uniform to Frame ใสคาน้ำหนัก DEAD 
แลวทำอีกครั้งใสน้ำหนัก LIVE 

120 MM

600 MM

120 MM

600 MM
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DEAD :  One-Way  =  311 kg/m2 

LIVE :  One-Way  =  300 kg/m2 

 

 

 

 

 

 

 

 เลือกหนาตาง 3-D View สั่งเมนู Display > Show Object Load Assigns > Load Pattern… 

 เลือกกรณีบรรทุก DEAD คลิกแถบ Area เลือก Uniform Load to Frame > Resultants 
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 สั่งเมนู Analyze > Run Analysis หรือกด F5 เพ่ือรันการวิเคราะหโครงสราง 

 ดูการแสดงผลของการเสียรูปทรงและโมเมนตดัดของกรณี LIVE จะไดดังในรูป 

 

 ดูการแสดงผลของการเสียรูปทรงและโมเมนตดัดของกรณี WINDY จะไดดังในรูป 

 

 สั่งเมนู File > Save บันทึกไฟล EX3 Steel Frame เพ่ือใชในบทตอไป  
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แรงกระทําบนหลังคา  

แรงกระทำบนหลังคาที่มีความลาดเอียงไดแกน้ำหนักโครงหลังคา, วัสดุมุง และน้ำหนักจรซึ่งเปน
น้ำหนักบรรทุกโนมถวงในทิศทางดิ่งลง และแรงลมที่ทำใหเกิดแรงดันซึ่งจะมีทิศทางตั้งฉากกับผิว
หลังคา สำหรับมุมเอียง 0 ถึง 20 องศาแรงดันจะเปนลบคือยกขึ้นทั้งสองดาน สำหรับมุม 30 ถึง 45 
องศาดานปะทะลมแรงดันจะเปนบวก สวนดานหลบลมแรงดันจะเปนลบ(แรงดูด)ดังในรูป 

 

ในตัวอยางตอไปน้ีจะสาธิตการใสน้ำหนักบรรทุกลงบนหลังคาโดยมีทั้งน้ำหนักบรรทุกโนมถวง
ในแนวดิ่งและแรงดันลมในทิศทางตั้งฉากผิวหลังคาโดยใชพื้นผิวหนังคาแบบ None แลวใสน้ำหนัก
แบบ Uniform to frame สำหรับน้ำหนักโนมถวง และใสแรงลมแบบสัมประสิทธิ์แรงดัน 

 

 เริ่มตน SAP2000 ใชหนวย Kgf, m, C สรางโมเดลใหม โดยกด Ctrl+N  

Windward
Cp = 0.8

Leeward
Cp = -0.5

Z

Y

Roof Windward
Cp = 0.5

Roof Leeward
Cp = -1.0

30-45oWIND
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 ในหนาตาง New Model เลือก Initialize Model from Defaults with Units > Kgf, m, C 

และ Grid Only ดังในรูป 

 

 กำหนดจำนวนและระยะหางเสนกริดในแตละทิศทาง 

 

 คลิกขวาในพ้ืนที่วาง เลือกรายการ Edit Grid Data คลิกปุม Modify/Show System… 
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 ในหนาตางขอมูลกริด คลิกเลือก Display Grids as > Spacing ปรับระยะหางเสนกริด Z2 จาก 
3 มาเปน 1.5 

 

 ปรับมุมมองเปนระนาบ Y-Z @ X = 0 แลววาดเสาและจันทันและใสจุดรองรับดังในรูป 

 

 คลิกจุดปลายบนเสาขางซาย สั่งเมนู Edit > Extrude > Points to Frames ใสคา dy = -1 

และ dz = -0.75 

 

 คลิกจุดปลายบนเสาขางขวา สั่งเมนู Edit > Extrude > Points to Frames ใสคา dy = 1 และ 
dz = -0.75 
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 กด Ctrl+A เลือกทั้งหมด แลวกด Ctrl+R ทำซ้ำ โดยใช dx = 4 และจำนวน = 1 

 ลากเสนเชื่อมระหวางโครงทั้งสองจนไดโครงสรางดังในรูป 

 

 สั่งเมนู File > Save บันทึกขอมูล ตั้งชื่อไฟลวา EX6 Simple Roof 

 สั่งเมนู View > Show Grid หรือกด Ctrl+D เพื่อปดการแสดงเสนกริด และ View > Show 

Axes เพ่ือปดการแสดงแกนทิศทาง 

 คลิกปุม    เลือก Joints > Invisible ออก เพ่ือใหแสดงจุดตอ และเลือก Fill Objects  

 สั่งเมนู View > Set 3D View… กดปุมใหแสดงมุมมอง xy 
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 คลิกปุม    เลือกพื้นชนิด None แลววาดพื้นหลังคาดานบนและลางโดยคลิกตามจุดตอที่
มุมทั้ง 4 วนทวนเข็มนาิกา (ดับเบิ้ลคลิกจุดที่ 4) แลวกด Esc เพ่ือออกจากการวาด 

 คลิกปุม    เลือก Areas > Local Axes เพ่ือใหแสดงแกน Loal Axes 

 

จะเห็นวาลูกศรสีแดงแกน 1 ของพื้นอยูในแนวราบทิศตั้งฉากกับจันทันซึ่งเปนทิศทางของแป 
ตรงกับที่ตองการใหถายน้ำหนัก (ถาไมตรงใหสั่ง Assign > Area > Local Axes ปรับมุม) 

 สั่งเมนู Define > Load Patterns สรางกรณีบรรทุก LIVE 

 คลิกเลือกพื้นหลังคา สั่งเมนู Assign > Area Loads > Uniform to Frame เพื่อใสน้ำหนัก
บรรทุก DEAD แบบ One-way ขนาด 50 kg/m2 แลวกดปุม Apply 
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 กด Ctrl+J เลือกพื้นหลังคาอีกครั้ง เลือกกรณีน้ำหนักบรรทุก LIVE แบบ One-way ขนาด 30 

kg/m2 แลวกดปุม OK 

 

 สั่งเมนู Define > Load Patterns สรางกรณีบรรทุก WINDY ใชมาตรฐาน NBCC2005 

 

 คลิกปุม Modify Lateral Load Pattern เลือกแบบ Exposure from Area Objects 
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 คลิกหนาตางสองมิติ สั่งเมนู View > Set 3D View คลิกปุม YZ แลวคลิกปุม    เลือก 
Area > Local Axes จะเห็นวาแกน 3 ลูกศรสีฟามีทิศพุงออกท้ังสองดานของหลังคา 

 

 ในหนาตาง 3-D View คลิกเลือกหลังคาดานลางซึ่งจะใหเปนดานตานลม (Roof Windward) 

 สั่งเมนู Assign > Area Loads > Wind Pressure Coefficients เลือกกรณีบรรทุก WINDY ใส
คา Cp = -0.5 เพ่ือใหเปนแรงดันกดลงสวนทิศกับแกน 3 ของพ้ืน คลิกปุม Apply 

 

 คลิกเลือกพื้นหลังคาดานบน เปลี่ยนคา Cp = 1.0 เปนบวกเพื่อใหเปนแรงดันดึงขึ้นตามทิศทาง
แกน 3 ของพ้ืนหลังคา แลวกดปุม OK 



 

SAP2000  C5 Analysis Mongkol  JIRAVACHARADET 173 
 

 

 ลองคลิกขวาที่พ้ืนหลังคาแตละดานเพ่ือตรวจสอบทิศทางแรงดันลมในแถบ Load 

ดานตานลม: 

 
 

 

 

 

 

ดานหลบลม: 

 

 คลิกเลือกพื้นหลังคาทั้งสองดานและคานอะเส สั่งเมนู Edit > Edit Areas > Divide Areas 

เลือกแบงพ้ืนตามเสนที่เลือก เพ่ือใหมีแรงสงผานมุมพ้ืนมาลงที่จุดตอหัวเสาและอะเส 

= tan-1(3/4) 
   = 36.87o

Z

Y

3

Cp = 1.0
CpY = 0.6

CpZ = 0.83

Cp = -0.5
CpY = 0.3

CpZ = -0.4
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 สั่งเมนู Analyze > Run Analysis หรือกด F5 เพ่ือรันการวิเคราะหโครงสราง 

 เลือกรายการ MODAL กดปุม Run/Do Not Run Case ใหไมรันกรณี MODAL 

 ดูการแสดงผลของการเสียรูปทรงและโมเมนตดัดของกรณี LIVE จะไดดังในรูป 

 

 ดูการแสดงผลของการเสียรูปทรงและโมเมนตดัดของกรณี WINDY จะไดดังในรูป 
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นํ้าหนักผนังบนพื้น  

ในกรณีที่มีผนังอิฐกอวางอยูบนพ้ืนโดยท่ีไมมีคานรองรับอยูดานลาง อาจสมมุติใหสวนของพ้ืนที่อยูใต
ผนังทำหนาที่คานโดยสรางเปนคานที่มีหนาตัดลึกเทากับความหนาของพื้นและมีความกวางเทากับ
ความหนาของผนัง 

 

เริ่มตน SAP2000 ใชหนวย Kgf, m, C สรางโมเดลใหม โดยกด Ctrl+N  

 ในหนาตาง New Model เลือก 3D Frames กำหนดคาดังในรูป 

 

 คลิกปุม    เลือก Fill Objects และ Apply to All Windows แลวจัดหนาตางดังในรูป 

Slab
thickness

Wall
thickness

Assumed
Beam
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 คลิกเลือกพ้ืน สั่งเมนู Assign > Area > Automatic Area Mesh เลือกแบงพ้ืนยอยขนาด 0.5 

 

 คลิกปุม    เลือกใหแสดง Show Analysis Model และ Apply to All Windows คลิกปุม 
Apply เพ่ือใหแสดงการแบงยอย เสร็จแลวปดการแสดงกลับคืน 

 



 

SAP2000  C5 Analysis Mongkol  JIRAVACHARADET 177 
 

 สั่งเมนู Define > Section Properties > Area Sections… เลือกรายการ ASEC1 แลวกดปุม 
Modify/Show Section กำหนดใหมีความหนา 0.15 m 

 

 สั่งเมนู Define > Section Properties > Frame Sections… คลิกปุม Add New Property

เลือกเปนหนาตัดคอนกรีตสี่เหล่ียมสรางเปนหนาตัดคาน UW ที่มีความลึก 0.15 m เทากับความ
หนาพื้น และความกวาง 0.10 m เทากับความหนาผนัง 

 

 ในหนาตางสองมิติ คลิกเลือกคานแนวด่ิงขางซาย กด Ctrl+R ใสระยะ dx = 2 m 

 



 

SAP2000  C5 Analysis Mongkol  JIRAVACHARADET 178 
 

 คลิกเลือกคานที่สรางขึ้นใหม สั่งเมนู Assign > Frame > Frame Sections เลือกกำหนดเปน
หนาตัด UW 

 สั่งเมนู Define > Load Patterns สรางรูปแบบรรทุก SDL และ LIVE 

 

 คลิกเลือกคาน UW สั่งเมนู Assign > Frame Loads > Distributed เลือกกรณีบรรทุก SDL 

ใสน้ำหนักแผคงท่ี 500 กก./ม. 

  

 คลิกหนาตางสามมิติ สั่งเมนู Display > Show Object Load Assigns > Frame เลือกกรณี
บรรทุก SDL ใหแสดงน้ำหนักแบบ Span Loading (Forces) แลวกดปุม OK 
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 สั่งเมนู Analyze > Run Analysis หรือกด F5 เพ่ือรันการวิเคราะหโครงสราง 

 เลือกรายการ MODAL กดปุม Run/Do Not Run Case ใหไมรันกรณี MODAL 

 ตั้งชื่อไฟลวา EX7 Wall on Slab 
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 ดูการแสดงผลของหนวยแรงและการเสียรูปทรงภายใตกรณีบรรทุก SDL โดยคลิกหนาตางสาม
มิติ สั่งเมนู Display > Show Forces/Stresses > Shells เลือกกรณี SDL, Shell Stresses, 

SMax และ Show Deformed Shape 

 

 คลิกหนาตางสองมิติ สั่งเมนูใหแสดงหนวยแรงภายใต SDL เชนเดียวกัน 

 

จะเห็นวาหนวยแรงและการแอนตมีคาสูงบริเวณใตผนัง สำหรับการออกแบบอาจใชคาโมเมนต
ดัดและแรงเฉือนในพ้ืนซึ่งบริเวณใตผนังจะมีคาสูงเชนกัน 
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นํ้าหนักบนพื้นท่ีบางสวน  

บางครั้งในพื้นเดียวกันอาจรับน้ำหนักบรรทุกไมเทากันเชนมีเครื่องจักรหนักวางบนพื้นหรือมีเสามา
กระทำโดยที่ดานลางไมมีเสาหรือคานรองรับ เราสามารถทำไดโดยการแบงพื้นเปนสวนยอยแลวใส
น้ำหนักบรรทุกแยกกัน 

 สั่งเมนู File > Save As ตั้งชื่อไฟลวา EX8 Load on Slab 

 คลิกเลือกคานแนวด่ิงและแนวนอน กด Ctrl+R ทำซ้ำจนไดดังในรูป (ระยะหาง 1 m) 

 

 เลือกพื้นและคานที่ใชเปนเสนแบง สั่งเมนู Edit > Edit Areas > Divide Areas เลือกแบงแบบ 
Divide Area Using Cookie Cut Based On Selected Straight Line Objects 

 คลิกเลือกและลบคานภายในพ้ืนที่ใชเปนเสนแบงออก 
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 คลิกเลือกพ้ืนภายใน สั่งเมนู Assign > Area Loads > Uniform ใสคาน้ำหนักบรรทุก LIVE 

 

 สั่งคลิกหนาตางสามมิติ สั่งเมนู Display > Show Object Load Assigns > Area เลือกกรณี
บรรทุก LIVE ใหแสดงน้ำหนักแบบ Uniform Load Resultants แลวกดปุม OK 

 

 สั่งเมนู Analyze > Run Analysis หรือกด F5 เพ่ือรันการวิเคราะหโครงสราง 

 ดูการแสดงผลของหนวยแรงและการเสียรูปทรงภายใตกรณีบรรทุก LIVE จะไดดังในรูป 
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จะเห็นวามีการแอนตัวและหนวยแรงสูงบริเวณรับน้ำหนัก 

 คลิกปุม    ปลดลอคโมเดล เลือกพ้ืนทั้งหมด 

 

 สั่งเมนู Assign > Area > Automatic Area Mesh เมื่อกลับมาสั่งแบงพ้ืนยอยขนาด 0.5 X 0.5 

m จะไดการเสียรูปทรงดังในรูป 
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ชองเปดในพ้ืน  

การวาดชองเปดในพื้นใชหลักการเดียวกันคือวาดคานเพื่อใชในการแบงพื้นออกเปนสวนๆแลวคลิก
เลือกและลบสวนทีเปนชองเปดทิ้ง 

 สั่งเมนู File > Save As ตั้งชื่อไฟลวา EX9 Slab Opening 

 คลิกเลือกพ้ืนตรงกลางแลวกด Delete ลบทิ้งเพ่ือสรางชองเปด 

 

 คลิกเลือกพ้ืนที่เหลือทุกแผน สั่งเมนู Assign > Area Loads > Uniform ใสน้ำหนัก LIVE 

 

 สั่งเมนู Analyze > Run Analysis หรือกด F5 เพ่ือรันการวิเคราะหโครงสราง 
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 ดูการแสดงผลของหนวยแรงและการเสียรูปทรงภายใตกรณีบรรทุก LIVE จะไดดังในรูป 
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การออกแบบ 
ในบทนี้จะกลาวถึงการออกแบบโครงสรางใน SAP2000 โดยจะเปนการออกแบบเหล็กซึ่งจะเปนการ
เลือกหนาตัดเหล็ก และการออกแบบคอนกรีตเสริมเหล็ก โดยหลังจากโครงสรางจะตองผานการ
วิเคราะห เราจะกำหนดกรณีบรรทุกรวมสำหรับออกแบบ เลือกมาตรฐานในการออกแบบและ
พารามิเตอรตางๆ เมื่อออกแบบเสร็จก็จะแสดงผลการออกแบบรูปแบบตางๆ ตลอดจนจัดทำเปน
รายงานออกมาในท่ีสุด 

การออกแบบโครงสรางเหล็ก Steel Design 

 สั่งเมนู File > Open เปดไฟล EX3 Steel Frame ขึ้นมาแลวสั่ง File > Save As ตั้งชื่อวา EX3 

Steel Frame DSGN  

 

การเลือกหนาตดัอตัโนมัต ิ Auto Select List 

 สั่งเมนู Define > Section Properties > Frame Section คลิกปุม 
Import New Property เลือกหนาตัด I / Wide Flange 
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 เลือกตารางหนาตัดเหล็กของไทยไฟล TH_WF เลือกหนาตัด W200 ถึง 
W400 เขามาดังในรูป (ลบหนาตัดที่ซ้ำกันโดยกด Delete Property) 

 

 คลิกปุม Add New Property เลือก Auto Select List 
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 ตั้งชื่อเปน AUTO1 เลือกหนาตัด W ทั้งหมดที่นำเขามา คลิกปุม Add ยายมาทางขวา เพื่อให
โปรแกรมทำการเลือกโดยอัตโนมัติ 

 

 คลิกปุม    ปดการแสดงพื้น Fill Objects และ Areas > Not in View เลือก Apply to 

All Windows 

 กด Ctrl+A เลือกองคอาคารทั้งหมด สั่งเมนู Assign > Frame > Frame Sections เลือก Auto 

Select List หนาตัดกลาง (AUTO1) จะแสดงข้ึนบนทุกองคอาคารดังในรูป 

 คลิกอีกหนาตางที่ยังไมแสดง สั่งเมนู Display > Show Misc Object Assigns > Frame เลือก 
Section Properties 
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จัดกลุมองคอาคาร Group Members 

สำหรับอาคารในตัวอยางนี้เราจะจัดเปน 4 กลุมคือ เสา (Column), คานทิศทาง X (BeamX), คาน
ทิศทาง Y (BeamY) และ แกงแนง (Brace) 

 สั่งเมนู Select > Select > Group หรือกด Ctrl+G จะเห็นวามีกลุมเสาและคานทิศทาง X ถูก
กำหนดอยูแลว 

 

 สั่งเมนู Select > Select Select Lines Parallel To Coordinate Axes or Plane เลือก
ระนาบ XY คลิกปุม Select เพ่ือเลือกคานท้ังหมด แลวกดปุม Close 

 กด Ctrl+Shift+G เลือกรายการ All Beams และ Replace Group คลิกปุม OK 

 กด Ctrl+G เล ือกรายการ All Beams คลิกปุ ม Select แลวเล ือก All Beams X คลิกปุม 
Deselect เพ่ือใหเหลือคานทิศทาง Y ที่ถูกเลือก 

 

 กด Ctrl+Shift+G คลิกปุม Define Groups > Add New Group ตั้งชื่อวา All Beams Y เมื่อ
กลับมาที่หนาตาง Assign to Group เลือกรายการ All Beams Y กดปุม OK 

 คลิกเลือกทอนแกงแนงทั้งหมด คลิกปุม Define Groups > Add New Group ตั้งชื่อวา Brace 

เมื่อกลับมาที่หนาตาง Assign to Group เลือกรายการ Brace กดปุม Apply 
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 สั่งเมนู Analyze > Run Analysis หรือกด F5 เพ่ือรันการวิเคราะหโครงสราง 

 สั่งแสดงผลการเสียรูปทรงและโมเมนตดัดเพ่ือตรวจสอบความถูกตองอีกครั้ง 

  

กรณีบรรทุกรวม Load Combinations 

SAP2000 จะทำการวิเคราะหโครงสรางภายใตน้ำหนักบรรทุกแตละกรณีแยกกัน การกำหนดกรณี
บรรทุกรวมทำเมื่อตองการผลการวิเคราะหหรือนำไปใชในการออกแบบซึ่งแตละมาตรฐานจะมี
ขอกำหนดกรณีบรรทุกรวมที่แตกตางกัน สำหรับในตัวอยางนี้เราจะออกแบบโครงสรางเหล็กแบบ
โดยวิธีหนวยแรงที่ยอมให (Allowable Stress Design, ASD) สมมุติวาตองการใชกรณีบรรทุกรวม
ดังตอไปน้ี (เปนการสาธิตไมไดใชครบทุกกรณี) 

1) 1.0D + 1.0L 

2) 1.0D + 0.75L + 0.45W 

3) 1.0D + 0.75L + 0.525E 

 สั่งเมนู Define > Load Combinations คลิกปุม Add New Combo…  
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 กรณีบรรทุกรวม COMB1 เลือกกรณีบรรทุก DEAD และ LIVE ใสคา Scale Factor = 1  

 

 สรางกรณีบรรทุกรวมที่เหลือโดยวิธีการเดิม กรณีบรรทุกที่มีแรงดานขาง WINDY หรือ EQKY 

จะมีทั้งคา  เนื่องจากแรงดานขางมีท้ังทิศ +Y และ –Y จนได 5 รายการ ดังนี้คือ 

COMB1  =  1.0 DEAD  +  1.0 LIVE 

COMB2  =  1.0 DEAD  +  0.75 LIVE  +  0.45 WINDY   

COMB3  =  1.0 DEAD  +  0.75 LIVE  –  0.45 WINDY   
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COMB4  =  1.0 DEAD  +  0.75 LIVE  +  0.525 EQKY   

COMB5  =  1.0 DEAD  +  0.75 LIVE  –  0.525 EQKY   

 

การส่ังออกแบบโครงสรางเหล็ก Steel Frame Design 

 เล ือกเมนู Design > Steel Frame Design > View/Revise Preferences เล ือกมาตรฐาน
ออกแบบ AISC-ASD89 และกำหนดพารามิเตอรออกแบบ 

 

 สั่งเมนู Design > Steel Frame Design > Select Design Group เลือกกลุมท่ีจะออกแบบคือ 
All Columns, All Beams X, All Beams Y และ Brace 
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 สั่งเมนู Design > Steel Frame Design > Select Design Combos เลือกกรณีบรรทุกรวมที่
จะใชในการออกแบบ COMB1 ถึง COMB5 และคลิกไมเลือกการสรางกรณีบรรทุกรวมอัตโนมัติ 

 

 สั ่งเมนู Design > Steel Frame Design > Start Design/Check of 

Structure หรือกด Shift+F5 เพ่ือเริ่มตนทำการคำนวณออกแบบ 

เมื่อโปรแกรมทำการออกแบบเสร็จจะแสดงหนาตัดที่เลือกและผลการออกแบบโดยระบุสีบนแต
ละองคอาคารตามอัตราสวนความตองการตอกำลัง (Demand/Capacity Ratio) ถามีคาเกิน 
1.00 เปนสีแดงแสดงวาองคอาคารน้ันกำลังไมเพียงพอไมผานการออกแบบ 
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 สั่งเมนู Design > Steel Frame Design > Verify Analysis vs Design Section เพ่ือตรวจสอบ
วาหนาตัดที่ใชในการวิเคราะหและที่ไดจากการออกแบบตางกันหรือไมจะได 

 

จากในรูปจะระบุวายังมี 86 องคอาคารที่ผลจากการออกแบบตางกับท่ีใชในการวิเคราะห 

 คลิกปุม  ปลดลอคโมเดล แลวกด F5 เพื่อรันวิเคราะหโดยใชหนาตัดที่ไดจากการออกแบบ 
แลวกด Shift+F5 เพื่อรันออกแบบ เลือกหนาตัดใหม แลวสั่งตรวจสอบซ้ำเชนเดิม จำนวนองค
อาคารที่ตางกันจะลดลง ซึ่งแมวาจะทำหลายครั้งก็ยังเหมือนเดิม ซึ่งเราอาจกด Yes เพื่อดูวา
เปนองคอาคารไหนท่ียังมีปญหาแลวทำการกำหนดหนาตัดใหโดยตรงแทนที่จะใช AUTO1 

 

จนกระท่ังหนาตัดที่ใชในการวิเคราะหและหนาตัดที่ไดจากการออกแบบท้ังหมดตรงกัน 
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 เพื ่อตรวจสอบเปนครั ้งสุดทายวาทุกองคอาคารผานหมด สั ่งเมนู Design > Steel Frame 

Design > Verify All Members Passed 

 

 คลิกขวาที่องคอาคารเพื่อดูผลการออกแบบ แลวคลิกปุม Details เพื่อใหแสดงรายการคำนวณ
โดยละเอียดที่ตำแหนงนั้น 
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การออกแบบคอนกรีตเสริมเหล็ก RC Design 

 สั่งเมนู File > Open เปดไฟล EX4 Simple RC 2 ขึ้นมาแลวสั่ง File > Save As ตั้งชื่อวา EX4 

Simple RC DSGN แลวกด F5 รันการวิเคราะห 

 

 สั่งเมนู Analyze > Run Analysis หรือกด F5 เพ่ือรันการวิเคราะหโครงสราง 

 สั ่งเมนู Design > Concrete Frame Design > View/Revise Preferences เลือกมาตรฐาน 
ACI318-14 และปรับคาพารามิเตอรออกแบบตามมาตรฐาน ว.ส.ท. ดังในรูป 

 

Pattern Live Load Factor : 
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มาตรฐาน ACI กำหนดใหคิดผลของการจัดรูปแบบน้ำหนักจร (Live Load Pattern) เม่ือ
อัตราสวน LL/DL > 3/4 ในโปรแกรม SAP2000 และ ETABS จะใชวิธีประมาณโดยใช Pattern 

Live Load Factor (Pllf) คือแฟกเตอรที่ใชประมาณความหลากหลายในการจัดรูปแบบน้ำหนัก
จร Pllf จะเปนอัตราสวนของน้ำหนักบรรทุกจรที่จะถูกนำไปคำนวณโมเมนตบวกกลางชวงที่จะ
เพ่ิมข้ึนตามสูตร 

 
2

pos,MAX DL
f2 Pllf (LL L )M f1 M

8
 

เมื่อ f1 =  ตัวคูณเพ่ิมน้ำหนักบรรทุกคงท่ี (1.4) 

 f2 =  ตัวคูณเพ่ิมน้ำหนักบรรทุกจร (1.7) 

 Pllf =  ตัวคูณรูปแบบน้ำหนักบรรทุกจรใน SAP2000 และ ETABS จะกำหนดไวที่ 0.75 

      ถาตองการใหคิดเต็มที่ใช 1.0 และใช 0 เพ่ือปดการใชงานทางเลือกนี้ 

กรณีบรรทุกรวมออกแบบคอนกรีตเสรมิเหล็ก  

 สั ่งเมนู Design > Concrete Frame Design > Select Design Combos… เพื ่อเลือกกรณี
บรรทุกรวมที่จะใชในการออกแบบ โดยอาจสรางเองจากเมนู Define > Load Combinations 

เชนเดียวกับในตัวอยางการออกแบบโครงสรางเหล็กที ่แลว หรือใหโปรแกรมสรางใหโดย
อัตโนมัติตามมาตรฐานออกแบบท่ีเลือกไว 

 คลิกปุม Set Automatic Design Load Combination Data เพ่ือต้ังคากรณีบรรทุกรวม 
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 อีกทางเลือกคือการกำหนดกรณีบรรทุกรวมโดยตรงหลังจากเลือกมาตรฐานแลว สั่งเมนู Define 

> Load Combinations คลิกปุม Add Default Design Combos 

 

 เลือก Concrete Frame Design เพ่ือสรางกรณีบรรทุกรวมตามมาตรฐานท่ีเลือกไว 
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 กรณีบรรทุกรวมจะถูกสรางขึ้นมาดังในรูปซึ่งเราสามารถคลิกปุม Modify/Show Combo เพ่ือ
ตรวจสอบแกไขได 

  

 

 

 

 

 

 คลิกหนาตาง  X-Y Plane @ Z=6  แลวคลิก    คลิกเอา Fill Objects ออก และเลือก 
Areas > Not in View ใหแสดงเฉพาะ Frames  
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เหล็กเสริมตามยาวในคาน  

 สั่งเมนู Design > Concrete Frame Design > Start Design/Check of Structures หรือกด 
Shift+F6 เพ่ือเริ่มการคำนวณออกแบบ แลวเปลี่ยนหนวยเปน Kgf, cm, C 

 

บนคานแตละตัวจะแสดงตัวเลข 6 ตัว คือปริมาณพ้ืนที่เหล็กเสริม (cm2) ของเหล็กบนและเหล็ก
ลางที่ปลายคานขางซาย, กลางชวงคาน และปลายคานขางขวา 

  

ดังนั้นใชเหล็กเสริม 2-DB16 ทั้งบนและลางยาวตลอด  As  =  2(2.01)  =  4.02 cm2 

 คลิกขวาท่ีคานเพ่ือดูรายละเอียดผลการออกแบบ 

 

1.135 cm2 1.135 cm2 3.537 cm2

1.625 cm2 3.03 cm2 2.298 cm2
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 คลิกปุม Summary เพ่ือดูรายการคำนวณโดยสรุปของการออกแบบหนาตัดคาน 
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เหล็กเสริมรับแรงเฉอืนในคาน  

 คลิกหนาตาง X-Y Plane สั ่งเมนู Design > Concrete Frame Design > Display Design 

Info… เลือก Shear Reinforcing ใหแสดงเหล็กเสริมรับแรงเฉือน 

 

 

คาท่ีแสดงคือพ้ืนที่เหล็กรับแรงเฉือนตอหนวยความยาว (Av/s) ตัวอยางเชน 0.023 

สมมุติใชเหล็กปลอก DB10 (Av = 2(0.785) = 1.57 cm2) 

ระยะหางเหล็กปลอก  s  =  1.57/0.023  =  68.3 cm  >  [d/2 = 18] Use s = 18 cm 

ดังนั้นจะไดผลการออกแบบคานคือ 
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ผลการออกแบบเสาคอนกรีตเสรมิเหล็ก  

 คลิกหนาต าง 3-D View สั ่งเมนู Design > Concrete Frame Design > Display Design 

Info… เลือก Longitudinal Reinforcing ใหแสดงเหล็กเสริมตามยาว 

 

จะเห็นวามีเสาหลายตนแสดงเปนสีแดงหมายถึงออกแบบไมผานตองตรวจสอบแกไข 

 

STIRRUP
DB10 @ 0.18 m

2-DB16

2-DB16
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 คลิกขวาท่ีเสาตนสีแดงเพ่ือดูรายละเอียดการออกแบบ กดปุม Summary และ B/C Details 

  

เมื่อกด B/C Details จะไดดังในรูป 
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เนื่องจากการออกแบบเปนแบบ Sway Special ซึ่งใชในโซนแผนดินไหวรุนแรง ในมาตรฐาน 
มยผ.1302 คือการออกแบบแผนดินไหวประเภท ง ซึ่งจะมีขอกำหนดใหเสาตองแข็งแรงกวาคาน
อยางนอย 20% หรือ 6/5 เทา ดังนั้นจึงไมผานการออกแบบ 

 กด Ctrl+A เลือกทั้งหมด แลวสั่งเมนู Design > Concrete Frame Design > View/Revise 

Overwrites… ในช  อ ง  Framing Type เ ปล ี ่ ย น เป  น  Sway Intermediate สำหร ั บ โซน
แผนดินไหวปานกลาง คือประเภท ค  

 

 คลิกหนาตาง 3-D View กด Shift+F6 เพ่ือรันการออกแบบอีกคร้ัง 

 

จะเห็นวาเหลือเสาตนแดงอยู 2 ตนตรงกลาง  

 คลิกขวาท่ีเสาตนกลางที่สีแดงเพ่ือดูรายละเอียดการออกแบบ 
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จะเห็นคำวา O/S #2 แสดงวามีขอผิดพลาดในการออกแบบ คลิกปุม Summary เพ่ือดูรายการ
คำนวณโดยสรุป จะเห็นวาขนาดหนาตัดไมเพียงพอ 

 



 

SAP2000  C6 Design Mongkol  JIRAVACHARADET 208 
 

 

 คลิก    ปลดลอคโมเดล สั่งเมนู Define > Section Properties > Frame Sections สราง
หนาตัดเสาเพ่ิมข้ึนคือ C30X30 ใชเหล็ก 4-DB20 แลวกำหนดใหแกเสาสองตนกลางอาคาร 

 

 

 

 

 คลิกเล ือกเสาสองตนกลาง สั ่งเมนู Assign > Frame > Frame Sections เล ือกหนาตัด 
C30X30 แลวกดปุม OK 

 

ในมุมมอง XZ บนเสนกริด 2 จะเห็นเสาสองตนกลางถูกเปลี่ยนเปนหนาตัด C30X30 

 กด F5 เพ่ือรันการวิเคราะห แลวกด Shift+F6 เพ่ือรันการออกแบบ 
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จะเห็นวาไมมีเสาสีแดงเหลือ แสดงวาออกแบบผานทั้งหมดแลว  ที่เสาสองตนกลางซึ่งเคยเปน 
O/S จะแสดงผลออกแบบเหล็กเสริมยืน 

ผลของแฟกเตอรรูปแบบบรรทุกจร Pattern Live Load Factor 

 คลิกหนาตาง  X-Y Plane @ Z=6  สั่งเมนู Design > Concrete Frame Design > Display 

Design Info… เลือกใหแสดง Longitudinal Reinforcing 

 

เราจะลองเปลี่ยนคาแฟกเตอรรูปแบบบรรทุกจร โดยใชผลการออกแบบคานที่วงไวเปนตัว
เปรียบเทียบ 

 ส ั ่ ง เมน ู  Design > Concrete Frame Design > View/Revise Preferences จะเห ็นว าคา 
Pattern Live Load Factor (Pllf) = 0.75 ซึ่งเปนคาเริ่มตนที่โปรแกรมตั้งไว 
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 ลองเปลี ่ยนคาเปน Pllf = 0 คือไมคิดผลการจัดน้ำหนักจร และ Pllf = 1 คือคิดผลการจัด
น้ำหนักจร 100% จะไดผลการออกแบบเหล็กเสริมดังนี้ 

   

จะเห็นวามีบางคาของโมเมนตบวกท่ีเพ่ิมข้ึนเมื่อคิดผลของการจัดน้ำหนักบรรทุกจร 

การออกแบบพ้ืนคอนกรีตเสริมเหล็ก RC Slab Design 

SAP2000 จะทำการออกแบบเฉพาะองคอาคารที่เปนโครง (Frame) แตจะไมการออกแบบพื้นและ
ผนังให โดยการออกแบบพื้นอาจสงออกไปทำในโปรแกรม SAFE สวนการออกแบบผนังจะอยู ใน
โปรแกรม ETABS แตถาเราตองการคำนวณแบบงายๆก็อาจจะพอทำไดใน SAP2000 คือนำคาแรง
ภายในพ้ืนมาคำนวณออกแบบเองดวยมือดังนี้ 

 คลิกหนาตางสองมิติ สั่งเมนู Display > Show Undeformed Shape 

 คลิกปุม    เลือก Fill Object และ Area > Local Axes ใหแสดงแกนเฉพาะของพ้ืนที่ 

จะเห็นวาแกน 1 (สีแดง) ของพ้ืนชี้ไปทางแกน X และแกน 2 (สีเขียว) ชี้ไปทางแกน Y 
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จากการวิเคราะหพื้นจะไดแรงภายในเปนองคประกอบยอยในแตละชิ้นสวนยอยของพื้นโดยมี
ทิศทางอางอิงกับแกนเฉพาะของพ้ืนดังในรูป 

ตัวอยางเชนถาเราตองการออกแบบเหล็กเสริมในทิศทาง X ซึ ่งจะตรงกับแกน 1 
องคประกอบแรงท่ีจะดูก็คือ M11 โดยจะเปนคาโมเมนตตอหนวยความยาวในระนาบ 

 คลิกหนาตางสองมิติ กดปุม    เลือก Shells… เลือกกรณีบรรทุกรวม DCON2 ซึ่งก็คือ 

1.4DL + 1.7LL และกำหนดคาตางๆดังในรูป 

 

 คลิกหนาตางสามมิติ สั่งเชนเดิม แลวเลือกเมนู Options > Dimensions/Tolerances เปลี่ยน
คา Screen Line Thickness = 1 

M11

M12
1

X

Y

M22

M12

2

Moments are per unit
of in-plane length
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ที่มุมซายลางจะแสดงคาโมเมนตนอยที่สุดคือ -1,281 Kgf-m/m คือโมเมนตลบบริเวณหัวเสา 
และคาโมเมนตมากท่ีสุด 593 Kgf-m/m คือโมเมนตบวกท่ีกลางชวง  

เราสามารถนำคาโมเมนตมาออกแบบพื้นโดยคิดเสมือนคานที่มีความกวาง 1 m = 100 cm 

และลึกเทากับความหนาพ้ืน S1 คือ 12 cm 

 

คำนวณพื้นท่ีเหล็กเสริมที่ตองการโดยวิธีประมาณ 

2u
s

y

M 1,281 100A 4.16 cm
(0.9d)f 0.9 0.9 9.5 4,000

 

ใชเหล็กเสริม DB10 (As = 0.785 cm2)  

ระยะหาง s ที่ตองการคือ 100 0.785/4.16  =  18.9 cm 

 ดังนั้นใชเหล็กเสริมบนเพื่อรับโมเมนตลบบริเวณหัวเสา DB10 @ 0.18 m 

 

h = 12 cm

b = 100 cm

S1

DB10 @ 0.18
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การออกแบบเหล็กเสริมในแผนคอนกรีต  
Concrete Shell Reinforcement Design 

โปรแกรม SAP2000 สามารถทำการออกแบบเหล็กเสริมในแผนคอนกรีตจากสนามโมเมนตซึ่งเปนไป
ตามขอกำหนดใน DD ENV 1992-1-1 1992 Eurocode 2: Design of Concrete Structures 

 เปลี่ยนหนวยเปน Kgf, cm, C, คลิกหนาตางสองมิติ แลวกดปุม    เลือก Shells… เลือก
กรณีบรรทุกรวม DCON2 เชนเดิม แตครั้งนี้เลือกชนิดการแสดงเปน Concrete Design และ
เหล็กเสริม Ast1 

 

ปริมาณเหล็กเสริม Ast1 คือคาพื้นที่เหล็กเสริมตอหนวยความกวางในทิศแกนเฉพาะที่ 1 ของ
แผนพื้นคอนกรีตซึ่งมีทิศไปทางแกน X 
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ที่มุมซายลางจะแสดงปริมาณเหล็กเสริมมากที่สุด 0.039 cm2/cm = 3.9 cm2/m  

ใชเหล็กเสริม DB10 (As = 0.785 cm2)  

ระยะหาง s ที่ตองการคือ 100 0.785/3.9  =  20.1 cm 

 ดังนั้นใชเหล็กเสริมบนเพื่อรับโมเมนตลบบริเวณหัวเสา DB10 @ 0.20 m 

 กดปุ ม    เลือก Shells… และกรณี DCON2 เชนเดิม แตเลือกเปน Bottom Face 

เพ่ือใหแสดงเหล็กลาง 

 

การสงออกขอมูลไปยัง EXCEL  

 ใน SAP2000 คลิกปุม    เลือกใหแสดงหมายเลขจุดตอ Joints > Labels 

 

 สั่งเมนู Define > Load Combinations สรางกรณีบรรทุกรวมเพ่ิมเติมคือ 
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 SERVICE : DEAD + SDL + LIVE คือนํ้าหนักบรรทุกใชงานสําหรับกําหนดขนาดฐานราก
หรือจํานวนเสาเข็ม 

 

 ULTIMATE : เลือกวิธีรวมแบบ Envelope เพื่อหาคามากที่สุดและนอยที่สุดของทุกกรณี
บรรทุกรวม (UCDON) 
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 สั่งเมนู Display > Show Table หรือกด Ctrl+T เลือกใหแสดง Joint Reactions และกรณี
บรรทุก SERVICE และ ULTIMATE (กด Ctrl คางไวเพ่ือเลือกหลายรายการ) 

 

 ในตาราง Joint Reactions ที่แสดงขึ้นมา ใหคลิกที่ชอง OutputCase เพื่อเรียงขอมูลใหกรณี
บรรทุก SERVICE และ ULTIMATE แยกกลุมกัน 

 

 สั่งเมนู File > Export Current Table > To Excel 

 ใน Excel ตารางยังไมเรียงคา ใหสั่ง Data > Sort เลือกใหเรียงตาม Column B 
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จะไดตารางขอมูลดังในรูปเพื่อนำไปออกแบบฐานรากตอไป 

 

การสรางรายงาน Creat Report 

 สั่งเมนู File > Report Setup เพ่ือต้ังคาตางๆของรายงานท่ีจะสราง ดังในรูป 

 

 สั่งเมนู File > Create Report เพ่ือสรางรายงานแบบอัตโนมัติ 
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การคำนวณแรงลม 
ตามมาตรฐาน มยผ.1311-50 

ในบทนี้จะกลาวถึงการคำนวณแรงลมตามมาตรฐานการคำนวณแรงลมและการตอบสนองของอาคาร 
ของกรมโยธาธิการและผังเมือง พ.ศ. 2550 (มยผ.1311-50) ซึ่งจะใชความเร็วลมอางอิงเปนความเร็ว
ลมเฉลี่ยในชวงเวลา 1 ชั่วโมงตามมาตรฐานการออกแบบอาคารของประเทศแคนาดา ป ค.ศ. 2005 
(National Building Code of Canada (NBCC-2005)) โดยจะกลาวถึงวิธีการคำนวณแรงลมสถิต
เทียบเทาโดยวิธีอยางงาย การพิจารณาคาสัมประสิทธิ์ในกรณีตางๆสำหรับโครงสรางรับแรงลมใน
ประเทศไทย ตัวอยางการคำนวณแรงลมบนโครงสรางรูปแบบตางๆ และการประยุกตใช งาน
โปรแกรม SAP2000 ในการคำนวณวิเคราะหแรงลมกระทำบนโครงสราง 

หนวยแรงลมอางอิงเนื่องจากความเร็วลม (q) 

หนวยแรงลมอางอิงเนื่องจากความเร็วลม สามารถคำนวณไดจาก 

 21q V
2

 (7.1) 

เมื่อ  q  ที่คำนวณไดมีหนวยเปน นิวตันตอตารางเมตร (N/m2) 

หรือ 21q V
2 g

 (7.2) 

เมื่อ  q  ที่คำนวณไดมีหนวยเปน นิวตันตอตารางเมตร (N/m2) 

  คือ ความหนาแนนมวลอากาศ มีคาประมาณ 1.25 กิโลกรัมตอลูกบาศกเมตร ที่ความดัน
บรรยากาศปกติและอุณหภูมิระหวาง 15 - 45 oC 

V  คือ ความเร็วลมอางอิงเปนคาความเร็วลมเฉล่ียในชวงเวลา 1 ชั่วโมงท่ีความสูง 10 เมตร ใน
สภาพภูมิประเทศโลง (open exposure) โดยมีคาบกลับซ้ำ (return period) 50 ป (V50) 

ยกเวน กลุม 4A และ 4B ความเร็วลมอางอิงของพื้นที่ตางๆในประเทศไทยเปนดังแสดงใน
รูปที่ 7.1 
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สำหรับการออกแบบท่ีสภาวะจำกัดดานการใชงาน 

 50V V  (7.3) 

สำหรับการออกแบบท่ีสภาวะจำกัดดานกำลัง 
 F 50V T V  (7.4) 

โดย V50 คือคาความเร็วลมที่คาบกลับซ้ำ 50 ป และ TF คือคาประกอบไตฝุน 

 
รูปที่ 7.1 แผนที่การแบงกลุมความเร็วลมอางอิง 

การจำแนกและการแบงกลุมความเร็วลมอางอิงมีจำนวน 5 กลุม ไดแก 

 กลุมท่ี 1 V50  25 เมตร ตอ วินาที TF  1.0  

 กลุมท่ี 2 V50  27 เมตร ตอ วินาที TF  1.0  

 กลุมท่ี 3 V50  29 เมตร ตอ วินาที TF  1.0  
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 กลุมท่ี 4A V50  25 เมตร ตอ วินาที TF  1.2  

 กลุมท่ี 4B V50  25 เมตร ตอ วินาที TF  1.08  

วิธีคํานวณแรงลมสถิตเทียบเทา 

วิธีการคํานวณแรงลมสถิตเทียบเทาเปนวิธีการอยางงายในการคํานวณแรงลมสามารถใชไดกับ
โครงสรางดังตอไปนี้ 

ก. ระบบโครงสรางหลักตานทานแรงลม (main wind-force resistant system) ของอาคารเต้ีย
และอาคารสูงปานกลางที่มีความสูงไมเกิน 80 เมตร และมีความสูงไมเกิน 3 เทาของความกวาง
ประสิทธิผลท่ีนอยที่สุด สามารถคํานวณไดจาก 

 i i

i

hWW
h

 (7.5) 

โดยที่    ผลรวมของทุกชั้นของอาคาร 

 hi   ความสูงจากพ้ืนดินถึงชั้นที่ i 

 Wi   ความกวางของอาคารในทิศทางต้ังฉากกับทิศทางลม ที่ความสูง hi 

ความกวางประสิทธิผลที่นอยที่สุดของอาคารใหพิจารณาจากทิศทางลมในทุกทิศทาง 
ข. ผนังภายนอกอาคาร (cladding) ของอาคารทุกประเภท 

 

รูปท่ี 7.2 การพิจารณาความกวางประสิทธิผลของอาคาร 

แรงลมออกแบบ 

หนวยแรงลมที่กระทําบนพ้ืนผิวภายนอกของอาคารในทิศทางลม สามารถคํานวณไดจาก 

 w e g pp I qC C C  (7.6) 

WIND
W1 D

W2

W3

h1

h2

h3
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โดยที่ p   หนวยแรงลมสถิตเทียบเทา (equivalent static wind pressure) กระทําตั้งฉากกับ
พื้นผิวภายนอกอาคาร โดยเรียกวา หนวยแรงดัน ถามีทิศเขาหาพื้นผิว หรือ หนวย
แรงดูด ถามีทิศพุงออกจากพ้ืนผิว 

 Iw   ตัวคูณความสําคัญแรงลม 

 q   หนวยแรงลมอางอิงเนื่องจากความเร็วลม (reference velocity pressure) 

 Ce   ตัวคูณสภาพการเปดโลง (exposure factor)  

 Cg   ตัวคูณลมกระโชก (gust factor)  

 Cp   สัมประสิทธิ์ความดันภายนอก (external pressure coefficient)  

หนวยแรงลมสุทธิเพื่อใชในการคํานวณแรงลมที่กระทําตอสวนใดสวนหนึ่งของดานใดดานหน่ึง
ของอาคารเชนผนังภายนอกหรือหลังคา เปนผลรวมแบบเวกเตอรของหนวยแรงลมที่กระทําบน
พื้นผิวภายนอกและหนวยแรงลมที่กระทําบนพื้นผิวที่กระทําบนพื้นผิวภายใน โดยที่หนวยแรงลม
ภายในคํานวณจาก 

 i w e gi pip I qC C C  (7.7) 

โดยที่ pi   หนวยแรงลมสถิตเทียบเทา (equivalent static wind pressure) กระทําตั้งฉากกับ
พื้นผิวภายในอาคาร โดยเรียกวา หนวยแรงดัน ถามีทิศเขาหาพื้นผิว หรือ หนวยแรง
ดูด ถามีทิศพุงออกจากพ้ืนผิว 

 Cgi   ตัวคูณลมกระโชก (gust factor) ของลมที่กระทําภายในอาคาร 

 Cpi   สัมประสิทธิ์ความดันภายในอาคาร 

ตารางท่ี 7.1 การจําแนกประเภทของอาคารตามความสําคัญตอสาธารณชน 

ประเภทของอาคาร ความสําคัญ 

อาคารและสวนโครงสรางอื่นที่มีปจจัยเสี่ยงอันตรายตอชีวิตมนุษย
คอนขางนอยเม่ือเกิดการวิบัติของอาคารหรือสวนโครงสรางนั้นๆเชน 

- อาคารท่ีเก่ียวของกับการเกษตร 
- อาคารช่ัวคราว 
- อาคารเก็บของเล็กๆซึ่งไมมีความสําคัญ 

นอย 

อาคารและสวนโครงสรางอื่นที่ไมจัดอยูในอาคารประเภทความสําคัญ 
นอย และ สูงมาก 

ปกติ 

อาคารและสวนโครงสรางอื่นที่หากเกิดการพังทลายจะเปนอันตราย
ตอชีวิตมนุษยและสาธารณชนอยางมาก เชน 

- อาคารท่ีเปนที่ชุมนุมในพ้ืนที่หนึ่งๆมากกวา 300 คน 

มาก 



 

SAP2000  C7 Wind Load Mongkol  JIRAVACHARADET 223 
 

- โรงเรียนประถมหรือมัธยมศึกษาท่ีมีความจุมากกวา 250 คน 

- มหาวิทยาลัยหรือวิทยาลัยที่มีความจุมากกวา 500 คน 

- สถานรักษาพยาบาลที่มีความจุคนไขมากกวา 50 คน แตไม
สามารถทําการรักษากรณีฉุกเฉินได 

- เรือนจําและสถานกักกันนักโทษ 
อาคารและสวนโครงสรางที ่ม ีความจําเปนตอความเปนอยู ของ
สาธารณชนเปนอยางมาก หรืออาคารท่ีจําเปนตอการบรรเทาสาธารณ
ภัยหลังเกิดเหตุเปนอยางมาก เชน 

- โรงพยาบาลที่สามารถทําการรักษากรณีฉุกเฉินได 
- สถานีตํารวจ สถานีดับเพลิง และ โรงเก็บรถฉุกเฉินตางๆ 

- โรงไฟฟา โรงผลิตนํ้าปะปา ถังเก็บนํ้า และสถานีสูบจายนํ้าที่
มีความดันสูงสําหรับการดับเพลิง 

- อาคารศูนยสื่อสาร อาคารศูนยบรรเทาสาธารณภัย 

- ทาอากาศยาน ศูนยบังคับการบิน และ โรงเก็บเครื่องบิน ที่
ตองใชเมื่อเกิดกรณีฉุกเฉิน 

- อาคารศูนยบัญชาการแหงชาติ 
อาคารหรือสวนโครงสรางในสวนของการผลิต การจัดการ หรือการใช
สารพิษ เชน เชื้อเพลิง หรือสารเคมี อันกอใหเกิดการระเบิดขึ้นได 

สูงมาก 

 ตารางท่ี 7.2 ตัวคูณความสําคัญของอาคาร 

ความสําคัญอาคาร 
ตัวคูณความสําคัญของแรงลม 

สภาวะจํากัดดานกําลัง สภาวะจํากัดดานการใชงาน 

นอย 

ปกติ 
มาก 

สูงมาก 

0.8 

1 

1.15 

1.15 

0.75 

0.75 

0.75 

0.75 

 

ตัวคูณสภาพการเปดโลง (Ce) 
ตัวคูณสภาพการเปดโลงใชปรับคาหนวยแรงลมใหแปรเปลี่ยนตามความสูงจากพื้นดินและสภาพการ
เปดโลงของภูมิประเทศ การคํานวณแรงลมโดยวิธีอยางงายแบงสภาพการเปดโลงเปน 2 ประเภท
ดังนี้ 
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ก. สภาพเปดโลงแบบ A เปนสภาพภูมิประเทศแบบโลงซึ่งมีอาคาร ตนไม หรือสิ่งปลูกสราง กระจัด
กระจายอยูหางๆกัน หรือเปนบริเวณชายฝงทะเล ใหคํานวณ Ce จากสมการ (7.8) หรือใชคาจาก
ตาราง 7.3 

 
0.2

e
zC

10
  (7.8) 

โดยที่  z  ความสูงจากพ้ืนดิน (หนวยเปนเมตร) ณ ตําแหนงที่คํานวณคาหนวยแรงลม โดยที่ถา 
Ce ที่คํานวณจากสมการ (7.8) มีคานอยกวา 0.9 กําหนดใหใชคา Ce  0.9 

ข. สภาพเปดโลงแบบ B เปนสภาพภูมิประเทศแบบชานเมือง หรือพื้นที่ที่มีตนไมใหญหนาแนน 
หรือบริเวณศูนยกลางเมืองขนาดเล็ก ใหคํานวณ Ce จากสมการ (7.9) หรือใชคาจากตาราง 7.3 

 
0.3

e
zC 0.7

12
  (7.9) 

โดยที่ถา Ce ที่คํานวณจากสมการ (3.8) มีคานอยกวา 0.7 กําหนดใหใชคา Ce  0.7 

สภาพภูมิประเทศใดๆ จะจัดอยูในสภาพเปดโลงแบบ B ไดจะตองมีภูมิประเทศในลักษณะนี้อยาง
สมํ่าเสมอในทิศทางตนลมเปนระยะทางไมนอยกวา 1 กิโลเมตร หรือ 10 เทาของความสูงอาคาร โดย
ใชคาที่มากกวา  

ขอยกเวน อาคารท่ีมีความสูงไมเกิน 80 เมตร และตั้งอยูในกลุมที่มีความเร็วลมอางอิง F 50(V T V )  

ไมเกิน 25 เมตร/วินาที ในรูปที่ 7.1 ใหใชเฉพาะสภาพเปดโลงแบบ A เทานั้น 

ตารางท่ี 7.3 คาประกอบเน่ืองจากสภาพเปดโลง (Ce) สําหรับวิธีการอยางงาย 

ความสูงจากพื้นดิน สภาพเปดโลงแบบ A สภาพเปดโลงแบบ B 

สูงไมเกิน 6 เมตร 0.90 0.70 
สูงเกิน 6 เมตร แตไมเกิน 10 เมตร 1.00 0.70 
สูงเกิน 10 เมตร แตไมเกิน 20 เมตร 1.15 0.82 
สูงเกิน 20 เมตร แตไมเกิน 30 เมตร 1.25 0.92 
สูงเกิน 30 เมตร แตไมเกิน 40 เมตร 1.32 1.00 
สูงเกิน 40 เมตร แตไมเกิน 60 เมตร 1.43 1.13 
สูงเกิน 60 เมตร แตไมเกิน 80 เมตร 1.52 1.24 

ความเร็วลมที่พัดขึ้นเนินเขาและจะมีคาเพิ่มขึ้นดังแสดงในรูปที่ 7.3 อาคารหรือโครงสรางท่ี
ตั้งอยูบนภูเขาหรือเนินลาดชันที่มีความลาดเอียงคืออัตราสวนระยะทางแนวดิ่งตอแนวราบมากกวา 1 

ตอ 10 คาตัวคูณสภาพการเปดโลงจะถูกปรับคาขึ้นเปน eC  คํานวณภายในระยะทาง hx kL  มี
คาเทากับ 

 2
e e 1 2 3C C 1 K K K   (7.10) 
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โดยที่ H  ความสูงของภูเขาหรือเนินลาดชันวัดจากระดับพื้นท่ีตนลม (เมตร) 
 K1   พิจารณาจากตารางที่ 7.4 

 K2   
h

x
1

kL
 

 K3   haz/Le  
 a   สัมประสิทธิ์ความเร็วลมตามความสูง 
 Lh   ระยะทางในแนวราบดานตนลมจากยอดเขาถึงระยะ H/2 

 
(ก) ลมพัดขึ้นเนินลาดชัน 

 
(ข) ลมพัดขึ้นภูเขา 

รูปที่ 7.3 การเพ่ิมข้ึนของความเร็วลมบริเวณเนินลาดชันและภูเขา 

ตารางท่ี 7.4 คาตัวคูณสําหรับคํานวณการเพ่ิมข้ึนของความเร็วลมบริเวณภูเขาและเนินลาดชั้น 

รูปรางเนินเขา 1

h

K
H / L

 a 
k 

x  0 x  0 

เนินเขา 2 มิติ (หรือหุบเขาท่ีคา H เปนลบ) 2.2 3 1.5 1.5 

z

V(z)

V(z)

x(Upwind)

Lh

x(Downwind)

H/2

H/2
H

Speed-up

z

V(z)

V(z)

x(Upwind)

Lh

x(Downwind)

H/2

H/2
H

Speed-up
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เนินลาดชัน 2 มิต ิ 11.3 2.5 1.5 4 

เนินเขา 3 มิติ ไมสมมาตร 1.6 3 1.5 1.5 

หมายเหตุ : สําหรับอัตราสวน H/Lh  0.5 กําหนดใหใช H/Lh  0.5 และแทนคา 
Lh  2H เมือ่คํานวณ eC  ในสมการ (3.10) 

ตัวคูณลมกระโชก (Cg) 

ตัวคูณสภาพการเปดโลงใชปรับคาหนวยแรงลมใหแปรเปลี่ยนตามความสูงจากพื้นดินและสภาพการ
เปดโลงของภูมิประเทศ การคํานวณแรงลมโดยวิธีอยางงายแบงสภาพการเปดโลงเปน 2 ประเภท 

(1) ตัวคูณลมกระโชกท่ีกระทํากับพื้นผิวภายนอกอาคาร 

ก. สําหรับโครงสรางหลักตานทานแรงลมใชคา gC 2.0  ยกเวน ปายและกําแพงใหใชคา 
gC 2.35  

ข. สําหรับโครงสรางรองและผนังหอหุมอาคาร(cladding) ใชคา gC 2.5  

(2) ตัวคูณลมกระโชกที่กระทําภายในอาคารใหใชคา giC 2.0  หรือคาที่คํานวณจากสมการ 
(7.11) ขึ้นกับปริมาณชองเปดของอาคาร ในกรณีที่อาคารมีขนาดใหญและไมมีผนังก้ันภายในซึ่ง
ทําใหปริมาตรอากาศในอาคารมีมาก ความดันลมภายในจะเปลี่ยนแปลงชากวาภายนอก ซึ่งใน
กรณีดังกลาวอาจใชคาท่ีคํานวณจากสมการ (7.11) 

 gi
i

o

1C 1
V1

6,950A

  (7.11) 

โดยที่ Vi  ปริมาตรภายในอาคาร มีหนวยเปน ลูกบาศกเมตร (เมตร3) 
 Ao   พ้ืนที่ชองเปดบนผนังภายนอกอาคาร มีหนวยเปน ตารางเมตร (เมตร2) 

(3) ตัวคูณลมกระโชกปรับแกจากผลการเพ่ิมความเร็วลมบริเวณเนินลาดชันและภูเขา  

ก. ตัวคูณปรับแก *
gC  ใชแทนตัวคูณลมกระโชกในบริเวณท่ีราบ คํานวณไดดังนี้ 

 * e
g g *

g

CC 1 (C 1)
C

  (7.12) 

ข. การปรับแกผลคูณของ p gC C  สําหรับอาคารเตี้ยที่ตั้งอยูบนภูเขาและเนินลาดชันทําไดโดย
คูณคา p gC C  ดวยอัตราสวน *

g gC / C  โดยที่ gC  คํานวณไดจากหัวขอ (1) และ *
gC  จาก

สมการที่ (7.12) 
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สัมประสิทธิ์ความดันลมภายนอก (Cp) สําหรับอาคารเตี้ย  

สัมประสิทธิ์ความดันลมภายนอกขึ้นกับรูปทรงของอาคาร ทิศทางลม และ ลักษณะการแปรเปลี่ยน
ของความเร็วลมตามความสูงอาคาร สัมประสิทธิ์ความดันลมภายนอกอาคารสําหรับระบบโครงสราง
หลักตานทานแรงลม (Main Wind Force Resisting System, MWFRS) แบงออกตามลักษณะ
อาคารไดแก อาคารเต้ีย, อาคารสูง และ โครงสรางพิเศษ 

สําหรับอาคารเตี้ยที่มีอัตราสวนความสูงตอความกวาง sH / D 1 ( Ds คือความกวางดาน
แคบที่สุด) และมีความสูงอางอิง (reference height) นอยกวา 23 เมตร สัมประสิทธิ์ความดัน Cp 

จะพิจารณาไดจากรูปที่ 7.4 และ 7.5  

 

รูปที่ 7.4 พ้ืนผิวอาคารเต้ียกรณีที่ 1 ลมพัดตั้งฉากสันหลังคา 

ตารางท่ี 7.5 ผลคูณสัมประสิทธิ์ CpCg สําหรับอาคารเต้ียกรณีลมพัดตั้งฉากสันหลังคา 

ความลาดชัน
ของหลังคา 

พื้นที่ผิวอาคาร 
1 1E 2 2E 3 3E 4 4E 

0o ถึง 5o 0.75 1.15 -1.3 -2.0 -0.7 -1.0 -0.55 -0.8 

20o 1.0 1.5 -1.3 -2.0 -0.9 -1.3 -0.8 -1.2 

30o ถึง 45o 1.05 1.3 0.4 0.5 -0.8 -1.0 -0.7 -0.9 

90o 1.05 1.3 1.05 1.3 -0.7 -0.9 -0.7 -0.9 

H

B

4E
3E

2E

1E

4

3
2

1

y
h

2.5H

WIND
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รูปที่ 7.5 พ้ืนผิวอาคารเต้ียกรณีที่ 2 ลมพัดขนานสันหลังคา 

ตารางท่ี 7.6 ผลคูณสัมประสิทธิ์ CpCg สําหรับสําหรับอาคารเต้ียกรณีลมพัดขนานสันหลังคา 

ความลาดชัน
ของหลังคา 

พ้ืนที่ผิวอาคาร 
1 1E 2 2E 3 3E 4 4E 5 5E 6 6E 

0o ถึง 90o -0.85 -0.9 -1.3 -2.0 -0.7 -1.0 -0.85 -0.9 0.75 1.15 -0.55 -0.8 

คําอธิบายประกอบรูปที่ 7.4 และ 7.5 
1. อาคารตองไดรับการออกแบบใหสามารถตานทานแรงลมไดทุกทิศทาง โดยมุมทั้ง 4 ของอาคาร

ตองถูกพิจารณาเปนมุมรับแรงลม (windward corner) โดยแยกพิจารณาเปนกรณีที่ 1 ลมพัด
ตั้งฉากสันหลังคา (รูปที่ 7.4) และกรณีท่ี 2 ลมพัดขนานสันหลังคา (รูปที่ 7.5)  

2. สําหรับความชันหลังคาคาอื่นที่ไมไดแสดงในตารางใหใชการประมาณสัดสวนโดยอางอิงจากคา
ในตาราง 

3. สัมประสิทธิ์คาบวกหมายถึงแรงกระทําตั้งฉากและพุงเขาหาพื้นผิวอาคาร(แรงดัน) สวนคาลบ
หมายถึงแรงกระทําพุงออก(แรงดูด) 

4. ตองคํานึงถึงผลรวมของหนวยแรงดันภายนอกและภายในเพื่อใหไดหนวยแรงดันที่ถูกตองสําหรับ
การออกแบบ โดยคาสัมประสิทธิ์แรงดันภายใน Cpi จะกลาวถึงในหัวขอตอไป 

5. สําหรับการออกแบบฐานราก (ยกเวนสวนที่ยึดโครงสรางและฐานราก (anchorage)) ใหใชคา 
70% ของแรงประสิทธิผล (effective load) ในการออกแบบ 

6. ความสูงอางอิง  h  มีคาเทากับความสูงชายคาอาคาร  H  เมื่อความชันหลังคานอยกวาหรือ
เทากับ 7o แตสําหรับหลังคาที่ชันกวา 7o จะใชเปนคาที่มากกวาระหวางความสูงกึ่งกลางหลังคา
และ 6 เมตร ดังแสดงในรูปที่ 7.6 

H

4E
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1E
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รูปที่ 7.6 ความสูงอางอิงของอาคารเตี้ย 

7. ความกวาง  z  ของพ้ืนที่บริเวณขอบผนังหนาจั่ว (gable wall) ใหใชคาที่นอยกวาระหวาง 10% 

ของดานที่แคบที่สุด และ 40% ของความสูง H โดยคา z ตองไมนอยกวา 4% ของดานที่แคบ
ที่สุดและไมนอยกวา 1 เมตร 

8. ความกวาง  y  ของพื้นที่บริเวณขอบอาคาร (end zone) ใหใชคาที่มากกวาระหวาง 6 เมตร 
และ 2z สําหรับอาคารที่เปนโครงขอแข็งหลายตัวมาตอกัน คา y อาจใชเปนระยะจากขอบ
อาคารถึงโครงขอแข็งภายในตัวแรก (first interior frame) 

9. สําหรับแรงกรณีที่ 1 ในกรณีที่อาคารมีคา B/H  5 คาสัมประสิทธิ์ที่เปนลบบนพื้นผิว 2 และ 
2E ควรจะใชกับพื้นที่ที่กวาง 2.5H จากขอบอาคารดานตนลมเทานั้น สําหรับพื้นสวนที่เหลือ
บนพื้นผิว 2 และ 2E ใหใชเทากับคาสัมประสิทธิ์บนพื้นผิว 3 และ 3E ตามลําดับ 

สัมประสิทธิ์ความดันลมภายนอก (Cp) สําหรับอาคารสูง  
สัมประสิทธิ์ความดันลมภายนอกสําหรับอาคารสูงที่มีคา sH / D 1 ( Ds คือความกวางดานแคบ
ที่สุด) และมีความสูงอางอิง (reference height) มากกวา 23 เมตร สัมประสิทธิ์ความดัน Cp จะ
พิจารณาไดจากตารางท่ี 7.7 และรูปที่ 7.7 

 
รูปที่ 7.7 สัมประสิทธความดันภายนอกสําหรับอาคารสูง 

 7o

H =
reference 
height, h

 7o

H
reference 
height, h

H

W

z

Cp = 0.8
(Ref. height = z)

Cp = -0.7
(Ref. height = H)

Cp = -0.5
(Ref. height = 0.5H)

Cp = -0.7
(Ref. height = H)

D
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ตารางท่ี 7.7  คาสัมประสิทธิ์ความดันบนผนังอาคารสูง 

พื้นผิว Cp ความสูงอางอิง* 
ผนังดานปะทะลม 0.8 z 

ผนังดานหลบลม -0.5 0.5H 

ผนังดานขาง -0.7 H 

ผนังดานบน -1.0 H 

*ความสูงอางอิงใชในการคํานวณคา Ce 

การรวมผลแรงลมในทิศทางลม, ทิศทางตั้งฉาก และโมเมนตบิด 

การรวมผลของแรงลมเนื่องจากแรงลมในทิศทางลม แรงลมในทิศทางตั้งฉากกับทิศทางลมและ
โมเมนตบิด เพ่ือคํานึงถึงการกระจายท่ีไมสมมาตรของหนวยแรงลม และผลของลมกระทําที่มุมปะทะ
ตางๆกับอาคารซ่ึงบางกรณีมีผลมากกวาลมกระทําตั้งฉากกับอาคาร 

การรวมผลแรงลมในหัวขอนี้ใชไดกับอาคารสูงปานกลางซึ่งสูงไมเกิน 80 เมตรและมีความสูง
ไมเกิน 3 เทาของความกวางประสิทธิผลนอยที่สุด และอาคารรูปทรงปกติที่มีความสมมาตรทาง
โครงสรางกลาวคือ จุดศูนยกลางแรงเฉือน และ จุดศูนยกลางมวลของแตละชั้นจะอยูตําแหนง
เดียวกัน หรือหางกันเล็กนอย 

 
รูปที่ 7.8 การรวมผลของแรงลมเนื่องจากแรงลมในทิศทางลม ตั้งฉากกับทิศทางลม และการบิด 

อาคารและองคอาคารจะตองถูกออกแบบใหสามารถรับผลรวมกระทําแรงลมในกรณี 1 ถึง 4 

ดังแสดงในรูปที่ 7.8 ดังนี้ 

PWX PLX

BY

BX

PWY

PLY

CASE 1

0.75PWX 0.75PLX

CASE 2

0.75PWY

0.75PLY

MT MT

MT  0.75(PWX PLX)BXeX
eX  0.15BX

MT  0.75(PWY PLY)BYeY
eY  0.15BY

CASE 3

0.75PWY

0.75PLY

0.
75

P W
X

0.
75

P L
X

CASE 4

0.563PWY

0.563PLY

0.
56

3P
W

X

0.
56

3P
LXMT

MT  0.563((PWX PLX)BXeX (PWY PLY)BYeY)
         eX  0.15BX                eY  0.15BY
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กรณีที่ 1 : หนวยแรงลมกระทําเต็มที่บนพื้นที่ตั้งฉากกับแตละแกนหลักของโครงสรางโดยพิจารณา
แยกกระทําทีละทิศทาง 

กรณีที่ 2 : 75% ของหนวยแรงลมบนพื้นที่ตั้งฉากกับแตละแกนหลักของโครงสรางรวมกับโมเมนต
บิดจากผลของการเย้ืองศูนยโดยพิจารณาแยกกระทําทีละทิศทาง 

กรณีที่ 3 : หนวยแรงลมตาม กรณีที่ 1 แตพิจารณาใหกระทําทั้งสองทิศทางพรอมกันที่ 75% ของ
คาท่ีระบ ุ

กรณีที่ 4 : หนวยแรงลมตาม กรณีที่ 2 แตพิจารณาใหกระทําทั้งสองทิศทางพรอมกันที่ 75% ของ
คาท่ีระบ ุ

โดยท่ี 
PWX, PWY   หนวยแรงลมดานตนลม ในทิศทางหลัก X และ Y ของอาคารตามลําดับ 
 PLX, PLY   หนวยแรงลมดานทายลม ในทิศทางหลัก X และ Y ของอาคารตามลําดับ 
 BX, BY   ขนาดอาคารในทิศทางหลัก X และ Y ของอาคารตามลําดับ 
 eX, eY   ระยะเย้ืองศูนยในทิศทางหลัก X และ Y ของอาคารตามลําดับ 
 MT   โมเมนตบิดตอความสูง 1 เมตรรอบแกนด่ิงของอาคาร 

สัมประสิทธิ์แรงดันลมภายในอาคาร (Cpi)  
แรงดันภายในอาคารจากผลของลมอาจมีคาเปนบวกหรือลบขึ้นกับตําแหนงและขนาดของชองเปด
บนผนังภายนอกอาคาร ถา p คือแรงดันภายนอก และ pi คือแรงดันภายใน แรงดันลมสุทธิ (net 

wind pressure) คือผลตางระหวางความดันภายนอกและภายใน (pn  p – pi) รูปที่ 3.9 แสดงสี่
กรณีของแรงดันภายนอกและภายใน 

 
รูปที่ 7.9 แรงดันลมสุทธิจากผลตางจของแรงดันลมภายนอกและภายใน 

+p +pi

pn  p - pi

+p -pi

pn  p  pi

-p +pi

pn  -p - pi

-p -pi

pn  -p  pi
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รูปที่ 7.10 ผลของชองเปดที่มีตอความดันลมภายใน 

สัมประสิทธิ์แรงดันลมภายใน (Cpi) ใชในการคํานวณหาหนวยแรงลมภายในอาคาร ซึ่งมี
ความสําคัญตอการออกแบบผนังภายนอกอาคาร และระบบโครงสรางหลักตานแรงลม คา
สัมประสิทธิ์ Cpi จะขึ้นกับชองเปดและรูรั่วบนผนังภายนอกของอาคาร โดยจะแบงออกเปน 3 กรณี
โดยกําหนดใหใชไดทั้งวิธีอยางงายและวิธีอยางละเอียด และทุกกรณีจะตองคํานวณหาคา Cgi จาก
สมการ (7.11)  

กรณีที่ 1 : อาคารปดทึบ (Enclosed Building) ใชคา Cpi  -0.15 ถึง 0.0 

 กรณีนี้ใชกับอาคารที่ไมมีชองเปดขนาดใหญ แตอาจมีชองเปดเล็กๆกระจายสมํ่าเสมอ 
โดยมีผลรวมพื้นที่ชองเปดบนผนังภายนอกนอยกวา 0.1% ของพื้นที่ผิวทั้งหมด คา Cpi 

ควรจะเปน -0.15 ยกเวนบริเวณที่ไมมีนํ ้าหนักบรรทุกภายนอกซึ่งจะใช Cpi   0.0  
อาคารในกลุมนี้จะเปนอาคารสวนใหญที่มีผนังปดลอมทุกดานและมีระบบปรับอาคาร
ภายใน หรืออาคารอื่นเชนคลังสินคาที่ไมมีหนาตางหรือชองเปดโดยที่ประตูถูกออกแบบ
ใหตานทานแรงลมไดและปดสนิทเมื่อเกิดพายุ 

กรณีที่ 2 : อาคารปดทึบบางสวน (Partially Enclosed Building)  
 อาคารในกลุมนี้มีชองเปดขนาดใหญ ( > 1% ของพื้นที่ผนัง) แตตองไดรับการปดสนิท

เมื่อเกิดพายุและมีความแข็งแรงเพียงพอ ใหใชคา Cpi  -0.45 ถึง +0.3 ตัวอยางเชน 
อาคารขนาดเล็กทั่วไปและอาคารสูงที่มีหนาตางซึ่งสามารถเปด-ปดไดหรือมีระเบียงซึ่งมี
ประตูท่ีสามารถเปดปดได 

กรณีที่ 3 : อาคารเปด (Opened Building) ใชคา Cpi  -0.7 ถึง 0.7 

 อาคารที่มีชองเปดขนาดใหญ โดยที่ความแปรปรวนของลมภายนอกอาคาร สามารถ
สงผลเขาไปภายในได ตัวอยางไดแก อาคารโรงงานอุตสาหกรรมและคลังสินคาที่ประตู
อาจจะเปดในระหวางเกิดพายุ หรือประตูไมสามารถตานพายุได 

 

  

Positive
Internal
Pressure

Negative
Internal
Pressure

Positive
Internal
Pressure

Negative
Internal
Pressure
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ตัวอยางท่ี 1 อาคารคลังสินคาหลังคาทรงจั่ว  

คำนวณแรงลมสำหรับออกแบบอาคารคลังสินคาชั้นเดียวมีความกวาง 20 เมตร ยาว 40 เมตร ความ
สูงชายคา 6 เมตร หลังคาทรงจั่วมาความชัน 1:12 หรือ 5o อาคารมีชองเปดหลายขนาดจัดเปน
อาคารกรณีที่ 2 คือมีการปดทึบบางสวน ดังแสดงในรูปที่ 7.11 

 

รูปที่ 7.11 อาคารคลังสินคา 
ขอมูลอาคาร 

 ตำแหนงที่ตั้ง กรุงเทพมหานคร ( V50  25 m/s ) 

 สภาพการเปดโลง สภาพภูมิประเทศแบบโลง ( A ) 

 ขนาดอาคาร ดานตั้งฉากสันหลังคา 20 m 

  ดานขนานสันหลังคา 40 m  

  ความสูงชายคา 6 m 

  ความชันหลังคา 1:12 (5o) 

 ความสำคัญอาคาร อาคารปกติ ( Iw  1.0 ) 

 ชองเปดอาคาร อาคารปดทึบบางสวน ( กรณทีี่ 2 ) 

 หนวยแรงลมอางอิง  
 2 2 21 1q V 1.25 25 390.6 N/m

2 2
  

ตัวคูณสภาพการเปดโลง ( Ce ) 

 
0.2

e
zC

10
 

0.26 0.90
10

   0.9   OK 

6 m
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แรงดันลมภายในอาคาร 

ตัวคูณลมกระโชกภายในอาคารใชคา  giC 2.0  

อาคารปดทึบบางสวน (กรณีท่ี 2) ใชคา  piC 0.45, 0.3  

ดังนั้นความดันลมภายในอาคารจะมีคาเทากับ 

 i w e gi pip I qC C C 21.0 390.6 0.9 2.0 ( 0.45) 316.4 N/m  

 i w e gi pip I qC C C 21.0 390.6 0.9 2.0 ( 0.3) 210.9 N/m  

แรงดันลมภายนอกอาคารและดวามดันลมสุทธิ 

พิจารณาความกวาง  y  ของพ้ืนที่ขอบอาคาร : 

 ระยะ  y    คาท่ีมากกวาระหวาง  6 m  และ  2z 

ระยะ  z    คาท่ีนอยกวาระหวาง 10% ของความกวางดานที่แคบท่ีสุดของอาคาร และ 
40% ของความสูง (แตตองไมนอยกวา 4% ของดานที่แคบที่สุด และไม
นอยกวา 1 เมตร) 

คาท่ีนอยกวาระหวาง 0.1 20  2.0 m และ 0.4 6.0  2.4 m  

 แตไมนอยกวา 0.04 20  0.8 m และ ไมนอยกวา 1 m 

 z    2.0 m 

 ระยะ  y    คาท่ีมากกวาระหวาง  6 m  และ  2 2.0  4 m 

 y    6.0 m 

กรณีที่ 1 ทิศทางลมตั้งฉากกับสันหลังคา 

จากรูปที่ 7.4 และตารางที่ 7.5 คาผลคูณ CgCp บนพ้ืนผิวตางๆของอาคารคือ 

มุมหลังคา พื้นที่ผิวอาคาร 
1 1E 2 2E 3 3E 4 4E 

0-5o 0.75 1.15 -1.3 -2.0 -0.7 -1.0 -0.55 -0.8 

สำหรับอาคารน้ี อัตราสวน B/H  20/6  3.33  5 ดังนั้นคาสัมประสิทธิ์ที่เปนลบบนพื้นผิว 2 และ 
2E ใชไดเต็มพ้ืนผิวตามปกติ 

แรงดันลมภายนอกอาคารจะมีคาเทากับ 

 w e g pp I qC C C g p g p1.0 390.6 0.9 C C 351.5C C  

แรงดันลมสุทธิ ( pnet ) เปนการรวมกันของแรงดันลมภายนอกและภายในอาคาร 
 net ip p p  
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เมื่อแทนคา CgCp ลงในสมการ แรงดันลมภายนอกและแรงดันลมสุทธิสำหรับกรณีท่ี 1 

พื้นผิวอาคาร แรงดันภายนอก 
(N/m2) 

แรงดันสุทธิ (N/m2)  

แรงดันภายในเปนบวก แรงดันภายในเปนลบ 
1 264 53 580 

1E 404 193 720 

2 -457 -668 -141 

2E -703 -914 -387 

3 -246 -457 70 

3E -352 -563 -36 

4 -193 -404 123 

4E -281 -492 35 

 

รูปที่ 7.12 แรงดันลมสุทธิในกรณีทิศทางลมต้ังฉากสันหลังคาและแรงดันภายในเปนบวก 

 

รูปท่ี 7.13 แรงดันลมสุทธิในกรณีทิศทางลมต้ังฉากสันหลังคาและแรงดันภายในเปนลบ 

6 m

WIND1E=193

1=53

2E=-914

2=-668
3E=-563

3=-457

4E=-492

4=-404

6 m

WIND1E=720

1=580

2E=-387

2=-141
3E=-36

3=70

4E=35

4=123
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กรณีที่ 2 ทิศทางลมขนานกับสันหลังคา 

จากรูปที่ 7.5 และตารางที่ 7.6 คาผลคูณ CgCp บนพ้ืนผิวตางๆของอาคารคือ 

ความลาดชัน
ของหลังคา 

พ้ืนที่ผิวอาคาร 
1 1E 2 2E 3 3E 4 4E 5 5E 6 6E 

0o ถึง 90o -0.85 -0.9 -1.3 -2.0 -0.7 -1.0 -0.85 -0.9 0.75 1.15 -0.55 -0.8 

แรงดันลมภายนอกอาคารจะมีคาเทากับ w e g pp I qC C C g p351.5C C  

แรงดันลมสุทธิ net ip p p  

เมื่อแทนคา CgCp ลงในสมการ แรงดันลมภายนอกและแรงดันลมสุทธิสำหรับกรณีท่ี 2 

พื้นผิวอาคาร แรงดันภายนอก 
(N/m2) 

แรงดันสุทธิ (N/m2)  

แรงดันภายในเปนบวก แรงดันภายในเปนลบ 
1 -299 -510 17 

1E -316 -527 0 

2 -457 -668 -141 

2E -703 -914 -387 

3 -246 -457 70 

3E -352 -563 -36 

4 -299 -510 17 

4E -316 -527 0 

5 264 53 52 

5E 404 193 720 

6 -193 -404 123 

6E -281 -492 35 

 
รูปที่ 7.14 แรงดันลมสุทธิในกรณีทิศทางลมขนานสันหลังคาและแรงดันภายในเปนบวก 

6 m
WIND

1E=-524

1=-510

2E=-703

2=-457
3E=-352

3=-246

4E=-316

4=-299

2 m
5E=193

5=53

6E=-492

6=-404
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รูปท่ี 7.15 แรงดันลมสุทธิในกรณีทิศทางลมขนานสันหลังคาและแรงดันภายในเปนลบ 

ตัวอยางท่ี 2 แรงลมบนอาคารโกดังโรงงาน SAP2000 
ในตัวอยางนี้จะสาธิตการใสคาแรงลมสําหรับอาคารโกดังโรงงานในตัวอยางที่ 1 โดยปรับเปลี่ยนให
ระยะหางระหวางโครงคือ 6 เมตร และมีการยึดโยงดังในรูป 

 

สรางโมเดล 
 เริ่มตน SAP2000 ใชหนวย Kgf, m, C สรางโมเดลใหม โดยกด Ctrl+N  

 เมื่อหนาตาง New Model แสดงขึ้นมา คลิกปุม Grid Only 

 กำหนดจำนวนและระยะหางเสนกริด 

6 m

1E=0

1=17

2E=-387

2=-141
3E=-36

3=70

4E=0

4=17

2 m
WIND 5E=720

5=52

6E=35

6=123

6 m
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 เสนกริดจะถูกสรางข้ึนดังในรูป 

 

 สั่งเมนู Define > Coordinate Systems/Grids คลิกปุม Modify/Show System… 

 

 ในหนาตาง Define Grid System Data คลิกเลือกใหแสดงกริดโดย Spacing 

 เปลี่ยนคา Grid ID : Z2 เปน 10 tan 5o = 0.875 
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 คลิกหนาตางสองมิต ิแลวคลิกปุ ม  และ  ไปที ่พ ิก ัด X = 0 เส นกริดจะถูก
ปรับเปล่ียนดังในรูป  

 

 คลิกปุม    บันทึกขอมูลตั้งชื่อไฟลวา EX4 Factory 

 เปลี่ยนหนวยเปน Kgf-cm สั่งเมนู Define > Materials หรือคลิกปุม    เลือกรายการ 
A992Fy50 แลวกดปุม Modify/Show Material…  
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 ตั้งชื่อเปน Fy2400 กําหนดคาตางๆในหนาตางคุณสมบัติดังในรูป 

 

คา Effective Yield Stress, Fye และ Effective Tensile Stress, Fue หาไดจากการ
คูณกําลัง Fy และ Fu ดวยแฟกเตอรตามมาตรฐานออกแบบ เชน FEMA 356 ตารางที่ 
5-3 ซึ่งโดยปกติจะอยูที่ประมาณ 1.1 คา Fye และ Fue จะใชในการสรางคุณสมบัติ
ของจุดตอหมุน (hinge) โดยอัตโนมัติสําหรับจุดตอหมุน P-M2-M3 และ P-M  

 

 

 เ ปล ี ่ ย นหน  ว ย เป  น  Kgf-mm ส ั ่ ง เ มน ู  Define > Section Properties Frame 

Sections… หรือคลิกปุม    บนทูลบาร  
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 คลิกปุม Add New Property เลือกหนาตัด Steel แบบ I / Wide Flange 

 

 ใสขอมูลของหนาตัด W400X107 และ W300X94 โดยใสคาขนาดตางๆดังในรูป 
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 คลิกปุม Add New Property เลือกหนาตัด Steel แบบ Angle หนาตัดฉาก 

 

 ใสขอมูลของหนาตัด L150X150X10 โดยใสคาขนาดตางๆลงตามชองที่กำหนดดังในรูป 

 

 เมื่อคลิก OK กลับมาที่หนาตาง Frame Properties จะมีรายการหนาตัดดังในรูป 
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โดยหนาต ัด W400X107 จะถูกใช เปนหนาต ัดเสาและโครงหลังคาหลัก , หนาตัด 
W300X94 ใชเปนโครงค้ำยันในทิศทางรอง และ หนาตัด L150X150X10 จะถูกใชเปนองค
อาคารยึดโยง ในกรณีออกแบบเลือกหนาตัดสามารถทำไดโดยใชเปนหนาตัดเลือกอัตโนมัติ 
(Auto Select List) ในการเลือกหนาตัดที่เบาที่สุด 

 เปลี่ยนหนวยเปน Kgf. m, C แลวเลือกหนาตางสองมิติ Y-Z Plane @ X=0  

 คลิกปุม    Draw Frame เขาสูโหมดการวาด เลือกหนาตัด W400X107  

 

 คลิกสรางเฟรมไปตามจุดตัดกริดดังในรูป แลวกด Esc เพ่ือออกจากโหมดการวาด 

 

 คลิกเลือกทอนจันทันหลังคา สั่งเมนู Edit > Edit Lines > Divide Frames เลือกแบงเปนสวน
ทอนเทากัน 

 

 คลิกปุม    เลือกใหแสดงจุดตอโดยคลิกไมเลือก Joints > Invisible 
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 คลิกเลือกสองจุดที่ฐาน สั่งเมนู Assign > Joint > Restraints… 

เลือกจุดรองรับแบบยึดแนน Fixed Support 

 

 กด Ctrl+A เลือกทั้งหมด แลวกด Ctrl+R เพ่ือทำซ้ำแบบเชิงเสนโดยใชคา dx = 6 m 

 

 เลือกหนาตางสามมิติ กดปุม Shift และลูกลอเมาสเพ่ือหมุนมุมมอง และกดลูกลอเมาสเพ่ือยาย
มุมมองใหเหมาะสม 
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 คลิกปุม    Draw Frame เลือกหนาตัด W300X94 วาดเสนเชื่อมระหวางโครงดังในรูป 

 

 คลิกปุม    Draw Frame เลือกหนาตัด L150X150X10 วาดทอนแกงแนงยึดโยงระหวาง
โครงดังในรูป 

 

 กด Ctrl+A เลือกทั้งหมด แลวกด Ctrl+R เพ่ือทำซ้ำใชคา dx = 12 m จำนวน = 3 

 สั่งเมนู View > Show Grid หรือกด Ctrl+D เพ่ือปดการแสดงกริด 
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 คลิกเลือกคานเชื่อมในโครงตัวแรก แลวกด Ctrl+R เพ่ือทำซ้ำใชคา dx = 6 m จำนวน = 1 

 

 คลิกเลือกคานเชื่อมระหวางโครงที่เพิ่งถูกทำซ้ำ แลวกด Ctrl+R เพื่อทำซ้ำใชคา dx = 12 m 

จำนวน = 2 

 

 สั่งเมนู File > Save หรือ คลิกปุม    เพ่ือบันทึกขอมูล 

 คลิกหนาตาง Y-Z Plane @ X=0 คลิกปุม  วาดเสนเชื่อมระหวางจุดฐาน 

 เลือกเสนเชื่อม สั่งเมนู Edit > Edit Lines > Divide Frames แบงเปน 4 สวน 
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 วาดเสนแนวดิ่งจากโหนดบนหลังคาลงมาที่จุดบนคานที่ฐานโดยใชหนาตัด W400X107 

 ลบคานที่ฐานออก เลือกปลายเสาลาง สั่งเมนู Assign > Joint  > Restraints กำหนดใหเปนจุด
รองรับแบบ Fixed 

 

 ตีกรอบจากขวาไปซายเลือกเสาและฐานทั ้งสามตน กด Ctrl+R ทำซ้ำโดยใช dx = 42 m 

จำนวน = 1 

 

 คลิกปุม  เพื่อรันการวิเคราะหโครงสราง เลือกกรณี MODAL คลิกปุม Do Not Run เพ่ือ
ไมใหรันการวิเคราะหโหมดการสั่นไหว 
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การกําหนดแรงลม  

การใสแรงลมอัตโนมัติทําไดโดยการเลือกมาตรฐานซึ่งสําหรับ มยผ.1311-50 จะอางอิงตามมาตรฐาน 
NBCC 2005 แลวใสคาพารามิเตอรใหโปรแกรมทําการคํานวณแรงลมสามารถทําไดเชนกันโดยเลือก
เปนแรงลมกระทําบนพื้นผิว ทําการสรางพ้ืนผิวแบบ None โดยหมุนแกนของพ้ืนไปในทิศท่ีจะสงผาน
แรงไปยัง จากนั้นใสแรงลมแบบสัมประสิทธิ์แรงดันลงเฟรมแบบทางเดียวซึ่งเปนฟเจอรใหมในเวอร
ชั่น 22.1.0 

 คลิกปุม    เพ่ือปลดล็อคโมเดล แลวสั่งเมนู Define > Load Patterns สรางรูปแบบบรรทุก 

LIVE, WindX และ WindY เลือกมาตรฐาน NBCC 2005  

 

 เลือกรายการ WindX แลวคลิกปุม Modify Lateral Load Pattern ใสคาตางๆดังนี้ 

 

Exposure from Area Objects จะคิดแรงลมบนพื้นผิว ถาไมมีพื้นผิวจริงจะสรางเปนพื้นผิว
แบบ none ที่ไมมีคุณสมบัติ จากนั้นจะทําการใสเปนคาสัมประสิทธิ์แรงดันสําหรับแตละพื้นผิว
ไดแก ผนังดานปะทะลม, ผนังดานหลบลม, หลังคาดานปะทะลม และหลังคาดานหลบลม 
สําหรับทางเลือกน้ีไมตองกําหนดพืน้เปนไดอะแฟรม 

Velocity Pressure (kPa) 

 2 2 21 1q V 1.25 27 455.6 N/m 0.46 kPa
2 2

  

Gust Effect Factor, cg     สําหรับโครงสรางหลักโดยวิธีอยางงาย  Cg   2.0 

Importance Factor, Iw    อาคารปกติ  Iw   1.0 
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 เลือกรายการ WindY แลวคลิกปุม Modify Lateral Load Pattern ใสคาตางๆเหมือนกัน 

 ใสรูปแบบบรรทุก LIVE เลือกเปนชนิด Live กดปุม Add New Load Pattern 

 คลิกปุม    เลือกใหแสดง General Options > Fill Objects 

 คลิกปุม   เลือกหนาตัด None แลวคลิกวาดพื้นผิวผนังและหลังคาเปนแผนใหญ  

  

คลิกไปตามจุดมุมวนทวนเข็มนาิกาและดับเบิ้ลคลิกจุดสุดทาย 

 คลิกปุม    เลือกใหแสดง Areas > Local Axes 

 

 

 

 

 

 

 สังเกตุแกนสีแดงในผนังและหลังคาใหอยูในแนวนอนเพื่อสงผานแรงลมไปยังเสาและโครงหลัง 
ถาไมใชใหเลือกพ้ืน สั่งเมนู Assign > Areas > Local Axes หมุนแกน 90 องศา 

 เลือกพื ้นผิวหลังคา สั ่งเมนู Assign > Area Load > Uniform to Frame เลือกกรณี DEAD 

แบบ One Way ใสคา 10 kgf/m2 คลิกปุม Apply 

 กด Ctrl+J เลือกพ้ืนผิวอีกครั้ง เลือก LIVE แบบ One Way ใสคา 30 kgf/m2 คลิกปุม OK 

 คลิกเลือกพ้ืนผิว, เสา และจันทันดังในรูป สั่งเมนู Edit > Edit Areas > Divide Areas 

 

สำหรับหลังคาลาดเอียง  = 5o  
ตารางท่ี 7.5 ผลคูณสัมประสิทธิ์ CpCg สําหรับอาคารเต้ียกรณีลมพัดตั้งฉากสันหลังคา 

ความลาดชัน
ของหลังคา 

พื้นที่ผิวอาคาร 
1 1E 2 2E 3 3E 4 4E 

0o ถึง 5o 0.75 1.15 -1.3 -2.0 -0.7 -1.0 -0.55 -0.8 
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เมื่อคา Cg  2.0 ดังนั้นคา Cp สำหรับ WindY คือ 

 1 1E 2 2E 3 3E 4 4E 

Cp 0.38 0.58 -0.65 -1.0 -0.35 -0.5 -0.28 -0.4 

ตารางท่ี 7.6 ผลคูณสัมประสิทธิ์ CpCg สําหรับสําหรับอาคารเต้ียกรณีลมพัดขนานสันหลังคา 

ความลาดชัน
ของหลังคา 

พ้ืนที่ผิวอาคาร 
1 1E 2 2E 3 3E 4 4E 5 5E 6 6E 

0o ถึง 90o -0.85 -0.9 -1.3 -2.0 -0.7 -1.0 -0.85 -0.9 0.75 1.15 -0.55 -0.8 

เมื่อคา Cg  2.0 ดังนั้นคา Cp สำหรับ WindX คือ 

 1 1E 2 2E 3 3E 4 4E 5 5E 6 6E 
Cp -0.43 -0.45 -0.65 -1.0 -0.35 -0.5 -0.43 -0.45 0.38 0.58 -0.28 -0.4 

 คลิกเลือกพื้นผิว 1E สั ่งเมนู Assign > Area Loads > Wind Pressure Coefficients เลือก
รูปแบบบรรทุก WindX การกระจายแบบ To Frames – One-Way (มีในเวอรชั่น 22.1) ใสคา 
Cp  0.45 (แรงดูดทิศเดียวกับแกน 3) 

 

 

 

 
 

 คลิกปุม Apply จากนั้นคลิกในพ้ืนที่วางในหนาตางโมเดล กด Ctrl+J เลือกพ้ืนผิวเดิม 

 เปลี่ยนเปนรูปแบบบรรทุก WindY และคา Cp  -0.58 (แรงดันทิศตรงขามกับแกน 3) 
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 ใสคา Cp ลงบนพ้ืนผิวตางๆโดยวิธีเดิมจนครบทุกพ้ืนผิว 

 

 ผนัง 2E :  WindX  >  Cp = 1,  WindY  >  Cp = 1 

   

 ผนัง 3E :  WindX  >  Cp = 0.5,  WindY  >  Cp = 0.5 

H
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 ผนัง 4E :  WindX  >  Cp = 0.45,  WindY  >  Cp = 0.4 

 ผนัง 5E :  WindX  >  Cp = -0.58 

 ผนัง 6E :  WindX  >  Cp = 0.4 

 ผนัง 1 :  WindX  >  Cp = 0.43,  WindY  >  Cp = -0.38 

 ผนัง 2 :  WindX  >  Cp = 0.65,  WindY  >  Cp = 0.65 

 ผนัง 3 :  WindX  >  Cp = 0.35,  WindY  >  Cp = 0.35 

 ผนัง 4 :  WindX  >  Cp = 0.43,  WindY  >  Cp = 0.28 

 ผนัง 5 :  WindX  >  Cp = -0.38 

 ผนัง 6 :  WindX  >  Cp = 0.28 

 สั่งเมนู Assign > Clear Display on Assigns 

 คลิกปุม    เลือกปดการแสดง Areas > Local Axes 

 คลิกปุม    หรือกด F5 รันการวิเคราะหโครงสราง 

 คลิกปุม    เลือกใหแสดงการเสียรูปทรงภายใตกรณีบรรทุก WindX และ WindY 
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 คลิกปุม    เลือกใหแสดงโมเมนต M33 ภายใตกรณีบรรทุก WindX และ WindY 

 คลิกปุม    เลือกใหแสดงโมเมนต M22 ภายใตกรณีบรรทุก WindX และ WindY 

 คลิกปุม    เลือกใหแสดง Axial Force ภายใตกรณีบรรทุก WindX และ WindY 
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แรงดันลมภายใน  
สำหรับโครงสรางในตัวอยางนี้สมมุติวาอาคารมีประตู หนาตาง และชองเปดเพื่อระบายอากาศ รวม
ทั้งหมดคิดเปนสัดสวนเทากับ 5% ของพ้ืนผิวทั้งหมดของอาคาร ประตูและหนาตางมีขนาดใหญ และ
ไมสามารถตานทานพายุได และชองเปดมีลักษณะกระจายอยางไมสม่ำเสมอ (non-uniformly 

distributed) โดยรอบอาคาร 
เมื่อพิจารณาตามมาตรฐาน มยผ.1311-50 หัวขอ 2.6 (ในหนังสือเลมนี้หนาที่ 48) พบวา

อาคารจัดอยูในกรณีที่ 3 เนื่องจากมีชองเปดคิดเปนสัดสวนมากกวา 0.1% ของพ้ืนที่ทั้งหมด มีประตู
และหนาตางขนาดใหญ และไมสามารถตานทานพายุได และลักษณะของชองเปดกระจายอยางไม
สม่ำเสมอรอบอาคาร 

ดังนั้นเลือกใชคา piC 0.7  และ gi gC C 2.0  สำหรับการคำนวณหนวยแรงลม
ภายในอาคารตามสมการ  i w e gi pip I qC C C  ซึ่งจะมีทั้งคาบวกและลบ โดยจะนำไปรวมกับหนวย
แรงลมภายนอกเปนคาหนวยแรงลมสุทธิ 

net i w e g p pi w e g pp p p I qC C (C C ) I qC C (C 0.7)  

ดังนั้นคา Cp สำหรับ WindY, WindYP และ WindYN คือ 
 1 1E 2 2E 3 3E 4 4E 

Cp 0.38 0.58 -0.65 -1.0 -0.35 -0.5 -0.28 -0.4 

Cp  0.7 1.08 1.28 0.05 -0.3 0.35 0.2 0.42 0.3 

Cp  0.7 -0.32 -0.12 -1.35 -1.7 -1.05 -1.2 -0.98 -1.1 

ดังนั้นคา Cp สำหรับ WindX, WindXP และ WindXN คือ 

 1 1E 2 2E 3 3E 4 4E 5 5E 6 6E 
Cp -0.43 -0.45 -0.65 -1.0 -0.35 -0.5 -0.43 -0.45 0.38 0.58 -0.28 -0.4 

Cp  0.7 0.27 0.25 0.05 -0.3 0.35 0.2 0.27 0.25 1.08 1.28 0.42 0.3 

Cp  0.7 -1.13 -1.15 -1.35 -1.7 -1.05 -1.2 -1.13 -1.15 -0.32 -0.12 -0.98 -1.1 

 คลิกปุม    เพ่ือปลดล็อคโมเดลใหสามารถแกไขได 
 สั่งเมนู Define > Load Patterns สรางรูปแบบบรรทุกเพิ่มคือ WindXP, WindXN, WindYP 

และ WindYN โดยเลือกรายการ WindX และ WindY เดิมมาแกไขชื่อแลวคลิกปุม Add New 

Load Pattern 

 



 

SAP2000  C7 Wind Load Mongkol  JIRAVACHARADET 255 
 

  คลิกเลือกรายการแรงลมที่สรางขึ้นใหม กดปุม Modify Lateral Load Pattern เลือกแบบ 
Exposure from Area Objects และใสคา Velocity Pressure = 0.46 

 

 คลิกเลือกแตละผนัง สั ่งเมนู Assign > Area Load > Wind Pressure Coefficient เล ือก
รูปแบบบรรทุก WindXP, WindXN, WindYP หรือ WindYN แลวใสคา Cp จากตารางให
สอดคลองกับทิศทางแกน 3 ของพื้นผิวซึ่งชี้ออกจากอาคาร ดังนั้นคาที่เปนลบ(หนวยแรงดูด)จะ
ใสเปนคาบวก และเลือกการกระจายแบบ To Frame – One-Way 

ตัวอยางเชนในรูป สำหรับผนัง 1E : 

  

 คลิกปุม    หรือกด F5 รันการวิเคราะหโครงสราง 

 คลิกปุม    เลือกใหแสดงการเสียรูปทรงภายใตกรณีบรรทุก WindXP, WindXN, WindYP 

และ WindYN 
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 คลิกปุม    เลือกใหแสดงโมเมนต M33 ภายใตกรณีบรรทุก WindXP, WindXN, WindYP 

และ WindYN 

 คลิกปุม    เลือกใหแสดงแรงตามแนวแกน Axial Force ภายใตกรณีบรรทุก WindXP, 

WindXN, WindYP และ WindYN 

 

การออกแบบ  
 สั่งเมนู Define > Group คลิกปุม Add New Group สราง 3 กลุมคือ FrameX, FrameY และ 

Bracing 

  

 สั่งเมนู Select > Select > Properties > Frame Sections เลือกหนาตัด W400X107 
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 สั่งเมนู Assign > Assign to Group หรือกด Ctrl+Shift+G เลือกใหเปนกลุม FrameX 

 เลือกหนาตัด W300X94 กำหนดใหเปนกลุม FrameY 

 เลือกหนาตัด L150X150X10 กำหนดใหเปนกลุม Bracing 

 กด Ctrl+G ตรวจสอบการกำหนดแตละกลุม 

 สั่งเมนู Define > Load Combinations คลิกปุม Add New Combo เพื่อสรางกรณีบรรทุก
สำหรับการออกแบบโดยวิธีหนวยแรงที่ยอมใหคือ 

 D + L 

 D + 0.6W 

 D + 0.75L + 0.45W 

เมื่อ W คือแรงลมไดแก WindX, WindXP, WindXN, WindY, WindYP และ WindYN 

 

รายการกรณีบรรทุกรวมจะเปนดังในรูปขางลาง 
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 ส ั ่ งเมน ู Design > Steel Frame Design > View/Revise Preferences… เล ือกมาตรฐาน 
AISC ASD89 

 

 สั่งเมนู Design > Steel Frame Design > Select Design Groups เลือกกลุมออกแบบ 

 

 สั่งเมนู Design > Steel Frame Design > Select Design Combo เลือกกรณีบรรทุกรวม 
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 คลิกปุม   เลือก Area > Not in View และไมเลือก Fill Objects เพื่อปดการแสดงพื้นผิว 

คลิก Apply to All Windows 

 สั่งเมนู Design > Steel Frame Design > Start Design/Check เพ่ือทำการออกแบบ 

 

จะเห็นวาหลายทอนเปนสีแดงแสดงวาออกแบบไมผาน  

 คลิกปุม  ปลดล็อคโมเดล แลวคลิกปุม  กด Import New Property นำเขาหนาตัด 
W300-W700 และหนาตัดฉาก L150-L250 

 

  Add New Property สรางหนาตัด Auto Select List สำหรับหนาตัด W ตั้งชื่อวา AUTOW 

และ AUTOL สำหรับหนาตัดฉาก 

 กด  Ctrl+G เล ือกกล ุ ม  FrameX และ FrameY แล วส ั ่ ง เมน ู  Assign > Frame > Frame 

Sections กำหนดใหเปนหนาตัด AUTOW กดปุม Apply 

 เลือกกลุม Bracing กำหนดใหเปนหนาตัด AUTOL 
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 คลิกปุม    หรือกด F5 รันการวิเคราะหโครงสราง 

 สั่งเมนู Design > Steel Frame Design > Start Design/Check เพ่ือทำการออกแบบ 

 สั่งเมนู Design > Steel Frame Design > Verify Analysis vs Design Section 
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 ถายังมีหนาตัดที่ตางกันใหกด F5 รันการวิเคราะห และ Shift+F5 รันการออกแบบ จากนั้นสั่ง
ตรวจสอบใหม วนไปจนกระท่ังไมมีหนาตัดที่ตางกัน 
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ตัวอยางท่ี 3 หลังคาทีจ่อดรถ 

โครงสรางหลังคาท่ีจอดรถมีขนาดตางๆดังแสดงในรูป 

 

 

 เริ่มตน SAP2000 ใชหนวย Kgf, m, C สรางโมเดลใหม โดยกด Ctrl+N  

 เมื่อหนาตาง New Model แสดงขึ้นมา เลือก Initial Model from Default Settings 

 

 เลือกเทมเพลต Grid Only 

 ใสจํานวนเสนกริดและระยะหางดังในรูป 
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250 600
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5,750
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50
0

600
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 เลือกหนาตาง X-Y Plane คลิกปุม  เปลี่ยนเปนมุมมองระนาบ X-Z  

 

 คลิกขวาในพ้ืนที่วาง เลือกรายการ Edit Grid Data… คลิกปุม Modify/Show System… 
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 แสดงกริดแบบ Spacing เปลี ่ยนขอมูลกริด X และ Z 

ตามท่ีตองการดังในรูป 

 

 

 เลือกหนาตางสองมิติ คลิกปุม  ใหแสดงมุมมองบนระนาบ X-Z @ Y=0 

 

  คลิกปุม  เพ่ือบันทึก ตั้งชื่อไฟลวา EX5 Car Park 

วัสดุและหนาตดั Material & Sections 

 เปลี่ยนหนวยเปน Kgf, cm, C สั่งเมนู Define > Materials… หรือคลิกปุม    เลือกรายการ 
A992Fy50 แลวคลิกปุม Modify/Show Material… 
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 ตั้งชื่อวา Fy2400 ใสคุณสมบัติตางๆดังในรูป  

 

 เลือกหนวย Kgf, m, C สั่งเมนู Define > Section Properties > Frame Sections  

 คลิกปุม Import New Property เลือกหนาตัด Pipe และไฟล TH_PIPE.PRO  

 เลือกนำเขาหนาตัด PIPE2-1/2(65)X3.2 และ PIPE3(80)X3.2 

 

 คลิกปุม Import New Property เลือกหนาตัด Tube 
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  คลิกปุม OK แลวคลิกปุม Open File… ในหนาตางตอมา 

 

 เลือกไฟล TH_RECT เลือกนำเขาหนาตัด HSS100X50X2.3 

 

 คลิกปุม  เพ่ือบันทึกขอมูล 

การวาดโครงสองมิต ิ 2D Frame 

 คลิกปุม  เลือกหนาตัด PIPE3(80)X3.2 แลวคลิกวาดจันทันหลังคาดังในรูป 

 

 คลิกเลือกจันทัน สั่งเมนู Edit > Edit Lines > Divide Frames เลือกแบงเปน 4 ทอน 
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 วาดเสาดิ่งบนเสนกริด B-1 และ D-1 แลวคลิกเลือกเสาและจันทันที่ตัดกับเสา 

 

 สั่งเมนู Edit > Edit Lines > Divide Frames เลือกแบงที่จุดตัดเสน 

 

 วาดเสาเอียงจากปลายลางเสนกริด C-1 มาที่จุดตัดเสา B-1 กับจันทัน แลวลบปลายเสนที่ไม
ตองการออกจนไดดังในรูป 

 

 คลิกเลือกเสาท้ังสอง สั่งเมนู Edit > Edit Lines > Divide Frames เลือกแบงเปน 4 ทอน 
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 คลิกปุม    เลือกใหแสดงจุดตอโดยคลิกไมเลือก Joints > Invisible 

 คลิกปุม  เลือกหนาตัด PIPE2-1/2(65)X3.2 แลวคลิกวาดทอนถักระหวางเสาดังในรูป 

 

 คลิกเลือกปลายลางเสา สั่งเมนู Assign > Joint > Restraints กำหนดใหเปนแบบยึดแนน 

  

 คลิกปุม  เลือกหนาตัด PIPE3(80)X3.2 แลวคลิกวาดทอนคํ้ายันใตจันทันหลังคาดังในรูป 

 คลิกเลือกทอนค้ำยัน สั่งเมนู Edit > Edit Lines > Divide Frames แบง 2 ทอน 
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 คลิกปุม  เลือกหนาตัด PIPE2-1/2(65)X3.2 บังคับเปนเสนดิ่งแลวคลิกวาดจากจุดแบงเลย
จันทันขึ้นไปเล็กนอย 

  

 คลิกเลือกจันทันและเสนดิ่ง สั่งเมนู Edit > Edit Lines > Divide Frames แบงที่จัดตัด 

 ลบเสนสวนเกินแลววาดทอนทแยงท่ีเหลือ 

 คลิกปุม    เลือกใหแสดง View Type แบบ Extrude 

 

 คลิกปุม  เพ่ือบันทึกขอมูล 
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การวาดโครงสามมิต ิ 3D Frame 

 คลิกปุม    เลือกใหแสดง View Type แบบ Standard และเลือกใหแสดงจุดตอโดยคลิกไม
เลือก Joint > Invisible และเลือก Apply to All Windows 

 สั่งเมนู Options > Color > Display เปลี่ยนสี Point เปนสีแดง เพ่ือใหเห็นชัดเจน 

 

 คลิกขวาในพ้ืนที่วาง เลือก Edit Grid Data แลวคลิกปุม Modify/Show System 

 

 เลือก Display Grids as Spacing  

 

 แกไข Y Grid Data โดยคลิกปุม Add เพ่ิมจำนวนเสนกริดเปน 5 เสนระยะหางชวงละ 5 m จน
ไดดังในรูป 
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 ใน X Grid Data ปดการแสดงเสนกริด B, C และ D 

  
 เมื่อคลิก OK เสนกริดในมุมมองสามมิติจะเปนดังในรูป 

 

 กด Ctrl+A เลือกทั้งหมด สั่งเมนู Edit > Replicate หรือกด Ctrl+R ทำซ้ำดวยระยะ dy = 5 

m จำนวน 1 โครง 
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 สั่งเมนู View > Show Grid หรือกด Ctrl+D เพ่ือปดการแสดงกริด 

 คลิกปุม  เลือกหนาตัด HSS100X50X2.3 วาดแปเช่ือมระหวางโครงดังในรูป 

 

 คลิกเลือกจุดตอที่ปลายแปดังในรูป สั่งเมนู Edit > Extrude > Extrude Points to Frames 

เลือกหนาตัด HSS100X50X2.3 ระยะ dy = -0.5 จำนวน = 1 

 

 คลิกปุม    เลือกใหแสดง Frame > Local Axes 
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จะเห็นวาแกน 1 (สีแดง) ของแปสวนยื่นไปคนละทิศกับแปชวงภายใน ดังนั้นจึงตองกลับทิศให
ตรงกันกอน 

 เลือกแปสวนยื่น สั่งเมนู Assign > Frame > Reverse Connectivity 

 

 

 คลิกปุม    เลือกปดการแสดง Frame > Local Axes และสั่งเมน ูAssign > Clear Display 

of Assign 

 ในมุมมองสามมิติตีกรอบจากขวาไปซายเลือกโครงขางขวาและแปชวงในดัวในรูป 

 

 สั่งเมนู Edit > Replicate หรือกด Ctrl+R ทำซ้ำดวยระยะ dy = 5 m จำนวน 3 โครง 
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 คลิกเลือกจุดตอที่ปลายแปดังในรูป สั่งเมนู Edit > Extrude > Extrude Points to Frames 

เลือกหนาตัด HSS100X50X2.3 ระยะ dy = 0.5 จำนวน = 1 

 คลิกปุม    เลือกปดการแสดง Frame > Local Axes ตรวจสอบแกนเฉพาะที่ของแปสวน
ยื่นวาตรงกับแปชวงในหรือไม 

 

หนาตัดแปจะเอียงไปตามความลาดเอียงของหลังคาคือ 

   tan-1(3333-2500)/5750    8.243o 

 สั่งเมนู Select > Select > Properties > Frame Sections เลือกหนาตัด HSS100X50X2.3 

คลิกปุม Select แลวกด Close 
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 สั่งเมนู Assign > Frame > Local Axes ใสคามุม -8.243 

 

 หมุนโมเดลสามมิติเพื่อตรวจสอบแกนเฉพาะที่ 2 (สีเขียว) ของแปวาเอียงตั้งฉากกับหลังคา
หรือไม 

 

 คลิกปุม    เลือกปดการแสดง Frame > Local Axes  

 คลิกปุม  เพ่ือบันทึกขอมูล 

การใสนํ้าหนักบรรทุก  
 สั ่งเมนู Define > Load Patterns สรางร ูปแบบบรรทุก LIVE และ WIND ตามมาตรฐาน 

NBCC2005 
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 เลือกรายการ WIND คลิกปุม Modify Lateral Load Pattern… 

 

 เลือกแบบ Exposure from Area Objects ใสคา Velocity Pressure = 0.4 kPa 

 คลิกปุม    เลือกใหแสดงพ้ืนผิวโดยคลิกไมเลือก Area > Not in View และเลือก General 

> Fill Object  

 คลิกปุม  เลือกหนาตัด None คลิกวาดพื้นผิวหลังคาไปตามมุมปลายแปโดยวนทวนเข็ม
นาิกาและดับเบิ้ลคลิกจุดสุดทาย 

 

 คลิกเลือกพ้ืนผิว คลิกปุม    เลือกใหแสดงแกนพ้ืนผิว Area > Local Axes 

 
จะเห็นวาแกน 1 (สีแดง) ขนานกับทิศทางแปซ่ึงยังไมเปนตามท่ีตองการ 
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 คลิกเลือกพ้ืนผิว สั่งเมนู Assign > Area > Local Axes ใสคามุม 90 องศา 

 

 
 คลิกปุม    ปดการแสดงแกนพ้ืนผิว Area > Local Axes 

 สั่งเมนู Assign > Clear Display of Assign 

 คลิกเลือกพ้ืนผิว สั่งเมนู Assign > Area Load > Uniform to Frame เลือกรูปแบบ DEAD ใส
น้ำหนักบรรทุกและทิศทางดังในรูป แลวกดปุม Apply 
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 คลิกเลือกพ้ืนผิว เปลี่ยนเปนรูปแบบบรรทุก LIVE ใสน้ำหนักบรรทุกและทิศทางดังในรูป แลวกด
ปุม OK 

 

สำหรับแรงลมนั้น ตามมาตรฐาน มยผ.1311-50 ในรูปที่ ข.7 ในภาคผนวก ข สำหรับหลังคา
ความลาดชันดานเดียวมุมไมเกิน 10o คา CgCp ของพื้นผิว r สวนใหญคือ -2.0 โดยที่คา Cg คือ 2.0 
ดังนั้น Cp = -1.0 เปนหนวยแรงดูด  

 คลิกเลือกพื้นผิว สั่งเมนู Assign > Area Load > Wind Pressure Coefficients เลือกรูปแบบ 
WIND ใสน้ำหนักบรรทุกและทิศทางดังในรูป แลวกดปุม OK 

 

 คลิกปุม  เพ่ือบันทึกขอมูล 



 

SAP2000  C7 Wind Load Mongkol  JIRAVACHARADET 279 
 

การวิเคราะหโครงสราง  
 สั่งเมนู Analyze > Set Load Case to Run  

 

 เลือกกรณี MODAL คลิกปุม Do Not Run แลวคลิกปุม Run Now เพื่อเริ่มรันการวิเคราะห
โครงสราง 

 คลิกปุม    ปดการแสดงจุดตอ Joint > Invisible และปดการแสดงพื้นผิว Area > Not in 

View และไมเลือก Fill Object 

 เปลี่ยนหนวยเปน Kgf-cm คลิกปุม  ใหแสดงการเสียรูปทรงภายใตกรณีบรรทุก DEAD, 

LIVE และ WIND 

 

 ตรวจสอบการแอนตัวที่ปลายจันทัน ภายใตน้ำหนักบรรทุกกรณี  
DEAD  มีการแอนตัวลงมา  0.82 cm 

LIVE  มีการแอนตัวลงมา  1.31 cm 
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WIND ปลายแอนตัวขึ้นไป 3.36 cm 

 

 คลิกปุม  เลือกใหแสดงแรงตามแนวแกน Axial Force ภายใตกรณีบรรทุกตางๆ 

 

 

 เลือกเมนู Options > Moment Diagrams on Tension Sides ใหแสดงโมเมนตในรูปแบบท่ี
ตองการ 

 คลิกปุม  เลือกใหแสดงแรงตามแนวแกน Moment 3-3 ภายใตกรณีบรรทุกตางๆ 
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จะเห็นวาการเสียรูปทรงและแรงภายในจากกรณีบรรทุก DEAD และ LIVE จะตรงกันขามกัน
แรงลม WIND ซึ่งชวยทำใหแรงรวมกระทำในการออกแบบลดลงซ่ึงจะกลาวถึงในหัวขอถัดไป 

การออกแบบโครงสราง  
แบงองคอาคารเปนสามกลุมคือทอนหลัก (Main) ที่รับแรงมากไดแกจันทัน, ขื่อ และเสา, กลุมทอน
รอง (Web) ที่รับแรงนอยคือทอนถักระหวางทอนหลัก และกลุมแป (Purlin) 

 คลิกปุม    ใหแสดงรูปทรงเดิมของโครงสราง 

 

 เลือกหนาตางสองมิติมุมมอง X-Z Plane @ Y=0.5 คลิกเลือกกลุมทอนหลัก 
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 คลิกปุม    ไปยังระนาบ X-Z อ่ืน เพ่ือคลิกเลือกจนครบทุกระนาบ 

 ส ั ่ งเมน ู Select > Select > Properties > Frame Sections เล ือกหนาต ัดท อกลม PIPE 

3(80)X3.2 

 

 สั ่งเมนู Define > Group คลิกปุ ม Add New Group สราง 3 รายการคือ Main, Web และ 
Purlin 

 

 สั่งเมนู Assign > Assign to Group หรือกด Ctrl+Shift+G เลือกกลุม Main 
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 สั ่งเมนู Select > Select > Properties > Frame Sections เลือกหนาตัดทอกลม PIPE 2-

1/2(65)X3.2 

 สั่งเมนู Assign > Assign to Group หรือกด Ctrl+Shift+G เลือกกลุม Web 

 สั ่งเมนู Select > Select > Properties > Frame Sections เล ือกหนาตัดกลองสี ่ เหลี ่ยม 
HSS100X50X2.3 

 

 สั่งเมนู Assign > Assign to Group หรือกด Ctrl+Shift+G เลือกกลุม Purlin 

 สั่งเมนู Define > Load Combinations คลิกปุม Add New Combo สรางกรณีบรรทุกรวม
สองกรณีคือ (อางอิงจากมาตรฐาน ASCE 7-16 สำหรับการออกแบบโดยวิธีหนวยแรงที่ยอมให) 
LC1 : DL LC2 : DL + 0.6W 
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 สั่งเมนู Design > Steel Frame Design > View/Revise Preferences เลือกมาตรฐาน AISC-

ASD89 

 สั่งเมนู Design > Steel Frame Design > Select Design Groups เลือกกลุมออกแบบ 

 

 สั่งเมนู Design > Steel Frame Design > Select Design Combo เลือกกรณีบรรทุกรวม 
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 สั่งเมนู Design > Steel Frame Design > Start Design/Check of Structure หรือกด 
Shift+F5 เพ่ือรันการออกแบบ 

 

 ซูมขยายบริเวณจุดรองรับ สั่งเมนู  เลือก Joints เลือกกรณี DL+0.6W 
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แรงดึงและแรงอัดในเสาทั้ง 2 ตน แสดงใหเห็นถึงโมเมนตพลิกคว่ำซึ่งเราจะตองนำไป
ออกแบบจุดรองรับฐานเสา ตอมอ และฐานรากเพ่ือตานทานการพลิกคว่ำ 

 
ในกรณีที่โมเมนตพลิกคว่ำไมมากดังเชนในกรณีนี้ การตานทานอาจทำไดโดยใชน้ำหนัก

ฐานรากมาตานทานโดยพิจารณาโมเมนตรองจุดหมุน O ที่ขอบฐานราก 

 

W

TC

O



สาํหรบัลกูค้า DRMK Software สามารถเข้าเร ียนคอรส์น้ีได้ฟรี แบบ Online ใน
ระบบเรียน คลิกเรียนที่น่ี (เพียงซื้อแค่ตวัใดตวัหน่ึง) 

หรือ ในกล ุ่มเร ียน คลิกเรียนที่น่ี 

https://etraining.tumcivil.com/p/online-e-training-sap2000-v25
https://etraining.tumcivil.com/p/online-e-training-sap2000-v25
https://www.facebook.com/groups/sap2025


ประชาสมัพนัธส์าํหรบัผ ูต้ ้องการเรียน Online คอรส์น้ี ฟรี 
 

สาํหรบัผ ู้ที่สนใจและต้องการสนับสนุนพวกเรา สามารถส ัง่ซื้อ DRMK Software 
ซึ่งม ีหลายตวั ราคาไม่แพง อปัเดตฟรี คลิกส ัง่ซื้อโปรแกรมได้ที่น่ี 
 

 
 
 

DRMK Software for Civil Engineer 
โดย ผศ .ดร.มงคล จิรวชัรเดช 
สามารถสัง่ซือ้โปรแกรมไดท้ี ่www.tumcivil.com  
โทร. 089-4990739 
LINE ID = @tumcivil.com 
 

https://engfanatic.tumcivil.com/engfanatic/shopping/search?keyword=DRMKSOFT
https://line.me/R/ti/p/@586jjwuz





